Posts by RaK

    Hallo Jungs,


    hab Suse8.1, vdr 1.1.20 und nach Hubertus alle libs und das DVD Plugin installiert.


    Installation lief ohne mucken durch.


    Ich leg ne DVD einund starte das Plugin uebers Menu. Dann passiert folgendes:
    - kurzer Bildaussetzer
    - ich sehe wieder das TV Programm
    - nach ca. 3 sec schwarzer Bildschirm
    - nach ca 1sec Restart vom DVD Treiber
    - und dann wieder das TV-Programm


    In der /var/log/messages steht nichts auffaelliges.


    Kann mir einer einen Tipp geben?


    Ich habe libdvdcss v2.0.0. Hier im Board stand
    dass es bei einem unter Suse8.1 mit der libdvdcss v2.0.3 funktionieren soll. Nur hab ich keine Ahnung wo ich die neue Version bekommen soll. Unter videolan.org/libdvdcss gibts nur die Version 1.2.5.


    Ich kapier dat nicht.


    Ach ja, CVS hilft mir nicht weiter, da ich mit meiner VDR Box nicht ins Inet komme. Habe sonst nur XP um ins Netz zu kommmen.


    Gruss

    Mensch! Vielen Dank fuer diesen Tipp. Eigentlich recht logisch. Es funktioniert bei mir. Ich setze mich mal mit Sergei in Verbindung, damit das auch in der Beschreibung von nvram Einzug findet.


    Gruss

    So langsam komme ich dem Problem auf die Schliche.


    Ich halte euch mal auf dem Laufenden, ganz geloest habe ich es naemlich noch nicht.


    Also, Ich nutze Suse8.1 und da steht in der /boot/grub/menu.lst als erste Zeile


    Code
    1. gfxmenu (hd0,0)/boot/message


    info grub liefert dazu die Info, dass das die Datei ist, die den grafischen Bildschirm vom Auswahlmenu beschreibt. Also hab ich die Zeile mal kurz auskommentiert.


    reboot lauft jetzt durch und startet den NVRAM-Reboot Eintrag. Das System geht nach ner Nanosekunde schlafen


    Es funktioniert!!!


    ABER!!


    Beim nächsten Anschalten gehtdas System auch sofort wieder schlafen. SCHEISSE!


    Also irgendiwe funktioniert die "--once" Option von savedefault dann nicht mehr.


    Ich musste ein Rescuesystem booten und den NVRAM-Reboot Eintrag (--default=1) in /boot/grub/menu-lst auskommentieren.


    Danach konnte ich auch wieder normal booten.


    Also, ich bin kein Stueck weiter.

    Hab von meinem vdr noch kein Inet.



    Samba macht auch zicken. Deshalb komme ich im Moment nicht an die Daten ran. Ganz oben im Thread hast du aber die relevanten Passagen.


    vdrshutdown ist default von nvram-wakeup, nur die oben genannten zeilen sind modifiziert.


    menu-lst kannst du auch oben sehen.


    Hoffe das reicht.


    Mal schauen wann ich Samba zum laufen bekomme.

    das mit dem umount /boot und mount /boot hab ich nicht kapiert. bei mir ist /boot nix was zumounten ist, sodnern nur ein Unterverzeichnis von / (root).


    Ist das wichtig?


    Manuell grub starten dauert auch so lange. Er versucht rauszubekommen, was / fuer ein Filesystem ist. Bei ext2 scheint es schneller zu gehen als bei reiserfs.


    Das ist aber zu ertragen. Bloed ist nur, dass er nicht autoatisch das nvram-reboot startet. Er waehlt es aus und das Menu wartet dann auf einen Tastendruck.


    Ich werde mir heute nochmal man grub zu Gemuete fuehren. Vielleicht finde ich da was?


    grub.conf find ich nicht. Bei mir heisst das /boot/grub/menu.lst. Meinst du das?



    Zu dem Problem mit der langen Wartezeit nach
    "Probing devices ...":


    Ich hab reiserfs in meinem root. Vielleicht braucht er fuer reiserfs laenger zum testen als fuer dein Filesystem.


    Wie kann ich ihm denn mitteilen was das feur ein Filesystem ist. Dann muesste er nicht probierem.


    Danke fuer eure Hilfe!


    Ich bescheib nochmal kurz was passiert.


    Wenn nvram ne neue Wakeup Time ins BIOS schreibt, dann greift der Mechanismus. Er durchlaeuft vdrshutdown, braucht ne weile bei "Probing ..." das ist aber zu ertragen.


    Dan rebootet er. Das menu von Grub kommt, der Auswahlbalken steht auf NVRAM-Reboot und er wartet auf eine Eingabe von mir. Naemlich Return. Wenn ich dann Return gedruckt habe, geht er ne Nanosekunde spaeter aus.


    Zum vorgegebenen Zeitpunkt geht er dann wieder an. Das Grub Menu kommt, der Auswahlbalken steht auf VDR, er wartet drei Sekunden und bootet.


    Das einzige was nicht funktioniert ist die Tatsache, dass er auf mein Return wartet.


    Wieso wartet er bei mir auf Return und bei dir nicht?


    Ach ja,


    Suse 8.1
    Grub 0.92

    Quote

    Original von Morone


    So , (hd0,13) muß natürlich an das System selber angepasst werden. Meist wohl (hd0) -> Grub in MBR .
    Vielleicht kann das ja jemand mal bei sich testen , der nvram nutzt.


    Genau das hab ich gemacht. Funktioniert fast!


    Ich hab das Problem, dass beim hochfahren zwar in Grub der NVRAM_Timer Eintrag ausgewählt ist, nur schient der timeout Eintrag nichtmehr zu gelten. Er wartet naemlich auf die Bestaetigung durch RETURN. Soweit so schlecht, denn damit klappt das nicht voellig ohne Eingriff.


    Ich hab es auch mit

    Quote


    savedefault --default=1 --once --timeout=3


    probiert. Klappt leider nicht. Genauere Infos zu den optionen von savedefaults hab ich auch nicht gefunden.


    Ausserdem dauert der Part

    Quote


    echo | grub << EOF
    ...
    EOF


    Ziemlich lange. Da kommt bei mir folgende Meldung:

    Quote


    Probing devices to guess BIOS driver. This may take a while.


    Ja und es dauert tatsaechlich ne Weile, so ca 30sec!


    Das erste Problem ist aber wesentlicher dringlicher, denn so ganz funktionierts ja nicht, wenn ich an der richtigen Stelle noch Return druecken muss.


    Ich hab selber wenig Ahnung von Grub und Co. Insofern bin ich auf eure Hilfe angewisen. Ich wuerde mich aber bereit erklaeren daraus ne kleine Howto zu machen. Wenns denn nun richtig funktiniert.


    Ich nutze Suse8.1 und damit Grub0.92.


    Gruss

    Hallo Jungs,


    ich hab das problem, dass ich den VDR des oefteren killen muss. Bin grad am rumtesten. Nur geht da jedesmal die EPG Daten verlohren, da vdr sie (so interpretiere ich das) nicht mehr speichern kann.


    Deshalb die Frage, kann man den EPG Scan auch gezielt einleiten?

    Hallo Jungs,


    ich hab ein EpiaM9000 Board und wuerde darauf gerne DivX mit dem Mplayer schauen. zZ nutze ich VDR1.1.20, mplayer.sh006a und mplayer90rc3.


    dma ist mitlerweile an. Hab so 35-40MB/sec.
    @all: Ist das normal oder wenig?


    In der mplayer.sh.con habe ich XResPal auf 358 beschraenkt. Qualitaet des Bildes reicht mir so auf dem TV. Bild soll ueber DVB Karte an den TV.


    CPU-Last ist 100%, Ton hoert sich abgehackt an.


    @all:
    Wie kann ich denn nun das letzte aus dem mplayer an Performance kizzeln. Habt ihr da Ideen?

    Hallo Jungs,


    bin Linux/VDR Newbie und hab ne Frage zur Uhrzeit.


    Meine Uhr im VDR geht ne Stunde vor. Ok, kein Problem dachte ich. Stellste se einfach zurueck.


    date -set 1:27


    Soweit so gut, im VDR steht die richtige Zeit. Rechner aus, Rechner an, zeit wieder ne Stunde vor.


    Ich dachte mir das wird vielleicht irgendwie uebers EPG (falsch) abgeglichen und hab das SatKabel abgezogen. Wieder Zeit zurueck gestellt, Rechner an, rechner aus, Zeit wieder falsch.


    Dann habe ich hier gesucht und was zum Thema SystemZeit und Hardwarezeit gefunden


    Also mit
    hwclock --set --date=1:27 --localtime --systohc
    beide Uhren zurueckgestellt.


    Wunderbar, funktioniert. Rechner aus, rechner an, Uhrzeit wieder falsch. ICH KAPIERS NICHT!


    Kann mir einer mal bitte verstaendlich erklaeren wie das mit den verschiedenen Zeiten, mit UTC, GMT+1, ... so unter Linux funktioniert?


    Ich verzweifle hier noch. Das funktiniert naemlich dann mit dem EPG net. Und das ist das was meiner Frau so gut gefaellt ;-)). Deshalb darf ich um diese Zeit auch noch an die Linux Kiste ;-).

    Der Tipp mit der zlib war entscheidend. Das Paket mit den Headerfiles war einfach nicht installiert. (bei Suse 8.1 zlib-devel)


    Danke!


    Ne weitere grosse Huerde war die Config fuer das mp3 Plugin. die muss naemlich in ein Unterverzeichnis plugins im allgemeinen config Ordner (Option -c von vdr).


    So richtig beschrieben steht das nirgendwo (zumindest war ich so bloed und hab es nicht gefunden).


    Als das dann bereinigt war, lief alles palletti!


    TNX@all

    @krueger:
    sandmann kenn ich schon. da habe ich auch nicht mehr gefunden. Der Link zu Lirc in vdrportal war hilfreich, hab ich irgendwie uebersehen. Danke!


    inschenjr :
    Folgendes habe ich gemacht. Achja, ich habe vdr 1.1.20.


    >cd /dvb/VDR
    >md /opt
    >cd opt
    >wget umn.dl.sourceforge.net/sourceforge/mad/mad-0.14.2b.tar.gz
    >wget www.zip.com.au/~erikd/libsndfile/libsndfile-1.0.3.tar.gz
    >wget www.elis.rug.ac.be/~ronsse/cdfs/download/cdfs-0.5c.tar.bz2
    >wget www.muempf.de/down/vdr-mp3-0.7.9.tar.gz
    >cd mad-0.14.2b
    >./configure --enable-shared
    >make
    >make install
    >ldconfig
    >cd ..
    >cd libsndfile-1.0.3
    >./configure
    >make
    >make install
    >ldconfig
    >cd ..
    >cd cdfs-0.5c
    >./configure
    >make
    >make install
    >ldconfig
    >cd ..
    >mv mp3-0.7.9 /dvb/VDR/PLUGINS/src
    >cd /dvb/VDR/PLUGINS/src
    >ln -sF mp3-0.7.9 mp3


    Sowiet ich das verstanden habe sind das alle benotigten Bibliotheken.


    /2/ ntfs mounten geht, aber nur read only ;-(


    /3/ ok, auf dem tty wo ich vdr starte funktionierts. Aber nur wenn ich vdr direkt starte (will sagen ohne runvdr), damit hab ich dann keine Kontrolle mehr ueber den vdr per kbd.



    wwoody : Die "alte" Anleitung kannte ich noch nicht. Beim lesen ist mir aufgefallen, dass VDR dort mit make ... MP3=1 uebersetzt wird. Das habe ich bisher nicht gemacht. Wurde nicht in der Anleitung erwaehnt. Werd ich heute abend testen.


    Noch offen ist fuer mich, ob ich ntfs read write mounten kann. Kann dazu nochmal einer was sagen?


    Danke an alle

    Hallo Kollegen,


    gestern kam meine Sat-Karte. Ich sag euch, dass war eine lange Nacht ;-).


    VDR laeuft soweit ganz gut. Hat nur ne Weile gedauert, bis ich gemerkt habe, dass der Ton zum Bild auch aus der Sat-Karte kommt und nicht aus der Soundkarte ;-). Tja, so gehts Newbys.


    Jetzt habe ich aber konkret ein paar Fragen. Vielleicht koennt ihr mir helfen.


    /1/ MP3-Plugin funktioniert nicht.
    Beim make install vom MP3 Plugin laeuft was schief. Beim linken findet er eine libary nicht. Zumindest interpretiere ich das als nicht so ganz versierter Linuxer so. Und zwar fuert das make inen Befehl aus da kommt "-lz" als Parameter vor (neben -lmad zB). Ich hab den VDR nicht dabei in der Arbeit.


    Macht mal
    make -n; make -n install | grep lmad


    Genau in dieser Zeile gibts ne Fehlermeldung "-lz not found" oder so aehnlich. Ich bin exact nach www.vdrnews.de/users/MerlinElMago vorgegangen.


    /2/ Ist ntfs wirklich nur read only unter Suse 8.1?
    Ich habe meine ganzen MP3s auf einem ntfs Laufwerk. Wenn ich das mounte, und versuche ne datei zu "touchen", dann sagt er das waere nur ein read only filesystem. Die /etc/fstab habe ich auch schon modifiziert und ro durch rw ersetzt.


    /3/ Steuerung ueber tty8
    Wenn ich vdr mit runvdr starte, dann kann ich das Keyboard uzr Steuerung nicht benutzen. Parameeter "-t /dev/tty8" ist beruecksichtigt in der runvdr. Unter root habe ich auch chmod +rw /dev/tty8 ausgefuehrt. Ich starte runvdr und wechsle mit Alt-F8 auf tty8. Wenn ich jetzt was eingebe (Menu Taste, ...) dann erscheinen die Zeichen auf dem tty, aber das laesst den vdr ziemlich kalt. Soweit ich das kapiert habe, brauche ich das um den vdr per tasten zu steuern, wenn er automatisch startet wenn ich den vdr hochfahre und mit den runleveln das gemanagt habe, dass vdr automatisch startet.


    /4/ Lirc
    In den vielen guten Anleitungen zum vdr habe ich nichts ueber Lirc gefunden. Ist das wirklich alles? IR Sensor an COM anschliessen, beim make den Parameter fuer die Remote Steurung angeben (hab die genaue Syntax grad nicht parat) und dann funktioniert das?


    So das war es erstmal. Danke im voraus an alle Leser und Helfer.

    Ronny : Danke fuer die schnelle Antwort


    @lola:
    Danke fuer den Tipp. Die Tasten und der Rechner existieren schon. Deshalb wollte ich es erstmal damit probieren. Falls das irgendwie nicht zufriedenstellen funktioniert, dann werde ich mir das auch anschauen.


    TNX@all

    Hallo Jungs,


    ich bin neu hier in der "VDR Scene", aber schon laenger im Bereich HTPC auf nem XP OS aktiv.


    Nun bin ich auf VDR gestossen und finde das Projekt sehr interessant. Das einzige was mich im Moment noch davon abhaelt XP plattzumachen und durch Linux&VDR zu ersetzen ist folgende Frage.


    Ich habe den Anspruch, dass mein HTPC auch komplett auch ohne FB gesteuert werden kann. Also nix Tatstatur, nix Maus, nix FB, sondern nur ein paar Tasten direkt am Gehaeuse.


    Fuer Win geht das relativ gut mit girder (www.girder.nl) und nem entrpechenden Plugin.


    Abgefragt werden die Tasten ueber den COM-Port. Einen Schaltplan gibts unter http://www.meierspage.de - How2s - WinAmpSteuerung fuer den ComPort


    Was mir jetzt zum VDR noch fehlt, ist die Info, ob diese Tasten auch unter Linux abgefragt werden koennen. Wie gesagt, ab schonmal hier im Forum gesucht und nix gefunden. Vielleicht ist der Punkt ja so trivial, oder so alt, dass das hier nicht auftaucht.


    Wuerd mich ueber ne Antwort freuen.


    Gruss und Off