Posts by habichthugo

    unter /var/lib/vdr/plugins kannst Du mit

    Code
    1. dpkg -l | grep ffmpeg

    die verwendete ffmpeg Version sehen.

    Code
    1. root@yavdr:/var/lib/vdr/plugins# dpkg -l | grep ffmpeg
    2. ii libavcodec56-ffmpeg 2.7.2~trusty~ppa1 amd64 ffmpeg codec library
    3. ii libavformat56-ffmpeg 2.7.2~trusty~ppa1 amd64 ffmpeg file format library
    4. ii libavutil54-ffmpeg 2.7.2~trusty~ppa1 amd64 ffmpeg utility library
    5. ii libswresample1-ffmpeg 2.7.2~trusty~ppa1 amd64 ffmpeg audio rescaling library

    Hatte jetzt gerade einen fetten Bild+Ton-Aussetzer (16:23):

    Zum Thema passthrough:

    Im vdr auf einen Sender gehen, der Dolby Digital unterstützt, zB ZDF, dann grüne Taste auf der Fernbedienung und digital Stream wählen. Ist dieser einmal gewählt, sollte es auch bei weiteren Sendern umgestellt sein.

    Oh man, Danke! Das war jetzt zu einfach, um selbst drauf zu kommen...


    Das Weitere macht keinen Sinn, wenn ich die Kiste nicht mit Netzwerkverbindung aus dem Schlaf bekomme. Beim yaVDR geht suspend to ram als Ausweichlösung. Aber was mache ich jetzt beim easyVDR?


    WOL geht übrigens ootb. Allerdings halt mit ohne LAN, aus dem ACPI-Schlaf.

    Hi,

    Wenn ein Plugin in easy Portal nicht ist kannst du es per apt machen. Danach dann im osd aktivieren.

    Flimmern kannst du im softhddevice in dessen OsD Optionen ändern. Hänge bitte ein easyinfo an.

    Mfg Stefan

    Hm, im softhddevice-OSD unter Plugins kann ich dazu nix entsprechendes finden. Was meinst du genau?


    easyinfo geht erst morgen wieder. Der ya ist wegen WAF jetzt wieder on.


    Das Wichtigste aber ist, die Kiste mit Netzwerk aus dem Schlaf zu kriegen. Sonst kann ich den nicht produktiv einsetzen. Und Passthrough…?

    Bei yaVDR wird der User und die Gruppe vdr mit der Id 666 angelegt. Wenn die bei easyVDR anders ist, musst du ein "chown -R vdr.vdr /mnt/yavdr" laufen lassen. Wenn du die dann aber wieder in yaVDR benutzen willst, entsprechend wieder zurücksetzen.

    Durch dir feste Id bei yaVDR sorgen wir dafür, dass die Videodaten bei jeder Installation ohne Probleme gelesen/geschrieben werden können.


    Lars.

    Das war mir prinzipiell schon klar. Irgendwie temporär mappen lässt sich das nicht? Das macht die Testerei jetzt erst mal nicht gerade einfacher.


    Ich habe mir jetzt das easy Portal angesehen:

    * Der VDR läuft schon mit softhddevice, und dort war (bis auf PCM) / ist auch alles auf Passthrougt eingestellt. Warum kommt der Ton dann nur als PCM an meinem Receiver an?

    * Wie stelle ich denn hier den Viewport ein (Flimmerkante bei SD oben wegschneiden)?

    * Wake-Up-Methode ist ACPI. suspend to ram gibt es nicht als Option. Eine andere Lösung mit funktionierendem Netzwerk habe ich aber bisher nicht finden können.

    * tvscraper kann ich unter Plugins/Addons nicht finden, nur scraper2vdr. Letzterer scheint ja wenn dann nochmals ein riesen Akt zu werden?


    p.s.: Habe jetzt mal skindesigner und shady (die ich unter ya wegen Versionskonflikt noch nicht testen konnte) aktiviert. Da kommt jetzt

    Code
    1. Feb 6 15:16:03 easyVDR easyvdr-systemstart: show easyvdr-logo
    2. Feb 6 15:16:03 easyVDR view-picture: start up
    3. Feb 6 15:16:03 easyVDR easyvdr-systemstart: delay lircd 2 s
    4. Feb 6 15:16:03 easyVDR view-picture: load_image_gtk: File not found or Permission error: /usr/share/easyvdr/images/easyvdr-logo.png

    Recht hat er: Der Link zeigt in die Luft...

    Woher wisst ihr den jetzt schon wieder, wie ich das gemessen habe? Das wäre wenn dann erst mal zu hinterfragen.


    Aber egal, Fakt ist, dass die Kiste tendenziell im suspend to ram weniger Leistung aufnimmt, als im poweroff. Bei der alten 0.5 sind's da sogar nur 0,7W, nach 'meiner' Messmethode...


    Und das eigentlich Thema hier war, meinem frischen yaVDR 0.6.2 die sporadischen Tonaussetzer abzugewöhnen. Jetzt habe ich mich auf die Neuinstallation mit easyVDR eingelassen und nun helft mir bitte, die auf einen vergleichbaren, dann hoffentlich besser funktionierenden, Stand zu ziehen.


    Jetzt muss ich erst mal noch meine Video-Partition einhängen, suspend to ram aktivieren und klären, warum ich statt Passthrough nur PCM-Ton habe. Letzteres erübrigt sich eventuell nach Installation des skindesigner, tvscraper bzw softhddevice(-openglosd) usw.? Hat es nun irgend welche Nachteile, wenn ich die Pakete via apt-get draufziehe, statt per easy Portal?


    Ich guck mir dann wohl erst mal an, was über's easy Portal geht...

    Mal noch nebenbei: Ich habe jetzt schon ein paar Tage ein Energiemessgerät vorm VDR hängen, ursprünglich um mal zu sehen, was das suspend to ram 'kostet'. Jetzt ist mir nebenbei aufgefallen, das die Kiste im suspend to ram weniger Leistung (ca. 2.1W) aufnimmt, als im poweroff-Zustand (ca. 2.8W). Da stimmt doch bei den neueren Ubuntus (im Zusammenspiel mit meiner HW) generell was nicht, mit dem Energiemanagement? Ist - wie gesagt - selbst bei der 18.04 offenbar noch so.

    So, die easyvdr-3.5.02-64-stable.iso ist jetzt ganz grob drauf. Noch habe ich nur gerootet und die lircd.conf, channels.conf und timers.conf übertragen.


    Auch diese Installation hat das Problem, aus dem poweroff nicht wieder mit Netzwerk hochzukommen, also z.B. beim Aufwachen durch Timer. Müsste ich also auch zu dem Trick mit suspend to ram greifen. Wie geht das hier?


    Meine lircd.conf passt(e) nicht ganz, aber jetzt fehlt mir praktisch nur noch die Guide (bisher KEY_EPG), die das aktuelle Programm öffnete.
    p.s.: Das ist die Erbschaft einer uralten Videorekorderfernbedienung, die sich bis auf meine Harmony/Hub vererbt hat. Möchte ich ungerne ändern, zumindest solange das neue System noch nicht sauber steht.


    Gemountet ist z.Z. offenbar nur die Systempartition (28G), erweiterte hat er zwar angelegt, werden aber offenbar nicht verwendet:

    Also mounte ich als nächstes meine 'alte' Videopartition auf der zweiten Platte und verbiege /video0 da hin?


    Ton habe ich z.Z. offenbar nur PCM (ProLogic), obwohl ich bei der Inst. Passthrough gewählt und alle höherwertigen Tonformate selektiert hatte?


    Und Skin ist jetzt erst mal Anthara (Flimmerzeilen am oberen Bildrand bei SD). skindesigner, tvscraper usw. kann/darf ich jetzt einfach per apt-get nachrüsten?

    Die Partitionen musst du nicht leeren, du kannst manuell partitionieren. Und auch nur installieren ohne Video-Partition geht und diese dann erst mounten nach dem Reboot nach dem easyvdr Setup.

    Hatte es jetzt zunächst noch mit der komplett departitionierten Platte und automatischer Partitionierung versucht: Wieder hängen geblieben. Dann manuelle Partitionierung, wobei er da meckerte, dass schon ein Ubuntu drauf sei. Also löschen und...er installierte ohne weitere Nachfrage offenbar auf Basis der vorherigen Partitionierung einfach los...Na ja...

    Noch ist er dabei. Ich habe jetzt mal 'serieller an ttyS0 (com1)' für meinen Atric/Seriell gewählt und 'Linux-Media-Experiment' für meine Cine S2. Zu meiner Graka. hat er mich auch schon befragt, da habe ich die Treiber des easyVDR-ppa gewählt. Alles ja schon mal nicht so easy (für mich). Jetzt gucken wir mal, wie das endet...

    Schon Tipps, wie ich anschliessend meine lircd.conf etc. rüber bekomme (ssh-(root)-Zugang)?

    S. Oben, wenn der Pcie Bus zu stark runtertaktet gab es Probleme mit Nvidia bei AMD . Das kann sich z. B. zur 0.5 unterscheiden.

    ...

    Du kannst ja mal komplett das runtertakten deaktivieren. Und im Uefi alles mit Speedstep...

    Du meinst u.a. so?

    Code
    1. /etc/rc.local +
    2. sleep 120 # Give CPU startup routines time to settle.
    3. echo performance | tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

    Das hat weder Einfluss auf die Kanalumschaltverhaspelungen der alten 0.5 noch auf die Tonaussetzer der 0.5 + dist-upgrade bis neu 0.6.2.

    Btw: was ist an einer Live-DVD schlimm zu testen?

    Nur weil easyvdr Ubuntu nutzt, muss nicht jede Config gleich der bei ya sein.

    ...

    Mir war u.a. nicht klar, dass die ISOs offenbar alle Live-fähig sind. Aber das Testen bringt dann ohne FB und Medien auch erst mal wenig...

    Ich habe mir jetzt die easyvdr-3.5.02-64-stable.iso gezogen und versucht zu installieren. Ist im ersten Ansatz ist das daran gescheitert, dass die vorhandenen Partitionen der Zielplatte nicht ausgehängt werden konnten. Muss ich die echt erst manuell leeren?

    Ja, und zumindest das Netzwerk erkennt auch dieser Installer nur nach einem Warmstart. Ein Phänomen wurde also schon mal erfolgreich vererbt...


    p.s.: Die easyvdr-3.5.02-64-stable.iso behauptet übrigens durchgängig eine 3.0 zu sein?

    Kannst du doch selbst gestalten, ist doch kein Problem. Das Wiki ist sehr gut beschrieben und learning bei doing ist da ein großer Faktor, kaputt machen kann man nix ;)

    Jo, klar, kein Problem - Danke!?


    btw.: Mir fehlen jede Menge Senderlogos. Gezogen habe ich die via apt-get install skindesigner-logos fonts-ds-digital. Es fehlen z.B. 'BR Fernsehen Nord HD', 'Pro7 MAX', 'NITRO' usw.

    Das sagt überhaupt nichts aus, zu den Problemen was du ständig schilderst. Mit den angeboten Lösungsvorschlägen befasst du dich auch nicht, z.B. gegenchecken mit der Live-DVD. Die Aussage was alles mit 0.5 ging bringt dabei herzlich wenig.

    Wieso? Damit ist zumindest klar, dass es nicht an der Hardware liegt - oder nicht? Ich habe doch schon diverses aufgegriffen, wie z.B. den Kernel hochgezogen. Und wenn beispielsweise mit dem aktuellsten Ubuntu das Problem mit der Netzverbindung immer noch da ist, warum soll das dann in irgend einer davon abgeleiteten Dispri. dann weg sein?

    Ja, ich mag nicht mal eben noch was ganz neues ausprobieren. Ich wette mit easyvdr gibt's auch wieder irgend welche Problemchen. Und da muss ich mich in die 'Details' dann erst wieder reinfuchsen.

    Entschuldigung, aber anders herum könnte ich nun sagen, versucht doch mal bitte ein bisschen mehr auf meine Gegebenheiten einzugehen, statt gleich den Holzhammer vorzuschlagen.

    Du hast Empfangsprobleme. Sonst gäbe es kein Frontend Timeout...

    Nochmals Entschuldigung, aber ich habe (offensichtlich) keine Empfangsprobleme und die Tonaussetzer treten auch beim abspielen von Aufnahmen auf, immer an anderen Stellen...


    Vielleicht bin ich ja wirklich zu stur, unfähig etc. Dann ignoriert mich doch bitte einfach. Jedenfalls sollten wir uns nicht mit gegenseitigen Vorwürfen zuposten, das macht doch keinem Freude.