Posts by UnWitt

    Hi,
    hat schon jemand eine Lösung für das reboot-Problem gefunden?
    Wie geht es weiter, wenn ich
    debtool -i lilo
    eingegeben habe?
    oder gibt es gar die Möglichkeit eine ältere Version von Grub (0.91 z. B.) draufzuspielen?
    Grüße
    UnWitt


    @ Cosmonova: den Thread über den Patch habe ich nicht finden können :-/

    Hallo, in diesem Beitrag möchte ich schrittweise erklären wie ich auf meinem alten 600er Rechner LinVDR 0.5 mit dem Plugin nvram-wakeup v0.91 installiert habe.
    Ich erzähle an dieser Stelle nichts neues weil alle Informationen die ich dafür benötigt habe immer hier irgendwo im Forum zu finden waren.


    Grundsätzliches für die allerlesefaulsten unter uns:
    - LinVDR ist eine minimale Distribution und ist damit eigentlich nicht für die installation weiterer, nicht vorgesehener Plugins gedacht. Um nvram-wakeup zu installieren muß man also ein kleines Bißchen in den Eingeweiden der Distribution herumwühlen.
    - Es wird von LinVDR bereits eine Weckfunktion über ACPI unterstützt. Bevor man sich also an nvram-wakeup haranwagt sollte man testen ob diese Funktion nicht vielleicht funktioniert.
    - Für beide Varianten (ACPI oder nvram-wakeup) muß man den LinVDR über den ATX-Powerknopf oder über die Power-Taste der Fernbedienung (über die Tastatur für gewöhnlich F12) ausschalten. Nicht über das OSD(OnScreenDisplay) Menü.
    - Als nvram bezeichnet man den nicht flüchtigen Speicher der Hauptplatine, also auch den Bereich, der mit den Aufweckzeiten beschrieben wird. Das Plugin, das dieses Beschreiben übernimmt, heißt nvram-wakeup.


    Und hier die Fehler, die ich erschlagen mußte:
    - Zunächst habe ich versucht irgendeine Version von nvram-wakeup zu installieren. Es funktioniert aber nur mit den beiden weiter unten aufgeführten Files. Nvram-wakeup 0.91 und der Kernel 4.2.21.
    - Dann hat meine Firewall auf dem Windowsrechner die Netzwerkkommunikation verhindert.
    - Danach habe die runvdr Datei mit dem Texteditor nano editiert. Nano interpretiert aber beim speichern irgendwelche Zeilenumbrüche und macht damit die runvdr unbrauchber. Mit dem Texteditor innerhalb des MidnightCommander hat es funktioniert.
    - Nvram-wakeup schreibrt nur eine Zeit ins BIOS wenn sie mindestens 10 Minuten in der Zukunft liegt.


    Rechner für LinVDR 0.5
    AMD Athlon 600
    Asus K7M
    DVB-s Karte
    20 GB IBM IDE Festplatte
    10 Mbit Netzwerkkarte


    Netzwerkverbindung zum Hauptrechner
    ISDN Internetzugang über den Hauptrechner (Win XP Pro)


    Zunächst habe ich im BIOS die Funktion Wake on Alarm aktiviert. Wobei ich mir vorstellen könnte, daß nvram-wakeup dies auch übernehmen könnte. Wenn es die Daten ins Bios schreiben kann warum sollte es dann nicht auch den Vermerk enabled an die richtige Stelle schreiben können.
    Nachdem ich dann von der LinVDR 0.5 Installations-CD gebootet und das Setup nebst Netzwerk- und Samba-Einstellungen durchgelaufen habe hat mein Fernseher schon ein Bild wiedergegeben.


    Nun konnte ich mich nach Auswahl einer Konsole (z.B. Alt-F1) in das System einloggen.
    Benutzername: root
    Kennwort: linvdr
    root ist gewissermaßen für Linux das, was für Windows NT und Konsorten der administrator ist. Vorteil: root darf alles
    Nachteil: root darf auch alles kaputt machen


    Hier habe ich dann nochmal „setup“ aufgerufen und den DNS-Server nachträglich eingetragen weil der bei der Installation nicht nachgefragt wird (wurde offenbar vergessen). Für das Gateway und den DNS-Server habe ich die IP's meiner Windowsmaschine eingetragen.
    Weil die Verkabelung und die Netz/Sambaeinstellungen korrekt waren konnte ich (nachdem ich die Firewall unter Windows deaktiviert hatte) auf die freigegebenen Ordner des LinVDR zugreifen.
    Nun habe ich auf meinem Hauptrechner eine Verbindung zum Internet hergestellt und drei Dateien heruntergeladen:


    1.den Kernel 2.4.21
    http://linvdr.org/download/lin…nvdr-kernel-2.4.21.tar.gz
    2.speziell für den 2.4.21er Kernel kompiliertes nvram-wakeup 0.91 Paket
    http://www.dpfeil.de/
    3.Putty
    http://www.chiark.greenend.org…atham/putty/download.html


    aufgrund einiger Anfragen im Forum wurde das Plugin nvram-wakeup 0.91 für LinVDR 0.4 kompiliert und in oben genanntes Paket gepackt. Vollbracht hat dies matrix79 aus dem VDR-Portal (Applaus Applaus).
    Da LinVDR 0.5 aber den Kernel 2.4.23 hat und dieses nvram-wakeup Paket damit nicht funktioniert muß der alte Kernel installiert werden.
    Da ich auf die Weiterentwicklung des 2.4.23er Kernels gut verzichten konnte war das ja kein Beinbruch.


    Um das Browsen auf dem LinVDR Rechner für den Linuxunerfahrenen etwas gemütlicher zu gestalten und um Konfigurationsdateien zu editieren habe ich auf dem LinVDR den MidnightCommander installieren und auf dem Hauptrechner das Programm Putty gestartet (EXE-Datei, braucht nicht installiert werden)
    Bei Putty mußte ich nun lediglich die IP-Adresse des VDR eingeben und hatte dann die Befehlszeile des VDR auf meinem Windows-Bildschirm.
    Um dem MidnightCommander zu installieren habe ich nun (bei bestehender Internetverbiudung) folgendes auf dem VDR eingegeben:


    linvdr:/# debtool -u
    linvdr:/# debtool -i libgpmg1 libglib1.2 file mc mc-common


    Nun habe ich die beiden heruntergeladenen Pakete übers Netzwerk in das Export Verzeichnis des LinVDR geschickt und mich dann wieder Putty zugewandt.
    linvdr:/# cd ..
    linvdr:/# cd ..


    um auf das Stammverzeichnis zu kommen,


    linvdr:/# tar -xzvf pub/export/linvdr-kernel-2.4.21.tar.gz


    Entpakt den Kernel und setzt die entsprechenden Links im Verzeichnis /boot


    linvdr:/# tar -xzvf pub/export/nvram_for_linvdr-0.4.tar.gz


    Installiert das Device /dev/nvram, das Kernelmodul nvram.o, ändert die Datei /etc/modules, setzt die Links in /boot auf den nvram-Kernel und kopiert die Datei vdrshutdown nach /usr/bin


    Nun mußte die Datei /etc/init.d/runvdr geändert werden. Hier habe ich den Fehler begangen und den Texteditor Nano genommen. Nano interpretiert beim speichern irgendwelche Zeilenumbrüche und macht auf diese Weise die ganze runvdr-Datei unbrauchbar und das System läuft nicht mehr an.
    Also habe ich den MidnightCommander (mc) genommen. (Mit der Taste TAB kann man übrigens die Bildschirmhälften wechseln und mit F4 wird die angewählte Datei editiert.)


    Die Zeile
    $BINDIR/vdr -L $PLUGINDIR $PLUGINS -v /video0 -c $CONFDIR -w 900 -E /ramdisk/epg.data -s /usr/bin/poweroff.pl < /dev/tty$vdrtty


    muß folgendermaßen geändert werden:


    $BINDIR/vdr -L $PLUGINDIR $PLUGINS -v /video0 -c $CONFDIR -w 900 -E /ramdisk/epg.data -s /usr/bin/vdrshutdown < /dev/tty$vdrtty


    poweroff gibt die Anweisung den Rechner auszuschalten.
    vdrshutdown gibt die Anweisung die Aufweckzeit des nächsten Timers ins Bios zu schreiben und dann auszuschalten.


    Beim nächsten Shutdown über die Power-Taste der Fernbedienung (F12 auf der Fernbedieungsersatztastatur) bzw. dem ATX-Powerknopf am Gehäuse sollten nvram-wakeup nun laufen und die Aufweckzeit ins BIOS schreiben. Bitte beachten, daß die Aufweckzeit mindestens 10 Minuten in der Zukunft liegen muß, sonst kümmert sich nvram-wakeup nicht ein Bißchen.
    Überprüfen kann man dann die neue Aufweckzeit wenn man mal ins BIOS geht und nachschaut.


    Wichtig ist auch daß man über das OSD
    Einstellungen/Sonstiges/Mindest Benutzer-Inaktivität (min): 0
    auf 45 Minuten oder so einstellt damit er nach der Aufnahme herunterfährt.
    Wenn es keine Benutzeraktivitäten während der Aufnahme gab fährt er wenn ich richtig informiert bin auch schon nach 5 Minuten herunter jedoch nicht wenn der Wert auf 0 stehen hat.


    So, ich hoffe ich habe nichts vergessen. Als ich diesen Thread verfasst habe war ich übrigens selbst noch ein Newbie und habe manche Tatsachen vielleicht nicht so gesehen wie sie jemand sehen würde, der den Durchblick hat. Also bin ich für Verbesserungen und Aufklärungen immer dankbar.


    Achso, wenn man auf der Konsole den Befehl logread eingibt kann man das Logbuch seit dem letzten Start lesen, falls mal etwas nicht geht und man wissen möchte, was es ist.


    Die Moral von der Geschicht:
    Nvram-wakeup habe ich tatsächlich installiert bekommen aber wenn bei manchen von Euch der Rechner trotzdem nicht anspringt wie bei mir :) wird es warscheinlich daran liegen, daß Eure Hauptplatine auch einen Neustart braucht um die neue Aufweckzeit zu „begreifen“.
    An dieser Sache bin ich selbst noch zugange aber Ihr könnt zumindest Klarheit darüber erhalten ob Euer Board einen Reboot braucht indem ihr:


    -die datei nvram-wakeup-mb lest, vorausgesetzt Euer Board ist dort zu finden. (müßte im nvram-wakeup Paket oder, noch aktueller, auf der Internetseite von nvram-wakeup zu finden sein)
    Da stehen dann solche Sachen drin wie :
    void asus_k7m(struct biosinfo *b)
    {
    CHECKSUM(b, 0x30);
    TIMEREGS(b, 0x57);
    b->need_reboot = ON_ANY_CHANGE;
    b->addr_stat = 0x56;
    b->rtc_day = 0x6F;
    b->reset_day = ON;
    b->shift_stat = 4;


    -Den Computer nach dem Ausschalten erneut einschaltet und beim ersten Pieps des Speakers wieder ausschaltet auf diese Weise funktioniert das Aufwachen bisher bei mir. Soll natürlich nicht so bleiben.


    So. Hoffe das hat geholfen. Bewertet mich (und den Thread) recht nett :fans
    Ciao


    UnWitt

    An alle sie es sonst noch interessieren könnte,
    Bei LinVDR 0.5 ist der Bootmanager GRUB im Einsatz und der befindet sich samt Grub.config in dem Verzeichnis /boot/grub.
    War ja wirklich nicht so schwer...........

    Hallo,
    an dieser Stelle hätte ich eine grundsätzliche Frage:
    wie richte ich eine der beiden Varianten in LinVDR 0.5 ein? Bzw. wo kann ich den Poweroffkernel bekommen und welchen Bootmanager hat Linvdr?
    Ciao


    UnWitt

    Hallo,
    habe mithilfe dieses Threads erfolgreich NVRAM-Wakeup auf meinem LinVDR 0.5 zum laufen gebracht aber leider habe ich noch ein
    Problem: Mein Board braucht auf jeden Fall einen Reboot nachdem die Zeit im Bios eingetragen wurde.
    Ich habe das Forum mit der nützlichen :suche -funktion tüchtig gefilzt und bin auch, sagen wir mal, fragmentweise fündig geworden.
    Die Begriffe "Grub" und "Poweroffkernel" habe ich jetzt immerhin schon mal gelesen aber welche Einstellungen oder Änderungen sind denn nun notwendig um den Rechner nach dem Herunterfahren über die Power-off Taste der FB bzw. nach Inaktivität für einen kurzen Moment wieder hochzufahren damit sich die Werte im Bios "festigen"?.
    Sorry, falls ich wieder blind gewesen sein sollte.
    Grüße


    UnWitt

    Tach,
    also wenn die Moderation nichts dagegen hat würde ich wie versprochen einen eigenen Beitrag eröffnen mit dem oben genannten Titel.
    Es soll eigentlich nichts anderes als eine Sammlung der Informationen die ich hier im Forum gefunden habe mit kleinen Erläuterungen aus der Sicht eines Anfängers incl. aller meiner Fehler die mir so untergekommen sind.
    Aber, ich brauche Zeit dafür.
    Vielleicht gehe ich sogar das Risiko ein und mache das LinVDR nochmal neu. 8oDamit ich auch nichts vergesse.
    Grüße

    Leute, ich nehme alles zurück.
    ich habe seit dem letzten Versuch gar nichts an meinem System verändert und gerade eben noch einmal auf den Power-off knopf der Fernbedienung (oder besser gesagt Tastatur) gedrückt und schon hat es gefruchten. Ob da in den letzten 24 Stunden irgendwas verheilt ist oder was............
    Nicht nur das, er hat auch tatsächlich eine neue Weckzeit ins Bios geschrieben.
    Jetzt muß ich zunächst mal noch etwas herumtesten und ausprobieren bis ich mich wieder melde.
    Vielen herzlichen Dank und bis bald. :fans

    Hi,
    mal sehen, was die sagen:


    linvdr:~# nvram-wakeup --debug
    nvram-wakeup: Printing debug messages enbled.
    nvram-wakeup: $Id: nvram-wakeup.h,v 1.26 2003/08/07 17:14:40 bistr-o-math Exp $
    nvram-wakeup: $Id: nvram-wakeup-mb.h,v 1.115 2003/03/18 13:44:04 bistr-o-math Exp $
    nvram-wakeup: $Id: nvram-wakeup.c,v 1.60 2003/08/06 13:46:32 bistr-o-math Exp $
    nvram-wakeup: Opening /dev/mem in O_RDONLY mode...
    nvram-wakeup: _DMI_ table found: base: 0xF04F0, size: 0x86A, count: 30
    nvram-wakeup: Following DMI entries found:
    nvram-wakeup: - Mainboard vendor: ASUSteK Computer INC.
    nvram-wakeup: - Mainboard type: K7M
    nvram-wakeup: - Mainboard revision: 1.XX
    nvram-wakeup: - BIOS vendor: American Megatrends Inc.
    nvram-wakeup: - BIOS version: 627.10
    nvram-wakeup: - BIOS release: 02/29/2000
    nvram-wakeup: Using following bios info:
    nvram-wakeup: need_reboot = -1
    nvram-wakeup: addr_chk_h = 0x30
    nvram-wakeup: addr_chk_l = 0x31
    nvram-wakeup: addr_chk_h2 = 0x00
    nvram-wakeup: addr_chk_l2 = 0x00
    nvram-wakeup: addr_stat = 0x56
    nvram-wakeup: addr_mon = 0x00
    nvram-wakeup: addr_date = 0x57
    nvram-wakeup: addr_wdays = 0x00
    nvram-wakeup: addr_hour = 0x58
    nvram-wakeup: addr_min = 0x59
    nvram-wakeup: addr_sec = 0x5A
    nvram-wakeup: shift_stat = 4
    nvram-wakeup: shift_mon = 0
    nvram-wakeup: shift_date = 0
    nvram-wakeup: shift_wdays = 0
    nvram-wakeup: shift_hour = 0
    nvram-wakeup: shift_min = 0
    nvram-wakeup: shift_sec = 0
    nvram-wakeup: rtc_time = 0
    nvram-wakeup: rtc_date = 0x6F
    nvram-wakeup: rtc_mon = 0x00
    nvram-wakeup: rtc_date_0_is_c0 = 0
    nvram-wakeup: rtc_mon_0_is_c0 = 0
    nvram-wakeup: reset_date = 1
    nvram-wakeup: reset_mon = 0
    nvram-wakeup: nr_stat = 1
    nvram-wakeup: nr_mon = 4
    nvram-wakeup: nr_date = 5
    nvram-wakeup: nr_hour = 5
    nvram-wakeup: nr_min = 6
    nvram-wakeup: nr_sec = 6
    nvram-wakeup: nr_rtc_date = 6
    nvram-wakeup: nr_rtc_mon = 5
    nvram-wakeup: nr_wdays = 7
    nvram-wakeup: bcd = 0
    nvram-wakeup: date_no_chk = 0
    nvram-wakeup: date_hack = 0
    nvram-wakeup: Opening /dev/rtc in O_RDONLY mode...
    nvram-wakeup: Hardware clock: 2004-03-16 20:13:11
    nvram-wakeup: rtc.tm_isdst : 0
    nvram-wakeup: rtc.tm_gmtoff: 3600
    nvram-wakeup: diff : 0
    nvram-wakeup: RTC is running in localtime!
    nvram-wakeup: Test (this should be the current time of the hardware clock): Tue Mar 16 20:13:11 2004
    nvram-wakeup: Opening /dev/nvram in O_RDONLY mode...
    nvram-wakeup: The size of /dev/nvram is 114 bytes.
    nvram-wakeup: value of the addr_stat byte is: 0x12.
    nvram-wakeup: value of the addr_date byte is: 0x26.
    nvram-wakeup: value of the addr_hour byte is: 0x14.
    nvram-wakeup: value of the addr_min byte is: 0x0A.
    nvram-wakeup: value of the addr_sec byte is: 0x00.
    nvram-wakeup: value of the rtc_date byte is: 0x06.
    nvram-wakeup: value of the addr_chk_h byte is: 0x08.
    nvram-wakeup: value of the addr_chk_l byte is: 0xF8.
    nvram-wakeup: Checksum is: 0x08F8.


    All values are displayed as they are stored in the nvram/rtc.
    (and do not correspond necessarily to the system date/time)


    WakeUp : Enabled (0x12)
    Date : 06 (0x26)
    Hour : 20 (0x14)
    Minute : 10 (0x0A)
    Second : 00 (0x00)
    rtcDate : 06 (0x06)
    Checksum: 0x08F8


    linvdr:~# biosinfo
    Mainboard:
    Vendor: ASUSteK Computer INC.
    Type: K7M
    Version: 1.XX
    BIOS:
    Vendor: American Megatrends Inc.
    Version: 627.10
    Release: 02/29/2000
    linvdr:~# ismod
    -bash: ismod: command not found


    was soll man dazu sagen............


    Das System habe ich übrigens folgendermaßen aufgebaut:


    Plan A:
    ich hatte zunächst LinVDR 0.5 installiert und wollte dann NVRAM dazupacken.
    Also habe ich gemäß Anleitung das spezielle Kernelpaket für NVRAM und danach NVRAM selbst entpackt.
    Das hat nicht geklappt und ich habe die Schuld LinVDR 0.5 gegeben. Der Fehler lag aber nicht am LinVDR 0.5 sondern am Texteditor Nano, welchen mir wie gesagt die RUNVDR zerschossen hat.
    Das wußte ich aber da noch nicht also habe ich es nochmal von neuem versucht.


    Plan B:
    Diesmal habe ich LinVDR 0.4 installiert, den speziellen Kernel entpackt, NVRAM-Paket entpackt und danach ein Upgrade auf LinVDR 0.5 gemacht.
    Vielleicht liegt ja dort irgendwo der Hund begraben.


    Also wenn wirklich niemand auf Anhieb weiß, woran es liegen könnte versuche ich es nochmal nach Plan A bevor wir uns hier alle verbiegen.


    @Charly
    wir schreiben unse Berichte noch :)


    Grüße

    Hi,
    /dev/nvram existiert auf dem Rechner. Ich hatte auch das Paket von Matrix nichtsdestotrotz ein zweites Mal entpackt. Daran dürfte es demnach nicht liegen.
    Allerdings wüßte ich nicht wie ich an den Lese/Schreibrechten was verändert hätte.
    Grüße


    p.s. Das eine sage ich Euch, wenn ich dies hier heil überstehe mache ich nicht nur ein Faß sondern auch einen Beitrag auf: "NVRAM und Linvdr 0.5, der Steinige Weg eines Anfängers zum Erfolg"
    hoffen wir, daß es dazu kommt

    Hallo, an dieser Stelle möchte ich doch auch mal mein Problem an den Mann bringen.
    rell  :)
    Habe ja "nvaram" auf meinem Linvdr (inzwischen 0.5) installieren können und nun bin ich auch bei diesem Shutdownproblem angelangt.
    Der Texteditor "nano" war übrigens auch bei mir genau das richtige Tool um die "runvdr" zu zerschießen.
    Aber zurück zu meinem Problem, äußert sich genau wie bei den anderern ich drücke die Power-Taste auf meiner Tastatur, auf dem Fernsehschirm kommt die Meldung, daß man den Shutdown unterbrechen kann und weiterhin passiert nichts.


    Also habe ich "logread" eingegeben und dort stand ziemlich am Ende:
    user.info executing 'usr/bin/vdrshutdown 0 0 0 "" 1'
    user.err nvram-wakeup[198]: /dev/nvram: No such device


    als Kernel habe ich den von matrix79 extra kompilierten .21er


    Im Moment habe ich das Gefühl nur in kleinen Schritten voran zu kommen. Naja, mühsam ernährt sich das Eichhörnchen.:versteck

    öhm. Soviel zum Thema eine dumme Frage zweimal fragen........
    Sei herzlich bedankt und geknuffelt oder was ihr da immer so macht.
    Ich werde dort gelerntes direkt anwenden.

    rell ,
    "runvdr" habe ich mit "nano" editiert.
    also wenn "nvram" bei Dir läuft, sollten wir uns vielleicht mal Online unterhalten.
    Dieser Beitrag hat sich langsam zu einem Monster entwickelt und ich verliere ehrlich gesagt langsam den Überblick.
    Wäre mir äußerst peinlich eine Frage hier ein zweites Mal zu stellen.
    Neue Erkenntnisse aus Sicht eines völligen Anfängers könnte ich ja dann immernoch hier anbringen.

    Hi, bin neu hier. Folgendes Problem:
    habe NVRAM für die LinVDR Version 0.4 Installiert.
    wann genau sollte NVRAM die nächste Startzeit ins BIOS schreiben? Beim Shutdown schätze ich.
    Weil: Wenn ich den Timer programmiert und übers OSD den Apparat abgeschaltet habe wurde die nächste Aufweckzeit im BIOS nicht aktualisiert.


    Ich bin ja schon froh, daß ich überhaupt wieder ein Bild habe.
    NVRAM zu installieren habe ich nach langem hin und her endlich hingebogen bekommen. Aber sobald ich die runvdr editiert ("poweroff.pl" durch "vdrshutdown" ersetzt) hatte, bekam ich auf dem Fernseher kein Bild mehr. Rückgängigmachen dieses Eintrags hat übrigens nicht geholfen.


    "Biosinfo" zeigt mir an, daß mein Asus K7M erkannt wird.