Posts by elmicha

    Ich hab's geschafft, aber ich weiss nicht genau, was davon überflüssig ist und was nötig:


    In /etc/default/vdr (das wird bei Ubuntu vor dem Start von /usr/bin/vdr gesourcet):

    Code
    1. export DISPLAY=:0


    In /etc/pulse/client.conf:

    Code
    1. auto-connect-localhost = yes
    2. auto-connect-display = yes


    Bei meinem normalen Desktop-User in einem Skript, das nach dem Desktop-Login gestartet wird (bzw. in den "Startprogrammen" bei Ubuntu):

    Code
    1. xhost +si:localuser:vdr
    2. pacmd load-module module-native-protocol-tcp


    Dieses tcp-Modul liess sich weder mit paprefs noch mit einem Eintrag in /etc/pulse/default.pa automatisch laden.


    Für das Softhddevice steht in /etc/vdr/plugins/plugin.softhddevice.conf:

    Code
    1. -s -g 671x378--7--7 -v va-api


    Um das Fenster dann auf dem Desktop anzuzeigen:

    Code
    1. svdrpsend plug softhddevice resu

    Ich hatte dasselbe Problem. Nach

    Code
    1. xhost +si:localuser:vdr
    2. svdrpsend plug softhddevice atta


    (als User, dem das Display gehört) bekomme ich jetzt ein Bild, yippi! "vdr" ist der User, unter dem der vdr läuft.


    Das Bild ist wirklich sehr gut (SD und HD). Unter 5% CPU (1,6 GHz) bei Fullscreen 1080i. Mausklick wechselt zwischen Fullscreen und Fenster, und die Fenstergrösse lässt sich auch ganz normal ändern.


    Jetzt fehlt mir nur noch der Ton. Da muss ich vermutlich dem pulseaudio beibringen, dass es den User vdr auch zulässt, aber wie?

    Mit dem aktuell auf www.dvbsky.net/Support.html verlinkten linux-3.0-media-20111024-bst-111205.tar.gz geht femon hier offenbar bei den SD-Sendern - die Werte sehen jedenfalls ähnlich aus wie mit meiner alten TeVii-Box.


    Bei den HD-Sendern ist STR immer 0% und BER wechselt ständig zwischen 0000... und ffff.... Nur bei Einsfestival HD ist STR 94% und SNR wechselt zwischen 64 und 72% .


    Bild und Ton sind jedenfalls einwandfrei, und die Fernbedienung geht auch (siehe Schnipsel für die lircd.conf im Anhang).


    Auf der Fernbedienung gibt's allerdings keine Tasten für Rot/Grün/Gelb/Blau und Lautstärke.

    Files

    • mystique.conf

      (2 kB, downloaded 212 times, last: )

    Ah ups, sorry, wenn der Eindruck entstanden ist, dass ich der Autor sei. Der Autor ist Thomas Edelmann, siehe den "Offizielle Webseite"-Link auf Androlib bzw. im Android Market. Da auf seiner Site noch nichts zu VDRoid zu finden ist, ist das Programm wohl noch sehr neu.


    Gerade ist ein Update auf Version 1.0.3 rausgekommen, wo der Absturz bei falscher IP-Adresse nicht mehr vorkommt.

    Das Problem hatte ich auch, als ich die IP-Adresse falsch eingegeben hatte. Nach Deinstallation, Neuinstallation und Eingabe der richtigen IP-Adresse hat's dann geklappt.

    Hi,


    ich weiss, das Thema ist alt - aber vielleicht hast Du das Ding ja noch in der Ecke rumliegen in der Hoffnung, dass sich noch was ergibt.


    Ich hatte dasselbe Problem - sporadisch kam diese Meldung "vp7045: USB control message 'out' went wrong.", meist direkt nach dem ersten Zugriff.


    Irgendwann kam mal die Meldung "hub 2-1.3:1.0: Cannot enable port 1. Maybe the USB cable is bad?". Nach einem kurzen Versuch mit einem anderen, "baugleichen" 5-Meter-Kabel hab' ich's mal mit einem 3-Meter-Kabel versucht.


    Und seit 2 Wochen ist das Problem jetzt nicht mehr aufgetreten.



    Michael

    Hallo Grégoire,


    ich habe noch 2.6.21, wollte aber auch von /proc/acpi/alarm wegkommen, da /proc/acpi/alarm ja bald wegfällt.


    Ich kann rtc-cmos laden und habe dann ein


    /sys/class/rtc/rtc0/wakealarm


    Das ist wohl die richtige Datei (siehe http://groups.google.de/group/linux.kernel/browse_thread/thread/53aec8e3cbf993e0/dfd1f4b664d640e8?lnk=st&q=%2Fproc%2Facpi%2Falarm+deprecated&rnum=1&hl=de#dfd1f4b664d640e8).


    Aber leider hat hier das Aufwecken bisher noch nicht funktioniert.


    Man soll wohl die Zeit in Sekunden reinschreiben (date +%s). Und wenn man ein zweites Mal reinschreiben möchte, muss man anscheinend zuerst einmal 0 reinschreiben.


    Und CONFIG_RTC muss wohl auf N stehen, siehe http://groups.google.de/group/linux.kernel/browse_thread/thread/53aec8e3cbf993e0/dfd1f4b664d640e8?lnk=st&q=%2Fproc%2Facpi%2Falarm+deprecated&rnum=1&hl=de#dfd1f4b664d640e8


    Vielleicht kommst Du ja damit weiter?


    Viele Grüsse...
    Michael

    Hallo,


    das Burn-Plugin ist super. Das einzige, was ich momentan ein bisschen vermisse, ist eine Datei-Grössenanzeige in der Liste mit den Aufnahmen, so dass man die Aufnahmen zusammen brennen kann, die zusammen ca. 4-5 GB ergeben.


    Ich hab' versucht, das hinzubekommen, aber einerseits sind meine C++-Kenntnisse schon sehr eingerostet, und andererseits habe ich keinen Schimmer von den zig Millionen Klassen, die das Burn-Plugin verwendet.


    Mit dem Patch werden die Dateigrössen ohne Beachtung der marks.vdr vor den Dateinamen in der Liste angezeigt:


    Code
    1. 17.07.06 19:59 [290.311] %@GoTV
    2. 18.07.06 21:37 [719.356] %@GoTV


    Deutlich netter wär's natürlich, wenn ich die Schnittmarken beachten könnte. In scanner.c gibt's eine class marks_scanner, mit get_total_size() und get_total_length() - eins davon würde wohl ungefähr passen. Der Constructor möchte einen recording_index& sehen. Aber wie kann ich das benutzen?


    Der angehängte Patch passt zu vdr-burn-0.1.0_pre21-r1.


    Viele Grüsse...
    Michael

    :mahlzeit


    Mein mysql läuft mit default-character-set = utf-8, deshalb hatte ich Probleme mit den Umlauten in xxv: alle Einträge in der Datenbank wurden beim ersten Umlaut abgeschnitten.


    Den Default-Characterset für mysql umzustellen, hatte ich keine Lust, weil dann ja die anderen Datenbanken wieder auf die Nase gefallen wären.


    Lösung: nur die xxv-Datenbank auf latin1 umstellen:


    In mysql (mysql -uxxv -pxxv xxv):



    Und in xxvd in der Zeile vor "return $dbh;" in "sub init_db_connect" (ganz am Ende von xxvd) einfügen:

    Code
    1. my $row = $dbh->selectrow_hashref("set NAMES 'latin1'");


    Nach Neustart von xxvd und Neu-Laden der Timer, Aufnahmen und Kanäle passt jetzt alles zusammen.

    Quote
    Code
    1. Aug 8 16:04:08 vdr kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
    2. Aug 8 16:04:08 vdr kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
    3. Aug 8 16:04:08 vdr kernel: ide: failed opcode was: unknown
    4. Aug 8 16:04:08 vdr kernel: ide0: reset: success


    Das sieht aber nicht gut aus. Ist DMA danach noch an? Bist Du sicher, dass das IDE-Kabel 80-adrig ist?