Posts by ecki

    Ich habe leider nur einen TV mit analogem Eingang. Aber das war ein guter Tip, ich habe verschiedene Kabel probiert, die ich noch rumliegen hatte und es waren deutliche Unterschiede im Rauschen. Das subjektiv beste Kabel für Analogempfang habe ich jetzt wieder an die DVB-C Karte angeschlossen und siehe da, ich habe auch auf S02 Empfang.


    An die Infrastruktur komme ich hier nicht so einfach ran. Da die abgeschlossen ist höchstens über den Hausmeister.


    Die verbaute Dose ist eine Astro GUT MMD 10 F, es geht ein direktes Kabel ohne Verzweiger von der Dose zur Karte.


    Mit etwas Glück ist das Problem mit dem getauschten Kabel aber schon gelöst.

    Ich bin auch frisch umgezogen und seit gestern Besitzer einer Digitaldevices C/T/T2 V7. Nach installieren der Treiber aus media_build_experimental funktioniert sie auch soweit. Allerdings bin auch ich nicht begeistert vom Empfang.
    Sender von S02 empfange ich gar nicht, S03 teilweise ok, teilweise mit starken Artefakten.
    Auch bei S38 (442MHz) kommt nix, im log steht nur frontend timed out.


    Das Mehrfamilienhaus ist relativ neu (ca 5 Jahre), es wird hier auch von Kabel Deutschland Internet mit 100Mbit verkauft.


    Gibt es irgendwelche Diagnosemöglichkeiten? Femon funktioniert mit den Treibern scheinbar nicht.


    Ursprünglich bin ich davon ausgegangen, dass DVB-C unproblematischer als DVB-S wäre.

    speefak
    Das stimmt so leider nicht. Jeder Tuner im VDR kann genau eine Frequenz (Transponder), nicht ein komplettes Band empfangen. Die ersten vier Clients können demnach komplett unabhängige Sender sehen. Falls aber jeder Client Sender von einem anderen Transponder empfängt, kann ein fünfter Client nur Sender von den 4 bereits getuneten Transpondern sehen.

    Das Webinterface vom jDownloader ist nicht wirklich gut, mit GUI ist es deutlich besser. Ich habe mir dafür nen vncserver installiert, der automatisch beim Systemstart jDownloader startet und ich mich bei Bedarf remote einklinke. Ich hatte es auch mit freeNX probiert, es aber nicht geschafft, dass eine grafische Session gestartet wird, ohne dass ich mich remote zumindest einmal einlogge. Falls jemand eine elegante Lösung mit FreeNX hat, immer her damit.


    Ich nutze dafür seit Jahren Debian mit den e-tobi Paketen. Als Clients nehme ich yaVDR, das Zusammenspiel klappt ohne Probleme. Beim reinen yaVDR ist der vorgesehene Upgradepfad nur über eine Neuinstallation, ärgerlich wenn man dann die anderen Serverdienste neu einrichten muss. Also würde ich ein Debian oder Ubuntu Server mit yavdr-repositories empfehlen. Alternativ kannst du auch drüber nachdenken, die Dienste in virtuelle Maschinen zu kapseln.

    Ich denke mal, das liegt am für root reservierten Platz auf der Platte. Die at-Jobs werden als user vdr geschrieben (bzw. nur angelegt, aber mangels Platz keine Daten). Die entsprechenden Fehlermeldungen landen aber als root im Log und dafür ist genügend Platz.


    Das Problem sollte sich für die Zukunft verzögern lassen, indem man den reservieren Platz auf 0 setzt:


    Code
    1. tune2fs -m 0 /dev/sdX

    Habe heute ein dist-upgrade gemacht. Dabei wurde nvidia-common von 285.05.09 auf 295.59 gebracht. Ich benutze 'Output to all devices'.


    Seit dem Update spielt XBMC keinen Film mehr mit Ton, beim Start kommt die Fehlermeldung "Failed to initialize audio device, check your audiosettings". Die 'Menütöne' in XBMC (also das klicken, wenn man den Menüpunkt wechselt) und VDR funktionieren problemlos.


    Hier mal das relevante XBMC-Log:


    ein aplay -l:

    Code
    1. **** Liste der Hardware-Geräte (PLAYBACK) ****
    2. Karte 0: NVidia [HDA NVidia], Gerät 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
    3. Sub-Geräte: 0/1
    4. Sub-Gerät #0: subdevice #0
    5. Karte 0: NVidia [HDA NVidia], Gerät 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
    6. Sub-Geräte: 0/1
    7. Sub-Gerät #0: subdevice #0
    8. Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
    9. Sub-Geräte: 0/1
    10. Sub-Gerät #0: subdevice #0


    Nach einem Downgrade auf die Ubuntu-Version 270.41.06 funktioniert Sound in XBMC mit ansonsten identischen Einstellungen. Ideen? Fehlen noch Infos?

    Ich hatte auch das Problem, dass der verlinkte segmenter nicht mit dem aktuellen ffmpeg kompilieren wollte.


    Glücklicherweise habe ich dann den Link von iNOB gefunden mit einer auf aktuelle ffmpeg's angepassten Version. Link


    Also die Anleitung auf der i-vdr.de Homepage mit dem aktuellen svn von ffmpeg spielt mit der segmenter-Version nicht zusammen. Vielleicht könnte das mal aktualisiert werden?

    Für mich ist das kein Problem. Dann löse ich das ggf. halt manuell auf, indem ich zum jeweiligen Gerät gehe. Aber wenn das Frauchen, Kind oder gar den besuchenden Schwiegereltern passiert (wenn ich nicht da bin), dann sind die völlig hilflos.


    Du kannst zum manuellen Einschalten auch mit der Harmony auf das Gerät gehen oder die An/Austasten auf das Displaymenü legen falls das öfter vorkommt.


    Ich habe aber letztens mal die von mir jahrelang erfolgreich ignorierte 'Help' Taste auf der Fernbedienung ausprobiert. Damit wird man durch ein Menü gelotst in dem die möglichen Probleme abgefragt ('Ist TV eingeschaltet?' etc.) und behoben werden. Ich denke, mal mit einem Hinweis auf diese Taste sollten sich die meisten Probleme auch von Laien beheben lassen.

    Wenn ich XBMC starte, läuft im Hintergrund vdr weiter und gibt auch weiter das aktuelle Programm aus. Es wird nur das Frontend beendet.


    Da ich den VDR als Streamdev-client betreibe, kann ich sehr gut beobachten, dass der Strem weiter vom Server gestreamt wird, wenn XBMC gestartet ist und der live-stream eigentlich gar nicht mehr gebraucht wird. Ich gehe davon aus, dass dies bei lokalen Empfangsgeräten dasselbe ist. Sie also weiter empfangen und das Bild des aktuellen Senders ausgeben, nur eben dass kein frontend da ist, welche die Daten darstellt.
    Es wird also immer eine Karte aktiv sein, welche nicht freigegeben wird und somit auch nicht durch dynamite deaktiviert werden kann.
    Suspendoutput sorgt jetzt dafür, dass statt des aktuellen Programms ein Standbild dargestellt wird, somit wird streamdev beendet und auch lokale devices sollten freigegeben werden.



    Möglicherweise habe ich hier auch nen Denkfehler und die Behandlung mit lokalen Devices läuft schon korrekt. Das kann ich mangels einer lokalen Karte leider nicht überprüfen.


    Mein Szenario ist in letzter Zeit eher so, dass ich unter 30% der Zeit live fernsehe und meist Aufnahmen schaue oder eben XBMC aktiv habe. In dieser Zeit fände ich es sinnvoll, wenn die devices auch nicht genutzt werden.

    Sorry, war nicht das beste Beispiel. Ich hatte nach einem möglichen Grund gesucht, warum man beim Start von XBMC nicht den VDR, sondern nur seine Live-Wiedergabe beenden sollte.


    Der zweite Grund mit dem LiveTV ist da wahrscheinlich etwas realistischer.

    Also ich selbst nehme auch alles auf dem Server auf. Allerdings kann ich mir Situationen vorstellen, wo es Sinn machen könnte. Beispielsweise wenn es einen Server für mehrere Parteien gibt, die jeweils ihre eigenen Aufnahmen machen wollen.


    Ein vielleicht nachvollziehbarerer Grund: Auf meinem Server läuft ein VDR mit minimalen Plugins. Die Plugins für LiveTV in XBMC ändern sich ja von Zeit zu Zeit, so dass ich diese ungern im Server installieren möchte. Der yaVDR holt sich also den Stream vom Server und stellt ihn lokal dem XBMC zur Verfügung. Dafür muss aber VDR weiter laufen.
    Das wird durch diese Methode nicht behindert. Also wenn XBMC gestartet wird, wird der Stream beendet. Wenn ich in XBMC LiveTV starte holt sich der VDR für diese Zeit wieder den Stream vom Server.

    Genau dasselbe Anliegen hatte ich auch. Nur war es mir zu radikal, den VDR gleich ganz zu beenden (falls z.B. per live-frontend doch mal ein Timer lokal gestartet werden soll). Stattdessen nutze ich das suspendoutput-plugin. Damit schalte ich die Wiedergabe auf dem VDR beim XBMC Start ab. Somit wird auch die streamdev-Verbingung beendet. Funktioniert bei mir super, ohne dass ich irgendwelche Nachteile oder Nebenwirkungen gefunden habe.


    Wie man das ganze macht, habe ich hier beschrieben. Ich hatte es auch als Feature-Request eingetragen, da ich keine Nachteile in dieser Methode finden konnte. In Zusammenhang mit dem dynamite Plugin sollte dies auch zu einer (kleinen) Stromersparnis führen, da während XBMC ausgeführt wird die DVB-Geräte abgeschaltet werden können. (Dies habe ich allerdings nicht getestet, da ich keine lokalen DVB-Geräte nutze.)

    Bist du denn sicher, dass du die Timer auch auf dem Server setzt? Nach dem Setzen im Client mal im Webinterface des Servers nachschauen.
    Standardmäßig werden die Timer nämlich weiter lokal gesetzt und du kannst sie auf den Server verschieben (wird im Timermenü als 'L' oder 'S' gezeigt).
    Ich sitze grad nicht am VDR, aber man kann in den Plugineinstellungen irgendwo angeben, dass er immer den Server für neue Timer nehmen soll.