Posts by leika

    aktuell versuche ich die Variante von etobi,


    ov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: VDPAU API version: 1

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: VDPAU information: NVIDIA VDPAU Driver Shared Library 390.116 Sun Jan 27 06:28:58 PST 2019

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: highest supported high quality scaling 1

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: feature deinterlace temporal supported

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: feature deinterlace temporal spatial supported

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: attribute skip chroma deinterlace supported

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: 4:2:0 chroma format with 4096x4096 supported

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: 4:2:2 chroma format with 4096x4096 supported

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: 8bit BGRA format with 16384x16384 supported

    Nov 14 15:17:05 vdrhd vdr[27513]: video/vdpau: 10bit RGBA format with 16384x16384 supported

    Nov 14 15:17:05 vdrhd vdr[27513]: audio: 'alsa' output module used

    Nov 14 15:17:05 vdrhd vdr[27513]: audio/alsa: supports pause: yes


    ffmpeg sollte debian9 standard sein

    3.2.14-1


    ich hab aber testweise auch mal einen clean compile von hier gemacht https://github.com/jojo61/vdr-plugin-softhdcuvid mit dem selben Ergebniss.


    Es mach keinen Unterschied ob ich das softhddevice auf nem minimalen WM laufen lassen (openbox hier), ob ichs auf einem "nackten" X starte oder ob ich das device seinen X Server selbst starten lasse (Option -x)


    Die full screen Elemente sind auch soweit gut, nur die partial updates sind in X Richtung nach links verschoben als ob er das change window immer auf x=0 basieren würde.


    :(

    Hi,


    nach langer Zeit habe ich meinem main VDR mal ein Update gegönnt. Leider habe ich nun Probleme mit dem Softhddevice und der OSD Darstellung.


    Sämtliche ReDraws sind nach links versetzt. Wenn ein Screen komplett gezeichnet wird ist alles OK, wenn jetzt aber ein Teil des Screens neu gezeichnet wird, also z.b. wenn man im Menue die Zeile wechselt und dann nur die beiden betroffenen zeilen neu gezeichnet werden. So passiert dies am linken Bildschirmrand. Das betrifft auch alle anderen Updates.


    Es ist auch unabhängig welches OSD Skin zum Einsatz kommt, ob Classic, Skindesigner, LCars, ..... Alles das selbe.


    Getestet habe ich auch mit vdr 2.4.0 sowie 2.4.1 sowohl vom etobi Repository als auch selbst kompiliert.


    Die Darstellung erfolgt auf einem XWindows mit einem openbox WM im Root.


    Es macht auch keinen Unterschied ob der softhddevice die OSD Größe automatisch erkennt oder ob sie auf fullhd fest eingestellt ist .... Langsam weis ich nicht mehr wo ich noch nachsehen kann ....


    Stefan

    Hi,


    ich habe aktuell ein etwas komplexews Problem das ich nur mit einem kruden workarround lösen kann.


    Ich setzte Softhddevice mit einer nvidia Karte ein und zwar an einem LG Oled TV per HDMI.


    Das Problem ist nun das sobald der VDR headless started (also z.B. start durch timer) der X Server nicht initialisiert wird und somit das Softhddevice keine X Server findet. Der VDR wird dann durch den watchdog beended und die Aufnahme zerstört.


    Starten des X Servers with empty initial config hilft nur bedingt da er dann nicht in der korrekten Auflösung startet und manuell ein neustart ausgelöst werden muss sobald der Fernseher online ist (bzw per Harmony elite und lircd....)




    Meine aktuelle Lösung lautet wie folgt.


    Der VDR started detached und bringt auch den X Server hoch / per seperated systemd job. Der X Server führt ein Xinit script aus falls er erfolgreich gestartet wurde in dem unter anderem ein background task gestarted wird der den VDR periodisch checkt und Attached falls er detached ist .....




    Also, Falls headless start -->


    VDR Started


    vdr-screen failed und restarted alle 5 sekunden ...


    (nachdem der TV connected)
    vdr-screen start ist erfolgreich und per xinit skript wird das softhddevice attached



    Falls TV start :


    vdr started
    vdr-screen started
    xinit script erkennt den "kürzlichen" vdr start un berechnet eine verzögerung von 10 sekunden nach vdr start (die Zeit dient dazu den vdr komplett hochfahren zu lassen, da ein zu frühes attach bei mir zu hängern geführt hat)
    --> nach 10 sekunden. Der VDR wird attached.




    Leider muss ich danach alle 10 sekunden den zustand prüfen um den vdr nach einem ggf. erfolgten restart/watchdog ihn wieder zu attachen. Das würde ich gerne anders lösen :-(



    Gibt es ein event das man prüfen kann, und das ausgelöst wird sobald ein HDMI gerät connected bzw. sich ändert ? In dem Fall könnte ich dies nutzten um den vdr-screen gezielt zu starten ?



    Stefan

    Hi ,


    ich weis, ein kontroverses Thema aber .....


    Ich baue nach fast 14 Jahren (wirklich schon so lange her ?) mal wieder einen VDR auf. Diesmal auch HD fähig und an einem neuen Fernseher :-)


    Gleichzeitig würde ich gerne auf SAT-IP umrüsten und habe daher erfolgreich eine Octopus Net mit MAX S8 in Betrieb .... Auch die nicht freien HD Sender sollten hier wenn möglich eingebunden werden. Ich weis ein durchaus kontroverses Thema das ich in dem Bezug einfach pragmatisch sehen. Unsere Community scheint mir leider zu klein um hier signifikanten Druck aufzubauen :-(.


    Ich glaube das ein oder zwei ein ähnliches Setup im Einsatz haben, und wäre um entsprechende Links oder info schnippsel sehr dankbar, gerne auch per PM oder so.


    Optimale Lösung wäre die Octopus mit CI Modul zu erweitern und so zentral zu verwalten, zweitbeste Lösung wäre der einsatz eines lokalen CI Modules und der Umbau von SAT-IP zu StreamdevServer/Client


    Stefan

    Hi,


    vieleicht kam das ja schon mal vor, ich hab leider noch nichts gefudnen.


    Ich habe nun scraper2vdr (inkl epg2vdr und epgd) im Einsatz mit shady skin. Das problem ist jetzte das manche Images "falsch" angezeigt werden. (Ich habe den Eindruck das dies bei allen movieimages vorkommt, serienimages sind OK)


    Das Problem ist das Movieimages ohne bounding box dargestellt werden das heisst das der EPG Text "über" das Image geschrieben wird. Serien Images sehen korrekt aus (textumbruch um das Bild herum)


    betroffen scheinen alle Darstellungen zu sein und auch das "alte" TVGuide Plugin. (TVGuideNG ist noch nicht im Einsatz)


    Ich hoffe jemand hat eine Idee oder hatte ein ähnliches problem ?


    Stefan

    Hi,


    ich hab ein Problem, und hoffe jemand hat eine Idee für Mich :-)


    Ich baue gerade nach etlichen Jahren einen neuen VDR auf. Die Anbindung der FErnbedienung erfolgt entweder per inputllirc oder remote plugin und die Darstellung mit softhddevice.


    Diesmal möchte ich allerdings auch weitere Dienste starten (Kodi, Chrome, ...) die teilweise auch per Remote gesteuert werden sollen. Mein Ansatz war den VDR "oben" zu lassen und nur das Device zu detachen damit evtl. laufende Aufnahmen weiterlaufen können. Der Ablauf für Kodi wäre aso


    DETA ; kodi ; ATTA


    das funktioniert auch, bis auf die Tatsache das der VDR im Hintergrund weiter die Kommandos der Fernbedienung annimt. Kann man dies pausieren ? (also zum Beispiel durch umbiegen des InputDevice oder pausieren des Plugins ?


    Leider habe ich noch nichts gefunden :-(


    Stefan

    Hi.


    Unser aktueller Main vdr ist jetzt fast 13 Jahre im Einsatz. Ich kann mich noch erinnern wie wir damals das Gehäuse (DIGN) in einer sammelbestellung importiert haben.


    Die Software wurde auf die erste CD vdr Version upgedatet und eine Festplatte wurde ersetzt (Ausfall)


    Ansonsten läuft noch alles wie gehabt (SD per start an ebenso alten CRT)


    Allerdings sind die Tage gezählt da der Fernseher einem LCD weichen wird und in dem Zuge werde ich auch den VDR auf aktuellen Stand bringen.

    Zwischen einem RPI2 und einem "ausgewachsenen" VDR auf Intel Basis, sehe ich bei den Umschaltzeiten unter Verwendung von SATIP keinen großen Unterschied. Ist ne Frage, wie man sich softhddevice/rpihddevice einstellt. Dann bekommt man auch schnelle Zappingzeiten.

    Das ist auch meine Erfahrung aktuell. Die Frage ist ob man mit vdpau noch schneller werden kann, und inwiefern SatIP vs. lokaler DVB Receiver einen unterschied macht.


    Beim Intel Nuc bin ich jetzt ohne große optimierung auf 2-3 sekunden, ich denke da geht noch was ?


    Stefan

    Hi,


    nach mittlerweile mehr als 13 Jahren klaglosem Betrieb plane ich einen VDR update meines Hauptgerätes. Der VDR selbst läuft noch problemlos aber ein neuer Fernseher ist "endlich" fällig und damit auch ein update auf HD.


    Die Frage stellt sich nun nach der Anbindung. Einserseits habe ich am Standort natürlich das klassische DVB-S Kabel liegen es würde sich also anbieten ein normales Setup mit interner DVB Karte (DD vermutlich) und NVidia GPU. Alternative und damit im kleineren Gehäuse könnte ich auch eine SATIP Anbindung realisieren. Ein SAT IP Server mit 8 Tunern ist schon seit einiger Zeit als zuspieler für diverse IPads sowie meinen Arbeitsplatzrechner im Betrieb und eine GB Netzwerkverbindung per Ethernet möglich.


    Leider habe ich "noch" keine gleichwertige Hardware für einen Vergleichtest, daher hoffe ich auf eure Erfahrungen. Wie schwer wiegen evtl. verlängerte Umschaltzeiten durch SATIP vs. lokalem Receiver. Ist dort überhaupt ein Unterschied feststellbar ?


    Diverse VDR auf SatIP sind im Moment im Testbetrieb, allerdings sind die Schaltzeiten hier nicht aussagekräftig da einerseits sehr schwache Hardware im Einsatz (RPi) bzw, intel Grafik (NUC)


    Stefan

    Hi,


    nach fast 12 Jahren eines lauffähigen VDR gebe ich mich gerade daran einen neuen zweit VDR auf aktuellere Technik aufzusetzten. Ich probiere dabei gerade verschiedene Hardware und laufe gleich in das erste Problem.


    Aktuell im Einsatz ein VDR auf Basis eines Debian Jessie mit den etobi quellen. Leider macht das softhddevice als Frontend sorgen. Ich bekommen unabhängig von meinen verschiedenen sound Einstellungen nur sehr bescheidenes Audio. Es ist schwer zu beschreiben aber es hört sich ein wenig wie cliping oder nicht passender Abtastrate an. Wobei ich auch manchmal den Eindruck habe das tiefe Töne bzw Hintergrundmusik sehr gut wiedergegeben werden jedoch die Vordergründe bzw mittleren bis hohen Tonlagen viel zu schwach sind, leise und dann mit einem klirren auch reißen bzw. clippen.


    Die Ausgabe erfolgt ist auf default bzw hw:0,0 (analog stereo)

    Die Soundkarte selbst kann ich glaube ich ausschließen da direkte mp3 Wiedergabe problemlos auf dem selben device funktioniert.

    Xinelibout mit sxfe zeigt das selbe Verhalten !


    Zuspieler ist im Moment ein SatIP service per wlan angebunden. allerdings habe ich keine Signalprobleme und auch die audiopids werden korrekt erkannt !


    Den Satip Server kann ich in sofern ausschließen das mehrere Softwareclients sowie ein zweiter VDR auf intel NUC basis keine Probleme mit dem audio haben, allerdings gefällt mir da die Darstellung nicht so daß ich zusätzlich andere Hardware teste :-)


    Irgendwelche Ideen wo ich noch schauen könnte bzw, was ich noch testen könnte um den Fehler weiter einzugrenzen ? Ich bin hier tatsächlich am Ende meiner Kenntnisse.


    Stefan

    Den versteh ich jetzt nich.


    die MVP ist dir zu teuer aber du willst nur fullfeatured ?


    also meine Empfehlung wäre (entsprechende Sat Kabel vorausgesetzt) 1 Server mit ausreichend Platte und 3 Budget Karten (alternativ 2 Budget und eine FF ums auch nach Instalation mal lokal testen zu können


    Dann hast du genug um 2 MVP unabhängig zu betreiben und ausserdem noch ne dritte Karte frei für unabhängige aufnahmen.


    du kannst auch erstmal mit 1 FF und 1 Budget beginnen und mal sehen ob du mit den Einschränkungen leben kannst.


    Stimmt von daher ist es auch unkritisch.


    Was ich nur nicht vberstehe. Irgendwie hat die Admin Ja/Nein Einstellung keine Auswirkungen. Ist das auch bei dir so und liegt an der Version des Plugins ? Oder steht hier was schief.


    Ist dir eigentlich eine Möglichkeit bekannt das Menue um die überflüssigen/gefährlichen Optionen zu erleichtern ? Im Zweifel kann/muß ich mir das Plugin halt selbst übersetzten aber dann müsste ich mir erst eine CT'VDR Dev aufsetzten :-(((


    mfg Stefan


    Hi,


    hat soweit funktioniert nur die cmds.conf meldet ein paar Fehler (Trennlinien und Pfade) und die Berechtigungen stimmen nicht (vor allem merkbar beim Themes-Wechsel)


    Ansonsten scheint es zu laufenauch wenn ich es wohl nicht häufig benutzen werde.


    mfg Stefan