Posts by TumblingDice

    Hello "brother in mind",


    actually I have the same trouble with Suse 10.1 Beta4. X( I installed / configured the "udev rules" as described here, but with no success. Do you have a solution now? Yes? Thanks for answering.


    By the way: searching for "Tecnotrend DVB-C 1500" I've seen your thread .
    Is your combination DVB-C FF + Budget working now? I'm interested because since ten days I own the DVB-C 1500 as an addition to my "old" DVB-C 2100. To use the new C 1500 I need a new kernel >= 2.6.15). So I decided to switch to the new Suse 10.1. What a mistake (see above) ;)


    Good luck + bye!


    Manfred

    Hallo Cody,


    mit 3 bis 4 Stunden pro Woche kann ich schon dabei sein, allerdings voraussichtlich erst ab Anfang September. Bis dahin werde ich versuchen soweit wie möglich den Thread zu beobachten.


    Wg. SVDRP
    Sicherlich hat SVDRP hinsichtlich Skalierbarkeit und Funktionsumfang seine Schwächen. Für die grundlegenden Funktionen reicht es ja völlig aus (was durch VDRAdmin und Xxv ja auch bewiesen ist).


    "Unsere" Java Schnittstelle sollte eh "unsere" Sicht auf den VDR abbilden und damit ausreichend vom SVDRP abstrahieren.


    Also kurz: bin dabei :)


    Ciao ...


    Manfred

    Hallo,


    ist ja witzig, wie sich die Ideen gleichen. Auch ich habe vor ein Web Frontend auf Java Basis zu entwickeln (JSP, Tomcat, ..), bin allerdings z.Zt. noch dabei auf meinem Linksys Router (Linux / Openwrt) ein PHP basiertes Portal / Firewall für den gesicherten Zugriff auf mein Netzwerk (inkl. VDR) zu schreiben. Zweck des ganzen ist
    [list=a]
    [*]die beteiligten Rechner (und damit auch meinen VDR) per WakeOnLan zu wecken
    [*]über dynamische IPTables-Konfiguration nur gesicherte Zugriffe zuzulassen
    [/list=a]
    Das ganze dauert noch ein paar Tage, da ich nur an Werktagen abends 1 bis 2 Stunden investieren kann.


    Aber zurück zur Java-Lösung:
    Ergänzend zu JSP basierten Web-Seiten habe ich für mich vor, zusätzlich eine SOAP Schnittstelle mit AXIS als "Soap Server" zu schreiben. Vielleicht können wir hier ein paar Entwickungen zusammenfassen.
    Meine angedachte Lösung basiert natürlich intern auch auf den Möglichkeiten von SVDRP. Gibt es hier eine Alternative ???


    Liebe Grüße + Viel Spaß !


    Ciao ...


    Manfred

    Hallo Bistr-o-Math,


    danke für die Antwort. Die README hatte ich natürlich gelesen, aber den Passus mit "second problem" doch irgendwie vergessen/überlesen: ;)


    Quote

    SECOND PROBLEM:
    Some boards do not wake up at all if powered off by APM methods.
    Some boards do not wake up at all if powered off by ACPI methods.
    Some boards do or do not wake up depending on the version of ACPI
    drivers in the kernel.


    Scheint also, dass mein ASRock Board nur mit 2.6 Treibern zum Auwachen zu bewegen ist. ACPI ist wohl eine Sache für sich ... :rolleyes:


    Ciao ...


    Manfred

    Hallo,


    ich habe ein kleines Verständnisproblem zum reboot für ein "Wake Up" per nvram.


    Vorab: mein Ablauf funktioniert, allerdings wüsste ich gerne warum ;)


    Board: ASRock P4i45PE, reboot zur Übernahme der nvram Einstellungen hier notwendig. Boot Manager: grub, eigenes Label für PowerOff, Konfiguration über grub Skript mit savedefault ..., Linux: z.Zt. SuSe 9.3.

    Der Ablauf funktuioniert soweit einwandfrei. :)


    Was ich aber nicht verstehe ist folgendes: Benutze ich das PowerOff Image aus dem nvram Paket (2.4.20 Kernel), schaltet der Rechner einwandfrei ab, startet aber nicht zur programmierten Zeit. Da dies bei einem manuellen shutdown einwandfrei funktiuoniert benutze ich für das Ausschalten den "normalen" 2.6 Kernel mit Runlevel 0 (= Halt Modus). Dies klappt einwandfrei.


    Ich frage mich allerdings: was passiert bei dem Reboot bzw. Ausschalten mit den BIOS Einstellungen, das bei einem simplen PowerOff so unterschiedliche Ergebnisse passieren ? Die Reboot Phase ist ja schon überstanden, so dass nach meinem Verständnis die nvram Einstellungen eigentlich übernommen sein sollten.


    Hat jemand eine Idee oder einen Link ? Besten Dank !


    Liebe Grüße


    Manfred


    P.S. Die nvram Config für das ASRock Board kann ich natürlich zur Verfügung stellen, falls jemand die benötigt.


    Hallo Ulrich,


    setze seit Jahren ausschließlich ASUS-Boards ein und war bisher (nachlassend) zufrieden. Allerdings denke ich, dass mein Problem eher
    ein EMV/IRQ-Problem ist (siehe http://www.vdrportal.de/board/thread.php?threadid=13702).


    Keine Ahnung, inwieweit jetzt deine Fragen über die bisherigen Postings alle (nicht) beantwortet sind. ;)
    Mein IR-Empfänger (DVBShop, COM-Anschluss, 2 m Kabellänge) läuft einwandfrei. Jeder andere IR-Empfänger mit RC5-Protokoll sollte aber auch einwandffrei funktionieren. Hinweis: Wenn Du den Kernel 2.6 einsetzen willst, brauchst du aber z.Zt. noch einen Patch für LIRC (http://flameeyes.web.ctonet.it/oldindex.html#lirc).


    Was den Prozessor betrifft: z.Zt. tendiere ich bei mir zu einem VIA Eden 600 MHz, es ei denn, ich entschliesse mich doch noch, DivX zu integrieren. Dann wird es wohl Celeron 2,0 oder XP2500. Aber auf solche Fragen kannst du wirklich keine konkreten Antworten erwarten. ;)


    Gruß


    Manfred

    Hallo Carsten,


    auch wenn du den Kernel 2.6 verwendest, musst du natürlich die entsprechenden Module z.B. per "modprobe" laden (Es sei denn, du hast die Treiber direkt in den Kernel gebunden, was ich aber nicht erwarte) ;)


    Welche Module das sind hängt natürlich von deiner Karte ab. Die installierten (und damit ladbaren) Module findest bei 2.6 unter /lib/modules/<kernelname>/kernel/drivers/media/dvb.


    Gruß


    Manfred

    Hallo Ulrich,


    bin selber noch ein "Grünschnabel", trotzdem versuche ich mich an ein paar Tips :rolleyes:


    Als Einsteiger würde ich nicht sofort das Gesamtsystem planen, sondern nach Möglichkeit mit einem Alt-Rechner einsteigen.


    Wenn du keine DivX etc abspielen willst reicht z.Zt. ein Rechner ab 300 MHz. Lediglich der Plattendurchsatz (DMA-Modus) sollte > 20 MB/ s sein. Falls du einen alten Rechner von der Bauart haben solltest, nutze ihn als Einstieg. Meiner Erfahrung nach weiss man eh erst nach mehrwöchiger (Monaten ?) Benutzung wohin der Hase beim VDR läuft und was man alles (nicht) braucht.


    Auf deine Fragen wird dir wohl keiner hier im Forum eine konkrete Antwort geben können, da hier zig verschiedene Philosophien, Anwendungsszenarien und (auch) Ideologien aufeinandertreffen.


    Entscheidend wird sein, was du langfristig mit dem System vorhast. (Weiss du das jetzt schon ??) Davon abhängig ist auch die Frage, ob du z.B. ein Full-ATX-Board (Anzahl PCI-Slots für Erweiterungen wie RGB/SPDIF/Scart-Ausgang) brauchst oder ob ein micro-ATX (klein = Integration ins Wohnzimmer) reicht.


    Um es kurz zu machen: Als Einstieg reicht eine TT DVB-S Karte (Rev 1.5) . Die erhälst du (relativ) günstig bei http://www.dvbshop.tv. Dort gibt es auch IR-Empfänger samt Fernbedienungen, die unter Linux (LIRC) lauffähig sind. Mit ca. 170 Euro + Alt-Rechner hast du deinen ersten VDR. Die Investition in die Karte ist wohl auch langfristig nicht verloren. Alles weitere kommt mit den Erfahrungen.


    Was mich betrifft habe ich als Kabelnutzer im doppelten Sinn den Griff ins K.. getan:
    a) verursacht meine Karte im neuen ASUS A7N8X-Bosra Artefakte (nicht im alten Board !)
    b) Gibt es eh bald nichts mehr zu empfangen.



    Gruß


    Manfred

    Hallo,


    habe auch ein Artefakte-Problem mit der DVB-C (TT 2.1), dies allerdings nur auf ASUS A7N8X-Boards. (siehe hier http://www.vdrportal.de/board/thread.php?threadid=13702)


    Weiss immer noch nicht, ob dies eventuell ein vom Board ausgehendes EMV-Problem ist oder ein "simples" Interrupt-Problem. Werde noch einen Versuch machen, ansonsten ist das Thema für mich gestorben. Gibt ja eh bald keinen freien Empfang mehr im Kabelnetz. X(


    Ciao ...


    Manfred

    Hallo,


    habe großes Interesse zu kommen, da ich am ersten User-Treffen nicht konnte !


    DISCLAIMER: Mit allzuviel produktiven Beiträgen meinerseits braucht ihr aber nicht zu rechnen, mein VDR ist noch im Aufbau. Werde wohl eher (mehr oder weniger) idiotische Fragen stellen (siehe auch meine Threads). Trotzdem ok ? ;)


    Kann aber nicht ewig bleiben !


    Liebe Grüße aus der Salzstadt !


    Ciao ...


    Manfred

    Hallo,


    Danke für die Antworten. Konnte erst heute reagieren, da ich am Wochenende weit entfernt von meinem Rechner war (Wäre wohl sinnvoller geswesen, meinen Beitrag erst heute zu posten ;))


    Zu den Antworten: Das CAM als Ursache scheidet wohl aus, da auch ohne CAM (CI-Modul abgeklemmt) die Effekte die gleichen sind. Das CAM selber läuft in meinem Alt-Rechner einwandfrei, zudem bereitet Premiere die wenigsten Probleme.


    An ein reines Treiberproblem glaube ich nicht, da auch unter den aktuellen Windows-Treibern die Probleme auftreten. Werde natürlich die neuen Treiber testen. Evtl. hilfreich ist aber, wenn die neuen Treiber (AV7110) ein Setzen des IRQ erlauben.


    Axel Hundt vom DVBShop hat als mögliche Ursache noch das "PCI Latency Timer"-Problem in die Waagschale geworfen. Werde versuchen hierzu heute noch mehr Info zu bekommen und mich ggf. melden. (BTW: Die Mail von Axel Hundt stammte von Samstag früh, 00:10 Uhr 8o)


    Was mich aber brennend interessiert: Gibt es jemand mit der gleichen Hardware-Konfiguration (DVB-C TT 2.1, ASUS A7N8X, AMD XP2500), der keine Probleme hat ?? Wenn ja, scheidet wohl EMV als Ursache aus. Wäre toll wenn er seine "lspci -vv" Ausgabe posten könnte, damit ich die PCI-Konfiguration (IRQ, Latency Timer, ...) mit meiner vergleichen kann. Danke im voraus ! :)


    Mal schaun, ob ich mein Problem bis Ende März gelöst bekomme. Dann gibt es nämlich im digitalen Kabelnetz kein ARD/ZDF mehr und mein Premiere Test-Abo läuft auch aus. Naja, bei einem schwarzen Bildschirmn gibt es zumindest keine Artefakte :D


    Gruß


    Manfred

    Hallo,


    habe mit meiner DVB-C Karte (TT 2.1) ein Problem mit Artefakten. Dies Problem ist grundsätzlich schon in mehreren Threads
    behandelt worden, die ich auch alle genau studiert habe. ;) Nach 3-wochenlangen, nächtlichen Versuchen ist das Problem hoffentlich soweit
    eingegrenzt, dass der ein oder andere von euch mir doch noch (bei diesem Problem) weiterhelfen kann.


    Zur Historie:
    Die Karte ist ca. 6 Wochen alt (gekauft bei USA-X.org, prima Service dort) und funktioniert einwandfrei in meinem alten Mainboard
    Asus K7M (Athlon 600) sowohl unter W2K (TT-Software) als auch unter Linux mit VDR (1.2.6 + 1.3.x). (Einzig offenes Problem: bei Timeraufnahmen von Premiere friert das Bild ein)


    Da ein Hardware-Upgrade des Linux-Systems anstand, habe ich vor ca 4 Wochen aufgrund guter Erfahrungen mit meinem WinXP-Rechner ein neues ASUS A7N8X-E Board mit Athlon XP-2500 gekauft (mein Win-XP Rechner läuft seit einem halben Jahr mit dieser Kombination (A7N8X, XP-2500) erfolgreich).


    Mit diesem Board habe ich nun folgende Probleme mit meiner DVB-C Karte:

    • Der Empfang vom ARD-Bouquet ist praktisch nicht möglich (Artefakte, Klötzchenbildung, Ton-Knackser)
    • ZDF ist häufig (aber nicht immer) mit wenigen Artefakten empfangbar, Premiere immer einwandfrei.
    • Das Umschalten bei allen Kanäle ist sehr langsam und führt nicht immer zum Erfolg (==> schwarzes Bild)
    • Die Wiedergabe aufgenommener Programmen ist einwandfrei


    Bei Programmen mit Artefakten usw. ist die Signalstärke weiterhin unverändert hoch, allerdings steigt der BER-Wert (BitErrorRate) stark an (6 bis 7 -stelliger Wert) an bzw. es kommt zu nicht korrigierbaren Fehlern (UNC-Wert). Generell ist der BER-Wert bei Premiere um 200, bei ZDF fast immer 4-stellig.


    In den Threads zu diesem Thema sind als primäre Probleme schlechte Empfangsqualität in Kabelnetzen, elektromagnetische Strahlung (EMV), IRQ-Probleme sowie
    Wärmeentwicklung angegeben. Habe daraufhin versucht, die Probleme soweit wie möglich einzugrenzen:

    • Probleme im Kabelnetz sind auszuschliessen, da zu jedem "Zeitpunkt" (5 Minuten brauche ich schon, um die Karte zu wechseln) über mein altes Board ein
      einwandfreier Empüfang möglich war bzw. ist. (der BER-Wert ist hier bei allen Kanaälen um 200, zudem: der Empfang über d-box immer möglich)
    • Wärmeentwicklung als Ursache scheidet aus, da das Problem bei kaltem Rechner sowie offenen
      Gehäuse genauso auftritt.
    • Eine externe (!) EMV-Quelle (Netzteil, DECT vom Nachbarn) scheidet aus, das das Problem auf meinem alten Board in ansonsten
      gleicher Umgebung nicht auftritt (gleiches Gehäuse, Netzteil, Standort, nahezu gleicher Zeitpunkt).
    • N-maliges Wechseln der PCI-Slots sowie deaktivieren des ACPI- und APIC-Modus brachte keine Veränderung.
      Allerdings habe ich es nie geschafft, dass die DVB-Karte alleiniger Owner eines Interrupts war.


    Dass ich diverse Treiber, Kernel-Versionen, VDR-Versionen, Channel-Konfigurationen usw. unter Linux ausprobiert habe versteht sich. ;)


    Um grundsätzliche Treiberprobleme (auch nforce2-Probleme unter Linux) auszuschliessen habe ich die Karte im gleichen Rechner unter WXP (ACPI-Modus) und
    W2K (ohne ACPI) ausprobiert, inlusive Wechsel der PCI-Slots ==> die gleichen Effekte (nur schlimmer).
    Um ein Hardwareproblem mit dem Board auszuschliessen, habe ich die Karte in meinem
    WXP-Rechner (nahezu gleiche Hardware, 1/2 Jahr alt, bisher keine Probleme) eingebaut ==> gleiche Fehler, nur noch schlimmer.


    Am Ende bin ich etwas ratlos. :rolleyes: Problematisch ist bei mir immer die Kombination A7N8X/XP-2500/DVB-C.
    Als verbleibende Ursache kommen für mich nur in Frage

    • EMV-Strahlung vom Board/Prozessor selber, das bei mir primär die ARD-Frequenz stört. Wenn dies der Fall ist,
      dann sollten doch alle A7N8X + DVB-Besitzer irgendo ein ähnliches Problem haben, oder ??
    • IRQ-Probleme. Wenn ein grundsätzliches IRQ-Problem da ist, sollte doch auch die Wiedergabe aufgenommener Programme gestört sein, oder ??
      Zudem ist der Empfang von Premiere jederzeit möglich.
    • Versteckter Defekt bei der DVB-Karte ?


    Weiss jemand Rat ? Hat jemand eine gleiche Hardware-Konfiguration (DVB-C, Board, Prozessor), die funktioniert ?
    Werde natürlich auch noch USA-X.org um Rat bitten.


    Danke für jede Hilfe ! :)


    Gruß


    Manfred


    Ach ja, das alte Board kann nicht behalten, da ich dies samt anderer Rechner-Teile bereits meiner Familie als Geschenk versprochen
    habe. Meine Lieferung ist jetzt auch schon seit fast 3 Wochen überfällig.