Posts by LotharE

    Hallo Zabrimus,

    nachdem der vtuner-ng aktualisiert wurde lässt sich der Patch für Kernel 4.9 nicht mehr anwenden:



    Schöne Grüße

    Lothar

    Hallo Zabrimus,


    mir war aufgefallen, dass das Einschalten per remote control unter ce22-ne nicht mehr funktioniert (ich meine das hatte schonmal geklappt).

    Das scheint am Service setup_bl301.service zu liegen:


    Code
    sh: /sys/class/bl301_manager/setup_bl301: No such file or directory


    Der Pad ist jetzt /sys/class/bl30_manager/setup_bl30


    Nach Änderung von setup_bl301.service klappt damit der remote wakeup wieder mit der Fernbedienung.

    Leider geht aber wol nicht mehr. Nach dem Ausschalten sind die LEDs am RJ45 Port aus;

    unter ce21-ng blinken die zweitweise und wol klappt dort.


    Du hattest ja kürzlich das Wakeup per RTC noch hinzugefügt; muss da für wol evtl. auch noch was gemacht werden?


    Schöne Grüße

    Lothar

    Danke jetzt baut's wieder.


    Allerdings habe ich jetzt mit der aktuellen Version von CE22 ein Problem:


    Code
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] loading plugin: /usr/local/lib/vdr/libvdr-softhdodroid.so.2.6.7
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] loading plugin: /usr/local/lib/vdr/libvdr-satip.so.2.6.7
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] loading plugin: /usr/local/lib/vdr/libvdr-skinnopacity.so.2.6.7
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] ERROR: /usr/local/lib/libGraphicsMagick.so.3: undefined symbol: xmlNanoHTTPCleanup, version LIBXML2_2.4.3
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] deleting plugin: satip
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] deleting plugin: softhdodroid
    Jun 19 18:22:23 CoreELEC vdr[4457]: [4457] exiting, exit code 2
    Jun 19 18:22:23 CoreELEC systemd[1]: vdropt.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
    Jun 19 18:22:23 CoreELEC systemd[1]: vdropt.service: Failed with result 'exit-code'.


    Da wird ein Einsprung in libGraphicsMagick.so.3 nicht gefunden ;(

    Hi Zabrimus,


    nach deinem letzten ffmpeg Patch baut CoreELEC-21ng nicht mehr:



    Der build für CoreELEC-22no ist zuvor damit fehlerfrei durchgelaufen.


    Schöne Grüße

    Lothar

    Ich hab nochmal weiter gesucht und folgendes probiert:


    Code
    CoreELEC:~ # systemctl stop vdropt
    CoreELEC:~ # sync
    CoreELEC:~ # umount --lazy --force /storage/videos/

    Damit gibt's keinen crash mit reboot mehr.

    Das könnte man als work around ins shutdown-Skript des VDR einbauen, bis das Problem gelöst ist.


    Schöne Grüße

    Lothar

    Dem Hinweis folgend habe ich in codec.c mal auf spdif_b umgestellt und tatsächlich hatte ich sofort Ton und es gab keinen Kanal, der Probleme machte.

    Ich hab mal einen neuen Build mit dem spdif Patch gemacht; jetzt gibt es auch bei mir keine Tonprobleme mehr! :thumbup:
    Falls die Einstellung geräte-abhängig ist, müsste man es wohl als Konfigurations-Parameter machen.


    Schöne Grüße
    Lothar

    Mit deiner Änderung wird das nfs Verzeichnis ohne explizite Versionsangabe jetzt mit nfs 4.1 eingebunden:


    Code
    CoreELEC:~ # mount -t nfs4
    qnap2:/video on /storage/videos type nfs4 (rw,relatime,vers=4.1,rsize=262144,wsize=32768,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.0.93,local_lock=none,addr=192.168.0.57)


    Ich lasse das mount skript dann so.

    Hallo, ich hatte es im Thread von Zabrimus schon geschrieben.


    Quote

    Das Problem mit dem Ton habe ich auch. Wenn ich von Kodi zurück zu VDR wechsle, ist der Ton auch dort da. Außerdem ist mir aufgefallen, dass bei einigen Sender weiterhin kein Ton da ist, da muss ich nochmal genauer schauen.


    Abgesehen dass der Ton erst nach dem Wechsel zurück von Kodi kommt, wird danach nur Dolby Ton ausgeben. Bei mp2 Ton hört man nichts. ARTE sendet z.B. sendet nicht in Dolby, so dass dort nichts zu hören ist.

    Ich hatte noch das Problem, dass der Mount des Video Verzeichnisses per nfs nicht klappte.

    Ich habe jetzt das vers=4 weggelassen; damit klappt's. Es wird dann mit Version 3 gemountet.

    Code
    CoreELEC:~/.config/system.d # mount -t nfs
    qnap2:/video on /storage/videos type nfs (rw,relatime,vers=3,rsize=262144,wsize=32768,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.57,mountvers=3,mountport=52482,mountproto=udp,local_lock=none,addr=192.168.0.57)


    Muss evtl. nfs4 im Kernel konfiguriert sein?


    Schöne Grüße

    Lothar


    Edit: Ich sehe gerade

    Bash
    #!/bin/bash
    
    
    set -e
    
    
    sed -i -e "s/CONFIG_NFS_V4=y/# CONFIG_NFS_V4 is not set/" ./projects/Amlogic-ce/devices/Amlogic-no/linux/linux.aarch64.conf
    sed -i -e "s/CONFIG_NFSD_V4=y/# CONFIG_NFSD_V4 is not set/" ./projects/Amlogic-ce/devices/Amlogic-no/linux/linux.aarch64.conf

    Hat das einen Grund, dass Du NFS4 für Server UND Client rausgenommen hast?

    Hallo Zabrimus


    ich teste jetzt auf einer SD Card das CE-22 mit dem neuen 5er Kernel.


    Der cefbrowser startet nicht wg. der libcef.so


    Im LD_LIBRARY_PATH liegen wohl noch die alten 32-Bit Versionen



    Wie komme ich an die aktuellen Versionen, muss ich noch was installieren?


    Schöne Grüße

    Lothar

    Leider bleibt der Fehler auch mit dem aktuellen Stand:


    Code
    Traceback (most recent call last):
    File "/home/lothar/VDRSternELEC/CoreELEC/scripts/genbuildplan.py", line 374, in <module>
    REQUIRED_PKGS = processPackages(args, ALL_PACKAGES)
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    File "/home/lothar/VDRSternELEC/CoreELEC/scripts/genbuildplan.py", line 303, in processPackages
    raise Exception(msg)
    Exception: Invalid package reference: dependency _mesa in package _cefbrowser::PKG_DEPENDS_TARGET is not valid
    Parallel build failure - see log for details. Time of failure: Fri Jun 14 15:58:11 CEST 2024
    make: *** [Makefile:10: image] Fehler 1

    Muss da sonst noch was aktualisiert werden?

    Hi Zabrimus,


    ich hab nochmal in ein frisches Verzeichnis abgerufen, jetzt läuft der build für CoreELEC-22-no durch ;)

    allerdings nur, wenn ich -extra cefbrowser weglasse.


    Mit -extra cefbrowser erhalte ich:

    Code
    Traceback (most recent call last):
    File "/home/lothar/VDRSternELEC/CoreELEC/scripts/genbuildplan.py", line 374, in <module>
    REQUIRED_PKGS = processPackages(args, ALL_PACKAGES)
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    File "/home/lothar/VDRSternELEC/CoreELEC/scripts/genbuildplan.py", line 303, in processPackages
    raise Exception(msg)
    Exception: Invalid package reference: dependency _mesa in package _cefbrowser::PKG_DEPENDS_TARGET is not valid
    Parallel build failure - see log for details. Time of failure: Fri Jun 14 13:28:33 CEST 2024
    make: *** [Makefile:10: image] Fehler 1


    Da scheint deine letzte Änderung noch nicht zu klappen.


    Schöne Grüße

    Lothar

    Hallo Zabrimus,

    ich habe auch nochmal ein CE22 build versucht.

    Bei mir bricht er immer hier ab:


    Vor zwei Wochen hatte das schon mal geklappt.
    Irgend eine Idee ?

    Schöne Grüße
    Lothar