Posts by TheOe

    Hallo,


    ich habe aktuell das Problem, dass mir das EPG von arte SD in KODI nicht korrekt angezeigt wird.
    Das EPG unter VDR hat diese Probleme nicht. Scheinbar ist ein täglich auftretender EPG Eintrag ab ca. 6 Uhr daran Schuld.


    Inhalt des Eintrags
    "ARTE
    El canal de televisiðn cultural."


    Dieser Eintrag hat immer eine Dauer von ca. 23 bis 24 Stunden. KODI (bzw. der VDR VNSI Client) wertet aus diesem Grund den Eintrag als aktuelle Sendung aus. Die tatsächlich laufende Sendung wird nicht angezeigt.


    Drei mögliche Lösungsansätze hätte ich:


    1. Das Verhalten von KODI bzw. VDR VNSI Client anpassen, leider reich dazu meine Kompetenz nicht aus.
    2. Den Eintrag routinemäßig aus den EPG Daten löschen, aber wo und wie setze ich da an?
    3. Ich ersetze die Daten von arte SD durch arte HD


    kann epgd in meinem Fall ein Lösungsansatz sein?

    Schlüssel mal bitte die Hardware und Software sauber.
    Mir ist nicht ganz klar um wieviel Rechner es geht.


    - Rechner
    - Mainboard
    - Grafikkarte und verwendeter Treiber
    - Linux
    - VDR Quelle (Yavdr, Distributor ?)
    - VDR Version
    - vdr-sxfe Version
    - vdr-sxfe mit welchen Parametern?



    Wie habt ihr das mit dem Fehlenden Power knopf gelöst?
    Der VDR Server muss ja auch irgendwann schlafen gehen können wenn er nicht gebraucht wird.


    Hallo Thomas,


    ich habe mir einen Script für cec gebastelt, der auf bestimmten TRAFFIC des TV wartet und den VDR entsprechend startet + wol und beendet. Den Script habe ich für MLD geschrieben und nur an einem LG TV bisher getestet. Bis auf die Weiterleitung einiger Tasten des cec via svdrpsend.sh, die sehr zeitverzögert sind, funktioniert es für das starten und beenden des VDR recht gut.


    Gruß TheOe

    Hallo,


    erst einmal Danke für den Hinweis, werde ich ausprobieren.


    Ich bin auch gerade damit beschäftigt, den cec-status des TV mit dem RPI auszulesen und vdr zu beenden wenn der Fernseher ausgeschaltet ist. Wird der Fernseher angeschaltet, so startet der Script den Server per wol und startet vdr neu. Die Scripte liegen unter /etc/init.d und funktionieren gut wenn ich sie manuell startet, sie werden aber nicht beim Hochfahren ausgeführt. Was muss ich tun, damit MLD die Scripte beim Hochfahren ausführt?


    cec-scanner # liest mit Hilfe von cec-client den cec-status des TV aus und stellt die Informationen unter /tmp/cec.log zur Verfügung
    cec-action # liest die Datei /tmp/cec.log aus und führt die entsprechenden Befehle aus.

    Files

    • cec-scanner.txt

      (1.34 kB, downloaded 139 times, last: )
    • cec-action.txt

      (3.2 kB, downloaded 158 times, last: )

    MLD hat scheinbar ein paar Probleme einige Dateien zu finden. /usr/bin/libcec-daemon und /usr/bin/cec-client brechen mit Fehlermeldung in der Konsole ab.


    ln -s /opt/vc/lib/libbcm_host.so /usr/lib/libbcm_host.so
    ln -s /opt/vc/lib/libvcos.so /usr/lib/libvcos.so
    ln -s /opt/vc/lib/libvchiq_arm.so /usr/lib/libvchiq_arm.so


    sollte das beheben.

    Quote

    Ich gebe auf mit MS Fernbedienung und habe mir X10 von Medion geholt


    Funktioniert damit denn auch das Starten des Rechners? Würde mich interessieren.


    P.S.: Hast Du den Fehler unter Punkt 6 meiner Anleitung berücksichtigt?


    Ich habe geschrieben

    Code
    1. ...
    2. start)
    3. echo "Starting $DESC"
    4. start-stop-daemon --exec $DAEMON --start -- $OPTIONS $EVENTS
    5. if [ ! -h /var/run/lirc/lircd ] ; then mkdir /var/run/lirc ; ln -s /dev/lir$
    6. ;;
    7. ...


    es muss aber heißen

    Code
    1. ...
    2. start)
    3. echo "Starting $DESC"
    4. start-stop-daemon --exec $DAEMON --start -- $OPTIONS $EVENTS
    5. if [ ! -h /var/run/lirc/lircd ] ; then mkdir /var/run/lirc ; ln -s /dev/lircd /var/run/lirc/lircd ; fi
    6. ;;
    7. ...


    was gibt den ls -l /var/run/lirc/lircd aus?

    Quote

    Original von Sambo
    nefulix das hatte ich schon versucht gehabt aber da läuft nicht alle tasten
    nur paar tasten unter Windows läuft alles
    nach oberen anleitung kein erfogt :schiel


    Ein bischen genauer wäre schon nicht schlecht…


    …und bitte ein bischen mehr Mühe beim Satzbau, sonst wird man nicht schlau daraus und es ist schwierig zu lesen… :lehrer1


    1. Was genau ist mit Windows? Läuft die Fernbedienung hier problemlos oder nur teilweise?
    2. " nefulix das hatte ich schon versucht gehabt aber da läuft nicht alle tasten" ich hoffe, das bezieht sich auf das Webinterface von yavdr oder was genau ist gemeint (sorry die Frage, aber das Webinterface verwende ich nicht)
    das funktioniert auch nur teilweise?
    3. "nach oberen anleitung kein erfogt" ich gehe mal davon aus, dass sich das auf meine Anleitung bezieht?! Was gibt irw bei Betätigung der Fernbedienung aus?


    Mit freundlichen Grüßen


    TheOe

    @ nefulix


    Quote

    ...meinte mit dem weiterführen des howto nur den Fernbedienungteil.


    OK da kann ich ja nochmal nacharbeiten.

    Quote

    ...Benötige also remote.conf nicht.Oder?


    Nein, wenn XBMC das Frontend für den VDR ist, braucht man die remote.conf nicht.


    @Sambo


    Quote

    Würde dieser Anleitung auch bei yavdr funktionieren?
    da ich auch mc 380 habe wollte mal fragen


    Ich arbeite zwar mit einem Standard-Ubuntu mit VDR und XBMC aus den yavdr-Quellen, aber im Prinzip sollte es auch mit einem reinen yavdr klappen. Die Unterschiede sollten marginal sein.


    P.S. Leg Dir mal eine aussagekräftige Signatur zu. Das hilft weiter.


    MfG
    TheOe

    Hi nefulix


    :welcome



    Stimmt. Danke für den Hinweis.
    Ich würde mal sagen, dass war ein Fehler mit copy und paste.
    Leider kann ich meinen Beitrag nach mehr als 14400 Minuten nicht mehr bearbeiten.

    Quote


    ...
    remote.conf?mmh?davon habe ich jetzt noch nichts gelesen.Werde mal gleich googlen..
    ...


    Ist für die Fernbedienung des VDR zuständig.
    http://www.vdr-wiki.de/wiki/index.php/LIRC

    Quote


    ...
    Könntest Du evtl. deine Anleitung kurz weiterführen.
    VDR und XBMC wie gewohnt konfigurieren kann ich noch nicht ;-)
    Danke schon mal


    Nein! Sorry, aber das Howto habe ich geschrieben um die spezifischen Probleme/Lösungen mit dem MC-380 zu dokumentieren. Nicht mehr und nicht weniger. Solltest Du eine Frage/Problem haben helfe ich gern. Ansonsten gibt es hier genug Anleitungen wie man einen VDR und XBMC aufsetzt.
    Eine aussagekräftige Signatur mit deiner Hard- und Software wäre dann hilfreich.


    mfg


    TheOe

    Quote

    Original von powercircle
    Hemingway :
    Kannst du irgendwie beschreiben, welche Stecker für die SPDIF-Verbindung notwendig sind und/oder wie die Belegung (SPDIF+Ground) auf dem GPU-PCB ist? Oder vielleicht sogar ein Bild des Kabels? Wäre eine Sehr große Hilfe.


    für ca. fünf Euro bei Ebay oder mal nett an den Hersteller schreiben. Bei meiner MSI lag ein Kabel bei.
    http://cgi.ebay.de/SPDIF-Kabel-intern-HDMI-Kabel-Nvidia-Grafikkarten-/120589144563?cmd=ViewItem&pt=DE_Computer_Grafikkarten_Grafikkarten_Zubeh%C3%B6r&hash=item1c13ac51f3

    Quote

    Original von powercircle
    Laut Datenblatt kann diese Karte HDCP per DVI mit entsprechendem DVI->HDMI Adapter. Was mir nicht klar geworden ist:



    Kann die Karte / eine 8400 GS ohne HDMI auch irgendeine Art von digitalem Tonsignal über DVI ausgeben?
    (Entsprechenden Adapter bzw. Kabel vorrausgesetzt)


    Falls ja, nach welcher Anleitung ist das ganze am schmerzlosesten einzurichten?


    Ganz einfach:


    1. Verbindungskabel SPDIF Mainboard/Soundkarte an SPDIF Grafikkarte
    2. Über geeigneten DVI auf HDMI Adapter an Fernseher anschießen.
    3. ob es 100% synchron mit dem Bild ist kann ich schlecht sagen, für mich hat es gereicht.
    aber analog und digital Ton sind nicht synchron zueinander.


    Meine Grafikkarte hatte zwar eine HDMI Schnittstelle, der Ton lief aber auch über den DVI Schnittstelle und da war ein enspr. Adapterkabel 0815 aus den Elekronikdiscounter oder Supermarkt angeschlossen.

    Quote

    Hier sind neben dem PCI-e 16x gleich zwei PCI-e als Platzhalter...


    Klasse, der Kühlkörper muss dann aber auf den Chipsatz sitzen. Bei einer Karte die den Huckepack trägt wie z.B. der von mir gelinkte MSI kann es Probleme geben. (siehe Kühlköper Chipsatz Mainboard) Wenn man darauf achtet sollte das i.O. gehen.

    Quote

    Müsste doch genau so funktionieren wie der BTX, oder?


    ATX oder BTX ist völlig egal, bis man ein neues Gehäuse sucht :tdw. Ich glaube nur FSC und ggf. Intel verwenden im großen Stil BTX-Mainboards.
    Für den Einstieg sieht der letzte Rechner ganz gut aus
    Hier die Pros und Contras wie ich sie sehe:
    +ATX
    +4 PCI Slots
    +2 PCIE Slots
    +PEG 16x
    +GBit LAN
    +Serial Port
    +4 SATA
    ~1 IDE (weiß nicht ob es eine ammenmärchen ist dass DVD-ROM und Festplatte an einem Kontroller die Festplatte bremst?!)
    -P4-D (rel. stromhungrig)
    -kein SPDIF (nicht zwingend erforderlich mit G210 oder besser ansonsten extra Soundkarte)
    -kein 5.1 / 7.1 Sound (wie gesagt extra Soundkarte wenn mans braucht)
    Wenn der vergleichsweise hungrige P4-D nicht stört :tup


    Wollace

    Quote

    Wie hab ich mir denn das mit den "Abstrichen in der Darstellungsqualität" vorzustellen. Mein Fernseher hat nen integrierten DVB-C Tuner und ich muss sagen das HD-Programm sieht schon ziemlich genial aus. Wie weit weg davon ist man dann mit VDPAU?


    Ich kenne zwar nicht die Qualität deines DVB-C Tuners, aber bei VDPAU kann es bei schnellen Kameraschwenks zu erkennbaren Versatz im Bildaufbau kommen zumindest bei mir und der GF9500