Posts by befi

    Wenn ich das richtig im Kopf habe, wird der VDR in der Vorkonfiguration beim Auslösen des Standby nicht gestoppt. Du kannst in der Datei /etc/yavdr/force-reload-services.list (die musst du anlegen, falls sie noch nicht existiert) Dienste eintragen, die nach dem Aufwachen neu gestartet werden sollen.

    Code: /etc/yavdr/force-reload-services.list
    1. vdr

    Falls das nicht genügt, schau mal in die Logdateien (dmesg und syslog), da sollte man sehen, was da genau passiert.


    Für das Entladen und erneute Laden von Kernelmodulen ist die /etc/yavdr/force-reload-modules.list vorgesehen. Auch hier kommt ein Eintrag pro Zeile. Die Reihenfolge ist Dienste stoppen, Module entladen, Module laden, Dienste starten: https://github.com/yavdr/yavdr…30force-reload/10_main#L3

    Danke für den Hinweis, habe das mal probiert, bringt aber leider auch keinen Erfolg. Auch ein zusätzlich sleep 5 mit service restart den ich in das script gebaut habe nützt nichts. Weiter wollte ich dann mit irgendwelchen delays nicht rumbasteln und habe das System nun erstmal auf einen echten powerdown gestellt.

    Hallo zusammen,

    seit Jahren nutze ich schon einen bisher perfekt funktionierenden yavdr 0.6

    Nun habe ich seit der Umstellung meiner defekten Tevii-Karten auf TT S2-3200 das Problem, das die Dinger grundsätzlich gut funktionieren, aber nach einem Suspend-To-RAM nicht eingebunden werden. Erst nachdem ich den vdr restarte (also nur den Prozess), werden die Karten eingebunden.

    Wo fange ich da an zu suchen, bin für jeden Tip dankbar!

    TIA!

    Nun funktioniert der wakeup mit ACPI, shutdown (S5) und den o.g. ASUS settings aus dem wiki ... eigentlich hatte ich das auch schon länger so eingestellt, was nun den eigentlichen Ausschlag für das Funktionieren gegeben hat, ist mir leider nicht klar ... naja, der Erfolg zählt :-)

    Hi,
    ich hoffe mir kann jemand einen guten Tip geben ... das Mainboard meines vdr hatte sich verabschiedet und musste gewechselt werden (auf ASUS M5A78L-M/USB3) . Inzwischen läuft so ziemlich alles wieder wie vorher, nur der Wakeup der Timer funktioniert noch nicht ... sehr ärgerlich :-/


    meine aktuelle konfiguration:


    yavdr-System settings:
    Suspend to RAM
    ACPI Mode


    in /etc/default/grub

    Code
    1. p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 13.0px Menlo}span.s1 {font-variant-ligatures: no-common-ligatures}GRUB_CMDLINE_LINUX_DEFAULT="vmalloc=256m quiet splash noresume nohz=off acpi_enforce_resources=lax hpet=disable"





    im BIOS habe ich Power -> APM Configuratiom "Power on From S5 by PME#" -> "Enable" gesetzt


    trotzdem startet er nicht, wenn ich eine Aufnahme programmieren und ausschalte.


    Was mich irritiert ist z.B., warum in /proc/acpi/wakeup nur S4 stehen

    Code
    1. p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 13.0px Menlo}span.s1 {font-variant-ligatures: no-common-ligatures}span.Apple-tab-span {white-space:pre}cat /proc/acpi/wakeup Device S-state Status Sysfs nodePCE2 S4 *disabled pci:0000:00:02.0PCE3 S4 *disabledPCE4 S4 *disabledPCE5 S4 *disabledPCE6 S4 *disabledPCE7 S4 *disabled pci:0000:00:07.0PCE9 S4 *disabledPCEA S4 *disabled pci:0000:00:0a.0RLAN S4 *enabled pci:0000:03:00.0PCEB S4 *disabledPCEC S4 *disabledSBAZ S4 *disabled pci:0000:00:14.2P0PC S4 *disabled pci:0000:00:14.4UHC1 S4 *enabled pci:0000:00:12.0UHC2 S4 *enabled pci:0000:00:12.1UHC3 S4 *enabled pci:0000:00:12.2USB4 S4 *enabled pci:0000:00:13.0UHC5 S4 *enabled pci:0000:00:13.1UHC6 S4 *enabled pci:0000:00:13.2UHC7 S4 *enabled pci:0000:00:14.5





    Könnte mir jemand einen guten Tip geben, wie ich mich der Ursache des Problem nähere?
    Danke im Voraus,
    Bernd

    Schau mal in deine channels.conf, ob da irgendwas merkwürdig drin aussieht. Irgendwie bekommt live einen NULL Kanal.
    Oder ist da evtl. ein nicht mehr vorhandener Kanal, der angezeigt werden soll? Bitte auch mal vdr-plugin-live-dbg installieren, falls vorhanden.


    Lars

    Hey Lars,
    super Tip! :cool1
    Die channels.conf war 0 byte .... nun muss ich sie mir halt neu zusammenbasteln. Die Frage bleibt, was die Datei geleert haben könnte ...


    Ja ja, von wegen nichts geändert. Wahrscheinlich neue Fritzbox, oder an der Config rumgemacht.


    Gerald


    Nein, wirklich nichts geändert auch keine andere Fritzbox oder so ... ne andere Hose habe ich heute an, das sollte aber nichts ändern :-)


    Hab die Fritzbox trotzdem mal aus der Config genommen, vdr crashed auch nicht mehr, ich seh einfach nix. X scheint grundsätzlich zu laufen, ich fahre das System normalerweise mit vdr-plugin-softhddevice. Zum Test habe ich mal XBMC probiert, der startet ohne Probleme.


    Wo könnte ich denn sonst noch schauen, wo es hängt?


    cu,
    Bernd

    Hi,
    es ist wirklich so, mein vdr läuft seit Jahren ohne Probleme, gestern abend war noch alles o.k., heute morgen kein Bild mehr (d.h. BIOS etc sehe ich, auch die startup-meldungen vom vdr, aber eben kein Fernsehbild mehr) ... und ich sehe keine direkte Fehlermeldung im dmesg,


    Kann mir jemand einen Tip geben?


    TIA,
    Bernd

    Files

    • syslog.txt

      (151.18 kB, downloaded 31 times, last: )
    • dmesg.txt

      (57.58 kB, downloaded 36 times, last: )

    Hi,
    mir ist eben aufgefallen, das ProSieben nun scheinbar den Episodentitel endlich im EPG Subtitle sendet, was vdrseriestimer sinnvoll nutzbar machen würde ... leider steht hinter dem Epsiodenname Genre, Land und Erscheinungsjahr, was ja ganz nett ist, aber die Erkennung stört:


    Code
    1. E 2380 1403267806 1763 50 0
    2. T The Big Bang Theory
    3. S Strafe muss sein, Sitcom, USA 2012
    4. D Howard lässt sich von Bernadette überreden, mit ihren Eltern essen zu gehen. Da er nicht weiÃ, worüber er sich mit den Rostenkowskis unterhalten soll, lenkt Bernadette das Gespräch auf die Angelleidenschaft ihres Vaters. Ehe sich d
    5. ie beiden Männer versehen, haben sie ihre Frauen für das nächste Wochenende zum Angeln miteinander verabredet. Aber vom Angeln hat Howard leider keine Ahnung und nun hat er höllische Angst, dass er sich hoffnungslos blamiert.|Regie:
    6. Mark Cendrowski|Drehbuch: Chuck Lorre, Bill Prady, Tara Hernandez|Kamera: Steven V. Silver|Schnitt: Peter Chakos|Darsteller:|Johnny Galecki (Leonard Hofstadter)|Jim Parsons (Sheldon Cooper)|Simon Helberg (Howard Wolowitz)|Kunal Nayya
    7. r (Rajesh Koothrappali)|Kaley Cuoco (Penny)|Melissa Rauch (Bernadette Rostenkowski)|Casey Sander (Mike Rostenkowski)|Meagen Fay (Mrs. Rostenkowski)|Mayim Bialik (Amy Farrah Fowler)
    8. e


    vdrtimer macht dann daraus:


    Hat jemand eine gute Idee?
    TIA,
    Bernd

    Hello world,
    hat jemand eine Idee, warum das yavdr-addon-pip nichts tut (also kein zweites Fenster öffnet?
    Im syslog steht nur:


    Code
    1. Sep 8 20:50:30 video vdr: [3023] executing command '/usr/share/vdr/menuorg-appswitcher standalone=no app=vdr-pip &> /dev/null '
    2. Sep 8 20:50:30 video kernel: [ 1324.698960] init: toggle main process (3618) terminated with status 1
    3. Sep 8 20:50:30 video vdr: [3611] Text2Skin: menu display update thread ended (pid=3023, tid=3611)


    Ich benutze sxfe als frontend, habe aber auch mit softdevice keinen Erfolg.
    Gibt es noch ein anderes Logfile? Oder evtl. eine Config-Datei, in die ich mal reinschauen könnte?
    TIA,
    Bernd

    hmmm, bei aktivierten Statusnachrichten im music-plugin ( setup von befi) habe ich auch den oben beschriebenen Effekt bei der Anzeige.


    Yes!
    Das war's, mit deaktivierten Statusnachrichten sieht es so aus wie es soll. Danke allen Beteiligten für's mitsuchen!


    cu,
    Bernd

    Gleiches Ergebnis (s.u.) :-/


    was mir noch aufgefallen ist

    Code
    1. Mar 2 16:50:34 video vdr: [6886] music: ctrl: couldnt save current playlist to file


    und

    Code
    1. Mar 2 16:54:22 video vdr: [7230] music: language set '/language/german'


    wo möchte er denn hinschreiben und wie könnte ich die Sprache mal testweise auf englisch ändern?


    Mar 2 16:50:13 video vdr: [6886] loading plugin: /usr/lib/vdr/plugins/libvdr-music.so.1.7.27
    Mar 2 16:50:13 video vdr: [6886] initializing plugin: music (0.9.9-dev2): MP3-/Audioplayer
    Mar 2 16:50:13 video vdr: [6886] music: music: initial configdir set to '/var/lib/vdr/plugins/music'
    Mar 2 16:50:13 video vdr: [6886] music: Loading skin 'MORONIMO_HD_GREY'
    Mar 2 16:50:13 video vdr: [6886] loading /var/lib/vdr/plugins/music/musicsources.conf
    Mar 2 16:50:13 video vdr: [6886] music: WARNING: removing trailing '/' from base /media/Musik/
    Mar 2 16:50:13 video vdr: [6886] music: loading id3 cache from /var/lib/vdr/plugins/music/data/admin/id3info.dat
    Mar 2 16:50:26 video vdr: [6886] music: language set '/language/german'
    Mar 2 16:50:34 video vdr: [6886] music: playback started with instant playlist 09 - Beneath the Surface.mp3
    Mar 2 16:50:34 video vdr: [6886] music: ctrl: couldnt save current playlist to file
    Mar 2 16:50:34 video vdr: [7027] music: player: player thread started (pid=6886)
    Mar 2 16:50:49 video vdr: [7027] music: player: player thread ended (pid=6886)



    root@video:/usr/share/vdr-plugin-music/music# svdrpsend PLUG music CONFIG
    220 video SVDRP VideoDiskRecorder 1.7.27; Sat Mar 2 16:52:13 2013; UTF-8
    900 /var/lib/vdr/plugins/music
    221 video closing connection


    root@video:/var/lib/vdr/plugins/music/themes# ls -latr
    insgesamt 48
    -rw-r--r-- 1 vdr vdr 8827 Okt 30 2011 MORONIMO_HD_BLUE.theme
    -rw-r--r-- 1 vdr vdr 8827 Okt 30 2011 MORONIMO_HD_GREY.theme
    drwxr-xr-x 5 vdr vdr 4096 Feb 24 15:53 skins
    drwxr-xr-x 10 vdr vdr 4096 Feb 25 19:52 ..
    -rw-r--r-- 1 vdr vdr 8827 Mär 2 13:46 current.colors
    drwxr-xr-x 3 vdr vdr 4096 Mär 2 13:46 .
    root@video:/var/lib/vdr/plugins/music/themes# mv current.colors current.colors.20130302
    root@video:/var/lib/vdr/plugins/music/themes# stop vdr
    vdr stop/waiting
    root@video:/var/lib/vdr/plugins/music/themes# start vdr
    vdr start/running, process 7230




    Mar 2 16:54:00 video vdr: [7230] loading plugin: /usr/lib/vdr/plugins/libvdr-music.so.1.7.27
    Mar 2 16:54:00 video vdr: [7230] initializing plugin: music (0.9.9-dev2): MP3-/Audioplayer
    Mar 2 16:54:00 video vdr: [7230] music: music: initial configdir set to '/var/lib/vdr/plugins/music'
    Mar 2 16:54:00 video vdr: [7230] music: WARNING: no themefile found ! Using default skin '/var/lib/vdr/plugins/music/themes/skins/DEFAULT/'
    Mar 2 16:54:00 video vdr: [7230] loading /var/lib/vdr/plugins/music/musicsources.conf
    Mar 2 16:54:00 video vdr: [7230] music: WARNING: removing trailing '/' from base /media/Musik/
    Mar 2 16:54:00 video vdr: [7230] music: loading id3 cache from /var/lib/vdr/plugins/music/data/admin/id3info.dat
    Mar 2 16:54:22 video vdr: [7230] music: language set '/language/german'
    Mar 2 16:54:31 video vdr: [7230] music: playback started with instant playlist 09 - Beneath the Surface.mp3
    Mar 2 16:54:31 video vdr: [7230] music: ctrl: couldnt save current playlist to file
    Mar 2 16:54:32 video vdr: [7528] music: player: player thread started (pid=7230)
    Mar 2 16:54:43 video vdr: [7528] music: player: player thread ended (pid=7230)


    [/code]

    Ich benutze die Version, die in der yavdr-paketliste ist. Wenn ich es starte, kann ich Musik auswählen, dann flackert kurz das UI vom plugin auf, danach sehe ich dann nen schworzen Bildschirm :-/. Musik wird abgespielt, ich kann das plugin bedienen, aber im play mode dann eben wieder nix ...



    Hab mal die settings vom softhddevice und music-plugin angehängt, vielleicht sieht jemand was.





    wenn auch niemand eine Idee hat, wäre es möglich das jemand der softhddev benutzt mal kurz das music-plugin in seiner umgebung ausprobiert und feedback gibt, ob ich hier ein persönliches Problem habe oder es wirklich nicht geht?
    Wäre ganz toll, besten Dank im Voraus!!!!

    O.K. ... das zucken ist weg, lag wohl an der Visualization, die habe ich ausgeschaltet. Nun habe ich direkt beim Start des plugins ein Bild, so wie es sein soll, dann wird's schwarz und ich seh' nur noch einen schwarzen Bildschirm mit Spieldauer und Fortschrittsbalken

    Gundsätzlich läuft das plugin ja auch, ich kann Musik auswählen und wenn ich Play drücke dudelt es lustig vor sich hin. Nur auf dem TV sehe ich nichts als eine zuckende, fortlaufende Zeitanzeige links unten und einen ebenfalls zuckenden Fortschrittsbalken. Auf Tasten/Fernbedienung reagiert alles ganz wie es soll. Jede weitere Hilfe ist sehr willkommen :-)


    Das syslog sagt:


    Glückwunsch und DANKE für diese großartige Distribution!
    Ich habe seit 2002 so manche VDR Installation gemacht und diese (bzw. der upgrade von yavdr 0.3) war mit Abstand die schmerzloseste, alle wichtigen Features liefen quasi OOTB


    Bernd