Posts by tmn505

    SurfaceCleanerZ arleady mentioned what are the usual use cases for VDR. You could use already proposed options and I'll add another one, add xineliboutput plugin and connect to local VDR with vdr-sxfe. All of them work but are a little bit clunky to use, if TV watching is not the main thing You do on Your PC.


    And there's a solution (buzzword!) for Your problem, install kaffeine. It's not on par with features that usual Windows programs You used have, but the basics are there. There's fine YouTube video from Hauppauge which illustrate how to set it up

    . Good luck.

    I do use tbsdtv drivers on 5.10 kernel albeit on Arch Linux x86_64. This might be an ARM drivers specific issue or patches applied on Armbian kernel. Judging from this site https://www.linuxtv.org/wiki/index.php/TBS5922 and the issue You linked, the compilation fails on module which Your card doesn't use. Use the build system to select the drivers You need:

    Code
    1. git clone https://github.com/tbsdtv/media_build.git && cd media_build
    2. make download
    3. make -C linux untar
    4. make menuconfig #select Your card here
    5. make -j($nproc)
    6. sudo make install

    In the menuconfig there are a lot of things pre-selected, try to narrow Your card modules to build as few drivers as possible, so the possibility of failed compilation goes lower. Good luck.

    In tntnet 3.0 there's no tntnet-config. You'll have to use pkg-config.

    But that's not all, later at compilation You'll get:

    Code
    1. g++ -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -O3 -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include -std=c++11 -Wfatal-errors -Wundef -Wno-deprecated-declarations -Wno-overloaded-virtual -Wno-unused-variable -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"live"' -DTNTVERSION=30000 -DCXXTOOLVER=30000 -DHAVE_LIBPCRECPP -I/include -I.. recordings.cpp
    2. recordings.ecpp: In member function 'virtual unsigned int {anonymous}::_component_::operator()(tnt::HttpRequest&, tnt::HttpReply&, tnt::QueryParams&)':
    3. recordings.ecpp:59:6: error: 'deletions_type' has not been declared
    4. 59 | for (deletions_type::const_iterator it = deletions.begin(); it != deletions.end(); ++it) {
    5. | ^~~~~~~~~~~~~~
    6. compilation terminated due to -Wfatal-errors.
    7. make[1]: *** [Makefile:34: recordings.o] Error 1
    8. make: *** [Makefile:191: pages] Error 2

    So it's better to use older cxxtools+tntnet for now.


    At some point where I used VDR on OpwnWrt I had to add similar patch. Back then I didn't delve what was the issue, but seeing it now the issue probably stems from using different source of libjpeg. Most distros use libjpeg-turbo now, but previously some used libjpeg from IJG (OpenWrt 18.06.x).

    Es geht so für alle Treiber im neuen media_build's wegen dieses commit:
    https://git.linuxtv.org/media_…c951fe52629b722f79c70883f
    Der build einstellt den CONFIG_DVB_DEMUX_SECTION_LOSS_LOG auf y. Um das zu umgehen ausführe Ich diese befehle:


    Code
    1. git clone git://linuxtv.org/media_build.git
    2. cd media_build
    3. make download
    4. make untar
    5. make stagingconfig
    6. sed -i '/CONFIG_DVB_DEMUX_SECTION_LOSS_LOG=y/d' v4l/.config
    7. make


    Vergiss nicht der Treiber zum installieren.

    Add the following to Your ~.xine/config_xineliboutput:

    Code
    1. video.output.vaapi_swap_uv_planes:1


    or search it for this string, uncomment and change the value to 1.
    For further tweaking, here You have some vaapi options explained:
    https://github.com/huceke/xine…i/blob/vaapi/README.vaapi


    Edit:
    Sorry, this is false, don't think this'll solve Your problem. When checked later I executed it with --video=xv.