Posts by Jinx138

    jsffm Super, vielen Dank nochmal! Letztlich war es bei mir so, dass egal, was ich in die asound.conf schrieb, es kam immer nur auf die Einstellung in der softhddevice.conf an. Dank Deiner Vorarbeit konnte ich das Script wie folgt anpassen:


    Das war dann auch mein erstes Script überhaupt, hat mich einige Zeit gekostet, den Code überhaupt zu verstehen (als Nicht-Coder) aber jetzt hab ich wieder richtig was gelernt!

    Nach einer Neuinstallation wegen neuer Hardware kann ich machen was ich will, ich schaffe es einfach nicht, dass nach einem Reboot der Ton läuft. Pulseaudio ist nicht installiert.

    Code
    1. $ aplay -l
    2. **** Liste der Hardware-Geräte (PLAYBACK) ****
    3. Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
    4. Sub-Geräte: 0/1
    5. Sub-Gerät #0: subdevice #0
    6. Karte 0: NVidia [HDA NVidia], Gerät 7: HDMI 1 [HDMI 1]
    7. Sub-Geräte: 1/1
    8. Sub-Gerät #0: subdevice #0

    Die /etc/asound.conf sieht so aus:

    Code
    1. defaults.pcm.!card 0
    2. defaults.pcm.!device 3
    3. defaults.ctl.!card 0

    Entsprechend habe ich die /etc/vdr/conf.avail/softhddevice.conf angepasst:


    Code
    1. [softhddevice]
    2. -a hw:0,3
    3. -p hw:0,3
    4. -d :0.0
    5. -f
    6. -g 1920x1080+0+0
    7. -v vdpau
    8. -D
    9. -w alsa-driver-broken

    Ein Speakertest speaker-test -c 2 -r 48000 -D hw:0,3 gibt dann: "Fehler beim Öffnen des Gerätes: -16, Das Gerät oder die Ressource ist belegt".

    Der Test auf hw:0,7 funktioniert dann.
    Wenn ich dann in der softhddevice.conf die Werte auf hw:0,7 ändere, ist der Ton da.

    Jetzt das Verrückte: Nach jedem Reboot geht das Spiel genau anders herum. Gerät 3 und 7 werden vertauscht, der Ton bleibt weg.

    Guten Morgen!


    Da ich für retroarch für meine nvidia 630 die Vulka-Unterstützung haben wollte, habe ich versucht, die o.a. Konfiguration (vdr-plugin-softhddevice-openglosd-ffmpeg-2.8 mit aktuellem nvidia-driver-435) zu installieren. Die Installation ging glatt durch, aber das frontend startet nicht mehr:



    Das gleiche passiert auch mit dem vdr-plugin-softhddevice-openglosd. Fehlt da noch ein Paket?


    Hat jemand Tipps für die Fehlersuche?

    Gibt es denn eine Möglichkeit Einträge, die aus <plugin name="desktop"> entstehen (in meinem Fall /Games/Retroarch), direkt in das Hauptmenü zu bringen, damit ich mit der FB nicht soweit navigieren muss?


    Und wie editiere ich den Aufruf (um verbose-mode zu bekommen: retroarch --menu --verbose >> retroarch.log 2>&1)?

    Hierzu würde es mir schon helfen, die Einträge und Aufrufe aus dem o.a. Eintrag zu sehen und zu analysieren. Dann kann ich mir einen eigenen Command Eintrag ins Menu schreiben (inklusive ausschalten des frontends, da es bei dem o.a. einfachen Aufruf im Hintergrund ja anbleibt).

    Danke für die schnelle Antwort. Aber auch nach ACPI_ENABLED=yes ändert sich leider nichts. (Wert geändert, reboot, Timer programmiert, ausgeschaltet, nichts passiert).

    In group_vars/all hatte ich bei der Installation nichts verändert: wakeup_method: acpiwakeup (und natürlich keine localhost variablen angelegt).


    Ist das soweit okay?

    Code
    1. Sep 10 21:36:33 yavdr vdr-addon-acpiwakeup: Writing 0 to /sys/class/rtc/rtc0/wakealarm
    2. Sep 10 21:36:33 yavdr vdr-addon-acpiwakeup: Writing 1568145693 to /sys/class/rtc/rtc0/wakealarm
    3. Sep 10 21:44:43 yavdr kernel: [ 1.759415] rtc_cmos 00:00: RTC can wake from S4
    4. Sep 10 21:44:43 yavdr kernel: [ 1.759571] rtc_cmos 00:00: rtc core: registered rtc_cmos as rtc0
    5. Sep 10 21:44:43 yavdr kernel: [ 1.759606] rtc_cmos 00:00: alarms up to one month, y3k, 242 bytes nvram
    6. Sep 10 21:44:43 yavdr kernel: [ 1.802178] rtc_cmos 00:00: setting system clock to 2019-09-10 19:44:35 UTC (1568144675)

    Hallo verehrte und kundige Mitstreiter.


    Mein System fährt leider nicht mehr automatisch hoch wenn Timeraufnahmen anstehen. Leider kann ich noch nicht einmal einschränken, ob es seit der Neuinstallation von yavdr-ansible scheitert (ich hatte soviel uptime ;o)) oder erst danach.


    Wenn ich zu Testzwecken den Rechner per sudo rtcwake -m no -s 60 && sudo poweroff wieder aufwecke, funktioniert das auch.


    In /etc/vdr/vdr-addon-acpiwakeup.conf steht ACPI_ENABLED=no, so dass ich davon ausgehe, dass standardmäßig der wakeup per rtc-wakeup aktiviert wird.


    cat /proc/driver/rtc gibt:


    Wo liegt denn wohl das Problem?

    Es sind so häufig die einfachen Dinge, Danke wmautner . Und das kommt davon, wenn man epg-plugins installiert, ohne vorher zu lesen, was die machen. Nach Löschen der epg.data und Deinstallation von epg2vdr und scraper2vdr lief alles wieder wie gewohnt. Ich war nur auf die falsche Fährte geführt, da nach dem Rückspielen des Backups der epg-Fehler auftrat und die channels.conf weg war.

    tja und da liegt wohl der Hase im Pfeffer:


    Das ist alles. Das passt so gar nicht zu meiner channel.conf, die da 159,3 kB groß ist.


    -rw-r--r-- 1 vdr vdr 236 Aug 31 21:07 epg.data sollte aber passen, liegt also nicht an den Rechten.


    $less /var/log/syslog | grep epg.data gibt u.a.


    bin nochmal zurück zu diesem system... epgd war mit sicherheit überflüssig, hab es deinstalliert.

    ich brauche tatsächlich nur die reinen epg-daten aus dem dvb datenstrom. da scheint etwas zu haken. aber was?

    Hast Du eventuel SQL-Fehler meldungen im Log so wie ich

    Hab natürlich auch Deinen thread gesehen, aber diese Fehler hab ich eben nicht (zumindest nicht im syslog).

    cat /var/log/syslog | grep mysql:


    Aber das hier könnte es sein, oder?

    $ cat /var/log/syslog | grep epg

    Code
    1. Aug 30 14:26:33 yavdr vdr: scraper2vdr: epgd busy, trying again in 60 seconds ...
    2. Aug 30 14:26:41 yavdr epgd: 742 DVB pending, mergeepg done after 172.203 seconds
    3. ...
    4. Aug 30 14:26:41 yavdr epgd: State now 'standby'
    5. Aug 30 14:26:41 yavdr epgd: Error: SVDRPCL: Connecting to '192.168.178.25:6419' Connection refused failed

    Wobei SVDR ja nix mit dem lokalen epgd zu tun hat...


    Ist das soweit korrekt?

    $ cat /etc/epgd/channelmap.conf-epgdata-astra


    $ cat /etc/epgd/channelmap.conf

    $ sudo systemctl status mariadb (alles i.O.):

    MariaDB [(none)]> show databases;


    Syslog nach epg-update:


    cat /etc/mysql/mariadb.cnf: