Posts by geeg07

    Mit einem Registry-Parameter kann man den Shutdown-Button ausblenden:


    Unter dem Schlüssel

    Code
    1. für den angemeldeten Benutzer
    2. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3. oder für alle Benutzer
    4. HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    einen neuen Parameter anlegen:
    Typ: DWORD
    Name: NoClose
    Wert: 1


    Dann benötigst du allerdings eine Verknüpfung für den Reboot im Startmenü oder am Desktop, wie es mini73 bereits erläutert hat, sonst gibt es auch keine Möglichkeit zum Reboot mehr.


    Meiner Meinung nach, verwendest du den falschen Parameter (TODAY=$(date +%Y-%m-%d_%H:%I))


    Das liefert eine Stunde lang das gleiche: %I = Stunde 01-12


    (TODAY=$(date +%Y-%m-%d_%H:%M))


    sollte passen...

    Code
    1. FOR /F "skip=2 tokens=3*" %I IN ('reg.exe query "HKEY_Local_Machine\Software\Programm\Application" /v Dirdata') DO @echo %I

    liefert den Inhalt, sofern der Inhalt keine Leerzeichen enthält.


    Alternativ würde sich noch die Windows Powershell oder ein kleines VB-Script dafür anbieten.

    Wenn es diese Zeile in deiner rc.local nicht gibt, dann hänge die beiden Befehle

    Code
    1. ntpdate de.pool.ntp.org
    2. hwclock --systohc

    einfach am Ende der rc.local an.


    Prinzipiell läuft es ja laut deinen Meldungen.


    Der Befehl ntpdate ohne Angabe des Zeitservers funktioniert nicht.

    Quote

    Original von De_uS
    Ich würde ja gern mittels NTP die Zeit aktkuell halten aber ich hab jetzt nirgends wo die erforderlichen Programme dafür gefunden.
    Und ohne Anleitung bekomme ich das auch nicht hin.


    Mit zenslack habe ich zwar nichts am Hut, aber HIER ist eine Anleitung, die für dich passen sollte.
    Das aktuelle NTP-Paket (enthält ntpdate) findest du auf www.ntp.org im Download-Bereich.

    Quote

    Original von StefanBogi
    Wie automatisiere ich den befehl also auf die richtige art und weise?!


    Eventuell wird ntpdate-debian nicht gefunden, crontab hat eine eigene Definition der Variable PATH.
    Versuch einmal beim Aufruf den Pfad mit anzugeben also z.B. /usr/local/bin/ntpdate-debian.

    Quote

    Original von knebb


    Dann schmeiss mal Dein sudo Krams weg! :unsch :gap


    Na so einfach ist es dann doch nicht :schiel


    Da hier auch Kids die vdr's nutzen, gibt es die mounts einmal mit "ro" und einmal mit "rw" (für mich, etwas mehr versteckt in Untermenüs).
    Das wurde erforderlich, als mir einmal mehrere meiner Aufnahmen gelöscht wurden.


    Jetzt könnte ich natürlich auch in der fstab 2 Einträge mit unterschiedlichen Verzeichnissen verwenden, aber ein Aufwand bleibt so oder so.


    Mit der sudo Lösung muss ich bei Änderungen, oder neuen Servern, nur die commands.conf editieren, jetzt würde die fstab noch dazukommen.
    Welche Vorgangsweise leichter zu warten ist, muss wohl jeder für sich selbst entscheiden.


    Allerdings gebe ich zu, dass das schon ein sehr spezielles Szenario bei mir ist.

    Quote

    Original von knebb
    Hmmm...ich habe es jetzt noch nicht getestet, aber ich denke dass mit "user" sowohl mount als auch umount gehen sollte...


    Hast Recht, das funktioniert.

    Quote

    Original von Tschennings
    zudem hat das da:
    Cmnd_Alias MOUNT = /bin/mount, /bin/umount, /usr/bin/smbmount
    gefehlt


    Dann kann es nicht funktionieren.


    Ich habe das wie angegeben bei mir auf mehreren vdr's im Einsatz, sollte also schon funktionieren...

    Also für mich ist das der einzige Weg, mit dem ich leben kann.
    Suchen musste ich bisher noch nicht, obwohl ich das schon im Einsatz habe, seit der vdr nicht mehr als root läuft :]


    Hier muss es möglich sein, per Befehl in der commands.conf, auch ein umount durchführen zu können, wenn die Aufnahmen vom Netzlaufwerk nicht mehr benötigt werden. Das wird wohl ohne sudo nicht funktionieren.


    Das Hauptproblem bei mir ist der vompserver, sind nämlich zu viele Aufnahmen vorhanden, stehen auf den vomp-clients nur sehr wenige Aufnahmen zur Verfügung.


    Es kommt halt immer darauf an, was man benötigt...

    Quote

    Original von Tschennings
    der mountbefehl: mount -t cifs -o username=123,password=456 //ip-des-server/freigabename /lokales-verzeichnis
    funktioniert aus der befehleszeile heraus als root prima, aber nicht, wenn ich die zeile in ein skript einfüge. ebenso nicht, wenn ich sie in die commands.conf eintrage - warum??? liegts am angemeldeten user? (root / vdr)?


    Um den mount Befehl als User vdr ausführen zu können, kannst du die erforderlichen Befehle in /etc/sudoers für den User vdr freigeben.


    Als root startest du mit visudo die Bearbeitung der Datei /etc/sudoers, diese sollte nicht direkt mit einem Editor bearbeitet werden.


    Für dein Vorhaben sollte die Datei folgenden Inhalt aufweisen, dann klappt mount auch als vdr

    Code
    1. # User privilege specification
    2. root ALL=(ALL) ALL
    3. #
    4. Cmnd_Alias MOUNT = /bin/mount, /bin/umount, /usr/bin/smbmount
    5. #
    6. # User privilege specification
    7. vdr ALL=(root) NOPASSWD: MOUNT


    In älteren Versionen des ctvdr war das Paket sudo nicht installiert, sollte also der Aufruf von visudo nicht funktionieren, ist noch folgendes erforderlich

    Code
    1. apt-get install sudo
    Quote

    Original von UFO
    Hi,


    da ja bald Weihnachten ansteht, noch etwas für Freunde "schöner" C-Programme
    (stammt nicht von mir, Irgendwo im Netz gefunden).


    :cool1 das kannte ich nicht.


    Für alle die keinen C-Compiler zur Hand haben die Ausgabe des Codes im Anhang und alle singen mit :].

    Files

    • xmas.txt

      (2.43 kB, downloaded 339 times, last: )
    Quote

    Original von UFO


    Das halte ich für ein Gerücht. Beides ist zulässig und korrekt.


    Wahrscheinlich ist es allerdings ein Entlassungsgrund, wenn jemand so programmiert. :D


    Alles schon gesehen. Zu Zeiten, als Speicher noch ein mittleres Vermögen kostete und von den Prozessoren die Bytes noch ziemlich langsam hin und her geschoben wurden, wurde beim coden auf jedes Byte Ersparnis und möglichen Gewinn an Performance Wert gelegt.
    Treten solche Zeilen geballt auf, braucht man sich über die Wartbarkeit keine großen Gedanken mehr machen. :schiel


    Ist aber alles eine Frage der Einstellung :unsch

    Quote

    Original von Mauki
    Allerdings dürfte dann auch das DVD-Meü garnicht sichtbar sein oder?


    Doch, das Menü funktioniert in diesem Fall ganz normal, da es nicht geschützt ist. Sobald du den Film startest wird es allerdings dunkel und du hörst im besten Fall noch den Ton.
    Das betrifft allerdings nur Kauf-DVD's mit CSS-Schutz.