Beiträge von TCr82

    Hi,


    ich habe vor längerer Zeit mir ein GLCD vom Typ T6963c besorgt und die ganze Zeit per Parallel Port an den PC verbunden. Jetzt habe ich einen neueren Mini-PC der keinen Parallel Port mehr hat. Jetzt dachte ich mir es ist doch sicher möglich, dass ganze per USB zu verbinden. Also hatte ich mir zuerst so einen Billig USB -> LPT Adapter Kabel besorgt, das wird aber unter Linux nur vom usblp Treiber geladen, der kein /dev/parport0 bereit stellt. Also habe ich ausführlich im Internet recherchiert und bin auf USB zu LPT Adpater gestoßen, die auf den Chip USS720 von Lucent basieren und unter Linux (Windows erkennt sie auch nur als USB-Druckerunterstützung und bietet keinen LPT Port) wohl auch für die Displays funktionieren sollten (wurde auch schon hier im Forum erwähnt). Leider werden diese nicht mehr Produziert und man bekommt sie auch nur noch spärlich. Ich habe aber einen Händler in der USA Ausfindig gemacht der das Kabel anbietet und hab mir mal eins bestellt.


    Jetzt habe ich das Kabel heute umgelötet, so dass ich nicht so viele Adapter (von Centronics auf DB25) benötige und auch das Kabel nicht so lang (das lange alte LPT Kabel + noch das neue lange USB Kabel) wird. Der Adapter wird auch unter Linux entsprechend erkannt und es sind alle Module geladen. Aber es funktioniert leider einfach nicht (mit showpic probiert).


    Ich habe auch gesehen dass es wohl auch möglich wäre mit dem picctl, nur weiss ich nicht wo ich die Platine her bekomme. Auch brauche ich eigentlich nicht die ganzen anderen Dinge (ausser das Dimmen des LCD wäre Interessant). Vielleicht gibt es ja aber noch ein anderes Projekt das einfach funktionieren kann. Toll wäre das Dimmen der Hintergrundbeleuchtung und wenn es unter Windows mit einer der bekannten LCD Programme funktionieren könnte (was aber nicht ganz so wichtig wäre).


    EDIT: Der Vollständigkeit halber: ich habe mal noch folgenden Adapter gefunden: http://www-user.tu-chemnitz.de…%20um%20den%20PC/USB2LPT/ - leider gibt es dafür wohl leider kein Linux Treiber


    EDIT2: das hier habe ich auch noch gefunden: Mit dem IO-Warrior56 soll man das Display auch an USB anbinden können.. nur der Preis von 60 Euro finde ich etwas hoch, da kann ich mir gleich ein Alphacool LCD Display 240x128 kaufen, was momentan fix und fertig für 60 Euro bestellt werden kann.


    EDIT3: hier ist wohl gerade auch was im Entstehen: USB_LCDGT: Drive all your Graphicals LCD based on T6963C driver with USB 2.0 bus

    wenn platz zum auslagern da ist würde ich entweder ein lvm mit ext4 oder btrfs nehmen. zfs wäre auch eine Option, braucht aber viel RAM.


    Bedeutet, alles auslagern, dann platten neu formatieren und alles wieder zurück.


    Ach, btrfs kann ein ext4 auch konvertieren....


    Gruß

    ich denke es macht mehr sinn das von der ubuntu implementierung machen zu lassen. Durch installation von landscape-common (das war das paket was ich vermisst hatte) sieht es nämlich so aus:



    Das kann man mit /usr/lib/update-notifier/update-motd-updates-available --force ausgeben lassen.


    EDIT: Okay, das update-motd-updates-available war schon vorher da... also auch ohne landscape-common, Siehe auch /etc/update-motd.d/90-updates-available

    Mein Vorschlag wäre das so abzuändern (ich bin muss das noch mal auf einer sauberen Installation gegentesten): https://github.com/yavdr/yavdr…tc/init/motd.conf/10_main


    das wird schief gehen:


    Code
    1. echo "Welcome to yaVDR $YAVDR_VERSION" >> /etc/motd


    Dann füllt sich das motd, besser nur ein >


    Und ich denke es ist gar nicht mehr nötig, dass run-parts laufen zu lassen, da laut der manpage das ganze von pam_motd (also beim login?) ausgeführt wird?!


    http://manpages.ubuntu.com/man…y/man5/update-motd.5.html

    außerdem ist das skript von yavdr nicht ausführbar (muss es das? EDIT: ja, muss ):




    und gut wäre eine Abhängigkeit auf update-motd. Das Paket war nicht per default installiert.


    EDIT: Okay, sehe gerade das Paket update-motd macht sowieso nichts. Es ist sozusagen leer...


    Okay, das Paket wurde durch libpam-modules ersetzt.


    http://manpages.ubuntu.com/man…y/man5/update-motd.5.html

    danke für den Hinweis.. ist mir auch schon aufgefallen und hab mich schon gewundert wieso es passiert - hatte ich früher immer durch leeren der /etc/motd beheben können. Deswegen hätte ich da jetzt auch kein Zusammenhang mit yaVDR gesehen...


    Gut das Google so effektiv ist, das hier kam schon als zweiter treffer zur suche von "motd ubuntu doppelt"


    Gruß

    Code
    1. root@vdr:~# head -n1 /etc/rc_keymaps/rc-medion-x10-or2x-mod
    2. # table rc-medion-x10, type: other


    ich habe eben auch mal die Datei so angepasst und neu gestartet - aber leider trotzdem keine verbesserung (tasten gehen nicht).


    Code
    1. root@vdr:~# head -n1 /etc/rc_keymaps/rc-medion-x10-or2x-mod
    2. # table rc-medion-x10-or2x, type: other


    hab aber noch das hier im log gefunden:


    Code
    1. Feb 22 00:40:15 vdr kernel: [ 7046.729287] init: eventlircd main process (999) killed by TERM signal
    2. Feb 22 00:40:56 vdr kernel: [ 2.825279] Registered IR keymap rc-medion-x10-or2x
    3. Feb 22 00:40:56 vdr kernel: [ 2.825513] input: X10 WTI RF receiver as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/rc/rc0/input5
    4. Feb 22 00:40:56 vdr kernel: [ 2.832691] rc0: X10 WTI RF receiver as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/rc/rc0


    der Prozess läuft aber letztendlich (war wohl vor oder beim neustarten)

    Hi,


    ich bekomme meine FB nicht mehr richtig zum laufen. Ich habe mir eine eigene rc-medion-x10-or2x angelegt und diese unter /etc/rc_keymaps/rc-medion-x10-mod abgelegt.
    Zusätzlich natürlich das template für /etc/rc_maps.cfg angelegt (und process-template /etc/rc_maps.cfg aufgerufen):


    nach einem Neustart geht die FB aber nicht, obwohl ir-keytable das Ausgibt:

    Code
    1. root@vdr:~# ir-keytable
    2. Found /sys/class/rc/rc0/ (/dev/input/event3) with:
    3. Driver ati_remote, table rc-medion-x10-or2x
    4. Supported protocols: other
    5. Enabled protocols:
    6. Name: X10 WTI RF receiver
    7. bus: 3, vendor/product: 0bc7:0006, version: 0x0200
    8. Repeat delay = 500 ms, repeat period = 125 ms


     
    erst nach dem ich das ausführe geht die FB (trotz fehler):

    Code
    1. ir-keytable -c -w /etc/rc_keymaps/rc-medion-x10-or2x-mod
    2. Read rc-medion-x10 table
    3. Old keytable cleared
    4. Wrote 53 keycode(s) to driver
    5. /sys/class/rc/rc0//protocols: Invalid argument
    6. Couldn't change the IR protocols


    früher hatte das alles noch so funktioniert... aber jetzt.. k.a. was da faul ist?


    Vielleicht hat wer eine Idee?


    Gruß

    das ist prima zu hören.


    Ich habe nebenbei ein paar kleine Anmerkungen:


    vdr-plugin-gamepad - VDR plugin that skips channels with unwanted content


    Hier stimmt die Beschreibung gar nicht - besser wäre sowas: Control VDR via a joystick device


    vdr-plugin-devstatus - <insert up to 60 chars description>


    Könnte man mal ändern auf: show status of all dvb devices


    vdr-plugin-epgsync - VDR plugin to control the OSD of a remote VDR


    Leider auch falsch: VDR plugin for EPG synchronization between VDR systems


    Grüße

    hi gurabli,


    sorry for my late answer, im not following the board really well, because I am always busy with work, family and other projects ;(


    the only thing I can say, that I use the videolan ppa for always fresh VLC.


    https://launchpad.net/~videolan/+archive/ubuntu/stable-daily


    What type of machine you have? I also have not such a powerful computer, only a old core 2 duo at 2.13GHz.
    But with VLC it was working well (yes it needs some time to start, but it was okay).


    I am not an expert in those codec stuff, I only followed recommendations which I found on google.


    But I think, when your machine has not mush power, you can just try to reduce the quality (see the bottom of the script at "case "$QUALITY" in"


    And if you prefer x264, theo or VP80 as video codec, depends also a little bit with your receiving device (what it can handle at best).

    All others things you have to probe for your self.

    Auch von mir ein fettes Danke. Eurer Einsatz ist wirklich wirklich super (auch wenn es hier und da immer mal harsche Worte regnet).


    Im April ist es schon wieder soweit und es wird eine neue Ubuntu 16.04 LTS Version im Hause stehen. Habt ihr euch schon Gedanken gemacht, wie es weiter geht im yaVDR in Bezug auf Upstart? Ist ein Umbau auf systemd geplant? Wird es wieder unstable/testing dazu geben wie es die ganze Zeit mit Ubuntu 14.04 LTS gab?


    Grüße,
    Thomas

    Hallo Leute,


    ich habe etwas am originalen externremux.sh Skript herum geschraubt, da ich immer Probleme mit dem Seitenverhältnis bei mencoder hatte und der mittlerweile ja nicht mehr entwickelt wird mit mplayer2. Zusätzlich ist beim aktuellen Ubuntu LTS auch ein Problem mit dem ffmpeg2theora aufgetreten...
    Deswegen habe ich erstmal ein wenig mit ffmpeg herum experimentiert, was auch Teils funktioniert hat. Letztendlich habe ich aber vlc eingebaut, was sehr gut klappt.


    Wollte hier einfach mal meinen Stand zur Verfügung stellen, und vielleicht bauen ja andere bei Interesse daran weiter.


    Gruß und viel Spass damit :)

    Dateien

    • externremux.sh

      (17,95 kB, 445 Mal heruntergeladen, zuletzt: )

    Du brauchst einen KVM Switch der das kann. Idealerweise einen KVM to IP. Denke das ist die beste Methode. Es gibt da einen richtig guten, nur kostet der auch etwas mehr: Lantronix Spider


    Sicherlich findet sich aber auch etwas kostengünstigeres.


    Gruß

    Naja es kann sich halt nicht jeder mit allem auskennen. Aber deswegen ist man doch in einer Gemeinschaft unterwegs um sich auszutauschen. Ich versuche ja auch immer brav erst mal selbst durch zublicken und forsche im Internet/Code nach. Aber ab einer gewissen Komplexität (wobei dieses Level bei mir normal schon hoch liegt) bzw wenn meine Suche zu keinem Ergebnis führt oder das Ergebnis nicht meinem Problem entspricht, erscheint es mir einfacher kurz bei den Experten durchzulauschen (mit einer so gut wie möglichen Beschreibung).


    Klar stelle ich auch mal eine Dumme Frage weil ich auf em Schlauch steh.


    Aber eigentlich ist das doch auch von Vorteil wenn Sachen hier fachlich Diskutiert werden, dann können andere sich auch daran bereichern.


    Ich kann wirklich gut verstehen das man manchmal genervt ist wenn jemand mit einer Anfrage ala "xy geht nicht" kommt, keine Details dazu liefert und nicht mal nach der Fehler Meldungen gegoogelt hat (Komme selbst aus dem Support Bereich).


    Aber ich denke dazu gehöre ich und manch andere hier sicher nicht.


    Darum finde ich die Umgangsformen hier manchmal leider richtig pampig und unfair.


    Z.b. das Thema Doku.. anstatt vorzuschlagen so einen Wiki Eintrag aufzubauen (was euch wieder einiges an Support Arbeit erspart da man blump darauf verweisen kann) kommt nur es wäre nicht hilfreich und wird kategorisch abgelehnt.


    Nochmal ich versehe es bedingt kann es aber trotzdem nicht für gut und konstruktiv heisen.


    Gruß

    immer das gleiche hier :(


    niemand hat hier was vorgeschrieben. ich habe nur gesagt es wäre hilfreich.


    der tonfall ist hier leider fast immer zum ****


    Keine Ahnung wieso ich und viele andere hier immer angemeckert werden...


    Ich habe das GANZ SICHER NICHT gesagt um irgendjemanden auf die füße treten zu wollen.