Posts by DanielG

    Hallo mal wieder,


    ich benutze jetzt vdr-1.3.32 mit bigpatch und versuche grad, tvonscreen-0.7.0 dafür zu kompilieren. Ich habe schon das patch von hier eingespielt (das von apex), aber er kennt "cDevice" nicht und bricht beim kompilieren ab...


    Brauch ich vielleicht doch noch irgendwelche Software? Eigentlich hat das doch keine großartigen Abhängigkeiten, oder?


    Grüße
    Daniel

    Seltsam dass scheinbar niemand sowas schonmal gesehen hat.


    Mittlerweile habe ich mit graphlcd-0.1.1 und showpic sowohl über 0x378 als auch über /dev/parport0 eine Ausgabe auf dem Display erreicht, und zwar mit dem "Feegy-Wiring".


    Wenn ich vdr von der Kommandozeile mit


    Code
    1. ./vdr -P'graphlcd -c t6963 -d /dev/parport0 -x 240 -y 128'


    starte, bekomme ich auf der Konsole nur "Killed" und meinen Prompt wieder.


    Im syslog steht dann


    Kann damit vielleicht jemand was anfangen?

    Hallo Gemeinde!


    Ich sitze grad dran und bringe meinen VDR auf einen neuen Stand.


    Jetzt hänge ich am GraphLCD. Ich habe ein t6963, das vorher einwandfrei lief.
    Nun zeigt es nur noch Pixelbrei. An sich ist in der graphlcd.conf auch alles "richtig" eingestellt.


    Was für Infos braucht ihr noch?


    Das ganze läuft auf
    vdr 1.3.32 mit bigpatch
    graphlcd-base-0.1.2-pre6a
    vdr-graphlcd-0.1.2-pre6


    Grüße
    Daniel

    Ja, hab ich gemacht.


    Geht auch nicht, obwohl


    Code
    1. vdr ~ # ll /dev/dvb/adapter0/
    2. crw-rw---- 1 root video 250, 1 Sep 13 22:56 audio0
    3. crw-rw---- 1 root video 250, 6 Sep 13 22:56 ca0
    4. crw-rw---- 1 root video 250, 4 Sep 13 22:56 demux0
    5. crw-rw---- 1 root video 250, 5 Sep 13 22:56 dvr0
    6. crw-rw---- 1 root video 250, 3 Sep 13 22:56 frontend0
    7. crw-rw---- 1 root video 250, 7 Sep 13 22:56 net0
    8. crw-rw---- 1 root video 250, 8 Sep 13 22:56 osd0
    9. crw-rw---- 1 root video 250, 0 Sep 13 22:56 video0
    10. vdr ~ #


    Ich bin am verzweifeln...
    Achja, und ich starte vdr als root, also sollten die Permissions auch reichen, oder?

    Hi Folks!


    Erstmal voraus, gesucht habe ich schon - ich finde leider nicht die Antwort, die ich suche.


    Ich habe die aktuellen DVB-Treiber aus den gentoo-sources verwendet (2.6.12-gentoo-r10) und bin nun so weit, dass ich sogar per lsmod alle module fehlerfrei laden kann.


    Aber wie erzeuge ich die Einträge under /dev/dvb/...


    Ein MAKEDEV-DVB.sh finde ich nicht... ;(


    VDR sagt:

    Code
    1. vdr: no primary device found - using first device!


    Oder seh ich da was falsch?

    Also, nachdem die Frage eigentlich war "Hardware gesucht" muss ich jetzt meine immer wieder gern ausgesprochene Empfehlung für ein Gehäuse loswerden: Das Antec Overture (link hier)


    Hab ich bei mir auch laufen, ist sehr leise und man bekommt standard-atx-boards rein, was die restliche Hardware-Auswahl meistens stark vereinfacht... ;)
    Ist halt leider nicht das kleinste, aber wenn man den Platz hat, warum mit Minigehäusen und irrwitzig aufwendigen Kühlkonzepten rumschlagen...

    Ich könnte dir höchstens ein "Workaround" anbieten...


    Kopier die Pakete, die du emergen willst von der CD nach /usr/portage/distfiles/


    Wenn emerge die Pakete in dem Verzeichnis findet, wird nicht versucht, sie runterzuladen.


    Grüße
    Daniel

    Sooo, jetzt hab ichs! :sonne


    In der runvdr musste ich das Plugin folgendermaßen angeben:

    Code
    1. vdr -P'mplayer -M /path/to/mplayer.sh'


    Kaum macht mans richtig, schon gehts...


    So dann, jetzt kann ich meinen restlichen 2. Weihnachtsfeiertag genießen. ;)


    Grüße
    Daniel

    Quote

    wieso wurde der mplayer nicht per emerge installiert ?


    Hmm, das habe ich bei meinem letzten System versucht, allerdings bin ich der Meinung, dass dann das "MPEG-PES to DVB-Card"-Feature gefehlt hätte... Kann mich auch irren.


    Aber ob ich jetzt selbst kompiliere oder emerge sollte doch nicht ausschlaggebend sein, oder? Immerhin läufts ja, wenn ich ihn von der Kommandozeile starte.


    Naja, ich debugge mal...


    [EDIT] Wohin soll denn die Debug-Ausgabe geschrieben werden? Im Syslog taucht nix auf... [/EDIT]

    Hallo Leute,


    also ich habe zwar schon ein paar Threads gefunden, die dieses Thema behandeln, aber keiner hilft mir weiter.


    Ich habe gentoo ohne X installiert, darauf dann vdr 1.2.6.
    Danach habe ich
    Mplayer 1.0pre3 bis pre5 jeweils selbst kompiliert und mit dem
    mplayer-plugin 0.8.3 und
    mplayer.sh 8.5 und 8.6 versucht, mplayer unter vdr zum spielen zu bewegen.


    Immer dasselbe Ergebnis: Bild kurz schwarz und dann wieder Fernsehbild. In den logs steht dann folgendes:

    Code
    1. Dec 20 22:58:53 vdr vdr[20577]: mplayer: player thread started (pid=20577)
    2. Dec 20 22:58:53 vdr vdr[20576]: mplayer: mplayer child started (pid=20576)
    3. Dec 20 22:58:55 vdr vdr[20577]: mplayer: player thread ended (pid=20577)


    Wenn ich von der Kommandozeile als root (vdr läuft auch als root) dann

    Code
    1. mplayer.sh test.avi


    starte, funzt alles wunderbar. (Natürlich nur, wenn VDR nicht läuft)


    Ach ja, Kontrollmodus ist Slave, und die Änderungen an der mplayer.sh (Framerate auf 30 setzen) habe ich auch vorgenommen...


    Hiilfe! ;(

    Also so prinzipiell klingt das alles ja ganz gut.


    Was ich auf der Suche nach einem passenden Gehäuse grade festgestellt hab ist aber, dass es immer mehr Gehäuse gibt, in die nur noch Low-Profile-Karten passen...


    Wäre es möglich, eine FF-DVB-Karte auf Low-Profile-Format zu pressen? Bzw sie so zu layouten, dass ein optionaler Budget-Teil dann quasi den Platz über dem Low-Profile-Gebiet beansprucht?


    Grüße
    Daniel

    Hmm, also meiner Meinung nach ist die Klangqualität bei MTV noch am besten - die nutzen wenigstens das volle Dynamikspektrum.


    Was die Codierung angeht, ist auch MTV nicht super, manchmal quietschts da auch ganz schön. Also wenn man Wert auf saubere Qualität legt, dann ist man nicht so gut bedient, wenn man über DVB aufnimmt...

    Hallo!


    Wenn dein Receiver nicht Dolby-Digital-fähig ist, dann kannst du das Stereo-Signal reingeben, und der integrierte Pro-Logic Decoder macht da Surround draus.


    Naturgemäß klingt das nicht so gut, wie bei einem AC3-System. Dazu gibts schon genügend Threads, glaube ich. ;)


    Außerdem: Wenn das Dolby-Zeichen "leuchtet", dann heißt das primär, dass Dolby vorhanden ist - nicht dass es auch rauskommt.
    Wenn dein Receiver aber kein AC3 verarbeiten kann bringts auch nix, das Signal am VDR anzuzapfen...


    Gruß
    Daniel

    In meiner Anleitung gibts eine solche Tabelle, aber die ist nicht Code-spezifisch, sondern beschreibt nur allgemein die Bedeutung der einzelnen Tasten für die unterschiedlichen Eingänge/Geräte.


    Wie gesagt, bei den meisten Codes sind nicht ausreichend Tasten aktiviert, was ich bei meiner FB am Leuchten oder nicht-Leuchten der jeweiligen Eingangswahltaste erkennen kann.

    Ist natürlich auch immer die Frage, für welches Device man den Code eingibt - bei mir hats nur für VID2 mit der 070 geklappt - dafür, wie gesagt, geht die SET-Taste nicht.


    Und das ist für den VDR ein wenig ärgerlich...


    Aber scheinbar sind die Codes auch für die älteren Receiver verwendbar.
    Und sowieso: harman/kardon rules! :strike2 Trotz FB-Unzulänglichkeiten...


    Grüße
    Daniel

    Also gut, nach etwas Suchen und Überlegen bi nich darauf gekommen, dass ich gestern ein "emerge system" gemacht habe - unter anderem hab ich mir nen neue gcc eingefangen...


    Nachdem ich den Treiber neu kompiliert habe, gehts jetzt wieder... puh... 8)

    Hallo!


    Hat jemand von euch schon mal folgendes gesehen?


    Code
    1. make[2]: Entering directory `/usr/local/src/linux-dvb.2003-11-08/driver'
    2. make[2]: *** No rule to make target `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/include/stdarg.h', needed by `dmxdev.o'. Stop.
    3. make[2]: Leaving directory `/usr/local/src/linux-dvb.2003-11-08/driver'
    4. make[1]: *** [_mod_/usr/local/src/DVB/driver] Error 2
    5. make[1]: Leaving directory `/usr/src/linux-2.4.25_pre7-gss-r7'
    6. make: *** [here] Error 2


    Das erscheint jetzt, wenn ich runvdr aufrufe. Kann jemand irgendwas damit anfangen?


    Ich habe Gentoo mit Kernel 2.4.25 und das System lief schon... Nur es sind auch keine DVB-devices mehr da... Warum verschwinden die einfach?


    Bei makedev.napi sagt er nur:

    Code
    1. It seems you are using devfs. Good!


    Installiert habe ich mit linux-dvb.2003-11-08 und vdr-1.2.6.


    Wenn jemand nen Tipp hat, wäre ich echt dankbar.
    Daniel