Posts by hondansx

    Ich muss hier auch mal ein positives Feedback abgeben. Markad ist ein lebendiges Projekt und unabdingbar. ;-)

    So macht der vdr erst richtig Spass.


    Ich werde testen und berichten.


    Danke für deinen jedesmal beispiellosen Einsatz.


    hondansx

    auf den ersten Blick vermute ich, das ist kein Bug, sondern ein fehlendes Feature.

    Grundsätzlich geht markad davon aus, dass es einen Timer Vorlauf gibt und es den Anfang selber suchen muss. Kaum jemand nutzt VPS, weil vor allem mit epg2vdr immer wieder von Problemen berichtet wird oder auch die Qualität der VPS Signale nicht immer optimal ist.

    Nutzt du epg2vdr ?

    Am einfachsten wäre es für mich, wenn du mir ein tar vom Aufnahmeverzeichnis zum Download bereit stellen könntest (Zugangsdaten dann per PM). Wichtig für mich sind deine originalen Timestamps der Dateien, darum ein tar. Geht das ?

    Hier gibt es einen Timernachlauf. Timer 16:10 /Aufnahme 16.12.35

    Hab ein log mit debug im Anhang. Dort sollte man alles sehen, evtl. reicht das ja schon.

    epg2vdr nutze ich nicht.

    Files

    • markad.log.gz

      (2.92 kB, downloaded 59 times, last: )

    Ich habe bei einer Serie, die immer um die gleiche Zeit beginnt (mit VPS), das Problem, das es den Anfang nicht findet.


    Code
    1. missed broadcast start by 2:40 min, length will be corrected
    2. recording started too late (startframe -8000), set start mark to start of recording



    Files

    • markad.log.gz

      (909 Byte, downloaded 56 times, last: )

    Ich denke nicht, das würde zu viele Probleme verursachen. Der Wert muss zusammen passen mit der Fehlerquote der Logo Erkennung. Wenn da jemand unbedingt selber was ändern will, kann er es ja im Code machen

    Was wäre den ein optimaler Wert dafür? Zum Verständnis: Wenn ein Logowechsel erkannt wird, dann ist dieser nur gültig wenn dieser Wert überschritten ist. Reichen da nicht z.B. 5 bis 10 sec.

    Ich vermute mal diese kurzen Werbeblöcke kommen nur in bestimmtem Sportevents. Hier war es Tischtennis.


    Die Werbemarken sehen jetzt korrekt aus bis auf eine.

    Ab 03:18 ist das Logo weg und es beginnt eine Werbepause.

    Bei 03:59 ist das Logo wieder da und die Pause ist beendet.

    Kann man hier auch noch optimieren?


    Code
    1. Sat Jul 11 08:04:02 [13217] INFO: detected logo start (15)* at 0:00:00.16
    2. Sat Jul 11 08:04:06 [13217] INFO: detected logo stop (4974) at 0:03:18.25
    3. Sat Jul 11 08:04:06 [13217] INFO: detected logo start (5976)* at 0:03:59.02
    4. Sat Jul 11 08:04:13 [13217] INFO: detected logo stop (15891) at 0:10:35.17
    5. Sat Jul 11 08:04:13 [13217] INFO: detected logo start (16896)* at 0:11:15.22

    Files

    Hi,


    auf Eurosport kommt oft Werbung die 40 -60 sec dauern, die werden erkannt aber verworfen:


    Code
    1. Wed Jul 8 21:48:41 [1296] INFO: mark distance between logo STOP and START too short (40.2s), deleting 15891,16896
    2. Wed Jul 8 21:48:41 [1296] INFO: mark distance between logo STOP and START too short (40.2s), deleting 62205,63210
    3. Wed Jul 8 21:48:41 [1296] INFO: mark distance between logo STOP and START too short (40.6s), deleting 94008,95022
    4. Wed Jul 8 21:48:41 [1296] INFO: mark distance between logo STOP and START too short (43.7s), deleting 170634,171726
    5. Wed Jul 8 21:48:41 [1296] INFO: mark distance between logo STOP and START too short (18.0s), deleting 192843,193293
    6. Wed Jul 8 21:48:41 [1296] INFO: mark distance between logo STOP and START too short (31.6s), deleting 200262,201051


    Desweiteren erkennt markad oft Logo start und stop. Aber wenn genau ich auf der Zeit nachschaue sehe ich das Logo in der Aufnahme.

    Files

    • markad.log.gz

      (3.79 kB, downloaded 88 times, last: )

    2. markad erkennt gar kein Logo im Start Teil bei dir. Bei mir schon. Ich vermute dein Logo unter /var/lib/markad ist schlecht oder nicht aktuell.

    Code
    1. Thu Jul 2 23:01:31 [25101] DEBUG: cMarkAdStandalone::CheckStart(): no logo start mark found

    Versuche mal:

    markad -v --loglevel=3 --autologo=2 --log2rec --logocachedir=/tmp nice <Pfand zur Aufnahme>

    Mit dem falschen --logocachedir und mit --autologo=2 erzeugt markad sein eigenes Logo.

    Poste mal das Log, ob es damit besser wird.

    Hi,


    mein Logo ist tatschlich zu schlecht, wobei das Ende der Show markad erkannt hatte nur den Anfang nicht.

    Die Logoautoerkennung hat es nun richtig gemacht. Muss ich zukünftig im Auge behalten, ob die vorhandenen Logos noch gut sind.


    Danke für den Hint.

    Ich habe auf ARD die Die_Carolin_Kebekus_Show mit einem Timer aufgenommen. Da in der Show keine Werbung vorkommt, sind 2 Schnittmarken vorhanden. Am Anfang und am Ende der Show.

    Die Anfangsmarke wurde aber nicht auf den Beginn des ARD-Logos gesetzt sonder vorher, wo noch kein Logo zu sehen ist und die Show noch nicht begonnen hat.


    Eine Idee dazu?

    Files

    • markad.log.gz

      (2.11 kB, downloaded 63 times, last: )

    Könntest du kurz erklären was die Parameter bedeuten in Zusammenhang Vor/Nachlauf Timer setzen?


    --astopoffs=<value> (default is 100) assumed stop offset in seconds range from 0 to 240

    --posttimer=<value> (default is 600) additional recording after timer end in seconds range from 0 to 1200

    Danke erstmal für die Tips.

    Ob nice oder after, das ändert an den Schnittmarken nichts.

    Mit selbstgesuchtem Logo wird nur noch das Ende des Filmes erkannt. Die Werbung (5x) findet markad gar nicht.

    Die Aufnahme wurde durch einen ein Timer mit 1Min. Vorlauf und 3Min. Nachlauf erzeugt.

    Gestartet wird markad dann mit einem hook nach der Aufnahme mit den genannten Parametern.

    Files

    • markad.log.gz

      (8.99 kB, downloaded 86 times, last: )

    Ich habe bei VOX (SD) sehr schlechte Marken. Ich frage mich wo ich ansetzen kann das zu verbessern.

    Ist ein einfache Datei ohne AC3 und mit gutem vorhandenem Logo.

    Jemand eine Idee?


    markad --cDecoder --astopoffs=0 --loglevel=3 -R --priority=19 --autologo=2 --backupmarks - after /video/@video/video0/James_Bond_007_-_Der_Hauch_des_Todes/2020-06-18.20.13.5-0.rec 

    Files

    • markad.log.gz

      (8.72 kB, downloaded 79 times, last: )

    Ich habe nun auf die letzte 4.2.2 aktualisiert. Bekomme mit dem neuen Decoder noch einen Segfault:



    Bitte teste nochmals mit dem neuen Decoder, da ist dann auch das Log ausführlicher. Das Log File dazu posten reicht dann für mich.

    Code
    1. markad --loglevel=3 --astopoffs=0 --cDecoder --log2rec nice <Pfad zum Recording>


    Mit dem neuen Decoder läuft es durch, aber es wird keine marks Datei erstellt.

    Files

    • markad.log.gz

      (6.2 kB, downloaded 112 times, last: )

    Ich bekommen einen Bus-Zugriffsfehler.



    Ich benutze folgendes:




    Code
    1. 00-markad-libavcodec58-V0-01.diff
    2. 01-markad-Makefile-V0-06.diff
    3. 02-deprecated-V0-04.diff
    4. 03-markad-decoder-V0-58.diff

    Files

    • markad.log.gz

      (2.65 kB, downloaded 114 times, last: )