Posts by hotzenplotz5

    oohh ich war blind ...
    ich hab jetzt das gefunden :


    https://github.com/Pulse-Eight…upport/cec-test-device.sh




    Code
    1. check_tv_power()
    2. {
    3. echo -n " * power status of the TV: "
    4. cec_client=`echo 'pow 0' | cec-client -t p -p 1 -d 1 -s | tail -n1 | grep 'power' | awk '{print \$3}'`
    5. if [ -z "${cec_client}" ]; then
    6. echo "ERROR"
    7. else
    8. echo "${cec_client}"
    9. fi
    10. }


    dabei darf libcec-daemon nicht laufen. dann kann man das überprüfen.


    ./cec-test-device.sh
    Pulse-Eight USB-CEC Adapter tester v0.1


    * power status of the TV: on



    na das sollte doch jetzt nicht mehr sooo schwer sein mit upstart ?(

    glotzipapa ich weiss nicht ob ich das hier her gehört, aber es wurde in deinem github repo entdeckt:
    https://github.com/realglotzi/ceclircd :D


    was mich interessiert, wie kann man das auf einem "normalen" also "nicht" raspi verwenden ?
    und gibt es mit deinem programm eine "erkennung" wenn man den tv anstellt. weil das mit libcec-daemon leider nicht funktioniert.


    d.h. libcec-daemon funktioniert alles ganz wunderbar ausser eben wenn man den tv ausschaltet und wieder anmacht libcec-daemon die verbindung
    verliert und auch nicht wieder automatisch herstellt.
    geht das mit deinem programm ? ?(

    als user vdr auf der konsole:


    squeezelite -o pulse
    Failed to create secure directory (/run/user/1000/pulse): Permission denied
    Failed to create secure directory (/run/user/1000/pulse): Permission denied
    Failed to create secure directory (/run/user/1000/pulse): Permission denied


    ich habe den eindruck pulseaudio und ich mögen uns nicht besonders. warscheinlich hat der pulseaudio programmierer auf halber strecke aufgehört zu programmieren und mit was anderem weitergemacht

    argh ok
    sek.


    achja beim beenden des plugins :



    evtl. sollte ich auch nochmal "default" als audio device testen. hab ich aber auch schon ...

    -l 3 in etc/default/vdr ?
    wenn ja, dann ist das alles was ausgegeben wird :(



    in var/log/vdr/upstart/vdr-frontend.log :



    ich schätze das hat nichts mit pulse zu tun ... ;(

    Code
    1. Nov 21 12:36:48 yavdr-lianli vdr: [5908] starting plugin: squeezebox
    2. Nov 21 12:41:06 yavdr-lianli vdr: squeezebox: started /usr/bin/squeezelite with pid 6120
    3. Nov 21 12:41:06 yavdr-lianli vdr: squeezebox: Trying connetion to 'localhost:9090', my mac is '00:22:4d:ab:ed:86'
    4. Nov 21 12:41:06 yavdr-lianli vdr: squeezebox: Connection to LMC server at 'localhost:9090' established


    sonst steht da leider nichts

    squeezelite -l steht oben 1. beitrag.
    also :



    Quote


    Was passiert, wenn wenn du squeezelite mit -o pulse bzw. -o default startest? Können dann sowohl der VDR als auch squeezelite etwas ausgeben?


    Code
    1. squeezelite -o default
    2. [09:38:20.815410] test_open:124 playback open error: Connection refused


    Code
    1. squeezelite -o pulse
    2. [09:38:08.031129] test_open:124 playback open error: Connection refused



    aber ich hab das auch in xbmc das problem.
    also mit xsqueeze kein tonn egal ob squeezeslave oder squeezelite

    horchi danke auch soweit fürs plugin !


    ich hab ein kleines problem hier mit dem ton. es kommt keiner :D


    vdr läuft hier mit trusty und pulseaudio.






    /etc/default/squeezelite


    Code
    1. # ALSA output device:
    2. SL_SOUNDCARD="pulse"


    /var/lib/vdr/setup.conf


    Code
    1. squeezebox.audioDevice = pulse



    ich hab schon mehrere varianten versucht keine geht .... also auch plughw:CARD=NVidia,DEV=7


    speaker-test -c 2 -r 48000 -D hw:1,7


    liefert mir tatsächlich ton bei gestoppten vdr
    frontend ist softhddevice.