Posts by FDF

    Also ich habe ewig rumprobiert und bin fürs erste zurück bei Windows. Der HD-Support ansich unter Linux ist super, aber bei Live TV war es einfach instabil. Das Bild war entweder grün gefärbt oder der Ton hat extrem geschnattert nach dem Einschalten. Es lief halt nicht zuverlässig, wie man es sich wünscht. ^^


    Die Intel-Entwickler selber haben auch schon angedeutet, dass der Linux Support bzgl. VAAPI beschränkt bleiben wird und so wird es wohl fürs Erste nichts...


    Danke euch trotzdem, eventuell tut sich ja bis zum Sommer (da habe ich dann wieder Zeit für solche Spielereien, dazwischen muss halt was stabiles laufen ^^) was. :)


    Seid aber ne nette Community, denke, dass sich hier noch viel mehr tun wird. Werde daher öfters mal vorbei schauen! :P

    Bevor du jetzt hier eine Show machst (und man kann auch höflich antworten), deaktiviere doch einfach mal alle Plugins und teste? Und dann nach und nach ein Plugin aktivieren, bis rauskommt, was Schuld ist?


    Das könnte auch einfach an dir liegen...

    Danke nochmal für eure Antworten! :)
    Habe gerade yaVDR erneut aufgesetzt (openELEC mit vaapi ging, aber da gabs ein paar Probleme) und daher hoffe ich gerade noch auf yaVDR. ;)


    Danke johns, ich werde mir die Anleitung anschauen und (sofern möglich) durchboxen. :P


    Quote

    Wenn es auf Windows gut funktioniert benutze Windows oder trete die intel Entwickler, damit sie etwas funktionierendes für Linux bereitstellen. Hier ist nicht der richtige Ort das zu diskutieren.


    Okay, dann werde ich mal schauen, ob ich die per Mail erreiche, was ja eigentlich möglich sein sollte. :D


    Wegen der Bildqualität: Es wäre halt für Intel User super, man könnte ja VDPAU und VAAPI einbauen. Für nVidia-User weiterhin VDPAU, für Intel User VAAPI. Aber wie schon gesagt wurde, liegen da wohl leider die Prioritäten wo anders, ich werde mal versuchen, mit dem vorhandenen Material etwas zu erreichen!

    Quote

    Ich hatte auch ein paar Monate mit der onboard-Grafik meines Core i5-2500 getestet und leider lief das weder unter Windows noch unter Oneiric so gut wie mit einer VDPAU-fähigen nVidia-Karte


    Naja, auf Windows läuft HDTV im DVBViewer und sonst das XBMC super. Da sind die Treiber ziemlich weit! ;)


    Das mit dem Vorkauen könnte ich ja gerne machen, aber dazu kenne ich mich nicht gut genug aus. Wenn mir jemand Insturctions machen könnte, wie ich sowas mache, könnte ich ein vaapi Build bauen...

    Hallo,


    Danke erst mal für eure Antworten! :)


    Fozzybär wrote:

    Die Grafik laggt? Welche Graka hast du denn da drin? Und wieviel % CPU frisst der VDR-Prozess? Guck mal mit dem Befehl "top" bzw. schau dir mal das Webfrontent ( http://127.0.0.1 ) an.

    Ja, ich benutze ich ja den Intel Core i3 mit integr. GPU (IGP) und die braucht unter Linux eben VAAPI, damit sie HD-Material dekodieren kann. Sonst übernimmt die CPU die Arbeit, was sie aber nicht schafft, daher laggt HD. Man braucht also VA-API Unterstützung.


    Fozzybär wrote:

    in der irexec.conf findest du (auskommentiert) den Befehl um XBMC via Fernbedienung zu starten. Eigentlich brauchst du nur ein Taste auf der Fernbedienung bestimmen. PS: Geh mal beim Fernsehschauen mit der Maus links (mittig) an den Bildschirmrand, da ist eine Quickbar. :-)


    XBMC zu finden war nicht mein Problem, aber es verweigert den Start, da "GLX Treiber" fehlen. Liegt halt daran, dass ich Intel Hardware verwende und daher eine angepasst Xorg.conf.yavdr brauche! ;)


    inde wrote:

    Hallo. Ich verwende momentan die Treiber des X-SWAT teams für meinen Core I3 (Sandybridge). Ich gehe mal davon aus, dass du die integrierte Grafik des Chips nutzen willst.


    Cool, das werde ich mal ausprobieren, Danke!


    inde wrote:

    Wenn ich es richtig weiß, gibt es vom yaVDR team momentan keine fertigen Pakete mit VAAPI Unterstützung für Xine. Deshalb habe ich XBMC als Frontend da hier die VAAPI Unterstützung funktioniert. Ich empfehle VDPAU abzuschalten.


    Was war dann dieses xine-lib-1.2-vaapi oder habe ich da was falsch interpretiert? Achja, nutzt du dann auch XBMC fürs Live TV?


    inde wrote:

    Meine xorg.conf ist nicht perfekt, aber läuft :-)


    Danke, das habe ich gesucht und werde es mal testen!


    fnu wrote:

    Da hast Du aber Glück gehabt das yaVDR so stabil bei Dir lief, wie bereits erwähnt gibt es keinerlei VA-API Unterstützung mit yaVDR. Es ist auch nicht abzusehen ob das je was wird, weil viele, viele Dinge ungeklärt sind.


    Schade, denn mit VA-API wären nach meinen Infos auch die AMD / ATI User bedient. ;)


    fnu wrote:

    Und nach meinen eigenen Tests, muß ich leider sagen ist die Bildqualität bei VA-API auch keinerlei Aufwand wert.


    Findest du? Oder war das jetzt nur rein auf die Qualitätsunterschiede bezogen? Wäre halt mehr Kompatibilität gegeben!

    Hallo Community,


    ich brauche eure Hilfe. Und zwar bin ich momentan dabei, mir einen HTPC (den habe ich schon länger, war was fertiges) aufzusetzen und würde gerne yaVDR einsetzen.


    Meine Hardware:
    CPU (inkl. GPU): Intel Core i3-330M
    RAM: 4GB
    HDD: 500GB
    TV-Karte: TechnoTrend TT-connect S2-3600 (extern, USB, DVB-S2)


    Ich habe yaVDR 0.4 einfach von der CD installiert und nach dem Boot natürlich kein Bild gehabt. Dann habe ich mich per SSH eingeloggt und nach dieser Anleitung (habe nur die Treiber installiert, das nvidia Zeugs aber nicht berührt) die Intel-Treiber installiert.


    Nach einem Reboot hatte ich Bild und nachdem ich meine channels.conf und diseqc.conf eingebaut habe, hatte ich auch Bild. Alle Sender (bisher nur FTA getestet) gehen, aber ich habe eben das Problem, dass HD laggt, da vaapi per Default nicht an ist.


    Jetzt habe ich gegoogled und bin dabei auf diese 2 Threads gestoßen:

    Nun zu meinem Problem, ich bin im Bereich Windows sehr erfahren, aber Linux ist Neuland für mich. Mit SSH kann ich umgehen und die Basis-Befehle sind auch kein Problem.


    Aber könnte sich eventuell jemand bitte die Zeit nehmen und mir kurz etwas ausführlicher aufschreiben, was ich machen muss, damit ich vaapi Support bekomme?


    Und außerdem wollte ich fragen, ob jemand hier Intel nutzt an einem Full HDTV und mir seine Xorg.conf.yavdr bereitstellen kann, damit ich XBMC starten kann (oder geht das anders?).


    Wäre wirklich über jegliche Hilfe sehr erfreut, da yaVDR bei mir bisher am stabilsten und ohne Abstürze lief!


    Danke schon mal! :)

    Hey Leute,


    wollte nur den Hinweis geben, dass OpenELEC inzwischen ein vdr-Plugin anbietet, welches LiveTV unter OpenELEC EXTREM erleichtert!


    Einfach über Einstellungen -> Add-Ons -> Weitere Add-Ons -> OpenELEC.tv... -> Dienste -> vdr zur Installation.


    Danach OpenELEC neu starten. Dann wieder zu den Add-Ons (dieses mal zu den aktivierten) und unter PVR-Klienten z.B. XVDR aktivieren.


    Zuletzt in den Einstellungen unter Live-TV gehen und da noch Live-TV anschalten und fertig. :)


    FTA-Channels laufen auf jeden Fall und tunen schnell! ;)