Posts by Bongo-007

    Ad.1 Kabel: neue Kabel

    Ad.2 50/60 Hz: 50 Hz

    Ad. 3"oder die SSD mal ein wenig weiter von den DVB Karten einbauen, bertreiben."

    Es ist eine große Mulitimediageh. SSD befindet sich in einem separtem Schacht ca. 10 cm. von SAT-Karten enternt

    Ad4. Firmware - ich verwnde immer die gleiche:

    https://linux4media.de/officia…loads/drivers/ngene_18.fw


    PS. Ich probiere gerade noch eine Andere Umgebung: Libreelec+VDR PVR.

    Aktuell keine Artefakte.

    Hallo zusammen,


    ich habe mein VDR-System aus Signatur, wie folgt neu aufgesetzt:


    1. Die relevante Config gesichert.

    2. SATA HDD abgeklemmt, SSD angeschlossen.

    2. Ubuntu Server 22.04 installiert, PPA auf jammy umgestellt, Playbook gestartet. Installtion wurde erfolgreich abgeschlossen.

    3. Die fehlende Firmware für meine DVB (cineS2 DVB-S2 Twin Tuner v5 mit Erweiterung) von https://linux4media.de/officia…loads/drivers/ngene_18.fw nach /lib/firmware runtergeladen.

    4. Die relevante Configs (Cannels, diseq,sources) kopiert, Reboot- >SAT Bild ist da.


    Die Fehlerbeschreibung:

    Nach einigen Minuten(Super Wetter) bilden sich Artefakte (ARD HD, ZDF HD, 3SAT HD). VDR-Neustart -> 2-3 Minuten, wieder Artefakte.

    Die alte Platte angeschlossen -> k e i n e Artefakte.


    Femon Altsystem:

    The DVB-Adapter is 0

    FE: STV090x Multistandard (DVBS)

    status SCVYL | signal 71% | snr 81% | ber 0 | unc 0 | FE_HAS_LOCK

    status SCVYL | signal 71% | snr 81% | ber 0 | unc 0 | FE_HAS_LOCK

    The DVB-Adapter is 1

    FE: STV090x Multistandard (DVBS)

    status SCVYL | signal 68% | snr 80% | ber 0 | unc 0 | FE_HAS_LOCK

    status SCVYL | signal 68% | snr 81% | ber 0 | unc 0 | FE_HAS_LOCK

    The DVB-Adapter is 2

    FE: STV090x Multistandard (DVBS)

    status SCVYL | signal 67% | snr 77% | ber 0 | unc 0 | FE_HAS_LOCK

    status SCVYL | signal 67% | snr 77% | ber 0 | unc 0 | FE_HAS_LOCK

    The DVB-Adapter is 3

    FE: STV090x Multistandard (DVBS)

    status SCVYL | signal 69% | snr 83% | ber 0 | unc 0 | FE_HAS_LOCK

    status SCVYL | signal 69% | snr 83% | ber 0 | unc 0 | FE_HAS_LOCK


    Femon Neusystem:

    FE: STV090x Multistandard (DVBS)

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 70% | snr 31% | ber 1 | unc 0 | FE_HAS_LOCK

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 70% | snr 31% | ber 1 | unc 0 | FE_HAS_LOCK

    The DVB-Adapter is 1

    FE: STV090x Multistandard (DVBS)

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 68% | snr 28% | ber 0 | unc 0 | FE_HAS_LOCK

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 68% | snr 28% | ber 0 | unc 0 | FE_HAS_LOCK

    The DVB-Adapter is 2

    FE: STV090x Multistandard (DVBS)

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 69% | snr 30% | ber 1 | unc 0 | FE_HAS_LOCK

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 69% | snr 30% | ber 1 | unc 0 | FE_HAS_LOCK

    The DVB-Adapter is 3

    FE: STV090x Multistandard (DVBS)

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 70% | snr 29% | ber 0 | unc 0 | FE_HAS_LOCK

    Problem retrieving frontend information: Unknown error 524

    status SCVYL | signal 70% | snr 29% | ber 0 | unc 0 | FE_HAS_LOCK


    Was auffält, dass snr in dem neuinstalliertem System sehr niedrig ist (noch mal: alles bis auf HDD unverändert)



    Der Auszug aus Syslog:


    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: can't render mixer: An invalid handle value was provided.

    Dec 9 16:21:08 yavdr vdr: message repeated 4 times: [ video/vdpau: can't render mixer: An invalid handle value was provided.]

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: can't render mixer: An invalid handle value was provided.

    Dec 9 16:21:08 yavdr vdr: message repeated 4 times: [ video/vdpau: can't render mixer: An invalid handle value was provided.]

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: can't render mixer: An invalid handle value was provided.

    Dec 9 16:21:08 yavdr vdr: message repeated 4 times: [ video/vdpau: can't render mixer: An invalid handle value was provided.]

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: can't render mixer: An invalid handle value was provided.

    Dec 9 16:21:08 yavdr vdr: message repeated 5 times: [ video/vdpau: can't render mixer: An invalid handle value was provided.]

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: can't render mixer: An invalid handle value was provided.

    Dec 9 16:21:08 yavdr vdr: message repeated 4 times: [ video/vdpau: can't render mixer: An invalid handle value was provided.]

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Dec 9 16:21:08 yavdr vdr: video/vdpau: out of surfaces

    Dec 9 16:21:08 yavdr vdr: video/vdpau: release surface 0xffffffff, which is not in use

    Ich komme leider nicht weiter. Erbitte um Hilfe.


    Gruss

    Hallo speefak,


    inux yavdr-oben 3.13.0-125-generic #174-Ubuntu SMP Mon Jul 10 18:51:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    root@yavdr-oben:/home/xbmc# nvidia-smi
    Thu Jul 27 19:55:03 2017
    +-----------------------------------------------------------------------------+
    | NVIDIA-SMI 384.47 Driver Version: 384.47 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GT 1030 Off | 00000000:02:00.0 On | N/A |
    | 45% 45C P8 ERR! / 30W | 135MiB / 1996MiB | 16% Default |
    +-------------------------------+----------------------+----------------------+


    +-----------------------------------------------------------------------------+
    | Processes: GPU Memory |
    | GPU PID Type Process name Usage |
    |=============================================================================|
    | 0 1216 G /usr/bin/vdr 56MiB |
    | 0 1392 G /usr/bin/X 76MiB |
    +-----------------------------------------------------------------------------+

    Hallo,


    ich habe GF 1030 (Zotac) eingebaut und die Beta-Treiber installiert und vom mir beschriebene Probleme :
    Unter Yavdr nutze ich Full HD, unter Kodi möchte ich die Auflösung 4096x2160 verwenden für:


    - hochauflösende Bilder


    - Full HD Videos.


    Leider ist das Menü zimlich träge und die Full HD Videos stottern.


    Ich habe alle möhliche Bidwiedeerhoraten ausprobiert - mit 24 stotter am weingstens.



    sind gelöst.

    Hallo,
    mein Tip wird zwar dein Problem nicht lösen aber ist eine Alternative zum schauen von DVDs.


    Ich erstelle von jede DVD/Bluray eine MKV-Datei.
    Die MKV lösche ich dann, nach dem ich den Film angeschaut habe.


    Die Vorgehensweise hat für mich zwei Vorteile:
    1. Keine Geräusche des opt.Laufwerks beim schauen
    2. Schnellere Sprünge



    Die Anleitung:


    1. Make MKV installieren
    sudo add-apt-repository ppa:ubuntu-ebower/ebower
    sudo apt-get update && apt-get install makemkv-install -f -y


    2. Make MKV aktualsieren (ca. jede 90 Tage wegen Lizenz!)
    makemkv-install latest


    3. Script erstellen
    z.B ripdvd.sh


    ....
    # Der Titel wird ermittelt
    titel=$(blkid -o value -s LABEL /dev/sr0)
    # Replace spaces with underscores
    titel=${titel// /_}
    pfad=/Pfad_Zum_Film-Ordner/$titel
    ######### Rippen ####################
    makemkvcon --minlength=3600 -r -r --decrypt --directio=true mkv dev:/dev/sr0 all $pfad
    ####################################


    # Meldung auf dem TV
    meldung=$(du -sh $pfad)
    echo "MESG DVD abgespeichert." $meldung | nc 127.0.0.1 6419
    chmod vdr $pfad


    4. Script als VDR Ausführbar machen
    nano /etc/sudoers
    vdr ALL=NOPASSWD: /Pfad_zum_Scrpit/ripdvd.sh


    Speichern


    5. Menü-Eintrag im VDR über Template erstellen


    cd /etc/yavdr/templates_custom
    mkdir var
    mkdir var/lib
    mkdir var/lib/vdr/
    mkdir var/lib/vdr/plugins
    mkdir var/lib/vdr/plugins/menuorg.xml


    nano /etc/yavdr/templates_custom/var/lib/vdr/plugins/menuorg.xml/86_dvdrip


    <command name="DVD-Abbild speichern" execute="sudo /Pfad_Zum_Script/ripdvd.sh &amp;> /dev/null &amp; " />


    Speichern und
    process-template /var/lib/vdr/plugins/menuorg.xml


    Du kannst jetztz über YAVDR-Menü deine "Scheibe rippen"


    Gruß

    You can "autorun" Kodi:


    1. nano /etc/init/kodi-start.conf
    author "anonymous"
    description "start Kodi once after boot or resume"


    # We only want this job to happen once per boot, hence 'startup and ...'.
    start on (startup and
    (started vdr
    and started vdr-frontend)
    or (resume
    and
    (started vdr
    and started vdr-frontend)))


    task


    script
    logger -t $0 "*** Switching to Kodi..."
    /usr/share/vdr/menuorg-appswitcher standalone=yes app=kodi display=1


    end script

    2. Save the file and reboot

    Hallo,


    ich habe eben mit einem internem Laufwerk beide Encoder ausprobiert - es funktioniert einwandfrei.
    Die gerippte Tracks werden abgespielt, das Format stimmt.


    Hinweise:


    1. Einstellungen-Wiedergabe->Einstellungelevel: Experte->Disks->Aktion nach Einlegen einer Audio CD->Rippen


    2. In den älteren Kodi-Versionen gabes noch ein anderen Weg:
    Music->Dateien->Laufwerk markieren->Kontext Menü->Rippen


    Diese Möglichkeit gibt es nicht mehr.


    Menü hat dann nur 3 Einträge:
    1. Öffnen/Schließen
    2. In Bibliothek aufnehmen (nein es wird nicht gerippt)
    3. Zu Favoriten hinzufügen

    Yeeees :D



    1.Addons->Benutzer-Addons->-Audio Encoder-> Flac Audio Encoder: Aktivieren
    2.Addons->Benutzer-Addons->-Audio Encoder-> Lame MP3 Audio Encoder: Aktivieren
    3.Einstellungen->Wiedergabe->Disks->Encoder: Flac Audio Encoder und Lame MP3 Audio Encoder sind da!


    Vielen Dank

    The following packages will be upgraded:
    kodi-audioencoder-flac kodi-audioencoder-lame
    2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 29.0 kB of archives.
    After this operation, 9,216 B of additional disk space will be used.
    Get:1 http://ppa.launchpad.net/yavdr/testing-kodi/ubuntu/ trusty/main kodi-audioencoder-flac amd64 1.1.0-3yavdr1~trustyubuntu1 [14.3 kB]
    Get:2 http://ppa.launchpad.net/yavdr/testing-kodi/ubuntu/ trusty/main kodi-audioencoder-lame amd64 1.2.0-3yavdr0~trusty [14.7 kB]
    Fetched 29.0 kB in 0s (181 kB/s)
    (Reading database ... 147856 files and directories currently installed.)
    Preparing to unpack .../kodi-audioencoder-flac_1.1.0-3yavdr1~trustyubuntu1_amd64.deb ...
    Unpacking kodi-audioencoder-flac (1.1.0-3yavdr1~trustyubuntu1) over (1.1.0-3yavdr0~trusty) ...
    dpkg: warning: unable to delete old directory '/usr/lib/kodi/addons/audioencoder.flac': Directory not empty
    Preparing to unpack .../kodi-audioencoder-lame_1.2.0-3yavdr0~trusty_amd64.deb ...
    Unpacking kodi-audioencoder-lame (1.2.0-3yavdr0~trusty) over (1.0.1-2yavdr1~trusty) ...
    dpkg: warning: unable to delete old directory '/usr/lib/kodi/addons': Directory not empty
    dpkg: warning: unable to delete old directory '/usr/lib/kodi': Directory not empty
    Setting up kodi-audioencoder-flac (1.1.0-3yavdr1~trustyubuntu1) ...
    Setting up kodi-audioencoder-lame (1.2.0-3yavdr0~trusty) ...
    Processing triggers for libc-bin (2.19-0ubuntu6.9) ...




    Kodi gestartet ->immer keine Lame und FLAC


    root@yavdr-oben:/home/xbmc# tree /usr/lib/kodi/addons/
    /usr/lib/kodi/addons/
    └── audioencoder.flac
    └── addons
    └── audioencoder.flac
    ├── audioencoder.flac.so -> audioencoder.flac.so.17.0
    ├── audioencoder.flac.so.1.1.0
    └── audioencoder.flac.so.17.0 -> audioencoder.flac.so.1.1.0



    root@yavdr-oben:/home/xbmc# locate audioencoder.flac
    /usr/lib/kodi/addons/audioencoder.flac
    /usr/lib/kodi/addons/audioencoder.flac/audioencoder.flac
    /usr/lib/kodi/addons/audioencoder.flac/audioencoder.flac.so
    /usr/lib/kodi/addons/audioencoder.flac/audioencoder.flac.so.1.1.0
    /usr/lib/kodi/addons/audioencoder.flac/audioencoder.flac.so.17.0
    /usr/share/kodi/addons/audioencoder.flac
    /usr/share/kodi/addons/audioencoder.flac/addon.xml
    /usr/share/kodi/addons/audioencoder.flac/addon.xml.in
    /usr/share/kodi/addons/audioencoder.flac/icon.png
    /usr/share/kodi/addons/audioencoder.flac/resources
    /usr/share/kodi/addons/audioencoder.flac/resources/language
    /usr/share/kodi/addons/audioencoder.flac/resources/settings.xml
    /usr/share/kodi/addons/audioencoder.flac/resources/language/English
    /usr/share/kodi/addons/audioencoder.flac/resources/language/English/strings.po


    Danke für die Mühe.
    Gruß

    Hallo,


    Einstellungen->Wiedergabe->Disks->Encoder:
    -AAC
    -WMA


    kein FLAC


    root@yavdr-oben:/home/xbmc# tree /usr/lib/kodi/addons/
    /usr/lib/kodi/addons/
    ├── audioencoder.flac
    │ ├── audioencoder.flac.so -> audioencoder.flac.so.17.0
    │ ├── audioencoder.flac.so.1.1.0
    │ └── audioencoder.flac.so.17.0 -> audioencoder.flac.so.1.1.0
    └── audioencoder.lame
    ├── audioencoder.lame.so -> audioencoder.lame.so.16.0
    ├── audioencoder.lame.so.1.0.0
    └── audioencoder.lame.so.16.0 -> audioencoder.lame.so.1.0.0





    PS. Vieleicht stimmen die Pfade nicht?
    http://www.easy-vdr.de/archive/index.php/thread-17901.html


    In meiner Doku zur kodi 15.2 steht:
    sudo ln -s /usr/lib/x86_64-linux-gnu/addons/audioencoder.lame /usr/lib/kodi/addons/audioencoder.lame
    sudo ln -s /usr/lib/x86_64-linux-gnu/addons/audioencoder.flac /usr/lib/kodi/addons/audioencoder.flac



    Der Ordner
    /usr/lib/x86_64-linux-gnu/kodi/addons
    existiert aber nicht.

    Hallo,


    Was muß ich machen?


    root@yavdr-oben:/home/xbmc# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
    libglew1.10 libsdl2-2.0-0 libxss1
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@yavdr-oben:/home/xbmc# apt-cache policy kodi-audioencoder-flac
    kodi-audioencoder-flac:
    Installed: 1.1.0-3yavdr0~trusty
    Candidate: 1.1.0-3yavdr0~trusty
    Version table:
    *** 1.1.0-3yavdr0~trusty 0
    500 http://ppa.launchpad.net/yavdr/testing-kodi/ubuntu/ trusty/main amd64 Packages
    100 /var/lib/dpkg/status
    1.0.1-2yavdr1~trusty 0
    500 http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu/ trusty/main amd64 Packages

    Hallo,


    bis auf die fehlende Audioencoder, die ich intensiv bisher genutzt habe, funktioniert alles super.


    Wie können die Audioencoder (flac,lame) angebunden werden?



    sudo apt-get install kodi-audioencoder-flac
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    kodi-audioencoder-flac is already the newest version.