Beiträge von DoubleXMinus

    So, ich habe jetzt mal grade noch 2 Logfiles erzeugt ;) (s. Dateianhänge)


    1. Logfile (1_log_reboot_megasat && 1_log_reboot_vdr_1_tuner_than_playback_switch_channel_stop_playback)*:
    * aufgrund der Dateigröße musste ich den "boot" Part in ein eingenes .txt-File kopieren.
    - VDR stoppen und satip-plugin mit Parameter -d1 (nur 1 Tuner) konfigurieren
    - MEG-8000 neustarten && Debugging aktivieren
    - VDR starten, abwarten bis Channel/EPG-Update abgeschlossen
    - Wiedergabe von ARD HD über Streamdev-Client
    - Switch nach ZDF HD auf Streamdev-Client
    - Wiedergabe beenden auf Streamdev-Client


    2. Logfile (2_log_reboot_android_satip_playback_switch_channel_stop_playback.txt):
    - VDR stoppen und aus lassen
    - MEG-8000 neustarten && Debugging aktivieren
    - Android Sat>IP-App starten
    - Wiedergabe von ARD starten
    - Switch nach ZDF
    - Wiedergabe beenden


    Vielleicht hat ja noch jemand lust und langeweile und kann in den Logs etwas lesen :D


    Ich bin jetzt mal offline, denke ich werde mich morgen wieder dran setzen, dann gucke ich mal ob ich ggf. mit Wireshark noch ein paar mehr Infos raus bekomme :)

    Mal etwas mehr Infos:


    Der Sat>IP-Server der MEG-8000 hat eine CLI welche sich hier befindet:

    Code
    1. /opt/bin/sat2ip_server/sat2ip_cmdl.elf


    Im Spoiler Ausgabe von
    /opt/bin/sat2ip_server/sat2ip_cmdl.elf -h


    Debugging kann mit dem Kommando eingeschaltet werden:

    Code
    1. /opt/bin/sat2ip_server/sat2ip_cmdl.elf -csrcdg2


    Hier durch wird die Kiste im /var/log/messages etwas gesprächiger.

    Kann jemand mit Problemen darüber berichten, wie sich das Gerät in Kombination mit anderen Clients, im Betrieb ohne VDRs verhält? Muss der Megasat dann auch immer wieder neu gestartet werden?


    Wenn mein VDR mal wieder kein Bild zeigen wollte, habe ich immer als 1. Schnelltest geprüft, ob ich mit dem Handy (Android Tivizen (gratis) / Android Sat>IP (kostenpflichtig) ) noch ein Bild bekomme wenn ich mich direkt an die Megasat verbinde (dafür darf mein VDR auch nur 7 der 8 Tuner verwenden ;) ).
    Das hat bisher immer geklappt (innerhalb der letzten 17 Tage ohne Neustart der Megasat)!


    Andere Sat>IP Empfänger (Hardware) habe ich leider nicht.

    Da ich mich jetzt längere Zeit nicht zu Wort gemeldet habe...
    Die billige China-Ware (aka Megasat Sat->IP Server 3) die hier so verteufelt wird... Läuft bei mir aktuell um ehrlich zu sein erstaunlich gut.


    Code
    1. [AS-B3S100-Server]$ uptime 14:46:02 up 17 days, 19:59, load average: 0.00, 0.01, 0.04



    Ich muss gestehen, mein Setup ist auch eher einfach gehalten, Quad-LNB direkt an den MEG8000 (kein Multiswitch/nur Astra 19.2)
    Mein VDR musste ich dagegen ab und zu einmal neu starten was aber eher mit dem HD+ Kram zu tun hatte.



    Ausgaben zu cpuinfo und ps im Spoiler ;)



    OT: Ich finde es auch etwas schade, das hier so viel "konstruktive" Unterstützung geboten wird.


    Niemand zwing Dich, hier im Forum zu lesen, oder Dich an einer Diskussion zu beteiligen!


    Aber mal abgesehen davon, ist doch gerade wegen der vielen "Fachkompetenz" herausgekommen, dass der "Megasat SAT to IP Server 3" eben ist, was er ist, nämlich billiger Chinaschei?dreck!


    Wer halt meint, dass er clever ist und billig kauft, der bekommt genau das, was er haben will.


    Solche Kommentare veranlassen mich, hier so wenig zu schreiben und vorallem auch immer weniger hier nach Unterstützung zu suchen.
    Wenn man schon etwas kommentieren muss, dann doch bitte mit konstruktiven Antworten!



    Sonstiges 1:
    1. Das DD Hardware besser läuft als ggf. günstigere Alternativen aus dem Ausland wissen wir glaube mittlerweile alle. Habe selbst sehr gute Erfahrungen mit DD gemacht habe, allerdings mit DVB-C.
    2. Geht es hier nicht darum herauszufinden wie gut diese Hardware funktioniert? Bzw. ggf. herauszufinden was an der Hardware nicht so gut funktioniert?
    3. Genau genommen hat hier fast keiner danach gefragt, welche Hardware besser läuft ;) (zumindest im Verhältnis zudem wie die DD hier als Allheilmittel angepriesen wurde)


    Sonstiges 2:
    Wer soll einen neuen Thread auf machen? Leute die diese Hardware besitzen und ggf. versuchen wollen das Beste daraus zu machen?
    Oder die Leute, welche der Meinung sind, dass ich meinen China-Müll lieber in die Tonne kloppen soll?

    Entschuldigt bitte wenn ich lästig bin - hätte da noch eine Frage (neben jener ob der Megasat einen Lüfter hat):

    Lüfter glaube ich nicht das einer verbaut ist... zumindest wurde die Kiste bei mir noch nicht so warm, dass es einen Lüfter benötigt hätte, und dauerhaft läuft zumindest keiner.


    Der Megasat hat ja 8 Tuner - kann er damit auch 8 verschiedene Transponder gleichzeitig empfangen - er hat ja nur 4 Anschlüsse.

    Ich hatte testweise 8 Unterschiedliche Kanäle laufen, davon waren definitiv mehr als 4 Kanäle von unterschiedlichen Transpondern. 1x ARD HD, 1x ZDF HD, 1x RTL HD, 1x PRO7 HD und noch ein paar SD-Sender... Die sollten m.W.n auf mindestens 5 verschiedenen Transpondern liegen.
    Wobei ich mir noch nicht sicher bin, ob für die Wiedergabe mehrerer Kanäle von einem Transponder ggf. auch mehrere Tuner verwendet werden. Das müsste ich nochmal prüfen.


    Im satip Plugin gibt es ja den ein oder anderen Quirk für eben die preiswerteren Boxen, welche verschiedene Situationen etwas verbessern.

    Gibt es hierzu ggf. irgendwo ein wenig Entwickler-Dokumentation? Vielleicht weiß ja jemand ohne groß suchen zu müssen ob es hier was gibt, bzw. ob hier im Forum bereits mehr (sinnvolles) geschrieben wurde.
    --> Sonst würde ich mich jetzt erstmal ungerne an rofafor wenden, da ich aktuell eher sporadisch online bin und auch nicht immer an die Hardware dran komme.





    --------------- EDIT ---------------
    Habe grade auf der Homepage von Megasat nochmal geguckt und da scheint gestern ein Firmware-Update (Version 3.1.6) zu der Kiste veröffentlicht worden zu sein.
    https://www.megasat.tv/support…/satip-server-3-firmware/



    Vielleicht tut das ja schon ein wenig. Werde ich heute abend mal aufspielen und spätestens morgen dann berichten. Leider gibt es keine Release-Notes o.ä.

    Hmm, da würde ich auf Esotherik tippen ... di

    fnu : damit hast du wahrscheinlich recht.
    Am nächsten Tag hat er nach dem "RTP Error" wieder alle Tuner belegt. Was wie du bereits vermutet hast, nichts mit dem Error und dem Betriebsmodus sondern am EPG-Update gelegen hat.


    Jetzt habe ich den EPG-Update im VDR deaktiviert und führe diesen per Cron-Job erstmal alle 2h aus. Seit dem läuft der Server (1 Tag) und hatte bisher keine Probleme.
    Die Woche über werde ich einmal diverse Aufnahmen machen und gucken wie sich die Kiste dann verhält.


    Das mit dem + läuft auch, hat aber ja genau genommen auch nichts mit der MEG-8000 zu tun ;) und werde ich auch ab jetzt auch nichts mehr zu schreiben.

    3PO : Das mit dem Billigscheiss verstehe ich grade nicht. Aber ist ja auch egal und irgendwie ein wenig Offtopic.Hast du auch was zum eigentlichen Thema beizutragen? Keines deiner Kommentare hat auch nur im entferntesten was mit dem Thread-Titel zu tun (abgesehen vom Wort "satip").
    Wenn du doch eine funktionierende Lösung hast, dann erleuchte doch die, die um Hilfe bitten.

    Nebenbei mal wieder was zum Thema:
    Das "alle Tuner werden genutzt"-Problem konnte ich lösen:

    • neuste Version von vdr-plugin-satip installiert (2.2.4 --> habs mir aus dem yaVDR-Testing ppa geholt)
    • in der Plugin-Config "Übertragungsart: RTP-over-TCP" einstellen

    Seit dem kann ich schön sehen, dass wenn der VDR im Log schreibt "SATIP: Idle timeout - releasing [device x]", dann wird im WebIf der MEG-8000 auch der Tuner freigegeben und bleibt frei.
    Ob damit auch das Verbindungsproblem von heute mittag behoben ist, kann ich noch nicht sagen, das wird sich aber noch zeigen.


    Bin ab jetzt offline... Wünsche einen schönen Abend.

    3PO : Genau genommen ist mir das egal wer was von Satip hält und es wie verwendet ;)
    Ich laufe seit ca. 5 Jahren mit einer solchen Lösung (nur ohne satip, zeitweise mit DVB-C-Tunern, teilweise mit einzelnen USB-Sat-Receivern) gut.
    Ziel war es, ein bewährtes System weiter zu verwenden, und das satip-Geraffel hier als "günstigen" Multi-Tuner einzusetzen, da ich aufgrund der Wohnsituation wieder auf Sat umsteigen muss/darf.


    Wenn du mir einen Tipp geben kannst, wie ich die Vorteile welche ich bereits aufgezählt habe, plus die Punkte von Hibbelharry, umsetzen kann, dann immer her damit. Ich bin für jeden Vorschlag offen.


    Was ich aber vermeiden möchte ist es, auf sowohl der "Server-Seite" als auch auf der Client-Seite eine Frickellösung zu haben.
    Unter Server-Seite verstehe ich auch sowas wie die + Logik (muss egal wie auf einem Server laufen), welche dann wieder an jedem Client konfiguriert werden müsste (was an einem Windows-PC mit VLC als Client übrigens ganz schön schwer sein dürft :P),


    das zentrale Aufnahmeverzeichnis welche ich auf jedem Client mounten müsste.
    Achja... und damit ich Aufnahmen auch bei ausgeschaltetem Client durchführen kann... brauche ich einen VDR-Aufnahme-Server, der wiederum per Remote-Timer gesteuert wird (Konfiguration an jedem Client)....
    --> wenn ich also so oder so schon einen Server 24/7 laufen habe, dann kann der auch gleich noch ein wenig mehr Arbeit mit übernehmen.


    Und vermutlich wird es dem MEG-8000 egal sein, ob ich mit 8 einzelnen vdr-plugin-satip-Clients drauf zugreife, oder mit einem Server der alle 8 Tuner anspricht (kann mich hierbei aber vielleicht auch irren, wird wohl noch eine Testoption werden).


    Zur MEG-8000:
    Ich hatte grade das 1. Mal das Problem, dass sich die Kiste scheinbar komplett verabschiedet hat, bzw. der VDR keine Verbindung mehr aufbauen kann.

    Code
    1. Jan 15 17:43:32 xx-mediaserver vdr: [13577] SATIP-ERROR: Detected invalid status code 454: rtsp://192.168.x.x/ [device 1]


    --> Reboot hilft, ist aber nervig ;) (der MEG-8000), Webinterface war noch erreichbar.

    Kaum bis kein manueller Konfigurationsaufwand am Client ;)


    MLD erkennt automatisch den Server und klappt quasi Out-of-the-Box mit dem yaVDR-Server
    --> Aufnahmeverzeichnis wird automatisch gemountet
    --> Channels.conf wird vom Server herunter geladen
    --> + muss nur am Server umgesetzt werden
    --> Remote-Timers, etc. wird automatisch installiert und konfiguriert


    Alles Gründe für mich auf die Server-Lösung zu setzen.

    Also das mit dem + funktioniert grundsätzlich mit Auflösung am Server und Wiedergabe dann am Clienten (ganz ohne zutun).


    Von der Stabilität der ganzen Konstellation bin ich grade noch nicht ganz überzeugt. Hatte zwar heute noch keine Probleme, außer der Tatsache das alle 8 Tuner so ziemlich dauerhaft laufen, aber große Aussetzer hab ich bisher dadurch nicht gehabt.
    Bzw. nach ein wenig hin- und herzappen hat der VDR-Server es dann geschafft doch das Bild an den Clienten zu liefern.

    Vielleicht sollten wir erstmal klären ob/wie gut diese gesamte Lösung läuft ;)


    Ich habe nach 1 Tag Testlauf folgendes Problem festgestellt:


    - ein Kanal wird wiedergegeben
    --> MEG-8000 blockiert Tuner 1
    - Wiedergabe beenden
    --> MEG-8000 gibt Tuner 1 frei
    - 10sec später wirft VDR eine Fehlermeldung: SATIP: Detected 117 RTP packet errors [device 0]
    --> MEG-8000 blockiert Tuner 1 erneut, diesmal wird er nicht mehr freigegeben


    - einen anderen Kanal wiedergeben
    --> MEG-8000 startet Tuner 2 (Tuner 1 bleibt geblockt)
    - VDR-Server herunterfahren
    --> MEG-8000 gibt alle Tuner frei


    Falls jemand eine Idee hat ;)


    In den Logs ist erst mal sonst nichts auffälliges zu sehen.


    Und zu dem SSH-Thema:
    Das Passwort für den root-User entspricht dem welches ihr im WebIf der MEG-8000 angegeben habt. (Default: root/admin)

    Also, ELV.de ist recht schnell mit versenden... Hab die Hardware bereits heute morgen geliefert bekommen.


    Also, heute morgen gleich den Megasat Server 3 mit 4 Sat-Kabeln (Schüssel mit Quad-LNB) verkabelt, ins Netzwerk geklemmt und testweise eine neue yaVDR-Instanz für den Test installiert.
    Dann vdr-plugin-satip installiert, channels.conf angepasst... und schon hab ich ein Bild am PC mit vlc (via streamdev)


    in yavdr wird das Plugin ohne besondere Paramter gestartet, somit werden alle SatIP-Server erkannt (auch ein AVM Fritz DVB-C WLAN Repeater). Es werden aber nur 2 Tuner initialisiert.
    Per Config-Änderung können hier aber 8 Tuner für übergeben werden (in yaVDR: /etc/vdr/plugins/conf.avail/satip.conf).


    Ein Test mit 8 VLC-Fenstern auf unterschiedlichen Sendern hat problemlos geklappt. Das WebInterface der MegaSat zeigt auch an, dass alle Tuner verwendet werden.
    Wird ein Stream geschlossen und von VDR der Tuner "released" wird auch der Tuner der Megasat wieder frei gegeben.


    Ich lasse das jetzt mal ein wenig laufen und gucke ob irgendwas passiert :)


    Aber bin erstmal positiv überrascht.


    Zu dem Unicable-Thema kann ich leider nicht behilflich sein... habe hier eine ganz "einfache" Quad-LNB Installation.


    Werde mich heute oder morgen auch nochmal dran setzen, das ganze mit VDR-Clients zu testen, welche über Streamdev mit dem VDR-Server verbunden sind. Natürlich werde ich berichten.



    ---- EDIT ----
    Habe jetzt noch den MLD5.1-Client auf dem Raspberry umkonfiguriert.
    Es laufen jetzt also 5 Kanäle in meinem Netz: 3x HD (öffentlich-rechtliche) und 2x SD (private) --> bisher ohne Probleme!
    Mein nächstes ToDo ist das + ;)

    Wir müssen uns leider noch ein wenig gedulden ;( . Amazon hat mich dazu verleitet die denkbar ungünstigste Versandkonstellation zu wählen die man wählen kann.
    Amazon Prime (DHL Express) an eine DHL Packstation = 2x nicht erfolgreiche Zustellung an Packstation.
    Habe die Bestellung storniert und bei elv.de erneut bestellt.


    Wird also vermutlich doch erst nächste Woche...


    TheEnvoy : Unicable kann ich leider nicht testen.

    Also noch kann ich nichts dazu sagen, allerdings warte ich gerade auf die Lieferung des Megasat Server 3. Bin schon gespannt wie Flitzebogen.
    (Warte darauf, dass der Postfahrer endlich mal mein Paket in der Packstation ablegt :rolleyes: )


    Werde heute nur noch einen kurzen Funktionscheck machen, morgen bzw. am Samstag hab ich dann wirklich Zeit mich damit zu beschäftigen.


    Natürlich lasse ich euch gerne an meinen Erfahrungen teilhaben :)


    ---- Edit ----
    Ein hoch auf DHL Express und Packstation.
    Heute wirds wohl auch nichts mehr mit dem Funktionscheck :§$%

    Ist zwar prinzipiell der falsche Thread... aber da hier schon Channel.conf-Eintrage gepostet wurden...
    Hier der Eintrag für UnityMedia (Kabel) funktioniert auf jeden Fall im Rhein-Main-Gebiet...


    ProSieben MAXX;Unitymedia:113000:M256:C:6900:613=2:614=deu@3:618:0:12113:9999:121:0

    Woher kopierst Du denn die imon_mce? Ich kann die nirgendwo finden. (/etc/rc_keymaps/ ist leer)

    olafc :
    Falls das Problem noch nicht gelöst sein sollte ;) und du nicht so lange warten willst/kannst bis das Geflecht um imon entwirrt ist :)
    In meinem Post oben habe ich geschrieben, dass sich die Dateien hier (/lib/udev/rc_keymaps/) zu finden sind. Dort sollte sowohl eine "imon_mce" als auch eine "imon_pad" vorhanden sein.
    Dort einfach die Datei "imon_pad" nach "imon_mce" umbenennen.
    PS: eine Sicherung der ursprünglichen "imon_mce" muss ich wohl nicht erwähnen ;)


    ui was für ein Durcheinander/Gewusel mit den verschiedenen Imons - sehr wahrscheinlich hats da irgendwo nen Fehler ... Lasst uns mal ein paar Tage Zeit das Geflecht um imon zu entwirren.

    steffen_b :
    Danke das ihr euch dem Thema annehmt. Falls es notwendig ist, stelle ich mich auch gerne zum Testen bereit.