Posts by zochi

    moin,


    eigentlich wollte ich paar Aufzeichnungen auslagern die sich angesammelt haben, die ich mir wahrscheinlich auch nie ansehen werde.
    Wenn die futsch waeren, was solls..
    mfg


    moin,
    habe hier eine WDC WD20EARS.
    Habe per badblocks laufen lassen und folgendes Ergebnis erhalten


    Garantie ist vor 20 Tage abgelaufen. :mua


    Und? :-)
    Schon mal gefragt ob die "Kulanz" kennen?
    Aber Ohne codes vom Diagtool hasste eh keien Chance. Die Platte gilt dann als heil...



    Also das das die Relocated sectors 0 sind ist sehr ungewöhnlich bei einer sterbenden Platte.
    Wie hasste das Teil denn angeschlossen? Ich erinnere das Lunix einst erhebeliche Problem bei grossen Datenmenge via USB hatten.
    Auch sitzen die SAT Stecker gerne mal lose.
    Wie sieht es mit der Stromversorgung aus?
    Einfach mal alle Kabel an allen Ende abziehen unstecken.
    Bringt zwar eist nix, aber wenn doch wäre es peinlich das nicht gemacht zu haben.


    Manchmal hilft es die Platte von vorn bis hinten mit "00" zufüllen.
    also so was: #dd if=/dev/zero of=/dev/sdX
    Die Daten sind dann natürlcih hin, wenn Du sie nicht vorher mit "dd_rescue"
    oder so runter krastzen lässt, aber vielleicht wird der Rest wieder guten Gewissens brauchbar.
    Evtl. hilft auch die Platte sich "secure deleten" zu lassen.


    Du weisst auch nicht ob die Platten auf den inneren Bahnen je funktioniert hat?


    So hatte ich das auch verstanden und kann es auch nachvollziehen. "Rattern" hatte ich auf den Ton bezogen.


    Ich las nur immer "video".

    Quote


    Dazu kann ich nichts sagen, sowas beobachte ich hier nicht. Kann aber daran liegen, daß ich eine TT-S2 6400 als Ausgabedevice benutze.


    Das sieht für mich so aus, als würde iregndwas 10sec auf Daten warten. Wenn "live" einen Stream liefert sind das nur wenige sekunden (2..3)

    Quote


    Hast du den Patch schon probiert?


    Ich habe eben versucht zu übersetzen...


    also


    cd /usr/src/vdr/vdr-1.7.33
    make clean
    make
    und
    dann
    #make install-bin
    (Sonst würde ja wohl alle .conf überschrieben??


    Ich glaube irgendwas stimmt da mit dem src path nicht,
    denn mein vdr-file ist nur halb so gross wie das das ich aus yaVDR0.5 habe...
    Die symbole werden es wohl nicht sein...



    Code
    1. root@vdr4:/usr/src/vdr/vdr-1.7.33# ll /usr/bin/vdr /usr/bin/svdrpsend
    2. -rwxr-xr-x 1 root root 1170 Aug 6 2011 /usr/bin/svdrpsend*
    3. -rwxr-xr-x 1 root root 1470888 Dec 20 00:27 /usr/bin/vdr*
    4. root@vdr4:/usr/src/vdr/vdr-1.7.33# ll ./vdr ./svdrpsend
    5. -rwxr-xr-x 1 500 users 1170 Aug 6 2011 ./svdrpsend*
    6. -rwxr-xr-x 1 root root 6605259 Jan 27 22:34 ./vdr*


    Danke für die Erklärung.
    Das "Nachrattern" ist aber -manchmal- nicht nur ein Video-Problem, sondern vorallem ein Audio.
    Wenn die Aufnahme an einer lauten Stelle endet rattert es im Ton.


    Irgendwie erklärt sich damit mir nicht, warum das Schüttelbild länger stehen bleibt, wenn man
    (mit Absicht) einen Kanal ohne Daten, z.B. den 3sat IPTV, als letztes "Live" eingestellt hatte.

    Ich denke mal das das 2 Probleme sind.
    a) Warum geht die SD-Prio über den aktuellen Live-Strang?
    b) Warum nimmt man SD-KArten im MIx


    zu b)
    Ich mache das, weil ich die Karten halt rumliegen hatte "Kannste ja mal einbauen"
    und -vorallem- die WinTV Nova-S als Fernbedienungs-Empfänger benutze, OOTB!
    Warum soll ich da viel basteln, wenn's eh rum liegt? (Da wusste ich ja noch nicht wie
    aufwändig werden würde um das ESC/EXIT/BACK-Tastenproblem zu lösen. Das gab es
    auch bei der X10, die mir aber viel zu träge und zu unempfindlich ist.)


    Damals war auch noch mein Stand, das ich, wenn ich eine DVB-Karte einbaue, diese gefälligst auch mit
    einem SIgnal versorgen muss, soll es nicht zu emergecy exists führen.


    Ob es eine aufnahme-technischen Vorteil gibt weis ich auch nicht so recht.
    "Früher" hatte ich ja fast nur H+L auf dem Hi Band und 4 Tuner reichten.
    Da waren 2 Kabel ja meist ausreichend, auf dem Lo band war nur BBC oder so.
    Durch HD liegt jetzt aber einiges mehr auf dem Lo Band.
    Insofern müsste ich, wenn ich HD schauen will, besser HD aufnehmen.
    Oder ebend noch min. ein weiteres Kabel ziehen.


    SCR oder 2 weitere Kabel wäre schon schön, aber SCR wird aber irre teuer(mit dem Technisat Router 2x180 Euro+Arbeit...
    ich weiss auch nicht, ob im Mux noch Ausgänge frei sind.).
    Der Gesetzgeber sollte vorschreiben, das jede Mietwohnung neben Wasser und Strom auch 4 Sat Kabel haben muss! :-)
    (Das wäre doch mal was für die Piratenpartei :-))


    Zu a)
    Es sind 2 "billig" Karten drin und unbelegt. Die eine an dem einen Strang und die anderen an dem anderen Strang.
    Technisch wäre es also möglich, die "andere" "Billig"-Karte zu nehmen.
    Device Bonding hat meiner Meinung nach immer so gearbeitet, das der "Live" strang
    die letzte Option ist und nicht die erste. Derzeit ist es die erste.
    Vielleicht wird das Problem reduizert, wenn ich Anschlüsse der SD Karten tausche.


    Also:
    Als "workarround" geht nur:
    Bonde keine S und S2 Karten auf einem Strang, oder finde dich damit ab, das das Bild beim Aufnahme start unnötigerweise einfriert?

    Moin!


    Für dynamite brauchst du entsprechende udev-Regeln, die anhand von irgendwas
    (PCI-Slot usw., "udevadm info" muss gefragt werden,
    Beipiele für den Aufruf findest du hier im Portal)


    Aha. Danke.
    Gbt es irgendwo "tragende" Beispiele? (In der Doku finde ich da nict wirklich was, und eher hier? Muss ich mal schauen...)


    Quote


    die Geräte eindeutig identifiziert. Leider gibt es bei den meisten PCI(e)-Karten keine Seriennummern, bei USB-Geräten schon.


    bei DVB Karten gäbe es ja die MAC-Adresse des net-devices. Wie man da rankommt weiss ich jedoch nicht.
    (Bei 4 DD Cine in einem PCI slot ist man wohl rel. aufgemissen, wenn da eine aus der reihe tanzt)


    Quote


    Wenn man mit dynamite_cardindex anfängt, sollte man allen Karten einen zuweisen, weil sonst eine Karte ohne cardindex sich einen Slot schnappt, der eigentlich für eine andere Karte gedacht war.


    Guter Hinweis, denn das ist ja eigentlich nicht so wie ich den Sinn von "dynamite" verstanden habe.
    Warum kann ich die device-Slots 1...8 nicht "reservieren"? Und alles was neu ist kommt hinten dran?
    Schlimmstenfalls funktioniert das neue dann nicht, aber das alte läuft weiter.

    Hallo


    immer mal wieder bleibt das Live Bild stehen wenn eine Aufnahme benginnt.


    Frage:
    Nimmt VDR Rücksicht auf den Live stream, wenn es ein Bonded device nimmt?
    Wenn nicht,
    Wie kann ich verhindern, das das Live Bild einfriert, wenn eine Aufnahme beginnt
    und dazu ein Device genommen wird, das mit am Live Strang hängt, obwohl das nächste an einen anderen,
    freien, Strang hängen würde?


    Dunkel erinnere ich mich an eine Zeit, als ein Aufnahmestart im Livebild zu einem kurzen Blackout führte.
    Das war nicht so tragisch wie jetzt "immer" die FB rausholen zu müssen, wenn eine Aufnahme startet.


    Es ist klar das ich bei 2 Strängen nicht mehr als 2 unterschiedliche Transponder-"Arten" nutzen kann(ausser mit SCR)
    Aber wenn der Recorder nur einen Strang braucht, warum greift er sich unnötigerweise den, auf dem der Live stream läuft und
    dreht ihm den Sateliten-Saft ab?



    Es sieht so aus, als würde die erste aufnahme immer auf dem Device 5(vdr) gestartet.
    Das ist aber mit 1(vdr) und 2(vdr) gebondet.
    der Live stream lief wohl auf 1(vdr) so das er einfroh als der Strang auf "lo" geschaltet wurde.


    OK, ich könnte nun bei 5(vdr) und 6(vdr) die STrängen tauschen.
    Damit ware 5(vdr) an einem nicht so wahrscheinlich vom Lve stream benutzen Strang.
    Aber sobald einwenig gezappt wurde, liegt dann evtl. doch der Livbe auf einem Device parallel zu
    5(vdr).



    vdr1.7.33
    6 dvb(S)Geräte.
    2x DD flex (1,2,3,4(vdr))
    1x WinTV Nova-S 5(vdr)
    1x Technisat SD 6(vdr)


    1,2,5 (vdr) Strang 1
    3,4,6 (vdr) Strang 2



    Femon:
    8 einsfestival HD 12421 H :
    0 OK
    1 OK
    2 OK
    3 OK
    x 4 wird übersprunge da aufnahme?
    5 OK


    phoenix HD 11582 H
    x 0 Nicht einstellbar
    x 1 Nicht einstellbar
    2
    3
    x 4 Nicht einstellbar(Kein S2)
    x 5 Nicht einstellbar(Kein S2)


    Kikaa (SD)
    x 0 Nicht einstallebar
    x 1 Nicht einstallebar
    2 Kika
    3 KiKa
    x 4 Nicht einstallebar
    x 5 Nicht einstallebar


    Device status:
    Device 1 einsfestival HD 12421
    Device 2 einsfestival HD12421
    Device 3 0
    Device 4 ZDF Info HD 11347 norecording, Live
    Device 5: KiKa 11953 Recording


    (Die unterschiedliche Nummerierung Linux/Femein/VDR macht die Fehlersuche (mit grep) nicht einfacher

    Na siehste, jetzt kennst Du die Zuordnungen :D


    Aber /dev/sda2 ist nicht dabei wie weiter oben angefragt von tag. Ist auch nicht weiter wichtig die Nummerierung, wird eh mit UUID gearbeitet bei vielen Linux Distri's


    sda2 ist "extended".


    Hi,


    gib nur

    Code
    1. blkid

    ein und ENTER drücken


    Da kam garnix.
    Hab wohl nicht lange genug gewartet.
    Achso, ja, der will auch auf sdb...und die Platte schläft und muss sich erst mal aufrappel.
    Daher die für diesen Vorgang ja ungewöhnliche Wartezeit.



    Code
    1. root@vdr4:~# blkid
    2. /dev/sda1: LABEL="BOOTROOT" UUID="ec2303ad-033e-4375-aedf-e0de56e13dea" TYPE="ext4"
    3. /dev/sda3: UUID="663d77c4-6ae1-42f3-9bd0-b54c0539bfd4" TYPE="xfs"
    4. /dev/sda5: UUID="7f806aa8-c7a0-4f83-b475-ca590d5e75ec" TYPE="swap"
    5. /dev/sdb1: UUID="2d78214d-e858-484f-bb43-6699df715036" TYPE="ext4"
    6. /dev/sdc1: LABEL="MYLINUXLIVE" UUID="C4AB-77CC" TYPE="vfat"


    Achso, ja seltsam. Das ist wohl dem nachträglichen partionieren zu verdanken.

    Welche UUID was ist findest Du mit einem simplen:

    Code
    1. blkid


    auf der Console


    Code
    1. root@vdr4:~# blkid -U ec2303ad-033e-4375-aedf-e0de56e13dea
    2. /dev/sda1
    3. root@vdr4:~# blkid -U 7f806aa8-c7a0-4f83-b475-ca590d5e75ec
    4. /dev/sda5
    5. root@vdr4:~# blkid -U 663d77c4-6ae1-42f3-9bd0-b54c0539bfd4
    6. /dev/sda3


    Was ist sda2?

    Hallo


    ich musste ebend mit femon zwischen Geräten umschalten, die u.U. keinen TS lieferten.
    Dabei sah ich einmal auch dieses "Nachrütteln" solange keine neuen Daten kamen.
    Also kein reines Aufnahme Problem.


    a) Ist das das Video Device
    b) Müsste VDR am Ende der Aufnahmen ein Schnipsel "schwarz" einkopieren, damit die Buffer leer gespült werden.
    c) oder dafür sorgen das das das Auszeichungsende auch das Frameende ist und nicht "mitten drin".

    Es spielt keine Rolle, ob oder wann fsck läuft. Bei XFS macht fsck sowieso nichts (man 8 fsck.xfs).


    Der Write-Cache der Festplatte könnte aber tatsächlich das Problem sein. Stehen im syslog irgendwelche Meldungen bzgl. write barriers? Wenn die nicht funktionieren, musst du den Write-Cache wohl dauerhaft abschalten. Nur erklärt das leider auch nicht, warum das Dateisystem im laufenden Betrieb beschädigt wurde.


    Also: Ich habe bisher einmal beobachtet, das nach einem löschen XFS_repair arbeiten musste.
    Ich will nicht ausschliessen, das ich, als die Kiste neu war, öfters mal so ausgeschaltet habe und das dabei defekte entstanden sind,
    die erst jetzt aufgefallen sind.



    Quote


    Vermutlich ist es unwichtig, aber ... Warum liegt sda2 hinter sda3?


    Da verstehe ich nicht auf was Du dich beziehst.
    sda2 müsste der swap sein. Den legt man heut zutagen ja danz nach hinten, weil man den eh nie brauchen(darf)


    sda3 habe ich nachträglich mit parted eingerichtet, da ich naiverweise erwartet hatte, das mich das Installatiosprogramm fragt, welche Quota oder Partions grösse für die Videos vorgesehen werden soll. Das die einfach unter "/" liegen, würden konnte ich mir einfach nicht vorstellen. Also musste ich das nachträglich machen.

    [README des Dynamite-Plugins an. Ist ja nicht so, dass man nicht sagen könnte, welcher Adapter im VDR welche Nummer bekommen soll.
    Falls das nicht genutzt wird, einfach mal im Wiki stöbern: http://www.vdr-wiki.de/wiki/in…der_DVB-Treiber_festlegen


    Ja, demnach könnte "dynamite" mangels TS-stream beschlossen haben, sich erstmal um die "anderen" Karten zu kümmern.
    So rutschen dann (manchmal) die Karten, die -auswelchem Grund immer- kein TS liefern "nachhinten"
    Das darf beim Bonding natürlich nie passieren, da da die Reihenfolge als "konstant" angenommen wird.


    M.Wn haben die Karten alle(?) ein Network Interface und das ne MAC-Adresse. Auch könnte man die PCI/USB Vendor/Produkt ID zum "bonden" verwenden,
    wenn die Hersteller die Seriennummern sauber verwalten würden...Aber hier könnte dann die PCI-Steckplat Nummer helfen, aber bei USB möchte ich
    dann schon das genau der Stick immer "dev 3" ist. Fehlt es, muss der Platz freibleiben. Halt wie bei udev/hotplug mit Ethernet.

    Da würfelt niemand, es geht rein nach dem Timing. Schau dir einfach mal die README des Dynamite-Plugins an.
    Ist ja nicht so, dass man nicht sagen könnte, welcher Adapter im VDR welche Nummer bekommen soll.
    Falls das nicht genutzt wird, einfach mal im Wiki stöbern: http://www.vdr-wiki.de/wiki/in…der_DVB-Treiber_festlegen


    Ich meinte ob es ein Tool (z.B. als Plugin) gibt, mit dem die Software (oder ich) -ohne grössere Schraubarbeiten im Keller oder am Gerät-
    feststellen kann, welche "Logischen" Geräte zusammengebondet sind. Würde das über die MAC-Adresse gehen, könnte sich das nie ädern.
    Und selbst wenn ich eine neue Karte reinstecke, ändern sich die Zurodnungen der nicht. Was jetzt ja durchaus passieren kann (und wird).
    Ich denke da auch an USB-Empfänger, die mal dasein können und mal nicht.
    Das DARF doch nicht dazuführen das die restliche Konfguration durcheinander gerät und garnix mehr geht.
    Ist ja nicht nur ein Problem beim Bonding, siondern auch, wenn nur eine spezielle Karte eine spezielle Funktion hat.


    Diese grausame Linux Spiel mit den wandernden Geräten kenne ich schon leidlich aus der Zeit, als ich 2 WinTV 794 drin hatte.
    Das war allerdings leicht zu bemwerken, da dann die FB nicht mehr lief...


    Die Links schau ich mir mal an. Danke.

    Hab mich verlesen.
    12265 ist grösser als 11700, also hi.


    BR-alpha;ARD:12265:HC34M2S0:S19.2E:27500:1401=2:1402=deu@3,1403=mis@3;1406=deu@106:1404:0:28487:1:1093:0
    Das Erste HD;ARD:11493:HC23M5O35S1:S19.2E:22000:5101=27:5102=deu@3,5103=mis@3;5106=deu@106:5104;5105=deu:0:10301:1:1019:0


    Aber warum friert das HD-Bild-"Low" ein, nur weil BR alpha ("High") eingestellt wird?
    Dann müsste die Device-Kabel zuordnung ja falsch sein?


    Ich habe mal am Gerät die Stecker eines Stranges abgezogen und
    einen Kaltstart (reset knopf) gemacht:


    #0 1 cx24123
    #1 1 stv090 (unten)
    #2 1 stv090 (unten)
    #3 X stv090 (oben)
    #4 X stv090 (oben)
    #5 X cx241123


    uups...


    Mit allen Kabeln dran resetet:
    #0 1 stv090 (unten)
    #1 1 stv90 (unten)
    #2 2 stv90 Kein EMpfang trotz kabel? Imzweiten Femon-Durchlauf schon
    #3 2 stv90 Kein EMpfang trotz kabel?Imzweiten Femon-Durchlauf schon
    #4 1 cx24123
    #5 2 cx24123


    OK


    FEmonNummer Kabelnummer Femoen-Name


    vdr:
    Device1 Connected to sat cable 1
    Device2 Connected to sat cable 1
    Device3 Connected to sat cable 2
    Device4 Connected to sat cable 2
    Device5 Connected to sat cable 1
    Device6 Connected to sat cable 2


    Das stimmt jetzt also.


    Kann das sein, das sich die Device-Reihenfolge bei Booten sich manchmal ändert?
    und davon abhängt, wie die Signal-Pegel beim Booten liegen?


    Wie soll denn da eine eindeutige Bonding-Zuordnung gemacht werden können?


    Gibt es ein Plugin das die Verbindungen "auswürfelt"? (Ausser manuell per Femon und laufenden Aufnahmen)
    Kabel "abziehen" ist ja irgendwie nicht ziehlführend, denn das Abziehen soll ja nur bei ausgeschalteten Rechner erfolgen,
    wenn man die Karten nicht gefährden will.


    Jede Karte hat doch ne MAC-Adresse, oder?.
    Kann diese nicht zur allzeit eindeutigen Zuordnung genutzt werden
    wie bei Ethernet-Karten ja auch?


    Wir haben den Bugtracker nicht geschrieben. Das wird einfach ein Default sein und wegen dir werde ich kaum nachforschen ob das zu ändern ist. Keine Lust.
    Wenn dir diese Einstiegshürde zu hoch ist, dann lass es einfach. Erspart uns Arbeit.


    Gerald


    Da stimme ich Dir zu:
    LMAA.