Posts by RaHe67

    Lieben Dank für die Hinweise. Brauche einen Kompass der mir sagt in welche Richtung ich weiterlaufen soll :D

    Vielleicht habe ich heute Abend wieder eine Stunde an der Kiste.


    Das sehe ich anders: Mittel-/langfristig sind Config-Dateien wesentlich sinnvoller als irgendwelche grafischen Oberflächen, weil man das scripten kann.

    Naja solange man nichts automatisieren und die Geschichte nur einmal anfassen und wenig pflegen will sind intuitiv benutzbare Oberflächen schon nicht schlecht. Besonders für Anfänger.

    Deshalb habe ich ja auch hier den Debian + OMV4 Unterbau gewählt. Ansonsten gebe ich Dir natürlich recht.


    Die bei Ubuntu enthaltenen VDR-Pakete mögen veraltet sein, aber sie funktionieren. Und sie reichen vollkommen für meinen Bedarf.
    e-tobi hatte ich in der Anfangszeit auch verwendet. Das ist dann aber regelmäßig in einem Chaos ausgeartet. Das mag sich in der Zwischenzeit gebessert haben.

    Was sind den die wesentlichen Unterschiede der Ubuntu vs. e-Tobi (Debian) Pakete (für einen unbedarften Nutzer erklärt)? Mal von der unterschiedlichen Distributionen und den vermutlich unterschiedlichen Versionsständen abgesehen. Oder beziehst Du Dich auf YaVdr Pakete wo noch viel mehr drin ist?


    Ralf

    Bitte nicht gefiltert nach Fehlern. Bitte die ganze Wahrheit

    Wollte Euch natürlich nichts vorenthalten. In den Logs, die ich rausgesucht habe stand auch nicht mehr drin :-(

    Als Linux Anfänger bin ich mir im Moment über die korrekten Startmethoden (SystemD, per Prozess, bzw Service Start) und die verschiedenen logging Outputs etwas verloren.


    --log=3.7 ist in der 00-vdr.conf ergänzt (erzeugt aber keine zusätzliche Ausgabe in dem log siehe unten)


    Nach dem Reboot hat wohl systemd den Vdr einmal erfolglos versucht hochzustarten.


    Also den Octopus unter der Addresse 192.168.2.33 scheint er gefunden zu haben. Das Live Plugin scheint Probleme mit der IPAddress zu haben und für mich sieht es so aus, als wenn ein fehlendes ir-Device den Exit verursacht ....


    Log-Datei als Anhang:

    log.txt


    Ralf

    Oder soll ich als Systemd Dienst starten (ich stehe hier als Newbie etwas auf dem Schlauch):


    Code
    1. systemctl restart vdr.service


    Dann kommt etwas mehr Output (gefiltert nach Fehlern):


    Also so bekomme ich keine zusätzlichen Angaben ins Log. Bleibt gleich

    Hier sieht die IP von live merkwürdig aus und antwortet auch nicht . Der vdr Prozess beendet sich ja auch immer gleich.


    Der Satip Server liegt im selben Subnetz und kann problemlos angepingt werden (vom VDR).

    Von Windows bekomme ich auch eine Tunerzuordnung und ein Bild.


    Der User 'vdr' ist auch in der /etc/passwd eingetragen ...


    Ralf

    Habe jetzt noch die von hopsi vorgeschlagenen plugins ergänzt. Am Verhalten des Servers ändert sich noch nichts:


    syslog:


    Service Status:



    Wo setze ich weiter an? Die SATIP Tuner werden anscheinend nicht angebunden.


    Gruß Ralf


    hast Du schon ein log vom vdr-Start hier gepostet?

    Sorry :wand, das ist im Eifer des Gefechts zwischen Server-Keller, Forum und Familie untergegangen. Bis jetzt hatte ich nur den systemctl status gepostet - den VDR Log habe ich noch gar nicht geprüft.

    Das hole ich nach sobald ich wieder an die Kiste komme - kommt davon wenn man sich mit dem Thema immer nur 20min ohne Unterbrechung beschäftigen kann ...

    Danke für die Hinweise, mein Eingangsproblem war aber siehe oben, dass der vdr.service sich sofort beendet. An fehlenden Plugins liegt das eher nicht oder?.

    Muss ich noch irgendwo mitteilen woher die SatIP Tuner kommen?



    Ich werde die Plugins bei Gelegenheit im Laufe der Woche mal nachinstallieren.

    Du brauchst noch ein Ausgabeplugin wie streamdev oder vnsi. Oder willst du nur aufzeichnen?


    Siehe oben. Soll eine reine Server installation sein.

    Hast Du eine channels.conf angelegt? Werden Deine Tuner erkannt?

    Bis jetzt nicht. Eventuell bricht ja der Vdr Service deswegen ab (siehe oben). Wollte ja den SatIP Server anbinden. Ich dachte das funktioniert über das 'vdr-plugin-satip' und dann automatisch (unbedarft wie ich hier herangehe :-p)


    Dann würde ich noch das live- Plugin installieren.


    Das werde ich wohl benötigen, aber verhindert vermutlich nicht den Service Abbruch/Crash ...


    Ralf

    Die Krux ist leider das du für VDR ein ganzes angepasstes OS brauchst wenn du nicht viel Zeit mitbringen willst da du per Plugins die fehlenden Funktionen von VDR ausgleichen musst.

    Meine Hoffnung war eigentlich, dass für einen 24H Betrieb (ohne TimerWakeup) über SATIP gar nicht so viele Plugins + Konfigurationen notwendig sind ...

    Habe zumindest das Grundgerüst soweit am laufen (Debian + OMV)


    Installiert wie hier beschrieben:

    https://openmediavault.readthe…stallation/on_debian.html



    Sources.list:


    deb https://packages.e-tobi.net/vdr-experimental/ stretch vdr-multipatch base

    deb-src https://packages.e-tobi.net/vdr-experimental/ stretch vdr-multipatch base


    Der Vdr startet noch nicht:

    Code
    1. >sudo apt-get install vdr
    2. >sudo apt-get install vdr-plugin-satip
    3. >vdr start
    4. vdr: no primary device found - using first device!


    Fehlt noch was an Vorraussetzungen?


    Ralf

    Danke für die Antworten!


    Einfacher ist es sicher ein yaVDR, mld oder Easyvdr zu nutzen und sich in die Konfiguration von LVM und Samba einzulesen.

    Oder NAS und VDR trennen.


    Genau das hatte ich ja mit meiner ursprünglichen Konfiguration siehe erster Post so beabsichtigt, die lief hier auch die letzten 4 Jahre (Ohne VDR-Server, 1 YaVdr Client). Da ich mich aber nicht täglich mit Linux Sytemen auseinandersetze hatte ich das Problem, das ich für jeden Handgriff wieder bei 0 anfange. Z.B. lief nach einem halben jahr die vermutlich zu klein gewählte boot Partition immer mit Kernel Updates voll, so dass händisch für die meisten Updates eingegriffen werden musste.

    Schon die Anpassung eines ursprünglich von mir eingebundenen Backup-Scripts und die Health-Kontrolle der Festplatten ist wegen meiner Faulheit im Laufe der Zeit unterblieben. Ich komme aus der Windows Welt und eine Web-Oberfläche, welche diese Aufgaben (neben der Konfiguration von Samba und Festplatten) kommt mir da wesentlich entgegen (deshalb war mein Gedanke OMV). Ist eben einfacher wenn man mal nur 1x im Monat draufschaut und nur alle 2 Jahre mal eine Festplatte dazuschraubt.

    Welche CPU nutzt du? Wenn der Celeron verbaut ist dann kannst Du nicht ganz so viel erwarten. Da würde ich auf OMV verzichten und ein reines Ubuntu installieren.


    Ja es ist der Celeron verbaut, allerdings mit 10GB Speicher. Ich hätte jetzt erwartet, dass ein Standard-OMV ohne Plugins keine große zusätzliche CPU Last erzeugt. Ist das mehr als eine (Web) Konfigurationsoberfläche für Samba + LVM? Für Docker oder VM wird es vermutlich etwas eng - je nach Ansprüchen.


    Statt von Workaround zu Workaround zu springen und solche absurden Dinge wie ein extra VM+OS aufzusetzen nur für VDR könnte man auch mal darüber nachdenken auf die führende/weitverbreitetste TV Server Software zu setzen die man einfach per Docker oder per apt in OMV/OS einbinden kann (kommt natürlich darauf an was man als Client nutzen will).

    Ich bin mir jetzt nicht sicher auf welche TV Server Software du abzielst (evtl. TvHeadend?). Ich habe mich allerdings seit 2011 sehr an den (ya)VDR gewöhnt und möchte eigentlich nur das Server Thema ergänzen. Das Thema Docker oder VM würde meiner Meinung nach nur Sinn machen, wenn es das Aufsetzen bzw. Warten durch Komplettpakete vereinfacht, wobei der Server dafür evtl. zu schwachbrüstig ist. Falls es fertig geschnürte Container/Pakete nicht gibt, macht das natürlich gar keinen Sinn.


    Wäre ein Ausgangspunkt Ubuntu + YaVdr sinnvoller? Dann hätte ich aber keine NAS Konfigurationsoberläche und inwieweit der Support von yavdr/easyvdr für neuere Ubuntu Versionen gediehen ist hat sich mir noch nicht voll erschlossen. Bei MLD umgekehrt bekomme ich ein Debian Basissystem und muss mich um FileServer / NAS Funktionalität auch selber kümmern.


    Grüße

    Ralf

    Hallo,

    ich betreibe schon seit einigen Jahren einen yavdr Client und lese hier seit 2011 fleissig mit.

    Da dieser so langsam in die Jahre kommt und die Installation bzw. Hardware anfängt Probleme zu bereiten möchte ich mein System neu aufsetzen und erweitern.

    Als ersten Schritt möchte ich den SAT Empfang vom YaVdr Wohnzimmer Rechner (DigitalDevices Tuner) auf einen Headless Server (HP Micro Server Gen8) auslagern. Eine Octopus.NET S4 habe ich die letzten Tage in Betrieb genommen.


    Nun brauche ich einen Startpunkt für den Server:

    Dieser soll nur NAS Funktionen + VDR übernehmen (im Zweifel auch 24H aktiv falls Wakeup ein Problem darstellt)


    Im Moment läuft auf diesem ein Ubuntu 16.04.5 LTS Server, wobei die Platten ungünstig partitioniert sind (zu kleine Boot Partition und ungünstige LVM) und ich deshalb das System neu aufsetzen möchte (meine Linux Kenntnisse sind leider begrenzt ich bin zu 99.99% auf Windows Platformen unterwegs :| )


    Am liebsten wäre mir etwas mit (NAS) Web-Konfigurationsoberfläche wie z.B. OpenMediaVault um die Management-Tätigkeiten möglichst einfach zu halten.

    Ich habe nur leider keine Hinweise gefunden inwieweit sich aktuelle VDR Versionen im OMV 4 aktivieren lassen (PlugIn, Docker bzw. Handarbeit).

    Informationen in Foren und Web gibt es zuhauf - scheinbar zum großen Teil veraltet - so dass ich erstmal eine Leitlinie brauche.


    Also meine Fragen an Euch erfahrene Nutzer:


    - Welche Distribution würdet Ihr momentan als Ausgangsbasis wählen (Ubuntu, OMV, o.Ä und welche Version)

    - Nutzung von Docker oder VM (aus meiner Sicht nicht notwendig falls das die Sache nicht vereinfacht)

    - Welche VDR Pakete (PPAs?) sollten der einfachheit halber genutzt werden? (YaVdr, EasyVdr, von Nutzern zusammengestellte Pakete)


    Erstes Ziel ist es meinen YaVdr dort als Client anhängen zu können. Als weiterer Schritt werden später 1-2 weitere Clients (Raspi3, X86) in meinem Heimnetzwerk hinzukommen.


    Ich brauche einen Startpunkt um mich langsam weiterentwickeln zu können.


    RaHe67

    Also ich teste es mal mit dem Austragen aus der
    /etc/vdr/plugins/order.conf


    Eintrag:
    -tvm2vdr


    Deaktivierung über das OSD hatte ich schon mal vor längerem probiert. Das Plug scheint dann aber immer noch geladen zu werden.


    Schon mal daran gedacht das die Stromversorgung für das gesamte System eventuell zu schwach ist ? Vor allem wenn noch die DVB Karte mitversorgt wird über den Bus ?

    Kann ich mir nicht vorstellen. Hatte zwar damals ein eher "schwachbrüstiges" Netzteil besorgt, aber Netzteile unter 300W sind ja kaum zu bekommen. Wenn ich mich richtig erinnere, habe ich etwas zwischen 280 u. 320 Watt (Markenware) verbaut - was defacto immer noch völlig überdimensioniert sein sollte.
    Kann aber bei Gelegenheit nochmal nachschauen ...


    Raf

    Hallo,


    bei hat sich mit dem Umstieg auf yavdr 0.5 ein ähnliches Phänomen eingestellt. Bei ca 10-30% der Bootvorgänge ein schwarzes Bild. Bei der Version 0.4 (gleiche Hardware) konnte ich das nie so beobachten.


    Symptom: Wiederholendes SysLog-Output ca. alle 30 Sekunden:


    Feb 3 15:12:44 Vdr1 kernel: [ 89.488743] init: vdr-frontend main process (2004) terminated with status 1
    Feb 3 15:12:44 Vdr1 kernel: [ 89.488798] init: vdr-frontend main process ended, respawning


    Längerer Ausschnitt aus dem Syslog:
    http://pastebin.com/3FCmHrrL


    Aus den oben von Freestyler gesendeten Syslogs konnte ich allerdings keine Überdeckung mit meinem Problem erkennen ... von daher bin ich mir nicht sicher, ob es sich um dasselbe Problem handelt.
    Bei mir handelt es sich allerdings nicht um ein Atom System (Celeron) und es ist auch RAM auf beiden Kanälen vorhanden. Gleich ist jedoch die Benutzung einer SSD als System-Platte.

    Scheint ein Problem bei der Tonausgabe via HDMI zu sein, oder?

    Nicht nur, ich hatte HDMI + Analog aktiviert. Die Analog-Ausgänge funktionieren dann auch nicht. Beim Beenden der Video Ausgabe von XBMC friert dann XBMC ein ...

    Was sollen wir aber dagegen tun? Weder auf die Nvidia-Treiber haben wir Einfluß, noch auf XBMC, wobei mein Bauchgefühl mir sagt, da müßte vmtl. eher was an XBMC angepasst werden ...

    War so auch nicht gemeint, sondern nur als Hinweis dass es sich nicht um einen Einzelfall handelt und um den Thread wieder ein bisschen aus der Versenkung zu holen, da er mir ja geholfen hat ...

    Ihr könntet noch die Version upgrade-safe "anketten":
    #/> sudo aptitude hold nvidia-current nvidia-settings


    Auch wenn das Gundlagen sind, war das noch genau die Info die mir fehlte. Also Danke für die Antwort, ich habe noch einen langen Lernweg unter Linux - mühsam ernährt sich das Eichhörnchen.


    Gruß Ralf

    Hallo, als Info für Fettnäpfchen-Verfolger


    bei mir hat sich (vermutlich durch ein heutiges dist-upgrade) dasselbe Problem ergeben.
    Die aktuelle Version ist ebenfalls 295.59.


    apt-cache policy nvidia-current



    Zeigt mir eine verfügbare Version 270.41 ... Ein Downgrade zu dieser Version hilft bei mir ebenfalls.


    Die Audio-Geräte sind laut aplay -l identisch.


    Gruß Ralf

    Hallo mk75:

    Hab ich von Schneisa bekommen:


    Nimm als Suchbegriff:

    Code
    1. ^Tatort($|:)


    Und stelle als Suche regulärer Ausdruck ein.

    Danke, dieser reguläre Ausdruck würde sich genau auf die beiden von Dir oben angesprochenen Fälle abbilden. Eine weitere Variante der Titel / Untertitel-Bezeichnung habe ich in der letzten Zeit nicht gesehen.


    Gruß
    Ralf

    Hallo mk75,
    seit 2-3 Monaten habe ich diesen Effekt auch festgestellt. Ich hatte für den Suchtimer auf den Titelnamen "Tatort:" losgelassen.
    Zumindest unter ARD HD werden die aktuellen Folgen am Sonntag damit nicht mehr gefunden, da der Titel nun vom ARD EPG so wie in deinem ersten Beispiel zur verfügung gestellt wird.
    Daraufhin habe ich den SearchFilter-String auf "Tatort" angepasst und habe damit genau den beschriebenen Effekt (und bis jetzt keine Lösung dazu). Ein weiterer Nachteil ist, dass jetzt auch andere Filme und Dokus aufgenommen werden, ich habe noch keine Möglichkeit gefunden die Suche noch etwas schärfer abzubilden.


    Ich habe kein tvm2vdr PlugIn aktiv. Die meisten dritten (ich habe das nicht weiter analysiert), formatieren den Titel noch mit "Tatort:XXX".
    Mit den tvm Daten hat das glaube ich nichts zu tun - das kommt vom Sender EPG


    Ralf

    Hallo,


    der parallel Thread
    Yavdr 0.4 atric rev.5 keine ausgabe


    klärt die Frage wie ein Template angelegt werden muss. Hier wird auch die


    /usr/share/xbmc/system/Lircmap.xml


    benutzt und über ein Script das Template Verzeichnis


    /usr/share/yavdr/templates/usr/share/xbmc/system/Lircmap.xml


    angelegt. Bleibt für mich die Frage ob und wofür die


    var/lib/vdr/.xbmc/userdata/Lircmap.xml


    und das zugehörige Template


    /usr/share/yavdr/templates/var/lib/vdr/.xbmc/userdata/Lircmap.xml


    benutzt werden?


    Gruß Ralf