Posts by Friedl

    Hallo Johannes,


    versuche doch mal, das ":0" nach extid wegzulassen oder auf ":1" zu setzen. Evtl. löst das dein Problem.


    Die Channelmap ist für alle Kanäle so gesetzt:

    Code
    1. epgdata:71:0=I-1-10301-10301 // Das Erste HD
    2. epgdata:37:0=I-1-11110-11110 // ZDF HD


    channelmap.conf wrote:
    Code
    1. // Format:
    2. // <source>:<extid>[:<merge>[:<vps>]] = <cid1>[,<cid2>[,<cid3>]]
    3. ...
    4. // <merge> Merge DVB and externel EPG for this channel
    5. // { y, Y, n, N, 0, 1 } (default 1, default for vdr is 0)


    siehe auch: http://projects.vdr-developer.…aemon.git/tree/README#n47


    Gruß
    Andreas

    Chriss, wenn man das immer erst starten muss, ist das wohl ein bisschen umständlich. Eine Lösung im Ausgabe-Plugin wäre mir lieber. Trotzdem danke für den Hinweis.


    Thomas, das ist schade, aber es ist deine Entscheidung.

    Dem Anwender ist letztlich egal, warum die Zeile da blinkt.
    Ich würde es, wie gesagt, über einen konfigurierbaren Zoom lösen.


    Dadurch würden sich vielleicht noch andere Vorteile ergeben. Vielleicht mag der ein oder andere ja, dass das Bild etwas größer wirkt bei kleinen Bildschirmen. Oder man nutzt es bei 4:3 Letterbox, vielleicht über die Fernbedienung umschaltbar oder automatisch, wie bei anderen Ausgabeplugins.

    Hallo Thomas,


    gibt es beim rpihddevice die Möglichkeit, eine Zoom-Funktion einzubauen? Hintergrund ist, dass bei SD-Sender oft die erste Zeile "flackert", was ich als störend empfinde.


    Auf dem PC mit softhddevice gibt es dazu die Einstellung, eine definierte Anzahl an Pixel abzuschneiden.


    Ich könnte mir einen Prozentwert im Setup vorstellen, mit dem man das nach eigenen Bedürfnissen einstellen kann.


    Mir habe selbst keine Kenntnisse in C++ und ein Selbstversuch hat nichts gebracht. Ich weiß ja auch nicht, wo ich da ansetzen musste oder wie aufwändig das wäre.


    Wäre super, wenn du dir mal Gedanken dazu machen könntest. Ansonsten bin ich absolut begeistert, was die kleine Kiste so leistet.


    Grüße
    Andreas

    Zu dem Thema, wie aus dem Internet auf Streamdev, etc. zugreifen: Warum nutzt du nicht einfach ssh mit Portforwarding? Somit wäre die Verbindung doch recht sicher und du musst keine unsicheren Dienste nach draußen freigeben. Kann man für andere Dienste auch prima nutzen...
    Alternativ wäre auch eine VPN-Lösung interessant. Persönlich habe ich aber mit ssh-Tunnel bessere Erfahrungen gemacht...


    Zum eigentlichem Thema: Klingt vielversprechend. Nutze selber gelegentlich Streamdev auf meinem HTC Desire mit Vplayer. Momentan allerdings direkt, indem ich die URLs der Kanäle aufrufe oder die Übersicht auf http://VDR-SERVER:3000/ nutze.

    Hab jetzt noch weitere Tests gemacht mit folgenden Ergebnissen:


    Firmware ist jeweils von TeVii-Treiber auf tevii.com:
    dvb-fe-ds3000.fw und dvb-usb-s660.fw


    Debian squeeze mit Standard-Kernel 2.6.32-5-amd64:
    - Treiber von TeVii-Homepage lässt sich kompilieren, gibt aber Aussetzter im SSH und die bekannten Probleme mit DVB-S2. DVB-S läuft mehr oder weniger.
    Es werden beim booten beide Firmware-Dateien geladen.
    Aufnahmen habe ich nicht weiter getestet, da ich hier nur einen Test-VDR mit streamdev-server laufen habe.


    - Aktuelles S2-Liplianin lässt sich nicht compilieren, bricht ab.


    Ubuntu Lucid Server:
    bleibt bei mir beim booten während des Ladens der USB-Treiber hängen. :(


    Debian squeeze mit vanilla Kernel 2.6.37-rc8:
    - Treiber von TeVii-Homepage nicht getestet.
    - Treiber von S2-Liplianin lässt sich compilieren, läuft soweit ganz gut mit DVB-S, DVB-S2 gibt die bekannten Probleme (liegt wohl am "improved" M88DS3002)
    Das Gute ist aber, dass es jetzt keine Hänger mehr im SSH gibt!
    Scheint wohl an der Kernelversion zu liegen oder am S2-Liplianin-Treiber.
    Hier konnte ich auch beobachten, dass der zweite Teil der Firmware erst beim Starten des VDR geladen wird.
    Beim ersten Teil wird die Firmware auch jeweils zweimal geladen. Ist hier noch ein Bug im Treiber?


    Umschaltzeiten sind aber weiterhin miserabel! :(


    Firmware ist die gleiche wie bei telesto:

    Code
    1. # md5sum /lib/firmware/dvb*
    2. a32d17910c4f370073f9346e71d34b80 /lib/firmware/dvb-fe-ds3000.fw
    3. 2946e99fe3a4973ba905fcf59111cf40 /lib/firmware/dvb-usb-s660.fw


    Auszug aus dmesg (interessant auch die ersten beiden Zeilen):


    Beim Start des VDR:

    Code
    1. [ 487.896022] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
    2. [ 487.917961] ds3000_firmware_ondemand: Waiting for firmware upload(2)...
    3. [ 524.000022] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
    4. [ 524.010274] ds3000_firmware_ondemand: Waiting for firmware upload(2)...


    Hoffe das hilft weiter...

    Quote

    Original von andreash
    Friedl : welche Firmware verwendest du? Die aus dem nicht funktionierendem Tevii Treiber (100315_Beta_linux_tevii_ds3000.rar)?


    Ich verwende den Treiber und die Firmware der S660. Der oben genannte Patch erweitert nur die USB-Kennungen um die S480, soweit ich das verstehe.
    Ich nutze momentan den Treiber direkt von tevii.com: http://www.tevii.com/s2_liplianin_1.tar
    Laut Patchbeschreibung sollte aber auch der normale Liplianin-Treiber gehen, wenn man diesen patcht.


    Nach dem Patch und dem installieren des Treibers bekomme ich zwei S660:

    Testsystem ist übrigens ein Squeeze, mit Lucid hatte ich Probleme, dass das System beim laden des USB-Treibers für die Karte hängen bleibt.

    Habe die Karte gestern bekommen und Recherchen ergaben, dass es sich wohl um zwei USB-Karten S660 auf einer PCIe-Karte handelt:
    http://linuxtv.org/wiki/index.php/TeVii_S480


    Habe den Patch von dieser Seite mal auf den Treiber von der Tevii-Seite für die S660 angewandt.
    Mit SD-Material läuft die Karte, mit HD gibts Ruckler - wie auf LinuxTV.org beschrieben:

    Quote

    This patch against s2-liplianin v4l branch (rev 054f002f4d23) adds basic support for the card. It uses the S660 firmware. DVB-S seems to be working, DVB-S2 is problematic (packet loss). The reason is unknown (firmware related? Too much bandwidth?).


    Wegen den angesprochenen Bandbreitenproblemen, wenn ich z.B. alle Sender der RTL-Gruppe als Stream laufen lasse, die auf dem gleichen Transponder senden, gibt es keine Ruckler oder Aussetzer.
    Kann es dann bei HD trotzdem zu Enpässen kommen, oder sehe ich da etwas grundlegend falsch?
    Wenn nicht, würde es Hoffnung geben, dass HD mit einem besseren Treiber oder einer neueren Firmware läuft.


    Folgendes liefert lsusb -v:


    Andreas

    Stimmt schon, was du sagst. Vor allem mit dem setzen des root-Passworts kann man ziemlich schnell unerwünschte Nebeneffekte erreichen.


    Ist das bei Ubuntu nicht so, dass er ein Passwort zum herunterfahren will, wenn man ein root-Passwort gesetzt hat? Und bei unterschiedlichen Passwörtern für root und User kommt man dann schnell durcheinander, welches Passwort er denn jetzt eigentlich will... ;)