Posts by nvertigo

    Hallo Thomas,


    da ist Dir ein sehr rundes (homogenes), elegantes und unaufdringliches Skin gelungen. Wir gucken hier jetzt gar nicht mehr TV, sondern nur noch Skin...:lol: Ernsthaft: gefällt uns sehr gut, und es ist das aller erste Mal, das hier auf die Dauer, etwas anders als EnigmaNG/DrakBlue läuft. Herzlichen Dank!


    Deine Bildlaufleisten passen sich wunderbar in Dein Listendesign ein - wie man jetzt noch die Funktionalität "wie erkenne ich in welche Höhe ich mich auf der Liste befinde" einbauen kann, ohne die Harmonie des Designs zu ruinieren, weiß ich im Moment noch nicht.


    Die Menu Icons sind auch sehr elegant geworden. Ich brauche jetzt ganz schnell EiB, damit ich mehr davon benutzen kann...;) Ich baue hier gerade etwas, um noch mehr von meinen Menuorg-MenuPunkten zu plakatieren. Dabei frage ich mich, ob man nicht irgendwie eine Tabelle in einer Datei implementieren könnte, die eine sed-Schleife im im Makefile auswertet, und einem damit das leidliche cut'n'paste erspart...


    Gruß, Ingo


    Du kannst ein Script zwischenschalten, d.h. epgsearch ruft nicht direkt den Seriestimer auf sondern dein Script, dieses ruft Seriestimer auf und gibt !invalid! aus wenn die Staffel nicht passt.
    So als Anregung: [Feature Request] VDRSeriesTimer.pl als Paket
    (Ist immer noch auf meiner ToDo das mal vernünftig umzusetzen (Python Snippets für individuelle Anapssungen, epgsearch TCP Schnistelle anstatt Scriptaufruf, restfulapi anstelle von SVDRP), aber VDR Projektmässig bin ich da momentan absolut unfähig mal was fertig zu bekommen (gerade zu verzettelt))


    cu


    Hallo,


    und evtl. könnte man dem Script dan einen Schalter verpassen, dass es die Folgen einer Serie, die schon aufgenommen sind, gleich umbenennt in NN/MM_Episoden_Name (NN=Staffel; MM=Folge), dann kann man in extrecmenu nach Namen sortieren und kann siene Serien über alle Sender in der richtigen Reihenfolge sehen... Mein J.A.G.-Verzeichnis könnte das gut gebrauchen... ...wennich Dir beim weiter Verzetteln helefen darf...


    Gruß, Ingo

    Hallo Tomas,


    Änderungen sind auf dem Weg zu Dir. DEVELOPER_FEATURES war natürlich nicht gesetzt (hatte es im text2skin Makefile, anstatt in Make.config vom VDR - und git reset --hard && git pull hat dann aufgeräumt).


    Deine Formatierung gefallen mir übrigens besser. Welche Fontgröße hast Du eigentlich im OSD eingestellt?


    Gruß, Ingo

    Hallo Thomas,


    supergeil. Hatte leider die beiden letzten Tage etwas Stress, daher erst jetzt meine Rückmeldung.


    Das dezente Blinken ist Dir sehr gut gelungen! Und auch die Timerkonflikt-Warnug gefällt mir prima - habe gerade mal im Duden nachgesehen: Es gibt zwei z.Z. gültige Versionen. Entweder eins bis drei als Zahlworte und danach mit 4, 5, 6 weiter; oder aber alles als Zahlworte... (ließt Du auch so gerne die Sebastian Sick-Kolumne in Soiegel-Online?)
    Ich habe mir das Blinken wieder etwas deutlicher gemacht (DarkGray), und die Schriftgröße der Konfliktwarnung auf die gleiche Größe wie Wochentag & Datum gesetzt.


    Jetzt habe ich noch zwei Wünsche (sorry, hätte ich auch vor der 0.0.3 drauf kommen können):


    - Bildlaufleisten in langen Listen (Aufnahmen, Programm, Kanäle und Timer)
    - Wiederholungen in den Sendungsinfos


    Gruß, Ingo

    Danke für die Schnipsel. Die Erklärung aus der Reference sagte mir nämlich gar nichts, außer dass es sich um zwei unterschoedliche Filter handelt...


    TimerConflicts ist in Common, also da wo auch CurrentEventsTitle1 usw. sind - behauptet jedenfalls die Reference.


    Das mit der Unmöglichkeit der RegEx erspart Dir ein paar neue Vorschläge von mir...;) (Je mehr ich lese, um so mehr verstehe ich Deine Anmerkung in einem der vorhergehenden Postings bezüglich der Einschränkungen von Text2Skin - und um so mehr steigt mein Resept für das schicke Anthra!!!)


    Gruß, Ingo

    Thomas


    ich habe noch ein Paar:


    • mail.png muss mailbox.png heißen
    • SUBMENU funktioniert nicht mit MenuTitle:clean und 'Plugin 'name''. Z.B.:
      Code
      1. <!--SUBMENU-LOGOS--> <image x1="30" x2="137" y1="10" y2="70" condition="equal({MenuTitle:rest},'Plugin 'extrecmenu'')" path="submenulogos/recordings.png"/>
      2. <!--SUBMENU-LOGOS--> <image x1="30" x2="137" y1="10" y2="70" condition="equal({MenuTitle:rest},'Plugin 'mailbox'')" path="submenulogos/mailbox.png"/>

      Habe ich eingefügt, sehe trotzdem nur das VDR-Logo


    Gruß, Ingo


    Edit: Meine Anmerkung zu SUBMENUs sind Unsinn. Ich hatte das Prinzip falsch verstanden. Allerdings matcht in der ersten Übersicht des extrecmenus der Titel Aufzeichnungen nicht gegen trans('Recordings'). Vermutlich weil "(NNN:nn frei)" noch dahinter steht...

    @caps


    Gucke mal nach, wie locale in Deinem vdr konfiguriert ist. Bei gen2vdr gehts es z.B. nach ./locale (in den vdr-sourcen) also musst Du beim Anthra /usr/local/src/VDR/locale angeben. Wenn Du keine Sorcen hast, nimm das Verzeichnis, wo die Datei vdr-text2skin.mo zu finden ist.


    Gruß, Ingo

    Hallo Thomas,


    herzlichen Dank für Dein Skin. Ich hatte bisher immer die Finger von text2skin gelassen, weil es bei meinen letzten Versuchen (vor gut einem Jahr) nich wirklcih stabil mit xine coexistierte. Ich habe es hier jetzt seit 72 h sehr stabil im Einsatz.


    Ich könnte jetzt schreiben, dass mir Dein Anthra sehr gut gefällt (was auch stimmt), aber ich glaube, dass ich Dir das größte Lob ausstelle, wenn ich Dir schreibe, was meine Frau gestern sagte, als ich kurz wieder EnigmaNG einestellt hatte: "Hey, mach wieder das schöne Schwarze...!"


    Ich habe noch eine Bitte: Könntest Du eine Timer-Konflikt-Warnung im Hauptmenu einbauen?


    Dann habe ich noch einen Schreibfehler: in 03_menu.xml steht einmal syteminfo.png statt systeminfo.png.


    Nochmal vielen Dank, Ingo


    P.S.: Die kleinere MuneItem Höhe nehme ich auch, wenn es saube skaliert (O-Ton nachdem ich den sed-befehl getestet habe: "Jetzt hast Du die grauen Dinger kaput gemacht...;))

    C3po : lass das .jpg weg.


    Gruß, Ingo

    Hallo,


    an erster Stelle möchte ich Carel und Helau danken, dass sie den LiveBuffer mit der Arbeit von Copperhead (auch an Dich Danke) verheiratet haben!


    Ich teste seit gestern Nachmittag und bin wirklich begeistert. Ich kann die Beobachtungen von Torsten73 im Wesentlichen bestätigen. Die Klötzlichebildung beim zu schnellen wieder Anlaufen nach Pause habe ich nicht nur bei ZDFHD sondern bei allen HD-Sendern (also auch 1080i-Sendern).


    No Signal habe ich bei ALLEN Sendern beim ersten Pausieren.


    Schnelles Vorspulen führt zu dem von Torsten beschriebenen Problem. Vorspringen bis zum aktuellen Zeitpunkt führt hingegen zum Live-Modus.


    Bei ZDF-HD habe ich ein anderes Problem: Die Zeit läuft im LB doppelt so schnell. D.h. wenn der Zeitbalken zeigt 30 Minuten, wenn erst 15 Minuten vergangen sind, und die Sekunden zählen doppelt so schnell hoch.
    Die 'normale' Aufnahme zeigt aber richtig an: wenn ich nach 30 Minuten ZDF-HD (Ard und Arte habe ich noch nicht getestet - vermute aber ähnliches) LB mit den Sprungtasten an den Anfang des LB zurückgehe und eine Aufnahme starte, wird der LB richtig vor die 'normale' Aufnahme gehängt, und diese hat dann sowohl im extrarec-Menu, als auch während der Wiedergabe die richtige Zeitangabe.


    Ich hatte während des Testens einen Absturz. Allerdings weiss ich nicht, ob der mit LB zusammenhängt. Es lief eine normale Timer-Aufnahme im Hintergrung und ich habe eine normale Aufnahme im Vordergrund gesehen:

    Code
    1. Apr 06 21:20:40 [vdr] [21298] EnigmaNG effects thread ended (pid=14398, tid=21298)
    2. Apr 06 21:22:07 [kernel] receiver on dev[15010] general protection ip:46f820 sp:7fc6243b5dd0 error:0 in vdr[400000+15400
    3. 0]
    4. Apr 06 21:22:07 [logger] PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
    5. PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
    6. PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
    7. PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
    8. PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
    9. Apr 06 21:22:07 [lircd-0.9.1-git] removed client
    10. Apr 06 21:22:09 [logger] VDR wurde beendet - RC: 0


    Ich bin wirklich begeistert von der Funktion und der Integration mit extPatchNG - vielen Dank an alle Entwickler und Patcher!!!


    Gruß, Ingo

    Hallo,


    ich habe hier helaus und carels Patch folgendes Problem - mit diesen Einstellungen:


    habe ich zwar LIVEBUFFER, aber das Setup von LIVEBUFFER greift nicht (geht natürlich über setup.conf). Außerdem lädt skinenigmang nicht, obwohl es sauber übersetzt.

    Code
    1. Apr 06 12:38:34 [vdr] [30455] skin "EnigmaNG" not available - using "classic" instead

    Im classic habe ich ein Hauptmenu mit nur 7 Einträgen. Der ExtP Beta9 von copperhead mit genau diesen Einstellungen (außer LIVEBUFFER natürlich) tat was er sollte.


    Außerdem habe ich die Patch-Config von Carel getestet, dabei habe ich gemerkt (wegen nicht eingeschaltetem MISSINGPLUGINS), dass nicht nur skinenigmang sondern auch streamdevserver und epgsearch mit unreolved Symbols aussteigen.


    Gruß, Ingo


    EDIT: Habe einen bösen Zeilen-Umbruch in Make.config gehabt (zu dicke Finger...;)) Teste jetzt weiter.

    Mit skinenigmang kann ich auch mit vdr-xine-0.9.4 das x11-overlay verwenden und habe es in der richtigen Größe bei 1080p. Und zwar mit exakt den Einstellungen, die man in Deinem Screenshot sieht. Daher vermutete ich, das es vieleicht nicht an vdr-xine liegt... Ich verwende im vdr-xine noch http://projects.vdr-developer.…-extensions-v13.2.diff.gz, aber das sollte eher nichts mit dem OSD zu tun haben.


    Gruß, Ingo

    Quote

    Original von TheChief
    Wo stell ich denn SHQ oder Overlay ein? Denn mit 1.7.17 hab ich immernoch den Fehler.


    EDIT: Das OSD geht nun. Hatte vergessen ein paar Dateien nach /usr/lib/xine zu kopieren. Allerdings sieht das OSD noch grausam aus. Finde die Einstellungen für X11-Overlay bzw. SHQ nicht mehr. War das nicht unter OSD in den xineliboutput Einstellungen?


    Menu->Einstellungen->Plugins->xine (0.9.4)->7. Eintrag von oben


    Gruß, Ingo

    Hallo Copperfield,


    ich möchte gerne folgende Patches benutzen:
    ALTERNATECHANNEL = 1
    CHANNELBIND = 1
    CHANNELPROVIDE = 1
    CUTTERLIMIT = 1
    CUTTIME = 1
    DDEPGENTRY = 1
    DVLVIDPREFER = 1
    #DYNAMITE = 1
    #GRAPHTFT = 1
    HARDLINKCUTTER = 1
    JUMPINGSECONDS = 1
    LIEMIEXT = 1
    LIRCSETTINGS = 1
    LNBSHARE = 1
    MAINMENUHOOKS = 1
    #MCLI = 1
    #MENUORG = 1
    NOEPG = 1
    #PINPLUGIN = 1
    PLUGINMISSING = 1
    #ROTOR = 1
    #SETUP = 1
    TIMERINFO = 1
    TTXTSUBS = 1
    #UNICABLE = 1
    VALIDINPUT = 1
    WAREAGLEICON = 1
    YAEPG = 1


    Leider ist es nun so, dass ich mit dieser Konfiguration nur 9 Einträge im Hauptmenu habe, und nur 5 in den Plugin-Einstellungen, obwohl ich eigentlich 15 Einträge im Hauptmenu und 21 im Pluginmenu haben müsste (ja, alle Plugins werden anstandslos geladen).


    Wenn ich nun zusätzlich den GRAPHTFT-Patch aktiviere (den ich eigentlich nicht benötige), sind die Menus zwar wieder vollständig, aber die graphischen Symbole in der Programmübersicjt werden durch Buchstaben und Zeichen ersetzt...


    Ich habe versucht selbst zu gucken, was welcher Patch (in diesem Fall der graphtft) macht, aber ich begreife es einfach nicht.:( Dir für Deine Arbeit ganz viel Dank, und noch mehr Anerkennung!!!


    Gruß, Ingo

    Hallo,


    leider kann ich den LNB-Sharing-Patch nicht ohne Dynamite benutzen, dann übersetzt der vdr nicht:


    Code
    1. dvbdevice.c: In constructor ‘cDvbDevice::cDvbDevice(int, int)’:
    2. dvbdevice.c:971: error: no matching function for call to ‘cDvbTuner::cDvbTuner(int, int&, int&, int&, fe_delivery_system&)’
    3. dvbdevice.c:326: note: candidates are: cDvbTuner::cDvbTuner(int, int, int, int, fe_delivery_system, cDvbDevice*)
    4. dvbdevice.c:256: note: cDvbTuner::cDvbTuner(const cDvbTuner&)
    5. make: *** [dvbdevice.o] Error 1


    Wenn ich (gezwungenermaßen) den Dynamite mit 'reinnehme, brechen xine und xineliboutput mit der gleichen Fehlermeldung ab:


    Code
    1. xineDevice.c: In constructor ‘PluginXine::cXineDevice::cXineDevice(cPlugin*, PluginXine::cXineSettings&, PluginXine::cXineRemote*)’:
    2. xineDevice.c:4371: error: call of overloaded ‘cDevice()’ is ambiguous
    3. /usr/include/vdr/device.h:799: note: candidates are: cDevice::cDevice(cDevice*)
    4. /usr/include/vdr/device.h:207: note: cDevice::cDevice()
    5. make: *** [xineDevice.o] Error 1


    Copperhead, ich beneide Dich nicht... ...um so herzlicheren Dank für Deine Arbeit!


    Gruß, Ingo