Posts by Asta

    Das schneiden von Aufnahmen war nur ein Beispiel. Das Bild setzt generell beim Festplattenzugriff aus, z.B. beim kopieren von Daten oder wenn eine laufende Aufnahme auf die Platte geschrieben wird. Das kann aber auch durchaus ein Problem des Kernels im Zusammenhang mit meiner DVB Sky USB Satkarte sein. Mit Debian Jessie ala Kernel 4.9.35 gibt es keine Probleme.

    Am rpihddevice liegt es nicht. Softhddevice macht genau dieselben Probleme.

    Leider macht auch der Linux Kernel ab 4.9.35 ein paar Probleme. Beim Zugriff auf eine Festplatte oder auf die interne SD (z. B. beim schneiden oder Aufnehmen) gibt es Bildstörungen. Kannst du ja vielleicht auch mal testen und berichten ob es bei dir auch so ist. Der Kernel hat aber nichts mit dem umschaltroblem zu tun. Auch auf einem 4.9.35 und VDR > 2.3.8 gibt es die Hänger.

    Buster macht leider bei mir Probleme. Es gibt immer wieder Bildstörungen im Live Bild und auch in den Aufnahmen wenn auf die Festplatte zugegeriffen wird. Das scheint ein Kernel Problem zu sein. Mit Kernel 4.9.35 ist alles ok. Mit 4.14 oder 4.19 habe ich diese Probleme. Deshalb bin ich leider an Jessie gefesselt. Das mit der alten Version bei den dev Paketen habe ich auch gesehen. Werde mal schauen ob ich das hinbekomme. Die Repositories der Debian Pakete kann ich nicht nehmen, da der PI ein ARM ist.

    Danke dir für deine Mühe. Ich probier mal ein bisschen rum.

    Leider installiert er markad standalone immer noch nicht. Siehe log. Kann das evtl. an ffmpeg liegen? Das installiere ich so:

    Code
    1. git clone https://github.com/FFmpeg/FFmpeg
    2. cd ffmpeg
    3. ./configure --prefix=/usr --libdir=/usr/lib --shlibdir=/usr/lib --docdir=/usr/share/doc/ffmpeg-9999/html --mandir=/usr/share/man --enable-shared --enable-mmal
    4. make -j4
    5. make install

    Files

    • putty.log.txt

      (17.24 kB, downloaded 34 times, last: )

    Ich versuche das Plugin auf einem RPI mit Raspbian Jessie zun installieren. Leider ohne erfolg. Ich habe mal die ausgabe von putty angehängt. Vielleicht kann mir da jemand einen Tip?

    Danke euch.

    Files

    • putty.log.txt

      (25.87 kB, downloaded 38 times, last: )

    OK, es geht. Ich habe nochmal komplett von vorne angefangen. Gefühlt hatte ich das schon ein paar mal. Ich glaube das ich Tatsache ein Problem mit dem Makefile patch hatte. Getestet habe ich Markad jetzt noch nicht, aber er hat kompiliert und "/usr/bin/markad" erstellt. Ich hänge trotzdem mal das log an. Vielleicht hilft es dem nächsten der ein Problem hat. Vielen Dank für deine Geduld.


    Edit:


    Ein erster Test mit ein paar Aufnahmen hat perfekte Marken gesetzt.

    :thumbup:

    Files

    • putty.log.txt

      (72.94 kB, downloaded 42 times, last: )

    libavcodec-dev:

    Installiert: 7:4.1.4-1+rpt1~deb10u1

    Installationskandidat: 7:4.1.4-1+rpt1~deb10u1


    libavformat-dev:

    Installiert: 7:4.1.4-1+rpt1~deb10u1

    Installationskandidat: 7:4.1.4-1+rpt1~deb10u1


    libavutil-dev:

    Installiert: 7:4.1.4-1+rpt1~deb10u1

    Installationskandidat: 7:4.1.4-1+rpt1~deb10u1


    Die Ausgabe von "make all" bekomme ich nicht vollständig kopiert. Es sind zu viele Zeilen für mein putty.

    Mit dem rpihddevice mit eingeschalteter Option "OSD mit GPU-Unterstützung" und VDR Version größer als 2.3.8 bekomme ich ztw. nach dem Umschalten kein Bild. Im Log erscheint nur das hier:

    Code
    1. Jan 12 14:25:13 raspberrypi vdr: [7770] switching to channel 10 S19.2E-1-1089-12060 (VOX)
    2. Jan 12 14:25:16 raspberrypi vdr: [7804] device 1 TS buffer thread ended (pid=7770, tid=7804)
    3. Jan 12 14:25:16 raspberrypi vdr: [7803] buffer stats: 966320 (18%) used
    4. Jan 12 14:25:16 raspberrypi vdr: [7803] device 1 receiver thread ended (pid=7770, tid=7803)
    5. Jan 12 14:25:16 raspberrypi vdr: [7770] max. latency time 4 seconds

    Alle VDR Versionen bis einschließlich 2.3.8 funktionieren dagegen ohne Probleme. Bei VDR2.3.8 bekomme ich ab und zu diesen Eintrag:

    Trotzdem kommt ein Bild, zwar etwas verzögert aber Bild. Diesen Eintrag habe ich bei VDR größer als 2.3.8 nie gehabt. Evtl. hängt das damit zusammen??

    Bei meinem PI mit Raspbian Buster kompiliert er das Plugin aber er installiert das eigentliche markad nicht.

    Code
    1. Jan 12 16:33:08 raspberrypi vdr: [16873] initializing plugin: markad (0.1.6 (ea2e182)): Markiere Werbung
    2. Jan 12 16:33:08 raspberrypi vdr: [16873] markad: cannot find /usr/bin/markad, please install