Posts by guigra

    Hi Razorblade,


    ich hing genau an der selben Stelle fest und habe in meiner Unwissenheit einfach params mit *p ersetzt und er ging weiter.
    Doch nun mault er hier rum :


    guido@vdr:/usr/src/dvbloop$ sudo make KDIR=/usr/src/linux-source-* install
    make -C /usr/src/linux-source-* M=`pwd` modules
    make[1]: Betrete Verzeichnis '/usr/src/linux-source-3.11.0'
    make[1]: Für das Ziel »/usr/src/linux-source-3.11.0.tar.bz2« ist nichts zu tun.
    CC [M] /usr/src/dvbloop/dvblo_adap.o
    /usr/src/dvbloop/dvblo_adap.c: In function ‘dvblo_adap_create’:
    /usr/src/dvbloop/dvblo_adap.c:348:18: error: ‘struct <anonymous>’ has no member named ‘status’
    dvblo->fe.tuner.status = TUNER_STATUS_LOCKED;
    ^
    make[2]: *** [/usr/src/dvbloop/dvblo_adap.o] Fehler 1
    make[1]: *** [_module_/usr/src/dvbloop] Fehler 2
    make[1]: Verlasse Verzeichnis '/usr/src/linux-source-3.11.0'
    make: *** [build] Fehler 2
    guido@vdr:/usr/src/dvbloop$


    Das könnte ein Problem meiner vorherigen Änderung sein.Oder ?


    mfg guigra

    Hi woz,


    wenn du auf deinen RPi ohne Login den vompclient laufen lassen möchtest so trage folgendes in die rc.local ein : vompclient. Beim Neustart sollte er dich nicht mehr mit einem Login behelligen sondern geleich los legen.Der einzige Nachteil besteht darin das ich für Änderungen am System eine PC benötige um den vompclient zu deaktivieren.Eine weitere Möglichkeit währe ein script welches auch mit der rc.local gestartet wird aber z.B nach dem beenden des vompclients auf einen Tastendruck wartet und wenn der nicht erfolgt das System sich beendet.


    mfg guigra

    Hi g3joker,


    da wirds etwas aufwendiger.Da du dein Flash platt gemacht hast brauchst du erst einaml einen Bootloader der das booten von anderen Medien erlaubt.Dieser muß dann in den Flashspeicher.Debian als OS ist eine gute Wahl.Ich habe das auf meinem mini2440 und auch auf meinem Raspberry Pi ist es installiert.Wichtig ist was man später machen will und wie die die HW der goflex home unterstützt wird um sie effizient nutzen zu können.


    mfg guigra

    Hi g3joker,


    bei meiner Arbeit mit Mikrokontrollern hatte ich auch mal den Fall das das System trotz korrekter Einstellungen nur wirres Zeug ausgegeben wurde.Die Lösung bestand darin auf der Platine der Schaltung RxD und TxD zu vertauschen.Wenn man das nicht macht kann keine Kommunikation zwischen den Geräten statt finden.Ich denke das ist ein Versuch wert bevor du Geld in die Hand nimmst.


    mfg guigra

    Hi 3gjoker,


    wollte dich nicht verunsichern :O .Es schien für mich die bessere Variante zu sein da du ja mit dem Lötkolben arbeitest.Das mit dem TTL ist in diesem Fall irrelevant da du ja die 3.3Volt hernehmen mußt die vom Board zur Verfügung gestellt wird um die Schnittstelle nicht zu töten.Was noch eine Möglichkeit wäre nur den GND und TxD Pin vom Board zuverwenden um zusehen ob überhaupt was rauskommt.Denn wenn da nichts kommt würde ich das Teil das Teil entsorgen.Bekommst du jedoch Lebenszeichen (egal ob erstmal wirres Zeug ist) würde ich weiterforschen.
    Ich wußte garnicht das man über die serielle Schnitstelle flashen kann.Ich kenne es so das es über LAN per FTP geht.Als allerletzte Rettungsmöglichkeit kennte ich noch die JTAG Methode so das denn das auf den Board möglich ist.



    mfg guigra

    Hi g3joker,


    hatte mit einem anderem Gerät das gleiche Problem wie du.Das dumme war das das gestörte System 3.3V Pegel auf seiner seriellen Schnittstelle hat und ich also nicht ich mein USB <--> Seriell mit 5V direkt anschließen konnte.Dshalb habe noch schnell eine Lochrasterplatine mit einem Max232(Levelshifter) und 4Elko's (1µF) bestückt der mit den 3.3V des seriellen Ports gespeist wird.So war ich auf der sicheren Seite und konnte nun sicher meine neue FW aufspielen.Da gibt es gute Anleitungen im Netz und eine davon hier : http://www.mikrocontroller.net/part/MAX232.


    Ganz wichtig, die Spannungsversorgung Vcc des Max232 muß immer an die Spannungsversorgung der Schnittstelle des gestörten Boards angeschlossen werden ansonsten hast du einen neuen Briefbeschwerer.


    mfg guigra

    Hi cinfo,


    deine Fehlermeldung aus der runvdr sind Leerzeichen an Stellen wo keine sein sollen.Das haben gda und Keine_Ahnung mir erklärt und nach erneuten abtippen in nano war auch dieser Fehler Geschichte.
    Was dein Problem : Datei oder Verzeichnis nicht gefunden (2): Cannot open /proc/net/if_inet6 betrifft so ist das ipv6 modul nicht geladen.Mach mal ne Konsole auf und gehe ins Verzeichniss /lib/modules/3.6.11+/kernel/net/ipv6 und mach mal insmod ipv6.ko Wenn das geklappt hat findest du das gesuchte Verzeichnis an der angegebenen Stelle.Das gleiche mach mal mit dem VLAN Modul 8021.ko.
    Trage diese Module in die /etc/modules ein und starte neu.Jetzt kannst du dein VLAN konfigurieren in dem du die /etc/Network/interfaces änderst.


    Schau mal hier : http://ubuntuforums.org/showthread.php?t=703387


    Wenn ein Update gemacht wird (überareiteter Kernel + Module + Firmware) kontrolliere ich ob die Module noch da sind und trage sie neu ein wenn sie nicht in /etc/modules stehen.Die /etc/Network/interfaces dürfte sich nicht ändern.Tut sie das doch steht sie eh auf DHCP.Ich sichere aber vor jedem Update die Interfaces und modules Datei den das spart das getippe.


    mfg guigra

    Hi gda,


    nun habe ich die runvdr nochmal abgetippt und erhalte nun den Fehler nicht mehr.Dafür hat sich eine neue Baustelle gezeigt die folgendes ausgibt wenn die runvdr mit Strg+C beendet wird:



    SetPid 10 Pid:5105 (Das Erste HD), Type:9, On:0, used:0 sid:10301 ca_enable:0 channel_ca:0
    Device 10 gets destructed
    Device 11 gets destructed
    Device 12 gets destructed
    Device 13 gets destructed
    Device 14 gets destructed
    Device 15 gets destructed
    Device 16 gets destructed
    Device 17 gets destructed
    Delete my Dev list
    /usr/local/bin/runvdr: Zeile 64: 2902 Speicherzugriffsfehler /usr/local/bin/vdr -w 60 -c /etc/vdr -E /var/vdr -u pi -L /usr/local/src/vdr/PLUGINS/lib -P'mcli --ifname eth0 --sock-path /tmp/mcli.sock --mld-reporter-disable --dvb-s2 1' -P'xineliboutput --local=none --remote=:37890 -f' -s /usr/local/bin/vdrpoweroff.sh
    So 16. Jun 14:14:20 CEST 2013 reloading DVB driver
    pi@raspberrypi /usr/local/bin $



    mfg guigra

    Hi Keine_Ahnung,


    danke für deine Antwort.Ich habe mir die runvdr nicht kopiert und auch nicht unter Windows bearbeitet.Diese Arbeiten erledige ich auf dem RPi mit dem Editor Leafpad.Es ist ne Menge Tipparbeit aber das macht mir nichts aus.Ich bin nicht der Copy & Paste Type denn wenn ichs tippe dann kann ich es mir besser für später merken.Ich werde mal die runvdr mit nano schreiben.


    @ gda


    Gibt es eine Möglichkeit unerlaubte Leerzeichen anzuzeigen?Kann ich nano für die Tipparbeit verwenden oder geht der nicht?


    mfg guigra

    Hi gda,


    hier mal die Ausgabe meiner Konsole :



    pi@raspberrypi /usr/local/bin $ runvdr
    /usr/local/bin/runvdr: Zeile 59: $'if\302\240!DriverLoaded': Kommando nicht gefunden.
    vdr: no primary device found - using first device!
    Delete my Dev list
    /usr/local/bin/runvdr: Zeile 63: -Pxineliboutput --local=none --remote=:37890 -f: Kommando nicht gefunden.
    So 16. Jun 09:38:07 CEST 2013 reloading DVB driver
    ^C
    pi@raspberrypi /usr/local/bin $



    Ich benutze die Standart runvdr nur eben mit angepassten user (pi) und den genannten plugins.Mir geht es erstmal nicht ums TV bild sondern nur ums laden des Plugins.


    mfg guigra

    Files

    • runvdr.txt

      (1.81 kB, downloaded 129 times, last: )

    Hi cinfo,


    wie man sieht kommt man mit etwas suche zum Ziel.


    Ich habe mir mal den neuen VDR 2.0.2 geladen und installiert alle Plugins gebastelt, wie für den VDR 1.7.31, lief alles gut.Also habe ich die runvdr wie immer mit mcli plugin und xineliboutput plugin bestückt und gestartet.Leider lief es nicht so wie gedacht.Beim starten kam die Meldung -P'xineliboutput --locale=fbfe --video=fb --audio=alsa --remote=:37890 -f ' : Kommando nicht gefunden.
    Im syslog stand kein Fehler sondern er hat das xineliboutput - Plugin einfach ignoriert. 8o Xine ist jetzt nicht mehr 2.2 sondern 2.3.
    Da muss ich mal genauer forschen weshalb ihm das plugin wurst ist.


    mfg guigra

    Hi cinfo,


    klar kann ich das.Zuerst möchte ich aber darauf hinweisen das ich diese Informationen bei Tante Google gefunden habe.Dazu habe ich nach raspbian - von usb stick booten suchen lassen.
    Ich schreibe mal in Stichpunkten auf was ich gemacht habe.


    - Raspbianimage vom 25.05.2013 geladen;
    - SD Karte mit gparted platt gemacht und mit und mit FAT32 formatiert;
    - unter Win 8 dann mit Win32DiskImager das Image auf die SD Karte geschrieben;
    - danach mit der Karte den RPi gebootet und konfiguriert und reboot;
    - dann USB Stick mit ext4 formatiert und an den Hub angeschlossen;
    - danach folgende Befehle nacheinander ausgeführt : sudo mount /dev/sda1 /mnt/. sudo cp -axv /. /mnt/. -> sudo cp -axv /dev/. /mnt/dev/.
    - der zweite und dritte Befehl brauchen etwas Zeit aber damit ist der Stick nun mit dem rootfs bestückt
    - ein sudo shutdown -h now ausführen und SD Karte entnehmen und am PC die cmdline.txt folgendes ändern aus root=/dev/mmcblk0p2 wird root=/dev/sda1
    - Karte aus dem PC entfernen und den RPi damit booten


    Jetzt wird immer das rootfs auf dem Stick benutzt.Es gibt bestimmt schon Leute die sich überlegen wie man den RPi ganz von Festplatte booten kann.


    mfg guigra

    Hi mule,


    was die Praxistauglichkeit betrifft wäre dann ein reiner VDR mit mcli-plugin die bessere Wahl. Was für Daten hat denn dein RPi?Ich betreibe meinen RPi mit 800Mhz und GPU und SDRAM mit normalen Takt.Mein RPi hat 512 MB und der Speicher ist mit 256MB fürs BS und 256MB für die GPU.Ich habe bei mir auf der SD-Karte nur die Bootpartition in Benutzung und das rootfs ist auf einen USB Stick augelagert.Damit läuft das System flüssiger weil der USB Stick beim Schreibzugriff schneller ist als eine SD Karte und auch die Lebensdauer der SD Karte verlänget sich dadurch.Bei Multimedia ist es wichtig das Daten so schnell wie möglich gelesen und zurückgeschrieben werde können und das ist leider
    bei einer SD Karte, auch nicht bei den modernen, nicht gegeben.


    mfg guigra

    Hi mule,


    du benötigst ein spezielles Image welches Raspbmc_mcli-vdr-012-beta.rar heißt.Das ist ein zusammengestelltes Image und beinhaltet schon alle Teile die du aufgezählt hast.Wenn du das genannte Image startest wird automatisch xbmc gestartet.Ich nehme mal an du hast das normale Raspbmc genommen.Die Firmware ist für Leute die keinen Netceiver haben sondern z.B. USB TV devices.


    Ich hoffe ich konnte dich einwenig erleuchten.


    mfg guigra

    Hi decembersoul,


    diese Fehlermeldung hatte ich noch nicht aber diese max latency time zeigt er bei mir im syslog mit 1 sek an.Wenn ich dann die runvdr stope wird alles beendet aber zum Schluss kommt ein Speicherzugriffsfehler.


    mgf guigra