Posts by OleS

    Bzgl. suspend-to-ram: war es nicht immer notwendig, diverse Kernelmodule (nvidia, ddbridge, usw.) vor dem STR manuell zu ent- und beim start wieder zu laden?


    Da muss die Datei /etc/yavdr/force-reload-modules.list existieren, bzw. angelegt werden. Anschließend die betroffenen Module mit Namen rein und testen.


    Cheers,

    Ole

    Die Option heißt Power On by PCI-E/PCI, da die Onboard-NIC eigentlich eine PCI-E/PCI Karte ist.


    Solltest du ein Mainboard mit aktueller Intel-NIC haben, würde ich das hier im Hinterkopf behalten, falls die Box Sekunden nach

    dem Shutdown automatisch wieder aufwacht.


    Eventuell ist aber auch (zusätzlich) WOL nicht sauber konfiguriert. Dazu muss auf der NIC das MagicPacket eingetragen werden.


    Code
    1. root@yavdr:~# ethtool eth0 | grep Wake-on
    2. Supports Wake-on: pumbg
    3. Wake-on: g

    So sollte das aussehen, wobei du natürlich eth0 durch den Devicenames deines NIC ersetzen musst.


    Setzen kannst du das via ethtool -s eth0 wol g und einen reboot überlebt es, wenn du eine udev-rule dafür bastelst:

    Code
    1. /etc/udev/rules.d/99-wol.rules:
    2. ACTION=="add", SUBSYSTEM=="net", NAME=="eth*", RUN+="/usr/bin/ethtool -s $name wol g"


    Cheers,

    Ole

    Ja, das kommt definitiv vom neuen Installer, den ich bei meiner Installation verwendet habe. Ich benötige die Features des alternativen Installers eigentlich nicht, daher wollte ich mal den Neuen testen. Das fehlende LVM ist mir leider erst hinterher aufgefallen, bei meiner relativ grßen SSD für das System ist aber auch das zu ertragen.


    Cheers,

    Ole

    So, der Splashscreen ist jetzt auch bei mir funktional.


    Hintergrund ist, dass die Serverinstallation von Ubuntu 18.04 eine Datei /etc/default/grub.d/50-curtin-settings.cfg anlegt, welche den Inhalt von /etc/default/grub überschreibt (vgl. hier). Dort werden per default folgende Parameter gesetzt:


    Code
    1. GRUB_CMDLINE_LINUX_DEFAULT="maybe-ubiquity"
    2. GRUB_TERMINAL=console


    Das setzt natürlich grafisches Grub-Menü und Plymouth außer Gefecht. Beide Zeilen auskommentiert, die passende Auflösung für meinen Zweitbildschirm in /etc/default/grub eingetragen

    Code
    1. GRUB_GFXMODE=1920x1080x32
    2. GRUB_GFXPAYLOAD_LINUX=keep

    und ein beherztes sudo update-grub machen den Bootsplash dann funktional.


    Leider bootet mein System so schnell, dass ich den Splashscreen nur ganze zwei Sekunden zu Gesicht bekomme... :-D

    Aber immerhin, keine Fehlermeldung mehr bzgl. nicht aktiviertem grafischen Modus im Grub.


    Cheers,

    Ole

    Ja, das wurde beim Update auf die 18er automatisch entfernt.


    Code
    1. root@yavdr:~# apt-cache policy kodi-bin
    2. kodi-bin:
    3. Installiert: (keine)
    4. Installationskandidat: 2:17.6+dfsg1-1ubuntu1
    5. Versionstabelle:
    6. 2:17.6+dfsg1-1ubuntu1 500
    7. 500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

    Momentan sind diese Versionen (kodi & kodi-x11) installiert



    Aber das kodi.log sagt 21:05:52.455 T:140225685013824  NOTICE: Starting Kodi (18.0-ALPHA2 Git:20121104-b9a7189). Platform: Linux x86 64-bit

    und das hier wären die Binaries.

    Code
    1. root@yavdr:~# ll /usr/bin/kodi*
    2. -rwxr-xr-x 1 root root 6709 Nov 4 2012 /usr/bin/kodi*
    3. -rwxr-xr-x 1 root root 2592 Nov 4 2012 /usr/bin/kodi-send*
    4. -rwxr-xr-x 1 root root 1825 Nov 4 2012 /usr/bin/kodi-standalone*


    Cheers,

    Ole

    Das mag sein, aber ich habe hier ein BIOS-Boot, kein UEFI.


    Bin auch gerade noch auf ein sehr eigenartiges Problem gestoßen. Ich habe Kodi durch die aktuelle nightly der Verion 18 ersetzt. Laut apt ist es auch die aktuelle Version aus dem GIT (20180529), starte ich aber Kodi finde ich in den Systeminformationen die Version 201204xx...


    Die binaries sind auch tatsächlich vom April 2012.


    Kann das jemand bestätigen?


    Cheers,

    Ole

    Vielen Dank, genau das war es. Unter Settings > System > Display > Whitelist habe ich jetzt mal testweise alles aktiviert (war bisher alles aus) und schon schaltet der TV brav auf 24Hz um. Die Familie freut sich!


    Cheers,

    Ole

    Und noch ein Thema ;-)


    1920x1080@24Hz ist unter Kodi nicht mehr möglich


    Sowohl AVR und TV unterstützen dieses Format, in der CustomEDID des TV ist auch eine entsprechende Zeile vorhanden. Kodi ist in Version 18 aus dem Nightly Repo installiert und unter Settings > Player > Video ist Adjust display refresh rate auf always gestellt.

    Bisher habe ich vermutet, dass es an der jetzigen xorg.conf liegt und diese für den TV folgendermaßen angepasst:

    Das hat allerdings auch nichts gebracht... :-/


    Für Tips bin ich wie immer sehr dankbar.


    Cheers,

    Ole


    Anbei noch die CustomEDID vom TV:

    beinhart danke für den Tipp, allerdings hatte ich das Problem für mich bereits in Post #15 erledigt.

    Ich bin gerade am nachvollziehen, warum bei mir der Zombie aus lircd/uname entsteht. Eventuell hängt

    das ja auch mit meinem anderen Problem bzgl. das ständigen zappens, wenn imon/rc_core aktiv ist

    zusammen... Mal sehen.


    Cheers,

    Ole

    Problem 1 error: no video mode in GRUB habe ich leider immer noch. In der Zwischenzeit habe ich mittlerweile nomodeset als Kerneloption, nvidiafb und vesafb in der initrd sowie weitere Konfigurationsoptionen in /etc/default/grub versucht. Er mag mich nicht... :-/


    Problem 2 (ein Zombieprozess, namentlich [uname]) besteht auch immer noch. Hier habe ich so überhaupt keinen Schimmer, was es sein könnte.


    Neu hinzugekommen Erledigt sind Mikroruckler im Livebild sowie in den Aufnahmen. Auffälligkeiten im LOG gibt es nicht, der TV läuft auf 50Hz, den Zweitmonitor habe ich manuell auf 60Hz festgesetzt. Momentan habe ich softhddevice-openglosd im Einsatz, da alle anderen Varianten Probleme bei der Darstellung des OSD gezeigt haben.


    Die Lösung war bei softhddevice Skalierung auf anamorph und Deinterlace auf TemporalSpatial sowie{ForceCompositionPipeline=Off, ForceFullCompositionPipeline=Off} in /etc/X11/xorg.conf


    Erledigt hat sich das permanente zappen durch die Kanäle. Im Gehäuse ist zusätzlich zum AtricUSB noch ein iMON Display samt IR-Empfänger verbaut und entweder beißt sich das in der jetzigen Konfiguration oder aber der IR-Empfänger ist defekt, jedenfalls kommt von ihm ständig ein CHAN+ am VDR an. Momentan habe ich das Teil mittels

    Code
    1. /etc/modprobe.d/imon.conf:
    2. blacklist rc_imon_pad
    3. blacklist imon
    4. blacklist rc_core

    geblacklisted und das Problem ist beseitigt. Schön wäre zwar, wenn ich das Display noch nutzen könnte, hat aber keine Priorität.



    Cheers,

    Ole

    Dann habe ich das auf meinem Altsystem vorher wohl fehltinterpretiert, weil die Aufwachzeit eh schon vorher gesetzt war.

    acpiwakeup-ng hört sich gut an, dann warte ich mal gespannt. :)


    Ich hoffe, dass ich über Pfingsten mal wieder ein bisschen Zeit für yaVDR habe.

    Nur keinen Stress, bisher läuft der yavdr-ansible richtig gut und ich bin mal wieder auf einem aktuellen Stand. :tup


    Cheers,

    Ole

    chmod a-x /etc/grub.d/05_debian_theme

    Werde ich testen, vielen Dank schon mal für den Hinweis.


    Probier mal, ob diese Änderung dagegen hilft

    Ist eingebaut, jetzt muss ich nur wieder in der Nähe des Gerätes sein.


    Wie kommst du auf cloud-init.target?

    Weil die Vergabe der IP in /etc/netplan/50-cloud-init.yaml konfiguriert ist, ich davon ausgegangen bin, dass dies dann das richtige target ist und weil network-online.target nicht funktioniert - da bekomme ich beim Booten wieder network unreachable. :)


    Cheers,

    Ole

    Moin zusammen,


    nachdem ich nun erste Gehversuche mit dem neuen yavdr ansible gemacht habe, versuche ich nun die restlichen Ungereimtheiten aus dem System zu bekommen.

    Diverse Dinge aus diesem Post sind bereits erledigt, aber um den dortigen Thread nicht zu unübersichtlich zu machen, fasse ich das Ganze hier mal zusammen.


    Eventuell hat ja schon jemand die eine oder andere Lösung zur Hand...


    1. beim Booten zeigt Grub error: no video mode selected

    Weder ein Setzen von GRUB_GFXMODE und GRUB_GFXPAYLOAD in /etc/default/grub noch ein Auskommentieren/Verändern von GRUB_HIDDEN_TIMEOUT und GRUB_HIDDEN_TIMEOUT_QUIET schafft Abhilfe


    2. nach dem Login bekomme ich die Meldung => There is 1 zombie process.

    Code
    1. ✔ ~/install/yavdr-ansible [bionic|…4]
    2. 09:14 # ps -ef | grep -i defun
    3. root 1159 1154 0 07:22 ? 00:00:00 [uname] <defunct>
    4. root 6840 4810 0 09:14 pts/1 00:00:00 grep --color=auto -i defun
    5. ✔ ~/install/yavdr-ansible [bionic|…4]
    6. 09:14 # ps -ef | grep 1154
    7. root 1154 1 0 07:22 ? 00:00:00 /usr/sbin/lircd --nodaemon
    8. root 1159 1154 0 07:22 ? 00:00:00 [uname] <defunct>
    9. root 6881 4810 0 09:14 pts/1 00:00:00 grep --color=auto 1154

    Die Fernbedienung funktioniert allerdings einwandfrei.


    3. der angeschlossene Zweitmonitor für osd2web geht nach einiger Zeit in den Stromsparmodus (blank screen)




    Folgende Punkte sind bereits erledigt, aber hier nochmal der Vollständigkeit halber erwähnt:


    4. Aufnahmeverzeichnis per NFS lässt sich beim Booten nicht einbinden


    Lösung: anscheinend funktionieren die systemd-eigenen Parameter xsystemd.automount, x-systemd.after=cloud-init.target zum Einhängen eines NFS-Mount nicht sauber, denn entweder bekomme ich ein network not available oder das System bleibt mit einem unendlichen Timeout beim Mount dieser Freigabe hängen. Schlussendlich habe ich den Mount aus der fstab in ein separates systemd-Script ausgelagert und per systemctl enable srv-vdr-video.mount aktiviert.



    5. Bei der Installation werden TV (an HDMI) und Infodisplay (an DVI) zwar erkannt, allerdings wird das Livebild auf dem Zweitmonitor angezeigt


    Lösung: anscheinend kommt die automatische Erkennung mit den Geräten durcheinander, da beide jeweils 1920x1080 unterstützen

    Lege ich in den host_vars die Reihenfolge der Geräte fest, passiert das nicht mehr.

    Code
    1. host_vars/localhost.yml:
    2. preferred_outputs: ["HDMI", "DVI", "DP", "VGA", "TV"]


    6. ansible bleibt bei der ersten Installation am Punkt lirc/eventlircd mit einem Fehler hängen


    Lösung: service eventlircd stop und install-yavdr.sh neu starten


    Für Tips bezüglich der offenen Punkte bin ich sehr dankbar.


    Cheers,

    Ole

    das OSD sieht sehr eigenartig aus

    Da hat bei mir ein apt-get install vdr-plugin-softhddevice-openglosd geholfen, welches das bisher installierte vdr-plugin-softhddevice-vpp ersetzt hat.


    Cheers,

    Ole

    Das Aufnahmeverzeichnis per NFS funktioniert jetzt auch. Ich habe den Export auf der Syno gelöscht und neu angelegt, schon passt es.

    Warum auch immer, denn an den Berechtigungen und Export- bzw. Mountoptionen hat sich nichts geändert.


    Cheers,

    Ole

    Code
    1. host_vars/localhost.yml:
    2. preferred_outputs: ["HDMI", "DVI", "DP", "VGA", "TV"]

    Mit genau diesem (also eigentlich dem default) Eintrag passt bei mir Bildschirmzuteilung. Da läuft also etwas bei der Erkennung falsch.


    Die Meldung vom eventlircd habe ich hier angehängt.


    Cheers,

    Ole