Posts by OleS

    Anbei eine Analyse mit TS-Doctor



    Cheers,

    Ole

    Ok, an pulseaudio liegt es auch nicht, mit reinem alsa bekomme ich auch die Fehler:

    Was mich etwas wundert ist folgende Zeile:

    Code
    1. Sep 10 13:44:14 htpc vdr: epg2vdr: Playing recording '�v0)�U'


    Der NFS-Export der Aufnahmen an mein Laptop gehängt und die Aufnahme per VLC abgespielt liefert auch keine Probleme.


    Cheers,

    Ole

    Lokal habe ich es noch nicht versucht, aber im Kodi auf der selben Box kann ich die Aufnahme fehlerfrei abspielen.

    Ich befürchte, dass da irgendetwas im pulseaudio schief läuft. Wie kann ich eigentlich wieder zurück auf alsa ohne

    pulseaudio, denn eigentlich benötige ich das nicht. Browser nutze ich am VDR nicht und ich habe auch keine

    unterschiedlichen Wege für Audio zu schalten.


    Cheers,

    Ole

    Ich habe das Skript jetzt mal so angepasst, dass es die moderne Variante nutzt, um die Aufweckzeit zu setzen

    Getestet und für gut befunden. Der VDR wacht jetzt wieder zuverlässig zu den gesetzten Uhrzeiten auf. Vielen Dank seahawk1986 !


    Cheers,

    Ole

    Vielen Dank, ist installiert und wird getestet.


    Und noch ein Problem:


    bei der Wiedergabe von Aufnahmen, die auf meinem NAS liegen und per NFS eingebunden sind, bekomme ich

    immer wieder Tonaussetzer. Hier mal das LOG:



    Irgendeine Idee, was das sein koennte?



    Cheers,

    Ole

    Hi *,


    muss ich für das vdr-addon-acpiwakeup noch irgend etwas zusätzlich zur Konfigurationsdatei /etc/vdr/vdr-addon-acpiwakeup.conf anpassen?

    Mir ist aufgefallen, dass es noch einen vdr-addon-acpiwakeup.service gibt, der bei mir nicht läuft...


    Code
    1. root@htpc:/etc/vdr# systemctl status vdr-addon-acpiwakeup.service
    2. ● vdr-addon-acpiwakeup.service
    3. Loaded: loaded (/etc/init.d/vdr-addon-acpiwakeup; generated)
    4. Active: inactive (dead)
    5. Docs: man:systemd-sysv-generator(8)


    Ich denke mal, hier liegt der Hund begraben?


    Cheers,

    Ole

    Das playbook ist gelaufen und openbox startet für das 2. Display mit rc2.xml

    Code
    1. vdr 1284 1 0 14:49 ? 00:00:00 /usr/bin/openbox --startup /usr/lib/x86_64-linux-gnu/openbox-autostart OPENBOX
    2. vdr 1501 1302 0 14:49 ? 00:00:00 /usr/bin/openbox --config-file /var/lib/vdr/.config/openbox/rc2.xml


    Allerdings funktioniert die Tastatur wieder nur, nachdem das Primärdisplay den Fokus bekommt.


    Cheers,

    Ole

    So, habe momentan eine Logitech Tastatur am VDR und lediglich XKeySym.* Einträge in der remote.conf (die yaVDR defaults),

    lircd.service ist deaktiviert - die Steuerung per Tastatur sollte ja trotzdem möglich sein, wenn ich das richtig verstehe.


    Allerdings: Tastendrücke kommen nicht am VDR an.


    evtest listet mir diese Devices:


    Und ein evtest auf Device 2 (Logitech K830) produziert auch Output:


    Cheers,

    Ole

    Ich grabe diese Thread nochmal aus, da sich mir gerade folgende Frage stellt:


    Mein Atric USB hat sich (wohl aufgrund der anhaltenden Hitzewelle ;-) ) verabschiedet. Jetzt habe ich hier noch einen FLIRC USB 2nd Gen.

    rumliegen, den ich als Ersatz ranziehen würde. Wie muss ich hier vorgehen, um die Anpassungen entsprechend durchzudrücken?


    Der momentane Stand ist, Harmony 350 mit KLS 1.1 Profil, Atric USB im lirc als /dev/irman.


    Zugegebenermaßen bin ich, was das Thema FB/lirc/uinput usw. angeht, nicht wirklich bewandert. :saint:


    Für zielführende Tips bin ich sehr dankbar.


    Cheers,

    Ole

    Siehe hier und hier.


    Die generelle Vorgehensweise wäre grob:

    1. Ubuntu 18.04 Server via alternative installer hochziehen

    2. git client installieren

    3. repo clonen

    4. local copy auf branch bionic stellen

    5. installer script ausführen


    Cheers,

    Ole

    Wegen deiner Temp/CPU Problematik würde ich mal die Berechtigung der Skripte

    In /var/lib/vdr/plugins/skindesigner/scripts prüfen, der Link temperatures sollte auf ein ausführbares Skript zeigen (Mode 755).


    Wieviele Timer listet dir denn ein svdrpsend lstt auf der Shell?

    Cheers,

    Ole

    Ergebnis - Plugin wird nicht geladen, die Dateien:


    /etc/vdr/plugins/autostart/autostart.conf und /etc/vdr/plugins/plugin.autostart.conf wurden erstellt, die entsprechenden Dateien in "/etc/vdr/conf.d" und "/usr/lib/vdr/plugins" fehlen.

    Schau mal, ob die Datei /etc/vdr/conf.avail/autostart.conf vorhanden ist. Wenn nicht, diese mit folgendem Inhalt anlegen:

    Code
    1. [autostart]
    2. -c <Pfad zur Konfigurationsdatei>


    In beiden Fällen noch ein vdrctl enable autostart und den vdr neu starten. Das sollte helfen.


    Cheers,

    Ole

    Auch ich habe zu Danken, nach mehreren Versuchen habe ich jetzt die passende mount unit für mich gefunden.


    Damit hat es jetzt mehrere reboots perfekt funktioniert. NFS mount nach aktiviertem Netzwerk, vdr nach dem mount,

    alle Aufnahmen sind zur richtigen Zeit vorhanden. :)


    Cheers,

    Ole

    Du meinst so?


    Damit startet der mount, obwohl noch kein Netzwerk online ist (bei Ubuntu 18.04 anscheinend nach cloud-final.service).


    Cheers,

    Ole

    Zu diesem Thema hätte ich auch noch eine Frage:

    Mein vdr.service startet schneller als mein nfs-mount via srv-vdr-video.mount obwohl ich eine entsprechende Datei /etc/systemd/system/vdr.service.d/override.conf angelegt habe, in der ich folgendes mache:

    Code
    1. [Service]
    2. After=srv-vdr-video.mount


    Der Inhalt der mount unit /etc/systemd/system/srv-vdr-video.mount:


    Die dependencies für vdr.service sehen eigentlich gut aus:



    aber der vdr startet ohne recordings, da der nfs mount zur Startzeit noch nicht komplett da ist. Hat jemand einen Tip für mich?


    Cheers,

    Ole