Posts by VDRFirtie

    Habe noch einen Beitrag gefunden, der auf einen Artikel [1] verweist, in dem folgendes geschrieben steht:


    Quote

    Wer den PC rechtzeitig per ACPI zur nächsten Aufnahme aufwecken möchte (Paket vdr-addon-acpiwakeup), der muss in jedem Fall Kernel 2.6.28 installieren. Zudem finden Sie auch für den Kernel 2.6.28 ein entsprechendes Debian-Paket mit den Liplianin-Treibern auf der Heft-DVD, falls Ihnen die Standard-Treiber des Kernels nicht ausreichen.


    Da ich aber

    Code
    1. 2.6.26-2-686

    benutze, könnte das vielleicht ein Problem sein, oder bezieht sich das nur auf den ctVDR ?


    [1] http://www.heise.de/ct/artikel…x-auf-Empfang-292096.html

    Ok, letzter Versuch:


    Code
    1. sudo sh -c "echo 0 > /sys/class/rtc/rtc0/wakealarm"
    2. sudo sh -c "echo `date '+%s' -d '+ 5 minutes'` > /sys/class/rtc/rtc0/wakealarm"
    3. cat /sys/class/rtc/rtc0/wakealarm


    check mit:


    Code
    1. cat /proc/driver/rtc


    Code
    1. shutdown -h now


    Code
    1. UTC=no

    und im BIOS auf lokal gestellt.

    Code
    1. hpet=disable


    LED am Tower signalisiert einen suspend oder standby Modus (das weiß ich nicht so genau).


    Ergebnis: Rechner wacht nicht auf !


    OK, Entweder ich mache etwas grundliegend falsch, oder das Board unterstützt ACPI nicht, oder das Board ist zu alt !


    Könnt Ihr mir ein Board empfehlen welches ACPI Out of the Box unterstützt, zu meinen IDE-HDD`s passt und für DVB-T ausreicht ?
    Sollte in einen ATX Tower mit ATX Netzteil passen, zumindest vorüberghend ... und nicht so teuer sollte es sein. Nach Möglichkeit auch gebraucht.

    Hallo,


    ich habe nun dem Kernel folgendes Parameter übergeben:

    Code
    1. hpet=disable


    Code
    1. kernel /vmlinuz-2.6.26-2-686 root=/dev/hda2 ro hpet=disable


    Danach nochmals folgendes abgesetzt:


    Code
    1. echo 0 > /sys/class/rtc/rtc0/wakealarm
    2. date +%s -d "Sat Dec 04 11:20:00 MET 2010" > /sys/class/rtc/rtc0/wakealarm
    3. poweroff


    Aber auch hier konnte ich nach dem Absetzen des wakealarms keine

    Code
    1. /proc/acpi/alarm

    Datei finden, geschweige denn das der Rechner sich eingeschaltet hätte.


    Sollte unter Debian doch die gleiche Datei sein, oder ?


    Code
    1. cat /proc/driver/rtc

    gibt eine Aufwachzeit 5 min. vor der abgesetzten Zeit an.
    Das wäre für mich auch erst einmal richtig.


    Was mir aufgefallen ist nach dem übergeben des Kernel Parameters: Die Status LED leuchtet nicht mehr wie zuvor. Da scheine ich wirklich etwas deaktiviert zu haben.


    Was kann ich noch versuchen ?


    Keiner eine Idee ?


    Wenn alles Stricke reißen, dann müsste ich mir ein anders Board zulegen, welches ACPI unterstützt.

    Sollten alle Stricke reißen, schaue ich mich parallel nach einem geeignetem Board um.


    Eine Möglichkeit wäre z.B. ein VIA EPIA M1000 Board.
    Leider habe ich keinerlei Erfahrungen mit solchen Boards und frage mich nun, ob ich das übergangsweise in mein ATX Tower eingebaut bekommen würde, vor allem ob die Stromversorgung mit dem ATX Netzteil überhaupt geht.


    Das Board aus der Vectra hätte ich wohl einbauen können.


    Ist das eine total bescheuerte Idee, oder eine Möglichkeit ?

    Scheint wohl nicht so trivial zu sein :-)


    Wenn ich

    Code
    1. find /proc/acpi/alarm

    abgebe, dann erhalte ich leider nicht

    Code
    1. /proc/acpi/alarm

    .


    ACPI support ist installiert.


    Meine /etc/default/rcS sieht wie folgt aus:


    Code
    1. TMPTIME=0
    2. SULOGIN=no
    3. DELAYLOGIN=no
    4. UTC=yes
    5. VERBOSE=no
    6. FSCKFIX=no
    7. RAMRUN=no
    8. RAMLOCK=no
    9. HWCLOCKACCESS=no
    10. HWCLOCKPARS="--directisa"


    Mache ich nur einen Fehler beim testen, oder unterstützt mein Board tatsächlich kein ACPI ?

    Hallo,


    ich möchte mein betagtes Gigabyte GA-7VRXP zum aufwachen via ACPI bewegen.


    Folgendes habe ich gemacht:


    Code
    1. dmesg|grep -i acpi


    Ausgabe hierfür:

    Code
    1. ACPI: RTC can wake from S4
    2. ...
    3. rtc0: alarms up to one year


    Dann habe ich folgendes versucht (lt. ACPI Wakeup


    Code
    1. echo 0 > /sys/class/rtc/rtc0/wakealarm
    2. date +%s -d "Tue Dec 02 20:39:00 MET 2010" > /sys/class/rtc/rtc0/wakealarm
    3. poweroff


    Code
    1. cat /proc/driver/rtc

    zeigt dann eine Aufwachzeit um 20:34:00 an.
    Das sieht eigentlich gut aus für mich.


    Auch mit einem anschließenden Reboot konnte ich den Rechner nicht zum automatischen Aufwachen bewegen.


    Dabei hatte ich die BIOS Uhr einmal auf UTC stehen, das andere Mal auf locale Zeit.


    Beide Male haben nicht zum erhoften Starten des Rechners geführt.
    Zu beobachten ist bei Absetzen des Kommandos, dass die LED für den Betriebszustand des Rechners dabei an ist (irgendein Schlafmodus). Ansonsten ist diese erloschen wenn der Rechner heruntergefahren ist.


    Meine BIOS Einstellungen sehen wie folgt aus:


    BIOS FEATURES SETUP


    * Interrupt Mode: APIC (PIC)



    Hier würde ich denken das die Einstellung OK so ist.


    Die IRQ sind wohl nicht relevant, habe sie aber der Vollständigkeit heit halber aufgeführt.
    POWER MANAGEMENT SETUP


    * ACPI Standby State: S1/POS (S3/STR)
    * USB Dev. Wakeup From S3: Disabled
    * Suspend Time Out (Min): Dis.
    * IRQ3: Monitor
    * IRQ: Mon.
    * IRQ5: Ignore
    * IRQ7: Mon.
    * IRQ9: Ign.
    * IRQ10: Ign.
    * IRQ11: Ign.
    * IRQ13: Ign.
    * IRQ14: Mon.
    * IRQ15: Ign.
    * Soft-Off by Power Button: Instant Off (Suspend)
    * AC Back Function: Soft-Off (Full-On, Memory)
    * Modem Ring/Wake On Lan: Ena.
    * PME Event Wake Up: Ena.
    * Keyboard Wakeup From: S1(Suspend) (S1/S3; S1/S3/S4/S5)
    * PS/2 Mouse Wakeup From: S1(Suspend) (S1/S3; S1/S3/S4/S5)
    * Resume On RTC Alarm: Dis.


    Dazu muss ich sagen, dass mein Board ca. 10 JAhre alt sein wird.


    Theoretisch könnte das Board ACPI tauglich sein (trotz des Alters), aber irgendwie gelingt mir keine Annäherung.


    Was könnte ich noch tun ?

    Hallo,


    die Lösung mit dem Board aus der Vectra Station ist doch in etwas die Klasse, die ich derzeit habe, oder vertue ich mich da ?
    Warum also sollte die Lösung nicht ausreichen ?
    Bitte bedenkt das ich DVB-T nutze !


    Wenn ich ein neues Board kaufe, so günstig das auch immer sein mag, dann kommen da noch der Proz., Kühler, RAM, ... oben drauf.
    Damit liege ich deutlich über 120,00 EUR --> korrigiert mich bitte falls ich mich täuschen sollte.


    Ich möchte aber in diesen Rechner so wenig Geld wie möglich investieren, da sicherlich irgendwann ein neuer fällig ist. Aber dann halt ein komplette neues System.


    Davon abgesehen, habe ich noch einmal Fahrt aufgenommen um mein Board bezgl. ACPI Fähigkeit zu untersuchen. Ich gebe da nicht so schnell auf.
    Vielleicht geht es ja doch, dann hätte sich das Thema glücklicherweise erledigt.


    Wenn jemand Erfahrungen mit ACPI und dem Gigabyte GA-7VRXP hat, dann bin ich sehr dankbar für jeden Hinweis.


    Ich habe via

    Code
    1. dmesg|grep -i acpi

    folgendes erhalten:

    Code
    1. ACPI: RTC can wake from S4
    2. ...
    3. rtc0: alarms up to one year


    Bin mir nun aber nicht sicher, wie viel das über die ACPI Fähigkeit aussagt.
    Vielleicht kann da jemand helfen ?


    Folgendes werde ich als nächstes mal versuchen:


    Code
    1. echo 0 > /sys/class/rtc/rtc0/wakealarm
    2. date +%s -d "Wen Dec 01 21:00:00 MET 2010" > /sys/class/rtc/rtc0/wakealarm

    Warten bis es geht ?


    Wohl nicht die Lösung die ich mir erhoffe.
    Warum sollte ich das tun ?


    Es gibt sicherlich Boards die meine Anforderungen erfüllen und passen.


    Zumal sie Vectra Lösung noch nicht vom Tisch ist.
    Das würde ggf. wohl ausreichen, oder ?


    Ich habe mich nun noch ein wenig mit ACPI beschäftigt und komme von meinem jetzigen Board nicht los.
    Die meisten Gigabyte Borads unterstützen ACPI.
    Die Versuche die ich seiner Zeit gemacht habe waren vielleicht auch nicht ausreichend ?
    Vielleicht sollte ich doch bei meinem Board den Versuch noch einmal wagen.


    Klar ist es schon sehr alt, aber vielleicht geht es ja doch.

    Na ja, sicherlich hast Du grundsätzlich Recht, aber derzeit benötige ich eine günstige Lösung die Ziel führend ist.


    An was denkst Du genau ?
    Eine konkrete Boardbezeichnung wäre schon toll.


    Ich benötige ein Board was 100% Linux komp. ist und ACPI nach Möglichkeit Out of the Box läuft.
    Weiterhin muss das Board zu dem Rest meiner angestaubten Hardware passen (IDE, AGP, ...), sonst kann ich mir direkt ein neues System zulegen.
    Das ist derzeit nicht !


    Jetzt kommt Dein Vorschlag !
    Was benutzt Du für ein Board (fehlt leider in der Signatur) ?

    OK, wenn ich mir das mit Deinem Board anschaue, dann würde das auch eine Stange Geld kosten.


    So einfach ist das alles nicht.


    Vielleicht wäre auch mein Plan B eine Alternative.


    1) HP Vectra VL420 Station kaufen (Board, Proz., Graka, Speicher).
    2) Avermedia AVerTV DVB-T-771 (dafür könnte ich später meine Hauppauge WinTV-HVR-1300 verkaufen, da ich die so oder so nicht wirklich benötige).
    3) HDD habe ich noch aus einem Technisat DVB-T Fesplattenrecorder (die sollte gehen) für das System, eine 250 GB habe ich in dem jetzigen VDR Rechner als Datenpartition. Die sollte ich umhängen können.


    Damit ein parallel System aufbauen bis alles so funzt wie es soll, dann könnte ich entweder das Mico-ATX Board in das jetzige Gehäuse (Silent Tower) einbauen, oder aber ein alternatives wie z.B.: Lian Li
    Was bei dem Lian Li nicht geht, ist meine 3,5" HDD, da dort nur eine 2,5" rein passt.


    Vielleicht stelle ich mir das ein bisserl einfach vor ???


    Lt. LinVDR Datenbank Mainboards wird bei dem Board angeblich ACPI unterstützt.


    Quote

    Hersteller Bezeichnung CPU Type Bauform PCI pOff WoT WoL Autor


    Quote

    Asus / HP P4B266-MX (I) Sockel 478 µATX 3 ok ok 29 ?? KalleKnall


    Habt Ihr mit diesem Board Erfahrungen die für mich nützlich sein könnten ?

    OK, neuen Speicher dazu.


    Mir schwebt vor ein kompllettes Board mit Proz. und Speicher zu ergattern.


    Das gibt es schon zu guten Preisen wenn es nicht das neuste sein muss ... und das kommt bei mir eh nicht in Frage wegen meiner alten Komponenten (HDD, ...).


    Bist Du mit Deinem Board zufrieden ?
    Unterstützt das ACPI/NVRAM Out of the Box ?


    Ist das ein ATX ?


    Ich habe mich als Alternative durch diesen Beitrag inspirieren lassen: http://www.gerloni.net/LinuxVDR/#KNOWNPROB


    Hier verwendet der Autor Komponenten aus einer HP Vectra VL420.
    Diese Stations gibt es bei eBay schon recht günstig.
    Meine Alternatividee ist gewesen, auf dieser Basis parallel ein System aufzubauen und dann wenn alles läuft die vorhandenen Komponenten aus dem jetzigen Rechner zu wechseln (HDD, ...).


    Hätte den Nachteil das ich ein neues Gehäuse benötigen würde für das Micro-ATX aus der Vectra Station, oder ist auch vorstellbar ein Micro-ATX in ein ATX Gehäuse zu schrauben ?
    Solche Gehäuse gibt es ja auch.
    Ob mein Silent Tower dafür ausgelegt ist, bin ich mir aber nicht sicher.
    Wenn das funktionieren würde, dann könnte ich später ein geeignetes Gehäuse (wenn es halt passt) anschaffen.


    Einfacher wäre halt nur ein neues Board in den jetzigen Rechner das ACPI unterstützt.


    Funktioniert ein Boardwechsel eigentlich ohne das System neun aufsetzen zu müssen ?
    Da fehlen mir die Erfahrungen.

    Hallo,


    ich weiß das diese Frage ständig gestellt wird, aber die Suche gestaltet sich doch recht schwierig.


    Mein Dilemma ist folgendes: Ich habe einen recht alten Rechner und ein Problem mit dem Board (Gigabyte GA-7VRXP), welches ACPI nicht unterstützt. NVRAM wird leider auch nicht Out of the Box unterstützt. Das Herantasten via Guess-Helper ist im Sande gestrandet.
    set_timer funktioniert ebenfalls nicht.
    Ich habe mich mittlerweile recht viel Zeit darauf verwendet eine der drei Lösungen zum laufen zu bringen. Vor allem bei der set_timer Lösung !


    Da ich aber die Zeit nicht dafür habe, muss ich mich nach einer einfacheren Lösung umschaun.
    Die wäre aus meiner Sicht ein neues/gebrauchtes Board.


    Hier würde ich Eure Hilfe und Erfahrungen benötigen.
    Nach Möglichkeit sollte das Board gebraucht zu bekommen sein.


    Formfaktor ist ATX, IDE für die HDD werden benötigt, AGP für die Graka.
    Speicher hätte ich noch aus dem jetzigen Board.


    Möglich wäre auch den Proz. zu verwenden, aber das könnte schon schwierig werden auf Grund des Alters.


    Das Ziel ist es ein Board zu finden was so wenig wie möglich an Geld kostet, aber ACPI Out of the Box unterstützt.


    Da set_timer und NVRMA eher Behelfslösungen sind, würde ich davon gerne absehen.


    Herzlichen Dank für Eure Unterstützung.

    Habe das richtige "time" wohl gefunden und von /usr/bin nach /usr/local/sbin kopiert. In /usr/bin habe ich umbenannt.


    Code
    1. TIME=/usr/local/sbin/time

    damit sollte das nun passen.


    Was ich jetzt seit ein paar Tagen habe: Rechner fährt hoch und die Systemzeit ist jedes mal komplett verstellt. Scheinbar immer auf 00:00 Uhr (UTC=23:00 Uhr).


    Verstehe ich nicht ganz.


    Das ist seit dem ich auf der Konsole versucht habe

    Code
    1. set_timer 1 600

    abzusetzen.


    Mir fehlt aber noch die Nr. mit dem vdrshutdow Skript und die diversen Anpassungen in der aus "set_timer" die dort beschrieben sind.

    Hallo,


    den 1. Versuch hatte ich bereits für ACPI schon gemacht. Das hat funktioniert. Deswegen bin ich auch darauf gekommen, dass NVRAM funktionieren könnte.


    Werde ich aber nochmals wiederholen wenn der Rechner nicht gerade (so wie heute Abend) beschäftigt ist.


    Grundsätzlich ist mir die Funktionsweise von set_timer schon klar. Das ist auch nicht mein eigentliches Problem.


    Das vdrshutdown Skript liegt unter /usr/share/doc/vdr/examples und ich kann mir nicht vorstellen, dass dieses wirklich benutzt wird. Auf der anderen Seite fährt der Rechner über deb VDR runter.


    Wo müsste den das Shutdown Skript liegen, damit der VDR dies nutzt ?
    Wenn ich das richtig gelesen habe, dann wird bei der Installation von nvram-wakeup das bereits vorhandene vdrshutdown Skript ausgetauscht. Aber da ist ja der Hacken.


    Dazu nutze ich auf der Tastatur (habe noch keine FB) "v" = Poweroff und dann löst VDR den Shutdown aus.


    time ist ein Deb-Paket, was aber meines Erachtens nichts mit nvram-wakeup zu tun hat. Das müsste ich ja dann in den Sourcen finden, oder ?
    Vielleicht hat das time was set_timer meint

    Code
    1. TIME=/usr/local/sbin/time

    auch mit dem time was ich als Paket meine nichts zu tun.


    Wenn Du mal bei den Sourcen von nvram-wakeup schaust, dann gibt es dort zwei Dateien die vielleicht passen könnten:


    Code
    1. time.8


    Code
    1. time.c


    Erstere sieht für mich eher wie eine Beschreibung aus. Zweite ist ein Skript.


    Die muss ich auf dem Rechner mal suchen gehen. Aber liegen beide nict da, wo set_timer sie erwartet.

    Wenn ich

    Code
    1. set_timer 1 600

    ausführe, dann erhalte ich folgendes:


    Code
    1. Wohnzimmer:~# set_timer 1 600
    2. /usr/sbin/set_timer needs the time command from nvram-wakeup


    Folgendes steht in dem Skript set_timer:


    Code
    1. # programs to use:
    2. HWCLOCK=/sbin/hwclock
    3. TIME=/usr/local/sbin/time


    In /usr/local/sbin gibt es kein Skript namens time.


    Also habe ich den Pfad auf /usr/bin angepasst wo das Skript time liegt.


    Führe ich erneut den Aufruf aus, erhalte ich folgendes:


    Code
    1. Wohnzimmer:~# set_timer 1 600
    2. /usr/bin/time: cannot run 1588204975: No such file or directory
    3. Command exited with non-zero status 127
    4. 0.00user 0.00system 0:00.00elapsed ?%CPU (0avgtext+0avgdata 0maxresident)k
    5. 0inputs+0outputs (0major+72minor)pagefaults 0swaps
    6. /usr/bin/time: cannot run 996616499: No such file or directory
    7. Command exited with non-zero status 127
    8. 0.00user 0.00system 0:00.00elapsed ?%CPU (0avgtext+0avgdata 0maxresident)k
    9. 0inputs+0outputs (0major+72minor)pagefaults 0swaps


    Wie kann ich erreichen, dass set_timer die Übergabe nicht von nvram-wakeup erwarte ?
    Was hat es mit dem Skript time auf sich ?

    OK, verstehe ich das richtig, dass time_diff kein Skript ist, sondern lediglich dort etwas gespeichert wird ?


    Code
    1. TIME_DIFF=/video/time_diff


    Das Verzeichnis video habe ich gefunden, liegt bei mir aber unter /var/lib/video.


    Demzufolge müsste die Änderung in set_timer so aussehen:

    Code
    1. TIME_DIFF=/var/lib/video/time_diff


    Verstehe ich das so richtig ?


    Kann ich das Skript manuell testen ohne den VDR ?
    Wenn ja, wie müsste das als Aufruf aussehen (bin da echt unterbelichtet). Kann mir jemand ein Bsp. geben ?

    Hallo,


    ich habe folgendes jetzt gemacht:


    Das Skript "set_timer" habe ich nach /usr/sbin kopiert.


    In der /etc/init.d/bootmisc.sh habe ich den Eintrag entsprechend auf /usr/sbin angepasst.


    In der /etc/vdr/vdr-nvram-wakeup.conf habe ich für den Eintrag SPECIALSHUTDOWN="" folgendes ergänzt: SPECIALSHUTDOWN="shutdown -r now" und

    Code
    1. # Set to "yes" to enable nvram-wakeup for VDR
    2. ENABLED="yes"

    gesetzt.


    Jetzt erhalte ich zwar nicht mehr die Fehlermeldungen, aber ein Test Timer hat leider auch nicht den gewünschten Erfolg des automatischen Aufwachens gebracht.


    In dem Skript set_timer steht folgendes:

    Quote

    # The System should not update the hardware clock in the shutdown process.
    # In Debian Woody set HWCLOCKACCESS=no in /etc/default/rcS


    --> Nun verwende ich aber Debian Lenny und habe genau das gemacht. Ist das für Lenny falsch und wenn ja, was muss ich dann tun ?


    Weiterhin steht dort:

    Quote

    # The wake up time must be set to 23:59:59 the day must be set to 31
    # if your board supports a month setting for the wakeup, set it to July


    Klingt jetzt nicht wie eine Bedingung und sollte auch ohne den Monat Juli funktionieren, da mein Board das mit dem Monat nicht unterstützt.


    Hier wieder der Hinweis auf das vdrshutdown Skript:

    Quote

    # in vdrshutdown replace:
    # $NVRAMCMD -ls $1
    # by
    # $PATH_TO_SET_TIMER/set_timer $1 $2


    ... und wo muss ich folgendes eintragen:

    Quote

    # and add the following line to your start script before vdr is started
    # $PATH_TO_SET_TIMER/set_timer


    --> Wäre das schon /etc/init.d/bootmisc.sh ?


    Hier die Rede von time_diff:

    Quote

    # files to use:
    TIME_DIFF=/video/time_diff


    Wo bekomme ich diese den nun her ?


    In folgendem Wiki, wird etwas zu der ctVDR Version geschrieben: http://www.vdr-wiki.de/wiki/index.php/C%27t-VDR_-_Set_timer
    In der /usr/share/vdr/shutdown-hooks/shutdown90.custom.sh steht ein bisserl was anderes wie in der Anleitung (s. erster Beitrag) die ich benutzt habe.


    Grundsätzlich benutze ich den VDR nicht mit root Rechten !!!


    Stimmt das was ich bisher gemacht habe grundsätzlich ?

    Wenn ich in der "vdr-nvram-wakeup.conf"

    Code
    1. ENABLED="yes"

    setze, alle anderen Möglichkeiten sind dabei auskommentiert, dann möchte der VDR nach einer Zeit x sich ausschalten.


    Das macht ER nur wenn ich wie oben beschrieben konfiguriere.


    Was wird hier angestoßen mit dem

    Code
    1. ENABLED="yes"

    ?


    Was mir weiterhin verdächtig vorkommt ist das fehlende "vdrshutdown" Skript welches ich unter /usr/share/doc/nvram-wakeup/examples/ gefunden habe.


    Für mich sieht das so aus, als ob überhaupt kein Shutdownscript gezogen wird.


    Auch das fehlende timediff Skript ist merkwürdig. So kann "set_timer" nicht funktionieren.

    Hallo,


    ich versuche nun schon seit Tagen meinen VDR zum automatischen Aufwachen zu bringen.
    Erster Anlauf über ACPI ist gescheitert, da Board zu alt (dazu habe ich auch einen Beitrag hier im Forum).


    NVRAM-Wakeup wollte ebenfalls nicht laufen und hatte den Nachteil, dass mein Board einen Reboot benötigt hätte (auch ein Beitrag hier im Forum).


    Also habe ich mich entschieden einen Versuch mit der Methode und dem Skript "set_timer" aus dem NVRAM-Wakeup Paket zu versuchen.


    Ich bin nach dieser Anleitung vorgegangen: set_timer


    Das habe ich 1:1 übernommen, bis auf:

    Quote

    #NVRAMCMD=/usr/sbin/nvram-wakeup
    NVRAMCMD="sudo /usr/sbin/set_timer"

    im ersten Versuch.
    Da hatte ich zuerst für ... /usr/sbin --> .../usr/bin eingesetzt, da auch zuvor dorthin verwiesen wurde.
    Hat aber nicht funktioniert und so habe dann auch an dieser Stelle, die mir trotzdem nicht einleuchtet, alles 1:1 so übernommen.


    Nun erhalte ich folgende Fehlermeldung wenn ich meinen VDR programmiere, bzw. über "poweroff" (auf meiner Tastatur via "v") ausschalten möchte:

    Code
    1. No special shutdown configured

    und

    Code
    1. Shutdown abgebrochen


    Ich habe bereits im Forum gestöbert und gelesen, aber da sind einfach zu viele Fragen für mich offen.


    Als erstes kam mir der Gedanke mit fehlenden Rechten.
    Ich starte den VDR unter einen anderen User wie den VDR (VDR als User) selber.
    Habe aber den VDR als Root gestartet und das gleiche versucht. Ergebnis ist ident !
    Daran kann es wohl nicht liegen denke ich mal.


    Hier alle wichtigen Auszüge:


    /etc/init.d/bootmisc.sh

    Code
    1. /usr/bin/set_timer


    /etc/default/rcS

    Code
    1. TMPTIME=0
    2. SULOGIN=no
    3. DELAYLOGIN=no
    4. UTC=yes
    5. VERBOSE=no
    6. FSCKFIX=no
    7. RAMRUN=no
    8. RAMLOCK=no
    9. HWCLOCKACCESS=no
    10. HWCLOCKPARS="--directisa"


    Hier bin ich mir nicht sicher ob die Einträge wirklich alle notwendig sind. Vor allem der letzte könnte von NVRAM stammen.


    Quote

    (3) in /etc/vdr/vdr-nvram-wakeup.conf aendern: auf "enabled"


    Habe ich wie folgt:

    Code
    1. ENABLED="yes"


    Hier noch die vollständige Conf-Datei: [1]
    Da bin ich mir nicht sicher ob der Fehler auch stecken könnte:

    Quote

    # SPECIALSHUTDOWN="lilo -R PowerOff ; shutdown -r now"
    SPECIALSHUTDOWN=""


    Müsste ich hier vielleicht einen Eintrag stehen haben ?


    /etc/sudoers

    Code
    1. Defaults env_reset
    2. # User privilege specification root
    3. ALL=(ALL) ALL
    4. wohnchris Wohnzimmer = NOPASSWD: /usr/sbin/xfsm-shutdown-helper
    5. # set_timer
    6. vdr ALL=NOPASSWD: /usr/sbin/set_timer


    Hier könnte evtl. der Konflikt mit den Rechten entstehen ?


    /usr/share/vdr/shutdown-hooks/S90.nvram-wakeup

    Code
    1. # NVRAMCMD=/usr/sbin/nvram-wakeup
    2. # set_timer - discription from "http://www.vdr-portal.de/board/thread.php?threadid=55324#post527032"
    3. NVRAMCMD="sudo /usr/sbin/set_timer"


    Code
    1. # $LOG "$NVRAMCMD -ls $TIMER $COMMANDLINE"
    2. # $NVRAMCMD -ls $TIMER $COMMANDLINE
    3. # set_timer - discription from "http://www.vdr-portal.de/board/thread.php?threadid=55324#post527032"
    4. $LOG "$NVRAMCMD $1 $2"
    5. $NVRAMCMD $1 $2


    Die vollständige findet Ihr im Anhang [2]


    Die RTC Zeit im BIOS habe ich auf den 31. um 23.59 und 59 sek. gestellt.


    Wie schaut das mit dem Shutdown Skript aus ?
    Ist da ein Problem zu suchen ?
    Was müsste ich hier prüfen, oder ggf. tun ?


    Das Skript timediff habe ich nicht finden können. Wird aber lt. diesem Artikel benötigt: Weckdienst
    Was hat es damit auf sich ?


    Es muss doch möglich sein, dass ich meinen VDR zum automatischen Start überredet bekomme.

    Was ich aber nicht verstehe sind die 13 min. Dif. in dem Test.
    Ein erneuter Test hat 5 min. Dif. gebracht. Das würde ich wieder verstehen.


    Warum nicht GA-7VRXP ?


    Habe die vdr-nvram-wakeup.conf entsprechend und auch die /boot/grub/menu.list geändert.


    Die von guess-helper generierte nvram-wakeup.conf habe ich nicht nach /etc kopiert und zum Einsatz gebracht.


    Nach dem ich alles fertig hatte und einen Test Timer programmiert habe, hat der VDR die Meldung gebracht, dass nvram nicht die Zeit setzen kann und der Shutdown abgebrochen wurde (sinngemäß).


    Mit dem Reboot schau ich mir an in wie weit mich das nervt.
    Ich habe gesehen, dass es kaum ein Gigabyte Board gibt, was keinen Reboot benötigt.


    Ich habe erst einmal alles wieder rückgängig gemacht damit der VDR läuft.
    Mit Grub das ist ja nicht ganz ungefährlich !


    Was ich mich frage, ob ich mit set timenicht besser beraten wäre.
    Dann würde auch der kurze Reboot entfallen.


    Gibt sehr viele Leute die mit set time sehr zufrieden sind.