Posts by gotscha

    Vielen Dank für Eure Hilfestellungen.


    pille2011 : Der Tipp zur xorg.conf hat in Verbindung mit softhdvaapi die Lösung gebracht.

    Wieder was gelernt.


    @ vdr_rossi: Vielen Dank für den Hinweis auf die Dokumentation. Die Tabelle mit den Ausgabe Plugins war mir bisher noch nicht so richtig aufgefallen.

    Lauffähig auf Intel ix-6xxx/ix-7xxx Prozessoren ist: softhdvaapi


    Ich werde auch noch softhddevice ausprobieren.

    Hallo Allerseits,


    leider habe ich Probleme mit der Neuinstallation des focal yavdr-ansible auf meinem Notebook.

    Nach der Installation erscheint kein Bild.


    Welche Einstellungen sollten in der host_vars/localhost Conf Datei für diese HW gewählt werden?

    selected_frontend: softhddevice ? oder etwas anderes?


    vdr_output_plugin: vdr-plugin-softhddevice-cuvid oder vdr-plugin-softhddevice ?


    Bei einer Installation mit beiden Zeilen auskommentiert, läuft die Installation durch un der vdr startet, jedoch erscheint nach dem vdr Logo kein Bild/Menü.


    In /var/log/syslog wird die folgende Zeile permanent gelistet:

    vdr: video/vaapi: vaSyncSurface failed


    Unter Bionic lief vdr-plugin-softhdddevice-vpp problemlos.


    Der Tuner wurde wie hier beschrieben https://www.vdr-portal.de/forum/index.php?thread/132556-gel%C3%B6st-yavdr-ansible-yavdr0-7-auf-intel-notebook-kein-bild-men%C3%BC # 12 ersetzt.


    Viele Grüße

    Bernhard

    Hallo Seahawk,


    vielen Dank für Deine Hilfe, Deine Lösung hat funkltioniert.


    Kannst Du mir bitte noch erläutern, warum das keine gute Idee ist, mit den GUI Programmen?

    Ist der Grund hierfür die Root Rechte bezüglich Sicherheit? oder das polkit an sich?


    Ich betreibe meine vdrs in einem separaten Netz, die vdrs werden nur temprär für Paketupdates/-installation mit dem Internet verbunden.

    Während dieser Zeit läuft nur das Byubo Terminal.


    Viele Grüße

    Bernhard

    Hallo Allerseits,


    nach der Neuinstallation von yavdr0.7 basierend auf Focal können Gnome Applikationen nicht mehr aus dem byubo Terminal gestartet werden.


    auf das Kommando "sudo gparted" kommt die Fehlerausgabe:

    "Unit tmp.mount does not exist, proceeding anyway.

    Unable to init server: Could not connect: Verbindungsaufbau abgelehnt


    (gpartedbin:3808): Gtk-WARNING **: 22:15:14.102: cannot open display:"


    Unter yavdr-ansible@Bionic war der Aufruf noch problemlos möglich.


    Hättet Ihr Tipps zur Behebung?


    Viele Grüße

    Benrhard

    1 ms reichen um die Kommando Annahme des vdrs während dem Schneiden sicherzustellen.


    Das Schneiden wird allerdings deutlich langsamer (Faktor > 10).

    Ist nicht ganz so schlimm, da das Schneiden jetzt problemlos im Hintergrund laufen kann.


    Eventuell versuche ich nochmal kürzere Zeiten, falls der Funktionsaufruf diese annimmt (z.B. 0.1 ms).


    Falls ich das richtig verstehe, müsste die "Move" Funktion in recordings.c enthalten sein.

    Allerdings finde ich keine Stelle an der mit ein cCondWait sinnvoll erscheint.

    Hallo Allerseits,


    ich verwende den vdr sowohl als Aufnahme Server als auch zum Ansehen der Server Aufnahmen in zwei anderen Räumen.

    Daher starte ich sehr oft das Schneiden eines Films welcher auf dem Server liegt von einem der beiden vdr Clients aus per Taste 2 auf der Fernbedienung.


    Anscheinend wird durch das Schneiden über das Netzwerk mein ansible vdr für die Dauer des Schneidens "unbedienbar".

    Diese Verhalten trat auf dem yavdr0.5, welchen ich zuvor verwendet habe, nicht auf, da im extrecmenu Plugin der Schalter "Bandbreite beim Schneiden begrenzen" aktiviert war.


    Gibt es eine einfache Möglichkeit eine solche Begrenzung im yavdr-ansible oder Core-vdr zu aktivieren?

    Oder gibt es über das OSD Menü ( oder Taste X der Fernbedienung) das Schneiden lokal auf dem Server zu starten?


    Der yavdr-ansible mit extrecmenung Plugin benutzt die Core-vdr Schnittfunktion laut diesem Post #6:

    Asrock J4105 itx erfahrungen probleme mit sata und tbskarte

    Diese Option gibt es in extrecmenung nicht mehr. Ich habe wohl vergessen, das aus dem Setup-Menü heraus zu nehmen, das mache ich noch.

    ExtrecmenuNG nutzt jetzt überwiegend die internen Funktionen vom Core-VDR, also auch die Schnitt- und Verschiebe-Routinen. Du kannst ja mal versuchen, den Schnitt direkt aus dem originalen VDR-Aufzeichnungsmenü zu starten. Wenn es sich dann genau so verhält, und das sollte es eigentlich, dann ließe sich das nur direkt im Core-VDR beeinflussen.


    Übrigens, wenn man das alte Plugin, also ohne NG, mit "USE_VDR_CUTTER" übersetzt hat, nutze es auch schon nicht mehr die eingebaute Schnittfunktion.

    dann bin ich scheinbar der einzigste, der das Plugin noch einsetzt!

    Bist du nicht :-)


    Für mich ist es immer noch ein must-have Plugin, da beim Verschieben die verfügbaren Verzeichnisse zur Auswahl angezeigt werden und man diese mit der Fernbedienung auswählen kann, während man bei internen vdr Verschieben den Verzeichnisnamen wissen und eintippen muß.


    Außerdem erlaubt es zusätzlich zum Aufnahmedatum noch die Filmlänge in der Übersicht anzuzeigen.


    Sehr schade.

    Bei einem Test mit einem dvbc USB Tuner startet das Trekstor Notebook das Bild korrekt.


    Dies bleibt auch für 3-4 Boots nach Abziehen des USB Tuners so, aber irgendwann verschluckt sich der vdr beim Start wieder und der Bildschirm bleibt danach wieder dunkel.


    Gibt es eine Möglich den vdr auch ohne Tuner/TV Quelle mit Bild zu starten?


    Das Trekstor Notebook soll mein Reise vdr werden (nur Wiedergabe, kein Live TV oder Aufnahme), da meines altes eeePC Notebook immer mehr zickt.


    Bernhard

    Vielen Dank für die Hinweise.


    Ich sehe da softhddevice in der Pluginliste. Ist es day richtige für deine Intelgrafik? Welches Ausgabeplugin ist auf der anderen Installation aktiv und welche Grafikkarte hat es?


    Lars

    Das Notebook bei dem es funktioniert ist ein Asus Zenbook mit Intel µP (i5-6xxx glaub ich) mit Intelgrafik. Hier kommt das Bild/Menü ohne Tuner bei einmaligem Druck auf die Power Taste.


    Das Notebook ohne Bild auf welchen yavdr 0.7 ist ein Trekstor P14B (Pentium N3350) bzw. testweise auch ein Trekstor A13B (Pentium N5000), jeweils mit Intel Grafik. Hier hilft auch ein Druck auf die Powertaste nicht, der vdr fährt direkt runter.


    Die funktionierende Referenz Installation ist ein Stand PC mit TV Karte und I5-3xxx, auf welchem der yavdr 0.7 direkt startet.


    Die Asus Notebook Konfigurationen ist per Rerun des Ansible Scripts vor ca. 2 Wochen auf Stand gebracht worden.

    Die Trekstor Notebooks sind diese Woche installiert worden.


    Quote

    Hast du dafür mindestens einen gültigen Eintrag in der channels.conf konfiguriert?

    Hatte den NASA Eintrag von yavdr0.6 kopiert und die vlcinput Input Datei aus dem github geholt.



    Nach Start des yavdr blinkte auch die Diode an der USB Netzwerkkarte eifrig.

    Daher vermute ich, daß der Sender empfangen wird.


    Ich werde das mal auf dem Asus Notebook verifizieren. Hier gibt es ja Bild :-)

    Hallo Allerseits,


    ich habe das Problem, dass yavdr0.7 auf einem rekstor Notebook nach der Installation ohne Bild startet (auch kein Menü).


    vdr läuft, xserver läuft auch.


    Ich vermute, dass das Bild wegen der fehlenden TV Karte nicht kommt, da der vdr nicht auf den letzten Sender tunen kann.


    Bei einer similaren Installation auf einem Asus Notebook, auch ohne Tuner. half hier einmaliges Drücken der Power Taste, um ein Menü zu bekommen und Filme wiedergeben zu können.


    Gibt es eine Einstellung, welche den fehlenden Tuner umgeht?

    Hallo Seahawk,


    vielen Dank für die Tipps.

    Channels.conf war vorhanden, aber die Antenne nicht eingesteckt.


    Habe -v va-api in die softhddevice config eingefügt, wie vorgeschlagen -> vdr startet direkt mit Bild.

    Das ist prima.


    Leider driftet der Ton immer noch zum Bild.

    Ändern der deinterlacer Einstellung hilft nichts.

    Habe die Versuche mit ZDH HD unternommen (720p).


    Das Problem ist anscheinend, daß der Monitor keine 50 Hz kann.


    Es wundert mich nur, wieso yavdr0.6 am selben Monitor Synchron betrieben werden kann.

    Aus welche Info der yavdr0.6 Installation kann man die Unterschiede ableiten?


    Anbei ein neues Log nach der Korrktur der ersten beiden Punkte (erzeugt mit journalctl -b -l ).

    Files