Posts by joba

    Beim erneuten restart von eventlircd kommen dann diese Zeilen

    Auffällig:

    Code
    1. Jul 7 12:24:46 ub59b yavdr-frontend[1371]: /usr/lib/python3/dist-packages/yavdr_frontend/lirc.py:46: Warning: Source ID 2 was not found when attempting to remove it

    Scheint so, als wollte er zwei Dinge freigeben, aber nur eins ist da - vielleicht wurde beim anlegen zwei Dinge unter der selben ID (ev-map) abgelegt. Vermutung: es ist nicht vorgesehen zwei Eingabegeräte mit der gleichen ev-map zu betreiben.

    Jetzt mit mehr Logging:

    auffällig ist für mich die Zeile:

    Code
    1. eventlircd[2294]: input device /dev/input/event6: created output event device

    diese gibt es zweimal für event6 und keinmal für event5 - nur warum?

    Ausgabe von

    journalctl -u eventlircd -b -l

    Code
    1. sudo journalctl -u eventlircd -b -l
    2. -- Logs begin at Wed 2019-05-01 12:21:07 CEST, end at Sun 2019-07-07 12:07:14 CEST. --
    3. Jul 07 11:46:38 ub59b systemd[1]: Started "eventlircd reads from kernel input devices and generates key presses on a lircd socket".

    In welchem Format müsste ich Tastennamen in /var/lib/vdr/remote.conf und der /var/ib/vdr/.kodi/userdata/Lircmap.xml am Beispiel KEY_PAGEDOWN eintragen:

    Code
    1. LIRC.Channel-   KEY_PAGEDOWN

    ??


    und

    Wenn ich es richtig sehe, müsste zweimal die gleiche evmap geladen werden:


    Wenn ich mit sudo evtest /dev/input/event5 teste kommt z.B. der Kanalwechsel:

    wenn ich mit sudo evtest /dev/input/event6 teste kommen die Lautstärkesignale


    Im Endeffekt kommen also die von event5 nicht beim vdr an. Ist das Problem eventuell dass ich zwei Eingabegeräte habe und nur das letzte funktioniert?

    Hallo Forum,


    ich habe einen folgendes Problem:

    yavdr mit ansible auf ubuntu 18.04.02

    mein Fernbedienungsempfänger hat zwei Eingabegeräte (Ausschnitt aus cat /proc/bus/input/devices):

    Wenn ich mit sudo irw Tastendrücke teste werden alle Tasten, die ich drücke angezeigt - allerdings kommt nur ein Teil beim vdr an. z.B. Lautstärke geht, Kanalwechsel nicht.

    Code
    1.  sudo irw
    2. 68 0 KEY_PAGEUP devinput # funktioniert nicht
    3. 6d 0 KEY_PAGEDOWN devinput # funktioniert nicht
    4. 73 0 KEY_VOLUMEUP devinput # funktioniert
    5. 72 0 KEY_VOLUMEDOWN devinput # funktioniert

    Hat jemand eine Idee wo das schief gehen kann?


    Danke


    joba

    Nach einigen Versuchen nach vorherigen ordentlichen Booten kann ich auch richtige Stacktraces produzieren (siehe Anhang).


    Mir scheinen das Verweise auf Probleme mit lircd zu sein:

    Code
    1. Dec 22 13:31:38 ub55 lircd-0.9.0[1040]: error reading from /dev/lirc0 (ret -1, expected 4)
    2. Dec 22 13:31:38 ub55 lircd-0.9.0[1040]: No such device


    und mit dem dvb-usb-technisat-usb2 - Module zusammenzuhängen:


    Bin weiter für Hinweise und Ideen dankbar.


    joba

    Hi zusammen,


    ich habe gerade meinen zweiten VDR zusammengebaut (siehe Signatur) und bin auch nach dem obligatorischen einfügen des Modules für die Skystar (dvb-usb-technisat-usb2 in /etc/modules) und herunterladen der Firmware sehr schnell zu einem lauffähigen System gekommen.


    - Vielen Dank an dieser Stelle für die hervoragende Arbeit!


    Jetzt würde ich gerne per Fernbedienung den vdr in den Standby schicken und dann wieder aufwecken. Dazu habe ich das Module (dvb-usb-technisat-usb2) auch schon in die /etc/yavdr/force-module-reload.list eingetragen.
    In den Standby funktioniert, aufwachen grundsätzlich auch, allerdings habe ich dann nur ein schwarzes Bild, kein Ton aber OSD (vorerst) und dann ist plötzlich auch das OSD weg:



    Auffällig ist dann ein Prozess (PID 3247, siehe auch ausschnitt aus dem syslog) der einen Prozessor zu 100% auslastet:

    Code
    1. vdr 3247 1 35 13:01 ? 00:04:41 /usr/bin/vdr -v /srv/vdr/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown.wrapper -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 6419 --lirc=/var/run/lirc/lircd -w 0 -Pwirbelscan -Pextrecmenu -Plive --port=8008 --ip=0.0.0.0 --log=INFO --epgimages=/var/cache/vdr/epgimages -Pfemon -Ptext2skin -Pepgsearchonly -Pepgsearch -f /usr/bin/svdrpsend -Pchannellists -Pstreamdev-server -Pquickepgsearch -Pdbus2vdr --shutdown-hooks=/usr/share/vdr/shutdown-hooks --shutdown-hooks-wrapper=/usr/share/vdr-plugin-dbus2vdr/shutdown-wrapper --upstart -Piptv -Pconflictcheckonly -Psofthddevice -D -Pmarkad -Prestfulapi --port=8002 --ip=0.0.0.0 --epgimages=/var/cache/vdr/epgimages --channellogos=/usr/share/vdr-channellogos -Pskinpearlhd --epgimages=/var/cache/vdr/epgimages -Pmenuorg -Pxvdr -t 10 -Pdynamite


    Angehängt habe ich den Ausschnitt des Syslog zum Einschlafen und den vom wieder aufwachen.


    Hat jemand eine Idee wo ich noch nach Fehlerursachen suchen kann oder was ich mal probieren könnte?


    Danke im Voraus


    joba