Posts by spitzb

    Mit der habe ich auch experimentiert, die läuft aber mit keinem VDR ab 1.7.3, weil es die Klasse cRemux nicht mehr gibt.


    Ich hatte mit 1.7.0 die neueste Version in Betrieb, die kommt aber mit den neueren VDR's nicht mehr zurecht, wahrscheinlich wegen des TS Formats.


    :((


    Falk

    Was ist eigentlich der Unterschied zwischen Live-TV und Wiedergabe einer Aufzeichnung. Bei der eHD wird doch sowieso immer im Transfer-Mode gearbeitet. Klar bei einer Wiedergabe kommen die Daten aus einer Datei, bei Live TV von der DVB-Karte. Wird denn beim Aufzeichnen etwas anderes gespeichert, als bei Live-TV an die Karte gesendet wird?


    Sorry, wenn ich hier dumme Fragen stelle, aber so richtig will mir nicht in den Kopf, woher die Daten kommen, die den hdplayer abschießen. Bei Live TV mit Empfangsstörungen kommt doch bestimmt viel mehr Müll, ohne das der hdplayer abstürzt.


    Falk

    Quote

    Mir fehlt einfach die Zeit um die Implementierung von PlayTs(), PlayVideoTs() und PlayAudioTs() im ReelBox Plugin zu machen


    Schade. Ich würd's machen, habe aber nicht die C++ Kenne.


    Ich habe aber eventuell einen Workaround gefunden. Wenn ich die Aufzeichnung mit ProjectX in PES umwandle (-tovdr), scheint sie normal zu laufen.

    Wenn ich mich richtig erinnere, wollte doch irgendwer mas dieses Problem angehen.


    Ich habe eine Aufzeichnung von Pro7, die nach wenigen Minuten zuverlässig den hdplayer abschiesst.


    Selsamerweise scheint das wirklich nur mit Aufzeichnungen von Pro7 zu passieren. Andere (ARD, ZDF, RTL2) laufen ohne Probleme.


    Bin ansonsten mit meiner eHD unter VDR 1.7.8 sehr zufrieden.


    Falk

    Ich habe jetzt, nach einiger Bastelei, endlich einen VDR 1.7.8 mit dem reelbox plugin zum Laufen bekommen. :idee


    Sieht bis jetzt ganz gut aus.


    Irgendwer wollte sich doch mal an die Beseitigung der Probleme beim Abspielen von TS-Aufzeichnungen machen?!? Ist da irgendwer 'dran?


    Ich muss allerdings sagen, dass ich beim Testen bisher keine derartigen Probleme hatte. Werde es aber sicher weiter im Auge behalten.


    Falk

    Ich habe eine Tevii S470 (PCIe) und eine TT S2-3600 (externe USB Box). Beide laufen sehr stabil. Über den Stromverbrauch kann ich nicht viel sagen. Du brauchst für beide Karten die S2-liplianin Treiber, sonst geht nix.


    Es gibt noch eine Dual - DVB-S2 Karte von Media Pointer, allerding gibt es dafür noch keine Treiber, die vernünftig mit VDR laufen. Sobald sich da etwas tut dürfte das auch eine hochinteressante Karte werden.


    Falk

    Ich möchte einen Versuch starten, einen VDR basierend auf der jeweils neuesten Software aufzubauen. Da ich nicht viel Ahnung von C++ habe, hoffe ich auf eure Hilfe. Vielleicht kann sich daraus eine neue Step by Step - Anleitung für einen HDTV - VDR entwickeln. Ich bin gerne bereit, alles zu protokollieren und dann zusammen zu schreiben.


    Zur Zeit betreibe ich einen VDR 1.7.0 mit folgender Hardware:
    - Intel Board
    - 1x Technotrend FF DVB-S Karte
    - 1x Tevii S470 DVB-S2
    - 1x Reel extension HD


    An Software läuft darauf:
    - VDR - 1.7.0 + Zulu's Ext72 Patch
    - reelbox Plugin
    - weitere Plugins: osdpip, osdteletext, fritzbox, graphtft, femon, tvonscreen


    Mein neuer Versuch besteht bis jetzt aus
    - VDR 1.7.8 + modifizierter Ext72Patch
    - vdr-reelbox patch aus Zulus Ext72
    - reelbox Plugin aktuelle svn Version
    - reelbox svn12673- patch


    Die VDR patches liefen durch, vdr lässt sich auch übersetzten. Der Patch des Reelbox - Plugins läuft auch ohne Probleme, allerding klappt die Übersetzung nicht:


    In file included from reelbox.c:29:
    ReelBoxDevice.h:43: error: expected class-name before '{' token
    make[1]: *** [reelbox.o] Fehler 1


    Was ist da jetzt falsch?
    Falk

    Hallo Allerseits,


    habe inzwischen herausgefunden, dass das Problem nicht mit der Tevii - Karte zusammen hängt. Deshalb Fehlerbeschreibung erstmal gelöscht


    Falk

    Quote

    denke mal die neue ehd ist hinn läuft ohne extra kühler fast gar nicht
    und mit kommt nach 10 minuten oder auch mal 3 stunden der fehler


    Ich hatte mal ein ähnliches Problem. Ohne Zusatzkühlung durch einen Lüfter stürzte die eHD nach 10 ... 30 Minuten ab und war nur durch Strom aus/ein wieder zum Leben zu erwecken. Mit Zusatzkühlung lief sie tagelang stabil.


    Ich hab meine eingeschickt und beim 2. Versuch wurde sie ausgetauscht. Nun läuft sie auch ohne Zusatzkühlung.


    Scheinbar haben einzelne Karten ein thermisches Problem. Oder du hast meine bekommen ;)


    Falk

    Das DD 5.1 was anderes ist, weiss ich auch.


    Das Problem ist genau das, was ich in meiner 1. Nachricht beschrieben habe. Wenn ich Programme umschalte, nutzt VDR bei allen Kanälen, die DD 2.0 oder DD 5.1 senden auch brav die DD Tonspur, während er nur bei dem Sender "Das Erste" stur auf stereo (nicht DD 2.0) wechselt. Manuell kann ich wählen zwischen Stereo und DD 2.0.


    Er soll halt entspechend seiner Einstellung immer, wenn vorhanden die digitale Tonspur nutzen.


    Falk

    Hallo,


    ich habe bei meinem VDR 1.7.0 eingestellt "Digitalton benutzen: Ja", was soweit auch funktioniert. einzige Ausnahme schein "Das Erste" zu sein. Immer wenn ich auf das Programm wechsle, geht VDR auf den Stereo Ton. Ich kann dann über Menü-Audio wieder auf dd 2.0 umstellen und alles ist gut. Nur leider beim nächsten Umschalten kommt wieder "Stereo" statt DD 2.0.


    Bei allen anderen Sendern, die permanent DD senden (SAT1, RTL, PRO7, ZDF) gibt es dieses Problem nicht.


    Was kann man da machen?


    Falk

    Quote

    modprobe dvb_ngene
    FATAL: Error inserting dvb_ngene (/lib/modules/2.6.30-gentoo-r2/extra/dvb-ngene.ko): Unknown symbol in module, or unknown parameter (see dmesg)


    Das sieht so aus, als hättest du die Header des Kernels verwendet, aber nicht die original DVB - Module des Kernels, sondern v4l-dvb oder s2-liplianin.


    Der ngene Treiber läuft ausschließlich mit den DVB - Modulen die mit dem Linux - Kernel kommen.


    Falk

    So, ich habe jetzt noch einmal auf einem anderen System gestestet. Im Zusammenspiel mit Kaffeine scheint der Treiber ganz gut zu laufen. Jedenfalls kommen keine Fehlermeldungen.


    Sobald aber VDR auf die Karte zugreift, gehen die Probleme los und es hagelt die Fehler, die ich früher schon gepostet habe. Da aber VDR mit anderen Treibern nachweislich gut zusammenarbeitet, kann es eigentlich nur so sein, dass der Treiber auf Anforderungen von VDR falsch reagiert und damit die Probleme verursacht.


    Falk

    Quote

    Original von rjkm


    Ja, den muss man anschliessen. PCIe kann keine zwei LNBs mit Strom versorgen ...


    Wenn man den nicht anschliesst bekommt der LNBH-Baustein übrigens keinen Strom. Der liegt auf I2C-Adresse 0x0b und 0x08!


    Wäre natürlich schon nicht schlecht, wenn man so etwas als Käufer nicht nur durch Zufall erfährt.


    Falk