Posts by whiterussian

    Naja; erstmal den monitor, bzw fernseher mittels testbild ( http://www.burosch.de ) richtig einstellen.


    In standard konfigurationen sind oft kontrast, schärfe und grün wert übertrieben....
    und ganz wichtig 50 hz zuspielung uber xorg.conf erzwingen....hab hier zwei lg`s mit und ohne 100hz, mit richtiger xorg.conf ist 100hz aus....
    wenn der monitor/fernseher 50 hz kann, ist das ergebniss zu vergleichen mit meiner alten röhre


    mfg

    #!/bin/bash
    mkdir /var/lib/video.00/Iso
    cd /var/lib/video.00/Iso
    rm -r dvd
    dvdbackup -M -i/dev/sr0 -odvd
    genisoimage -dvd-video -o $(ls dvd/)-full.iso dvd/
    rm -r dvd


    erzeugt auch gleich eine iso, falls nicht gewünscht die beiden letzten zeilen auskomentieren


    hab da im howto bereich mal was geschrieben, wie man voll, bzw. nur den hauptfilm mit dvdbackup und lxdvdrip einließt und shrinkt(hauptfilm)
    muss das irgendwann mal überarbeiten, sind ein paar kleine fehler und cruxen drin.

    Wenn ich die wareagle Symbole über das OSD abschalte hat dies keinerlei Auswirkung.
    Hintergrund ist, dass ich gerne das skinelch nutzen würde, aber diese damit nicht zurecht kommt.
    Soll heißen ich sehe nur Quadrate anstatt von Symbolen, das hatte ich auch bei tobis extension vdr schon, wareagle abschalten war damals der weg zum erfolg.
    Über die Setup.conf gehts im übrigen auch nicht.
    PearlHD ist halt für meine Augen zu klein. So weit ich weis kann man ja die Schriftgröße von PearlHD nur beim kompilieren beeinflussen, oder gibts da Tricks?


    Hat jemand ne idee dazu?


    Grüße gurke2009

    Mit mit dem AMD board zu Spdif, bzw testwiese auch durchgeschleift zur 9500Gt.


    root@vdr-basti-org:~# aplay -l
    **** Liste von PLAYBACK Geräten ****
    Karte 0: SB [HDA ATI SB], Gerät 0: ALC889A Analog [ALC889A Analog]
    Untergeordnete Geräte: 1/1
    Untergeordnetes Gerät '0: subdevice #0
    Karte 0: SB [HDA ATI SB], Gerät 1: ALC889A Digital [ALC889A Digital]
    Untergeordnete Geräte: 0/1
    Untergeordnetes Gerät '0: subdevice #0


    root@vdr-basti-org:~# aplay -L
    default:CARD=SB
    HDA ATI SB, ALC889A Analog
    Default Audio Device
    front:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Analog
    Front speakers
    surround40:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Analog
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Analog
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=SB,DEV=0
    HDA ATI SB, ALC889A Digital
    IEC958 (S/PDIF) Digital Audio Output
    null
    Discard all samples (playback) or generate zero samples (capture)


    in config geändert, funktioniert mit xine und xineliboutput


    audio.output.speaker_arrangement: Pass Through
    audio.device.alsa_passthrough_device:iec958:AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2
    audio.device.alsa_front_device:plug:iec958


    dd 5.1 und stereo über spdif funktionieren , über hdmi kann ich nur stereo ausgeben (mein Fernseher).
    xbmc hab ich noch nicht probiert.
    gruß gurke 2009


    EDIT: pcm.!default iec958:SB funktioniert hier.
    bin mir allerdings nicht sicher ob ich in der /var/lib/vdr/.xine/config die default werte wieder hergestellt habe


    audio.output.speaker_arrangement: Pass Through <= muss gesetzt sein, ist das default so?
    audio.device.alsa_front_device:plug:front:default
    #audio.device.alsa_passthrough_device:iec958:AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2

    Funktioniert hier für SD besser als Lenny+Tobi VDR.
    DANKE!
    Habe lirc über euer Web-interface gesetzt und musste autoserial.conf auch anpassen, fürn seriellen empfänger.
    Vieleicht intigriert ihr irgendwann noch einen Auswahldialog für xorg.conf datein, kein Gemecker sondern bloß ne idee.
    Für ne 9500Gt an einem LG32LH2500 full-hd muss man hier z.b. etwas tricksen um 50Hz zu erhalten.


    /etc/X11/xorg.conf.yavdr


    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder63) Tue Oct 20 21:01:12 PDT 2009


    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Oct 20 21:00:15 PDT 2009


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection


    Section "Files"
    EndSection


    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection


    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "LG TV"
    HorizSync 30.0 - 83.0
    VertRefresh 58.0 - 62.0
    Option "DPMS"
    # 1920x1080p @ 50Hz (EIA/CEA-861B)
    ModeLine "1920x1080@50" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    EndSection


    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 9500 GT"
    Option "ModeValidation" "DFP-2:AllowNon60HzDFPModes, NoMaxSizeCheck, NoPredefinedModes, NoDFPNativeResolutionCheck, NoHorizSyncCheck,NoVertRefreshCheck "
    Option "UseEvents" "True"
    Option "UseEdidFreqs" "False"
    Option "UseEDIDDpi" "FALSE"
    Option "ExactModeTimingsDVI" "True"
    Option "RenderAccel" "true"
    Option "OnDemandVBlankInterrupts" "true"
    EndSection


    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1920x1080@50"
    EndSubSection
    EndSection


    Ergibt 1080p


    Gruß gurke2009

    Die Skripte die ich hier gefunden hab um DVDs zu Vdr zu rippen haben bei mir nicht wirklich zufriedenstellend funktioniert.


    Deshalb hab ich ein wenig gegoogelt, hier und dort etwas zusammen geklaut und mit meinen rudimentären Shell wissen zusammen gefriemelt.


    Herausgekommen sind zwei kleine Shell-Skripte, die nur den Hauptfilm einer DVD oder die gesamte DVD in eine Iso Datei umwandel, welche man dann mittels vdr-sxfe anschauen, mittels Filebrowser-plugin brennen oder im falle einer kompletten dvd zur weiteren Bearbeitung auf USB-Platte kopieren kann.


    Ich rufe alles mit dem Filebrowser-plugin auf, da es mir die Ausgabe der Shell anzeigt, einen einfachen weg bietet bei bedarf die Skripte zu killen und ich nicht weis wie ich die Variabel zu brennen sonst übergeben sollte.


    Code
    apt-get install lxdvdrip dvdbackup mkisofs


    /etc/lxdvdrip.conf anpassen


    /usr/bin/rip.sh erzeugen


    /usr/bin/ripfull.sh erzeugen


    /usr/bin/burn.sh erzeugen

    Bash
    #!/bin/bash
    growisofs -dvd-compat -use-the-force-luke -Z /dev/dvd=$name ;
    OUT=$?
    if [ $OUT -eq 0 ];then
       svdrpsend.pl MESG "DVD brennen erfolgreich"
    else
       svdrpsend.pl MESG "DVD brennen fehlgeschlagen"
    fi
    exit 0


    burn.sh rip.sh ripfull.sh ausführbar machen

    Code
    chmod +x /usr/bin/rip.sh
    chmod +x /usr/bin/ripfull.sh
    chmod +x /usr/bin/burn.sh


    in /etc/vdr/plugins/filebrowser/commands.conf einfügen

    Code
    Rip Hauptfilm:*:sh /usr/bin/rip.sh:r
    Rip Komplett:*:sh /usr/bin/ripfull.sh:r
    Burn:*:name=%f ; export name ; sh /usr/bin/burn.sh:r


    in /etc/vdr/plugins/filebrowser/othercommands.conf einfügen

    Code
    Burn
    Rip Hauptfilm
    Rip Komplett


    Nach einem /etc/init.d/vdr restart sollte es gehen


    Anmerkung: lxdvdrip.conf muss natürlich den eigenen Gegebenheiten angepass werden
    lxdvdrip erzeugt .img Dateien, welche aber scheinbar eine .iso konforme Struktur haben, weshalb einfaches umbenennen reicht.
    EDIT: ich benutze übrigens Debian Lenny mit e-tobi paketen
    /dev/sr0 und /var/lib/video.00/Iso müssen auch den eigenen Gegebenheiten angepasst werden.
    Lxdvdrip shrinkt den Hauptfilm übrigens auch, so dass er auf eine dvd-5 passt.

    guten abend.
    da ich für einen rückelfreien betrieb von e-tobis vdr unter ubuntu 9.04 auf die xineliboutput version 1.0.4-1 zurück musste, habe ich mir dieses packet aus den quellen gebaut.
    ist es möglich, apt mit zu teilen, dass man gerne das packet 1.0.4-1 anstatt 1.0.4+cvs20090826.1640
    von e-tobi laden würde?
    denn von hand laden,debianizieren,patchen,bauen hab i jetzt durch und so wäre es halt schöner.
    tante google und apt-get source -h haben mir nicht weiter geholfen.


    MfG Knopel

    Ich werde die nächsten tage das system aller hier befindlichen (mittlerweile vier) vdr's neu aufsetzen.


    nun meine Frage.


    Wie stabil läuft xbmc mit debian lenny?
    Der vdr soll nach wie vor als solcher über xineliboutput für das was er am besten kann zuständig sein.
    Halt als vdr.
    Aber ich habe vorallem das bedürfniss nach einer lösung zum anschauen von bildern und einer etwas komfortableren bedieneung für die musikwiedergabe.
    Es würde also auf einen paralellen betrieb hinaus laufen und nich auf die aktuell angestrebte verknüpfung von xbmc und vdr.
    Offiziel unterstützt ist ja wohl eigentlich ubuntu, wobei ich da wiederum nicht weiß wie stabil der vdr läuft, benutze diesen hier nur gelegentlich auf meinem Laptop, mit hannos repo......



    und noch eine frage ist die hud ausgabe von xineliboutput eigentlich nur mit compitz u co möglich, oder geht das auch ohne weiteren windowmanager? geht halt um ein gleichbleibend großes osd...


    mfg Knopel256


    PS: es geht ausschließlich um sdtv ohne vdpau........

    Schaut mal unter lsmod wie das geladene modul genau heißt.
    ich glaube cx88-dvb.
    Wenn ihr den vdr nun ausschaltet (etc/init.d/vdr stop) und mit modprobe -r cx88-dvb und anschließend modprobe cx88-dvb das modul neu ladet und danach den vdr neustartet (etc/init.d/vdr start) dürfte die karte erkannt werden.


    das müsst ihr dann nurnoch bei jedem start machen lassen z.b. /etc/rc.local
    z.b.
    ==========================================================
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    modprobe -r cx88-dvb
    modprobe cx88-dvb
    exit 0
    ======================================================


    geht hier in 3 systhemen


    mfg knopel


    edit:
    hab gerade erst mitbekommen, dass das bei euch nur beim neustart, der vdr-software auftritt.
    (/etc/init.d/vdr restart ?)
    wenn dem so ist, dann tragt doch in die commands.conf : modprobe -r cx88-dvb && sleep 2 && modprobe cx88-dvb ein und gebt dem vdr per sudoers die autorität dies zu tun
    ====================================================================
    vdr ALL=NOPASSWD: /sbin/modprobe
    ====================================================================


    bei mir hat er die module halt bloß beim booten nicht richtig geladen


    hoffe, dass hilft

    Entschuldigung, habs abgeändert.
    Wie gesagt bin noch am lernen und so hat es hier halt ohne negative Nebeneffekte funktioniert.
    Gegen killall switch.sh ist doch nichts einzuwenden? Oder?


    Vielen Dank für die erklärungen...., Wirklich!

    Ich hatte bei irexec eine Konstellation entsprechend:
    Buton 1 = killall vdr-sxfe && mms -u vdr


    und


    Buton 2 = killall mms -u vdr && vdr-sxfe --lirc .......xvdr+tcp://localhost


    Das hat es als daemon mit gemacht, bloß mit dem erwähnten Effekt, das Vdr-sxfe sich mit erneutem Versuch expotential neu zu starten schien.
    Und ohne daemon musste ich halt den entsprechenden Prozeß mit killall beenden.


    gda: :unsch Tschuldigung... bin selber noch am lehrnen... mal ne blöde Frage: Wie stoppe ich den die Sache eleganter?

    Was passiert den bei dir was nicht gewollt war?
    Hier gehts so problemlos..
    ##### bin beim Probieren nen paar mal in komischen Schleifen gelandet.
    irexec? Keine Ahnung ich muss es danach jedes mal neu starten und als irexec -d /etc/lirc/lircrc hatte es so nette Effekte wie Vdr-sxfe beim 1. Aufruf ein mal starten, beim 2. 2 mal und beim 3. 4mal .......
    Deswegen dieses Script.

    So ich hab mich nun zum ersten mal "ernsthaft" mit der Bash beschäftigt und hab nun folgende Lösung.


    Dazu ein paar Erläuterungen:
    Das schaltet jetzt je nach dem, was beendet wurde zwischen MMS und Vdr in einer Endlosschleife um.
    Ich benutze irexec damit ich wenn vdr-sxfe mal hängen sollte, die Ausgabe, sprich den gesammten Fluxbox, neu starten kann.
    Das funktioniert hier aber nur einmalig, weswegen ich Lirc und damit irexec jedesmal danach neustarten muss.
    In /etc/vdr/vdr.default muss


    Quote

    OPTIONS="-w 60 --lirc=/dev/null"


    stehen, damit wenn vdr-sxfe beendet ist, der Vdr nicht auf Lirc reagiert und so MMS mit Lirc gesteuert werden kann.


    Starten tuhe ich den Vdr nun mit dem Befehl in der:
    /home/(Benutzername)/.fluxbox/init


    Quote

    session.screen0.rootCommand: sh /scripts/switch.sh



    Welcher das Srcipt:
    /scripts/switch.sh



    aufruft.


    In /etc/vdr/command-hooks/commands.custom.conf steht zusätzlich


    Quote

    MS starten:sh /scripts/vdr-mms.sh


    /srcipts/vdr-mms.sh


    Quote

    #!/bin/bash
    sudo killall -9 vdr-sxfe
    exit 0


    und in /etc/mms/Config


    Quote

    shutdown_script = sh /scripts/mms-vdr.sh


    /scripts/mms-vdr.sh


    Quote


    #!/bin/bash
    sudo killall -9 mms
    exit 0


    In der /etc/lircrc und /home/(Benutzername)/.lircrc



    in der /scripts/kill-switch.sh


    Quote


    #!/bin/bash
    sudo killall -HUP fluxbox
    sudo killall switch.sh
    exit 0


    Alles Sripcte müssen mit

    Quote

    chmod +x script.sh


    ausführbar gemacht werden.