Posts by lotan_rm

    Ich hatte mit folgenden Veränderung an den vier Progressbar Symbolen Erfolg:


    - Hints/Autohint
    - rechte äußere Hint-Grenze 10 Punkte nach rechts versetzt


    Keine Ahnung, ob da aus Font-Design-Gesichtspunkten quatsch ist, schafft aber bei mir schöne fließende Übergänge beim Progressbar trotz eingeschaltetem Anti-Aliasing.


    Generierter Font ist leider zu groß zum Anhängen.

    Ich hatte mir die einfachen und doppelten Rahmen-Symbole von ein paar Fonts in Fontforge angeschaut und festgestellt, daß die teilweise 20 unter 0 und 20 über die eingestellte Breite des Zeichens hinausragen (zumindest so meine Interpretation).


    Ich hatte dann versucht, diese Erkenntnis mit den Progressbar-Symbolen entsprechend nachzuahmen. Leider ohne Erfolg (die Abstände der Progressbar-Symbole waren dann nur unregelmäßig).


    Ich schreibe das hier nur, weil ich nach Trial & Error vorgegangen bin. Ich habe keine Ahnung von Font-Design (ich weiß nicht mal die Einheit der oben beschriebenen 20 unter-/überragen). Vielleicht kennt sich hier aber jemand anders ein wenig mehr mit Fonts aus und kann die Progressbar-Symbole selbst bei eingeschaltetem Anti-aliasing verbunden aussehen lassen.

    Unter folgenden Vorraussetzungen:


    - vdr-nordlichtsepg-0.9-test1.tgz
    - vdr-nordlichtsepg-0.9-test1-utf8fix.diff
    - vdrsymbols-ttf-20080415.tgz


    verbessert folgender Patch bei mir die Ausgabe des Progressbar.


    Perfekt ist das Ganze aber noch nicht, da immer noch Abstände zwischen den Symbolen angezeigt werden.


    Ich könnte mir vorstellen, dass der Font vielleicht noch ein bisschen angepasst werden muss.

    Hallo,


    mein Problem:


    beim Umschalten von Kanälen bleibt mein VDR System "stecken" und zeigt "No Signal" an. Die Menüführung des VDR reagiert dann weiterhin, eventuelle Aufnahmen werden ebenfalls weiter fortgesetzt aber auch ein weiterer Kanalwechsel bringt kein Bild mehr.


    Nach eingängigem Lesen in diesem Forum habe ich zwei neuralgische Punkte in meinem System entdeckt, die auch schon bei anderen Probleme verursacht haben:


    [list=1]
    [*]meine DVB-S Karte: Technisat Skystar2
    Ich habe gelesen, dass es in früheren Kernelversionen probleme mit dem "Sleep Mode" gegeben haben soll, ich benutze gerade die Kernel-Version 2.6.22.1.
    Ich vermute aber, dass es eher weniger am Treiber liegt, da eventuelle die Aufnahmen ja funktionieren.
    [*]Plugin: VDR-Xine (0.7.11)
    Von der Bedienung und den Fähigkeiten ist das Plugin mein absoluter Favorit, aber ich habe schon von einigen Problemen im Zusammenhang mit diesem Plugin hier im Forum gelesen.
    [/list=1]
    Ansonsten hat mein VDR die Version 1.4.7 und ich habe das ganze auf einer Gentoo Distribution aktuellen Datums laufen.


    Meine Vermutung ist, dass sich vielleicht irgendein Task, der den Stream für xine versorgt aus irgeneinem Grund aufhängt.
    Leider kenne ich mich im VDR Code zu wenig aus, um nachzuprüfen, ob das überhaupt sein kann.


    Deshalb, zu meiner hauptsächlichen Frage:
    Kann mir jemand von Euch eine Empfehlung zur Herangehensweise an dieses Problem empfehlen?


    Ich habe im System Log keine Fehler direkt nach dem "steckenbleiben" gefunden. Die letzte Meldung vor dem steckenbleiben ist typischweise folgende:

    Code
    vdr: [26020] TS buffer on device 1 thread started (pid=17625, tid=26020)


    Nach dem Umschalten macht diese Meldung für mich Sinn.


    Andere Meldungen, die mir nicht so ganz gut erscheinen tauchen zwar ab und zu auf, aber mit denen kommt scheint der VDR wohl zurechtzukommen, z. B.:

    Code
    vdr: [17625] cTS2PES got 0 TS errors, 1 TS continuity errors
    
    
    vdr: [6655] buffer usage: 100% (tid=6654)
    vdr: [6564] closing SVDRP connection


    Auf der VDR Konsole konnte ich leider genausowenig finden wie bei der Xine-UI Konsolenausgabe, wobei das nicht so viel heissen soll, da es gut sein kann, dass sich ein möglicher Fehler schon aus dem sichtbaren Bereich gescrollt hat bis ich da bin.


    Vielen Dank im Voraus für Eure Tips!