Posts by enouk

    Hallo,


    ich hab mal eine kleine Test und Vergleichsreihe mit verschiedenen Kartenkombinationen gemacht. Details sind unten. Alle Test wurden unter gleichen Bedingungen (RAID im Sleep-Modus, keine Aufnahme, Stream, ect ) durchgeführt.


    Fazit bisher für mich:
    - Zwischen den einzelnen Revision habe ich keinen Unterschied messen können. Hier scheint der von shf erwähnte Softwarefilter bei der Rev 1 keine Rolle zu spielen.
    - Jede Sat Karte verbraucht ohne laufendem VDR bei geladenen Modulen ca. 4 Watt.
    - Sobald der VDR läuft kommt der Prozessor fast nie in den C3- Status. In Folge dessen steigt der Verbrauch um weitere 6 Watt.
    - In Summe verbraucht eine Sat Karte also 10 Watt bei laufendem VDR.
    - Werden mehrere Karten gleichzeitig betrieben, so erhöht sich der Verbrauch entsprechend, jedoch nicht linear. 4 Karten brauchen zusammen im Leerlauf 16 Watt - mit laufendem VDR 31 Watt. Dies ist nach meiner Meinung nicht verwunderlich, denn der Prozessor ist schon bei einer Karte kaum noch im C3.
    - Der VDR "macht" irgendetwas permanent mit den Karten. Der VDR-Verbrauch ohne Karten ist minimal.
    -Das Abschalten der EPG-Suche und des Channelscans brachte bei mir keine meßbaren Unterschiede.


    Eigentlich müsste man die dem VDR anzulastenden 15 Watt per Software einsparen können. Eventuell durch automatisches VDR Stop wenn keine Aufnahme läuft. Dann müsste er nur manuell bei Bedarf gestartet werden (nicht gut).
    Oder der VDR kappt die Kartennutzung, wenn Sie nicht gebraucht wird (nur wie?).


    Morgen installiere ich mal den VDR ohne jegliche Plugins und schaue mal ob da nicht irgendetwas zwischen funkt, bzw. ich versuche mal einen VDR <1.7. Den VPS-Scan habe ich noch nicht getestet, der könnte auch noch eine Ursache sein.


    Vielleicht könnte mal jemand mit einer anderen Karte als der Skystar nach dem Powertop schauen und sagen ob es hier wesentliche Unterschiede gibt.



    _______________Messungen
    Kein VDR ohne Sat-Karten, keine DVB-Module IDLE -Stromverbrauch 55 Watt


    VDR läuft ohne Sat Karten, keine DVB-Module laut LSMOD, IDLE -Stromverbrauch 56 Watt


    Kein VDR, eine Sky-Star2 2.6 B, DVB-Module geladen, IDLE -Stromverbrauch 60 Watt


    VDR läuft, eine Sky-Star2 2.6 B, DVB-Module geladen, IDLE -Stromverbrauch 66 Watt

    Quote

    Original von SHF
    Die 14W Mehrverbrauch werden Grösstenteils auf das Konto der DVB-Karten bzw. des LNB gehen.
    Was hast du denn da genau angeschlossen (Kartentyp & Anzahl, LNB / Mutischalter, ...)?


    Die 4 Satkarten hängen an einem Multischalter (Digisat 9016N)
    3x Technisat SkyStar2 DVB card (rev 01)
    1x Technisat SkyStar2 DVB card (rev 02)


    Quote

    Original von SHF
    Bei den Karten mit b2c2_flexcop-Chip ist auch die Chip-Revision wichtig. Bei den ersten Revisionen funktioniert der Hardware-PID-Filter nicht richtig, daher wird der komplette Transponder übertragen und dann per Software gefiltert.
    Die Datenrate auf dem PCI-Bus dürfte damit ungefähr 3-4 mal so hoch sein wie bei einer mit Hardware-PID-Filter.
    Ob das allerdings einen Unterschied beim Stromverbrauch macht kann ich nicht sagen.


    Das mit der Softwarefilterung war mir neu. Das wird natürlich bei 3 Karten einen ganz nette Busbelastung erzeugen. Ich werde mal die Karten bischen hin und her tauschen und gucken, was passiert wenn nur die rev 02 drin ist, bzw. nur die rev 01.


    Wie sieht den bei Euch der Powertop aus, wenn andere Satkarten verbaut sind?


    Gruß Enouk

    @all, danke, irgendwie rätsele ich immer noch.


    lexi , die platten schlafen, laut powertop sind es Zugriffe auf die Tunerkarten.


    gda Bei den Treibern tut sich nicht viel:
    VDR ist mit /etc/init.d/vdrdevel gestoppt:


    Code
    1. lsmod | grep b2c2_flexcop
    2. b2c2_flexcop_pci 2875 0
    3. b2c2_flexcop 17393 1 b2c2_flexcop_pci
    4. dvb_core 61563 2 stv0299,b2c2_flexcop
    5. cx24123 9399 1 b2c2_flexcop
    6. cx24113 5128 1 b2c2_flexcop
    7. s5h1420 8045 1 b2c2_flexcop
    8. i2c_core 11900 7 dvb_pll,stv0299,b2c2_flexcop,cx24123,cx24113,s5h1420,i2c_i801


    Beim Start des VDR ist der einzige Unterschied in Zeile 2 zu finden:

    Code
    1. lsmod | grep b2c2_flexcop
    2. b2c2_flexcop_pci 2875 31
    3. b2c2_flexcop 17393 1 b2c2_flexcop_pci
    4. dvb_core 61563 2 stv0299,b2c2_flexcop
    5. cx24123 9399 1 b2c2_flexcop
    6. cx24113 5128 1 b2c2_flexcop
    7. s5h1420 8045 1 b2c2_flexcop
    8. i2c_core 11900 7 dvb_pll,stv0299,b2c2_flexcop,cx24123,cx24113,s5h1420,i2c_i801


    Wenn ich das richtig verstehe, wird das Modul nicht entladen, jedoch
    nicht mehr genutzt (läuft ja auch kein vdr).


    Aber used bei 31: Ist das nicht ein bischen viel?
    gda : Ist das das was Du meinst?


    Und hier noch eine Ausgabe von powertop mit vdr:

    und ohne vdr:


    Verhält sich der VDR und powertop bei Euch ähnlich?


    Gruß Enouk

    gda : Danke für die Antwort. So ganz verstehe ich das nicht oder ich stell mir das gerade ganz falsch vor ;-).


    Wenn ich den vdr stoppe und alle anderen Dienste weiterlaufen lasse, verschwinden die Interrupts im powertop und der Verbrauch geht um 13 Watt runter.


    Ich dachte, dass wären Softwareinterrupts, im Gegensatz zu Hardwareinterrupts, die vom Programm gesetzt werde, ähnlich wie bei Raidzugriffen etc. Beim Resync der Platten steigt das Ganze auf über 10000 an und weckt mir den gerade gut eingeschlafenen Prozessor aus seinem C3 Schlaf auf (soweit meine laienhafte Vorstellung).


    In einigen Stellen wird das Reduzieren dieser Interrupts als wesentliches Kriterium zum Energieoptimieren beschrieben und als erreichbares Ziel <10/sek angegeben. Mit ca. 1300/s durch den VDR liegt das ganze deutlich drüber. Ohne VDR komme ich zu Zeit auf etwa 80/s.


    Gruß Enouk

    Hallo,


    ich optimiere zur Zeit den Stromverbrauch meines Servers.


    Einiges hat ganz gut gegriffen: Spin-Down der Datenplatten, Ausbau der Grafikkarte, deaktivieren von USB und allem unnötigen auf dem MB, entfernen aller nicht benötigter Software. Im Leerlauf bin ich dadurch von Anfangs 130 Watt auf jetzt 70 Watt runter. Letzte grosse Baustelle ist anscheinend der VDR selber.


    Mit laufendem VDR verbraucht der Server 14 Watt mehr. Hauptursache ist wohl, daß der Prozessor kaum noch in den C3 kommt.


    Powertop meldet > 2000 Interrupts/sek:


    (2040,5) <interrupt> : ahci, Technisat/B2C2 FlexCop II/IIb/III Digital TV PCI Driver
    (469,2) <interrupt> : Technisat/B2C2 FlexCop II/IIb/III Digital TV PCI Driver


    Ich vermute mal, daß der VDR irgendetwas ständig mit den Satkarten am machen ist. Hat jeman einen Tipp, wie ich die Interrupts reduzieren kann, ohne dabei die Funktionalitäten zu beschneiden (EPG ...)


    Gruß Enouk

    Quote

    Original von cjhbabel
    Wenn die Satkarten wirklich zwischen 15-20W


    Glaube nicht, daß es so viel ist, das wären bei mir 60-80 Watt bei 4 Karten. Da bleibt nicht mehr viel für den Rest übrig (118 Watt bei 8 Platten + 4 GB RAMM). Ich schrub die nächstes WE mal raus und messe mal den Unterschied.

    Wie sieht es eigentlich mit dem Einsparpotential bei DVB-S-Karten aus? Ich habe 4 Skystar im Rechner die ziemlich heiß werden (aber auch ziemlich gut funktionieren). Har schonmal jemand einen Vergleich, bzw. Hinweise zum Energieverbrauch gesehen?


    Gruß Enouk

    Danke TomG für die Mühe die Du Dir machst. Die 1.7.10 läuft bei mir ohne Probleme. Ich war von der Stabilität der Devel-Version angenehm überrascht, nachdem ich vor drei Wochen vom eTobi-VDR umgestiegen bin.


    Was schön wäre, wenn XXV mit aktualisiert wird. Die 1.1.4 mit der aktuellen SSV läuft ganz gut mit der 1.7.X zusammen.


    Viele Grüße
    Enouk

    @xnalph + gda : Danke für die Infos.


    vdr-sxfe hab ich bisher immer für meine USB-Boot Geschichten genutzt. Funktioniert ziemlich gut. Beim installieren des Debians gestern abend war der Bildaufbau in der Box ziemlich langsam. Bin mal auf heute Abend gespannt, wenn ich den vdr installiere. Ich konnte mir gestern nicht vorstellen, daß die Anzeige für eine Videowiedergabe schnell genug ist.


    Btw: Müsste es nicht möglich sein, ein Virtualbox Image mit VDR-Client zu erzeugen und für jedermann online zu stellen, oder spricht da etwas dagegen? (Ausser das einem der Bastelspass entgeht)


    Gruß Enouk

    Quote

    Original von killajoe
    VirtualPC will bei mir nicht mal vom TFTP-Server ein Image ziehen. Geschweigedenn sich überhaupt ne IP per DHCP zuweisen lassen. Das ist aber auch ein Mist :schiel


    Wie schauts denn mit ner Samba-Freigabe aus? Kann man Schnittmarken vom VDR auch mit ProjectX einlesen und abspeichern?


    Ich habe gestern VirtuaPC ohne Probleme mit einer Debian Lenny CD im Netz zum laufen gebracht. Ich gehe aber mal davon aus, dass die Grafikausgabe zu langsam ist um dann damit zu schneiden. Ich teste es heute abend mal.



    Es gibt einige Howtos über das Bearbeiten von VDR-Aufnahmen mit ProjectX. Immer läuft das darauf hinaus, daß Du die Aufnahme erstmal demuxen musst.


    Nach meiner Meinung ist das alles viel zu umständlich und langwierig im Vergleich zum Bearbeiten mit dem VDR.


    Ich habe es mal eine Weile per Linux-Boot-USB Stick gemacht und dann zum Schneiden einen der Windows-Rechner halt unter Linux gebootet. Das ging ganz gut und ich konnte wenigstens verschiedene Rechner damit nutzen. Ich werde mir am nächsten Wochenende mal einen aktuellen Stick machen. Hierzu gibt es ja hier im Forum wirklich hervorragende Anleitungen.


    Man merkt halt, daß der VDR nicht unbedingt als ein Client-Server System ausgelegt ist und es schon etwas frickelig wird wenn den VDR als Server mit n Windows-Clients betrieben wird und der Server über keine Grafikkarte verfügt.


    Gruß Enouk

    Quote

    Original von killajoe
    Hi,



    Also das muss ich unbedingt mal versuchen. EinVMware-Image müsste doch tun.



    Dann meinte ich das in meinem Post weiter oben ;)


    Hallo,


    killajoe
    und schon ausprobiert, funktioniert es?


    Kann man priniziell mit Virualbox oder Vmware einen VDR-Client unter Debian auf einem Windows-Rechner einrichten, der dann zum schneiden der Videos mißbraucht wird, oder spricht da etwas dagegen. Hat das schonmal jemand zum laufen bekommen?


    Gruß Enouk

    Aktuell scheint wohl die 1.4 zu sein, die noch nicht Einzug in e-Tobi gefunden hat. So wie ich die Änderungen verstehe, werden TS-Files noch nicht unterstützt aber ansonsten sind viele schicke Änderungen gegenüber der 1.2. gemacht worden.


    Hat das vielleicht schon jemand die 1.4 mit den letzen SVN laufen und kann etwas über die Kompatibilität zu 1.7 sagen? Ansonsten werde ich in den nächsten Tagen mal mein Glück versuchen.


    Was micht wundert ist, daß es um Tools wie xxv, vdradmin, live etc. so ruhig ist. Gibt es so wenig Leute die einen VDR-Server im Keller betreiben und dann mit mehreren Windows-Clients unabhängig darauf zugreifen? Oder gibt es für den Fall bessere Lösungen?


    Gruß Enouk

    Hallo,


    ich hab mich an VDRDEVEL 1.7.9 gewagt und war angenehm überrascht wie stabil und einfach es lief. Danke an Klaus und alle Beteiligten.


    XXV läuft anscheinend soweit zusammen mit der 1.7.9, nur die neuen TS-Aufnahmen werden nicht angezeigt. Gibt es da schon eine Lösung oder eine Alternative zu XXV?


    Danke + Gruß Enouk

    Hallo,


    ich habe das ipacks Problem mit der gleichen Fehlermeldung auch:


    mit der 1.7.9-1devel1 und vdrdevel-plugin-ffnetdev bleibt das Bild nach 2 Sekunden hängen. OSD funktioniert weiter, mehr aber nicht.


    mit 1.6.0-11 und ffnetdev 0.1.0+svn20071201.1427-8 läuft es ohne Probleme.


    VLC ist jeweils 1.0.1.


    Hat jemand einen Tipp, bzw. eine Lösung dafür gefunden?

    Quote

    Original von holymoly
    moin,
    laeuft das bei euch noch fehlerfrei ?
    Bekomme hier

    Code
    1. parsing ..
    2. Unexpected element <data>...


    mfg


    Hallo,das gleiche bei mir, abo ist aber ok.
    Hat jemand das Problem schon gelöst oder war das nur eine "zeitweilige Störung"?


    Viele Grüße
    Enouk

    Hallo,


    gibt es hier etwas neues?


    sigiberlin : Hast Du das - und nun - schon beantwortet?
    Bei mir sieht die Ausgabe identisch aus.
    Spielt die unterschiedliche Ausgabe utf8 utf-8 eine Rolle?
    Ich habe Lenny im Einsatz und komme mit der Gentoo-Anleitung nicht klar :(.


    Viele Grüße