Posts by kiwix

    Hi,

    ich bin mir nicht ganz sicher, aber ich glaube das Problem besteht schon länger und ich damals auch darüber gestolpert.


    Wenn der experimental VDR konfiguriert wird, dann kann man die deb Pakete ohne Probleme verwenden und dann ist es auch der 2.4er :)

    Das ist meine apt Quelle und damit wuppt mein debian stretch/e-tobi vdr einwandfrei in einem Proxmox Container:


    deb http://packages.e-tobi.net/vdr-experimental stretch base backports addons vdr-multipatch


    Und dran denken, in einem LXC muss der vdr als root laufen.

    cu

    kiwix

    Hallo zusammen,


    ich habe nach langer Zeit meinen Streaming Server umgebaut. Der vdr läuft jetzt in einem Linux Container (LXC unter Proxmox 5).


    Der vdr läuft (eTobi vdr-experimental / multipatch) mit streamdev und live plugin. Wenn ich aber xineliboutput aktiviere bekomme ich immer folgenden Fehler


    Sep 1 22:42:04 tv vdr: [636] ERROR: /usr/lib/vdr/plugins/libvdr-xineliboutput.so.2.2.0: undefined symbol: _Z13x_avahi_startiii

    Sep 1 22:42:04 tv vdr[636]: vdr: /usr/lib/vdr/plugins/libvdr-xineliboutput.so.2.2.0: undefined symbol: _Z13x_avahi_startiii


    Ich habe auf fehlende libaries getippt und avahi-daemon nachinstalliert, aber leider keine Besserung. Ich hätte das gerne am Laufen, damit ich im Live Plugin das OSD habe,


    Hat da jemand eine Idee?

    Danke und Gruß
    Kiwix

    Hallo zusammen,


    ich wollte hier nur kurz mal festhalten, dass sich anscheinend das shutdown Verhalten
    geändert hat. Mein VDR läuft als reiner Aufnahme und Streaming Server, so dass er
    immer anbleiben soll.


    Ich habe gestern auf meinem Ubuntu Server auf die yavdr testing Pakete aktualisiert.


    In der /etc/default/vdr fehlte der ENABLE_SHUTDOWN=0 Eintrag. Doof wie ich war,
    habe ich den einfach wieder hinzugefügt und prompt ist der Server nach 300 Minuten
    herunter gefahren.


    Also nehme ich jetzt mal an, dass der Eintrag ignoriert wird :-)


    Ich habe jetzt mal die beiden EInstellungen


    Code
    1. MinUserInactivity = 0
    2. MinEventTimeout = 0


    gesetzt. Ich hoffe das passt jetzt (kann ich nach dem Einkaufen wieder verifizieren :-)


    Ich schreibe das hier um


    a) das ggf. von einem Spezi verifizieren zu lassen und
    b) andere darauf hinzuweisen, damit die ggf. nicht überrascht werden.


    Grüße
    KiWiX

    Hallo,


    super! Das mit der Mail habe ich mir schon fast gedacht und freue mich, dass es dann mit der PN funktioniert habe.


    Ich hatte aber schon etwas Angst, dass Du das Interesse verloren hast, da der letzte Post vom Mai war.


    Bzgl. der tntlib, anbei mal die Informationen von meinem System. Wenn Du noch was benötigst, dann nur raus damit :-)


    Gruß
    Markus aka. KiWiX




    und zu guter letzte noch die Info aus yavdr - main - precise:


    Code
    1. tntnet 2.0+rev.1308-0yavdr0~precise

    Hallo zusammen,


    nur damit dieser Thread mal nicht in der Bedeutungslosigkeit verschwindet,
    auch wenn ich anscheinend der einzige bin, der das Plugin verwendet.


    Ich habe den Entwickler methodus am 2.10. per öffentlicher gmail
    Adresse um Hilfe gebeten und leider bis heute noch keine Antwort bekommen.
    Ich habe es gerade auch noch mal per PN probiert. Vielleicht meldet er sich ja.


    Zusätzlich habe ich mal auf diesen Thread hier im vdr-plugin Bereich verlinkt,
    vielleicht hat ja einer der ehemaligen Betatester noch einen Tipp.


    Gruß
    KiWiX


    PS: Weis einer ob/wie ich mir noch mal die ältere Version aus dem Launchpad
    herunterladen kann, damit ich zumindest immer mal wieder den upnp Dienst
    hier mit meinen Clients weiter testen kann?

    Hallo,


    ach jetzt sehe ich das auch. Das ist aber verwirrend:


    Code
    1. [FULLYBUILT] amd64 build of vdr-plugin-upnp 1.0.0.git20130307-0yavdr8~precise in ubuntu precise RELEASE
    2. Build started on 2013-09-05 on louvi (virtual64) and finished on 2013-09-05 taking 5 minutes — see the log
    3. [FULLYBUILT] amd64 build of vdr-plugin-upnp 1.0.0.git20121124-0yavdr3~precise in ubuntu precise RELEASE
    4. Build started on 2013-03-07 on chindi10 (arm ppa builder) and finished on 2013-03-07 taking 4 minutes — see the log


    Beides mal Version 1.0.0. Laut der Webseite http://projects.vdr-developer.org/projects/plg-upnp/news
    müsste es sich aber bei der älteren version um den RC handeln und jetzt wird die aktuelle Version des Quellcodes
    verwendet.


    Das ist das knappe Changelog dazu



    Ich werde heute Abend mal versuchen die SQL lite Datenbank zu finden und werde diese mal löschen, denn laut
    dem Fehlerlog


    Code
    1. #3 0x00007fab7e96bb96 in malloc_printerr (action=3, str=0x7fab7ea67913 "free(): invalid pointer", ptr=<optimized out>) at malloc.c:5018
    2. #4 0x00007fab6e536690 in sqlite3_free () from /usr/lib/x86_64-linux-gnu/libsqlite3.so.0
    3. #5 0x00007fab645ecea8 in tntdb::sqlite::SqliteError::SqliteError(char const*, char*, bool) () from /usr/lib/tntdb/tntdb2-sqlite.so
    4. #6 0x00007fab645ec259 in tntdb::sqlite::Connection::execute(std::string const&) () from /usr/lib/tntdb/tntdb2-sqlite.so


    Könnte es hieran liegen. Vielleicht wurde ja die DB geändert und jetzt fällt er auf die Schnauze.


    Mal sehen heute Abend geht es weiter.


    Gruß
    KiWiX aka. Markus

    Hallo,


    da bin ich wieder.



    Sieht für mich auf den ersten Blick so aus, wie bei mini73/Lars.


    Außerdem hatte ich das gleich Problem, nachdem ich das Quellpaket lokal noch mal
    neu gebaut habe. Das Paket lies sich bauen per dpkg installieren und dann kam auch
    der Fehler.


    Unwissende Grüße
    KiWiX aka. Markus

    Oh.


    Meintest Du noch


    Code
    1. $ apt-cache policy vdr-plugin-upnp
    2. vdr-plugin-upnp:
    3. Installiert: (keine)
    4. Kandidat: 1.0.0.git20130921-0yavdr0~precise
    5. Versionstabelle:
    6. 1.0.0.git20130921-0yavdr0~precise 0
    7. 500 [url]http://ppa.launchpad.net/yavdr/testing-vdr/ubuntu/[/url] precise/main amd64 Packages
    8. 100 /var/lib/dpkg/status


    Aber das war für mich klar, denn er hat ja das Plugin aus der Quelle geholt. Hat man doch
    schon im ersten Post gesehen.


    Oder stehe ich jetzt auf dem Schlauch?


    Gruß
    KiWiX

    Hallo,


    anbei die Ausgaben der apt-cache policy


    Code
    1. $ apt-cache policy vdr
    2. vdr:
    3. Installiert: 2.0.3-0yavdr0~0.5
    4. Kandidat: 2.0.3-0yavdr0~0.5
    5. Versionstabelle:
    6. *** 2.0.3-0yavdr0~0.5 0
    7. 500 [url]http://ppa.launchpad.net/yavdr/testing-vdr/ubuntu/[/url] precise/main amd64 Packages
    8. 100 /var/lib/dpkg/status
    9. 1.7.22-1 0
    10. 500 [url]http://de.archive.ubuntu.com/ubuntu/[/url] precise/universe amd64 Packages


    Ist also der neuste yavdr testing. Bis vor das letzte Update des vdr-plugins-upnp
    hat ja auch alles wunderbar funktioniert. In einem älteren Thread habe ich noch
    den Hinweis gefunden, dass es ein Problem mit der libupnp sein könnte, aber da
    kann ich keine im yavdr testing repository finden.


    Gruß
    KiWiX

    Hallo,


    seit dem letzten Update des oben genannten Paketes, bekomme ich immer wieder die folgende Fehlermeldung:


    Code
    1. WARNING: The following plugins have been left out due to really binary incompatibility: upnp.


    Installiert habe ich es unter meinem Ubuntu Precise 64bit via apt-get.

    Code
    1. Hole:1 [url]http://ppa.launchpad.net/yavdr/testing-vdr/ubuntu/[/url] precise/main vdr-plugin-upnp amd64 1.0.0.git20130921-0yavdr0~precise [321 kB]
    2. Entpacken von vdr-plugin-upnp (aus .../vdr-plugin-upnp_1.0.0.git20130921-0yavdr0~precise_amd64.deb) ...
    3. vdr-plugin-upnp (1.0.0.git20130921-0yavdr0~precise) wird eingerichtet ...
    4. $ sudo /etc/init.d/vdr restart
    5. Restarting Linux Video Disk Recorder: vdr
    6. Searching for plugins (VDR 2.0.3/2.0.0) (cache miss): vnsiserver3 devstatus femon xineliboutput markad osdteletext conflictcheckonly live epgsearch epgsearchonly streamdev-server quickepgsearch


    Ich habe es auch schon mal als Quellpaket herunter geladen und neu kompiliert und ich bekommen wieder die
    gleiche Fehlermeldung.


    Liegt es am Paket selbst oder habe ich noch eine andere Abhängigkeit nicht erfüllt?


    Gruß
    KiWiX

    Also das, was ich bisher getestet habe:


    Das Erste HD via WLAN - geht fast gar nicht. SD klappt wunderbar.
    Das Erste HD über LAN (100MBit Router) alles in Ordnung, außer dass mein Macbook pro (2008'er) und VLC ca. 90% CPU Kast haben. Es erscheint recht stabil, so wie es vorher auch schon war.


    Aber ich habe bisher auch noch keine richtigen Streaming Clients. Es wird wenn dann nur mal von ein oder zwei Rechner aus mit VLC geguckt. Interessanter sind da für uns die Aufnahmen im TS Format, da diese über den minidlna an den entsprechenden Client in unserem Panasonic Fernseher geschickt werden. So kann ich unabhängig vom Fernsehprogramm aufnehmen, denn das kann der blöde Receiver im Panasonic nicht, Man kann immer nur das sehen, was auch gerade aufgenommen wird. Ich würde mcih da echt gern mal mit dem Produktmanager unterhalten, wie oft der schon das aufgenommen hat, was er gerade sieht.


    Somit bin ich da wahrscheinlich nicht der beste Ansprechpartner, aber zum Thema Streaming und Clients gibt es ja noch einige Threads. Aber in der Regel ist das Streaming von Seiten der Software weniger das Problem sondern eher das Netz oder die entstehende Last am Client. So zumindest meine Erfahrungen bisher (Streame seit nun knapp 6 Jahren).


    Gruß
    KiWiX

    Hallo,


    das mit der Signatur stimmt, das ist aber der Server der im Moment noch seinen Dienst verrichtet.
    Der neue Server ist ja noch nicht ganz fertig und wird erst in den kommenden Tagen/Wochen den alten ablösen.


    Kurz und knapp zur Installation.


    Server ganz normal von DVD aufgesetzt (mit der CT' DVD) und auf Unity 2D umgestellt, da der Standard Unity Desktop mit den Inteltreibern immer abschmiert.


    Danach die folgenden yaVDR PPA (falls nicht bekannt, wird das Einbinden der PPA in auf den Launchpad Seiten beschrieben) eingebunden.


    linux-firmware-yavdr von
    https://launchpad.net/~yavdr/+…eld.series_filter=precise



    vdr und plugins von
    https://launchpad.net/~yavdr/+…eld.series_filter=precise



    und nach einem apt-get update vdr und benötigte plugins (live, streamdev-server, markad, xineliboutput, epgsearch, osdteletext) per apt-get install installiert. Danach bisher nur kurz das lokale Netzwerk und das Beenden des Servers in den configs eingestellt und das war es dann fürs erste.


    Weitere Dienste auf meinem Server sind


    ssh
    samba (Version 3 denn das samba4 Paket lies sich nicht installieren)


    apache (mit php und mysql)



    minidlna von
    https://launchpad.net/~stedy6/+archive/stedy-minidna


    (der Standard Ubuntu ist älter und funktioniert gar nicht!)


    Es kommen auf jeden Fall noch


    foorked-daapd (streamen von mp3s zu iTunes)


    cups-pdf (als PDF Drucker für die letzen zwei Windows Rechner)
    vdr-sxfe (habe ich noch nicht ohne Abhängigkeit zu nVidia Paketen gefunden :-) )
    postfix
    dovecot (per IMAP als E-Mail Archiv)


    Ich überlege noch, ob ich zusätzlich wieder LCDproc inkl. einem kleinem Display am Parallelport aktiviere, damit ich den Status des Servers auch ohne Konsole im Blick habe, aber das ist totale Nebensache/Spielerei :-)


    und da der Server dann wahrscheinlich immer noch genügend Dampf hat, überlege ich dann noch irgendwann virtualbox zu aktivieren


    Auf meinem alten Server (der aus der Signatur) habe ich z.Zt. noch Capisuite als Anrufbeantworter und Fax laufen, diese Dienste ersetzte ich gerade durch meine Fritz!Box, so dass der neue ohne ISDN auskommen darf.


    So und nun zu den Erfahrungen, da gibt es noch gar nicht so viel zu sagen, denn wie schon angesprochen läuft er erst seit vergangenen Sonntag und ist noch nicht fertig eingerichtet. Von Ubuntu 12.04 bin ich etwas enttäuscht, denn das einige Pakete gar nicht funktionieren und das Thema mit der Grafik hat mich am Anfang etwas stutzig gemacht und wirkt nicht so zuverlässig wie 10.04, aber die ist ja ausch schon zwei Jahre alt und somit gebe ich 12.04 noch ein paar Monate.


    Ich kann hier aber in ein paar Wochen noch mal abschließend zusammen fassen.


    Gruß
    KiWiX

    Hallo,


    auf das Thema mit dem Macbook pro Modell hätte ich auch selber kommen können :-(


    Es ist ein Macbook pro 5,1, also Late 2008 (Oops schon fast 4 Jahre alt :-) ) mit
    2,4GHz Core2Duo, 4GB RAM, NVIDIA GeForce 9400M 256 MB


    Allerdings verwende ich wegen längerer Akkulaufzeit meist die onboard Grafik, deren
    nVidia Kennung weis ich aber jetzt nicht genau.


    Gruß
    KiWiX

    Hallo liebes yaVDR Team,


    auch wenn's oft heist "Nicht geschimpft ist gelobt genug!" möchte ich heute doch mal einen anderen Weg gehen.


    ich möchte mich mal bei Euch allen für Euren Einsatz und die Arbeit bedanken.


    Auch wenn ich selbst nicht auf yaVDR setze, sonder "nur" Eure Paket auf meinem Ubuntu Server einsetze möchte ich mich gerade trotzdem bei Euch bedanken, denn ohne Euren Einsatz hätte ich keinen ordentlichen laufenden VDR. Gut ich könnte einen selbst bauen, das habe ich auch schon mal von den Basis Sourcen probiert und ging voll in die Hosen. Auf Basis von e-Tobi hat das schon mal geklappt, aber so ist es einfach so einfach und ich kann den Komfort Wert schätzen.


    Am Sonntag Ubuntu Precise installiert, yaVDR PPAs eingebunden und nach ca. 3 Stunden hatte ich einen laufenden Streaming Server.


    Also vielen Dank an alle Aktiven!


    Grüße aus dem Binger Loch
    Markus aka. KiWiX

    Hallo zusammen,


    endlich bin ich es mal angegangen und ich bin dabei meine Server Hardware zu aktualisieren.


    Mein alter Server (Sempron) hat ausgesorgt, da er keinen PCI Express Slot hatte.


    Jetzt ist es ein aktueller Celeron geworden. Dank der tollen yaVDR Pakete ist ein Ubuntu 12.04 mit den entsprechenden VDR Pakten von yaVDR PPA geworden. Soweit alles kein Ding, aber dann kam der Schock.


    Schaue ich mir den Stream auf meinem Macbook pro mit VLC an, dann habe ich eine CPU Auslastung von 90% begleitet von einem Lüftersound der mich fast taub macht.


    Hat hier ggf. ein andere Mac User mal einen Tipp für einen andere Streaming Client, der ggf. das Hardware decoding unterstützt.


    Grüße aus dem Binger Loch
    KiWiX