Posts by dron72

    LNB ist jetzt da und Unicable läuft auf allen 3 Tunern (1*Budget DVB-S und 2*Mystique Satix)
    Kann der vierte Kanal vom Unicable dann an den neuen Fernseher.


    Eigentlich wollte ich die Budget Karte an den Legacy Anschluss hängen - und nur die Satix an Unicable - aber das habe ich auf Anhieb nicht hinbekommen.
    Wenn jemand mal auf die andere Config schauen mag.


    EDIT: Habs hinbekommen, so gehts:
    diseqc.conf


    scr.conf

    Code
    1. 0 1210
    2. 1 1420
    3. # 2 1680
    4. # 3 2040


    Schnipsel ist von hier.


    Aber Danke nochmal für den Tipp mit dem LNB - jetzt habe ich die Situation bei mir deutlich verbessert, ohne großen Aufwand. Ganz wie ich mir das vorgestellt habe!

    Hallo zusammen,


    ich wollte mich mal an STR/S3 machen - und es diesmal nach Fehlversuch nicht wieder abstellen, wie bisher ;-)
    Also habe ich es im Webfrontend mal wieder eingestellt.


    Beim Shutdown kommt der Rechner aber direkt wieder hoch - das Syslog scheint ein paar Hinweise zu geben, mit denen ich aber (noch) nicht so recht was anfangen kann:
    Erstmal dauerts 53 Sekunden im Status "Preparing system for mem sleep" was ich recht lange finde...

    Code
    1. Mar 24 19:00:53 vdr kernel: [ 847.716623] PM: Preparing system for mem sleep
    2. Mar 24 19:01:46 vdr kernel: [ 848.130610] Freezing user space processes ... (elapsed 0.001 seconds) done.
    3. Mar 24 19:01:46 vdr kernel: [ 848.132847] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
    4. Mar 24 19:01:46 vdr kernel: [ 848.134029] PM: Entering mem sleep


    Dann scheint er Probleme zu haben, die Platten schlafen zu schicken:

    Code
    1. Mar 24 19:01:46 vdr kernel: [ 878.816049] ata4.00: failed command: STANDBY IMMEDIATE
    2. und
    3. Mar 24 19:01:46 vdr kernel: [ 878.848051] ata5.00: failed command: STANDBY IMMEDIATE


    Dann ist das suspend of devices fertig; ggf geht hier schon ein großteil der Zeit drauf (31 Sekunden):

    Code
    1. Mar 24 19:01:46 vdr kernel: [ 879.348060] PM: suspend of devices complete after 31213.712 msecs


    Aber dann gibts einen Fehler mit Stacktrace, beginnt im Log mit:

    Code
    1. Mar 24 19:01:46 vdr kernel: [ 879.511934] ------------[ cut here ]------------
    2. Mar 24 19:01:46 vdr kernel: [ 879.511939] WARNING: CPU: 0 PID: 2947 at /build/linux-uz1EVo/linux-3.13.0/fs/sysfs/dir.c:486 sysfs_warn_dup+0x86/0xa0()
    3. Mar 24 19:01:46 vdr kernel: [ 879.511940] sysfs: cannot create duplicate filename '/devices/system/cpu/cpu1/cpufreq'
    4. Mar 24 19:01:46 vdr kernel: [ 879.511975] Modules linked in: tcp_diag inet_diag autofs4 snd_hda_codec_hdmi nfsd auth_rpcgss nfs_acl nfs lockd sunrpc fscache snd_hda_codec_analog stv0299(OX) stv6110x(OX) lnbp21(OX) kvm serio_raw k8temp edac_core edac_mce_amd snd_hda_intel videobuf_dma_sg(OX) snd_hda_codec snd_hwdep videobuf_core(OX) snd_pcm v4l2_common(OX) videodev(OX) snd_page_alloc snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq rc_imon_pad(OX) snd_seq_device joydev snd_timer imon(OX) rc_core(OX) nvidia(POX) stv090x(OX) snd i2c_nforce2 soundcore drm dvb_core(OX) media(OX) shpchp lp mac_hid parport hid_generic usbhid hid usb_storage psmouse forcedeth floppy pata_acpi sata_nv pata_amd [last unloaded: cxd2099]
    5. Mar 24 19:01:46 vdr kernel: [ 879.511978] CPU: 0 PID: 2947 Comm: s2ram Tainted: P OX 3.13.0-113-generic #160-Ubuntu
    6. Mar 24 19:01:46 vdr kernel: [ 879.511979] Hardware name: System manufacturer System Product Name/M2NPV-VM, BIOS ASUS M2NPV-VM ACPI BIOS Revision 5005 06/02/2010


    Und dann gehts direkt wieder in den Neustart:

    Code
    1. Mar 24 19:01:46 vdr kernel: [ 879.512392] CPU1 is up
    2. Mar 24 19:01:46 vdr kernel: [ 879.512664] ACPI: Waking up from system sleep state S3


    Hier der komplette (meiner Meinung nach) relevante Ausschnitt des Syslog:


    Die DVB Module habe ich als force-reload eingetragen; habe gehofft, das hilft:

    Code
    1. oliver@vdr:/etc/yavdr$ cat force-reload-modules.list
    2. ngene
    3. dvb_ttpci
    4. stv0299


    Kann mir jemand einen Tipp geben, wo und wie ich weiter suchen soll?
    BTW: Auch, wenn ich oben von langer Dauer schreibe - wie lange STR dauert ist mir egal; ich finde es nur komisch.
    Das Ziel ist, dass der Rechner aus dem S3 deutlich schneller started, als beim Cold Boot - allein BIOS POST dauert schon gefühlt "ewig", obwohl alles auf minimum geschaltet ist. Cold Boot incl. allem sind bei mir aktuell ca. 1 Minute.


    Danke!


    EDIT: Hier scheint ein entsprechender KernelBug besprochen zu werden, wenn ichs richtig interpretiere; mir ist noch nicht klar, ob das ursächlich für das Verhalten ist. Inzwischen habe ich auch das nvidia Modul in die force-reload Liste aufgenommen - ohne Erfolg.

    Ui, das ist ja mal richtig gut. Gleich 24 Teilnehmer....
    Ich habe inzwischen aber das andere Ding bestellt.
    Mein Plan:
    - Legacy 1 ans Schlafzimmer
    - Legacy 2 an meine Budget Karte (kann wohl kein Diseqc/Unicable; ist übrigens eine Technotrend/Hauppauge DVB card rev2.3 [13c2:000e]
    - Unicable mit 4 Fach Verteiler (ebenfalls bestellt) an den neuen TV und and die beiden Eingänge der Satix S2


    So muss ich keine Kabel neu legen und "nur" den LNB tauschen und dem VDR entsprechend Unicable/Diseqc beibringen. Aber dazu gibts ja einige Infos, und wenn die Satix nicht rumzickt, werde ich das wohl hinbekommen.


    Am Wochenende weiss ich, ob der Plan aufgeht.


    Danke nochmal für all Eure Antworten!

    Von daher mach das LNB mit integriertem SCR Sinn. Oder halt den Multischlater durch einen mit SCR erstzen. Gibts mittlerweile auch zu Hauf.


    Genau auf so einen LNB wirds bei mir wohl rauslaufen. Muss ich nur noch klären, ob meine SAT Karten (Budget DVB-S, Mystique SaTiX-S2 V2 CI Dual) mit Unicable können, sonst bringt das ganze nichts.
    Einen separaten Multischalter habe ich nicht - nur eben den, der im LNB drin ist.
    Schlauer bin ich diesbezüglich noch nicht - ich finde zu meiner S2 Karte kein "ja" und kein "nein".

    Danke für Eure Antworten!


    Das sollte so funktionieren. Die Verteiler müssen Unicable-tauglich sein. Und der Fernseher muss auch mit Unicable umgehen können.


    VDR kann das, ob die Karten da spezielle Anforderungen erfüllen müssen und ob Deine das erbringen, weiß ich nicht. Frag google ;-)


    Habe Google schon gefragt - zu meiner Dual Tuner Karte finde ich nur was von 2010 - und da wird auf eine andere Karte verwiesen, die das sicher kann; zu meiner habe ich auf die schnelle keine Aussage gefunden. Im VDR Wiki steht nichts von speziellen Anforderungen an die Karten. Ich werde mal weiter suchen - es sei denn, jemand kann direkt sagen: Ist ne reine VDR Sache - jede Sat Karte kann das...
    Der neue Fernseher und auch der Receiver im Schlafzimmer können Unicable.


    Einfacher, und ohne zur Schüssel klettern zu müssen, geht es hiermit:
    https://www.amazon.de/Dur-line-Einkabell…keywords=ucp+30.
    Gleicher Effekt. Aus Deiner einen Leitung zum Wohnzimmer 3 Stück machen. Die 2. Leitung für den Fernseher nehmen. Fertig.


    Danke, aber wenn ich das richtig verstehe, funktioniert das bei mir nicht. Ich habe einen Quad LNB (mit eingebautem Multischalter) verbaut, von dem aus die Kabel direkt zu den Receivern gehen. 2 ins Wohnzimmer, 1 ins Schlafzimmer, einer ist frei.
    Das Teil braucht aber (logischerweise) 3 Anschlüsse vom LNB, bleibt noch einer frei fürs TV im Wohnzimmer oder im Schlafzimmer...
    Ich denke, mit dem anderen Vorschlag fahre ich besser; zum LNB komme ich ganz gut mit ner Leiter. Die aktuelle Version hat sogar 2 Legacy Ausgänge.


    oder einfach nur via VDR gucken, so mach ichs seit über 10 Jahren...


    ...Für mich wäre das ok, nicht aber für den Rest meiner Familie; müsste ich wohl noch Arbeit leisten ;-)

    Hey, das klingt ja vielversprechend.


    Wenn ich das richtig verstehe, kann ich mit dem LNB (an den ja zwei Sat Kabel angeschlossen werden können)
    1 Kabel (statt bisher 2) ins Wohnzimmer legen, 4 fach Verteiler dran - 1 Kabel von dort an den TV, 3 Kabel an die VDR Tuner - und alle können komplett unabhängig auf Sender zugreifen
    1 Kabel ins Schlafzimmer legen.


    Und habe recht günstig mein Problem gelöst (LNB rund 50€, 4 fach Verteiler rund 15-20€)
    Wenn...ja wenn die Karten (laut Signatur) im VDR denn auch mit Unicable umgehen können. Können die das? Oder ist das reine Software/VDR Sache? Habe yavdr 0.6.1.
    Im Schlafzimmer steht ein Xoro HRS 8500 als Receiver - laut Anleitung kann der mit Unicable umgehen.


    SAT>IP Server hatte ich mir auch angesehen; wäre eine Option die Octopus NET kosten mir aber aktuell zu viel und alles andere scheint eher Ärger zu machen.

    Hallo,


    mein Problem: Ich habe einen VDR gemäß Signatur und derzeit 2 Sat Kabel vom Quad LNB zum VDR im Wohnzimmer gelegt. 1 Sat Kabel geht ins Schlafzimmer, 1 Anschluss am LNB ist noch frei.
    Im VDR habe ich 3 Tuner - 2 davon teilen sich einen LNB (über einen ganz simplen 2 Fach Verteiler und entsprechende Konfiguration im VDR, dass die beiden sich einen LNB teilen)
    Soweit, so gut - passt für mich alles.


    Bisher haben wir "einfach Fernsehen" über DVB-T geschaut - ab Ende des Monats gehts dann nur noch mit DVB-T2 und zumindest für die privaten nur noch mit so ner Karte, die ich mir nicht kaufen will.
    Bleibt also noch Satellit (zumindest geht da SD)
    Dafür kommt demnächst ein neuer Fernseher ins Haus, der dann ebenfalls direkt mit Sat Signal versorgt werden soll. (Philips 49PUS7101/12, Im Januar günstig bei Saturn bestellt, soll bald geliefert werden...)


    Wie mache ich das am Besten?
    Kann ich den zweiten LNB ebenfalls mit so nem 2 fach Verteiler zwischen TV und VDR-Tuner teilen?
    Oder anders - gibt es irgendwas, das dem VDR sagt: Der Fernseher nutzt gerade den LNB, schalte den Tuner bitte ab und nutze die andern - schalte auf keinen Fall auf dem LNB Band oder Polarisierung um....
    Nicht, dass der VDR startet, mit dem geteilten Tuner ne Aufnahme machen will und dadurch auf dem Fernseher das Bild weg ist...


    Ggf. gibt es "intelligente" Switches o.ä. - oder irgendeine andere Lösung, an die ich gerade nicht denke. Wäre mein Favorit.


    Alternativen, die mir sonst in den Sinn kommen:
    a) 3. Kabel legen (Nachteil: Aufwand (Kabel verlegen, Löcher bohren etc. :-) )
    b) 1 Kabel exklusiv fürs Fernsehen, anderes Kabel per 2 Fach Verteiler am VDR wie bisher; ein Tuner kommt raus... Nachteil: Wenn man dann doch über VDR Live Signal schauen will und gleichzeitig aufnehmen will, kann es zu Kollisionen kommen, wenn die beiden verbleibenden Tuner im VDR sich einen LNB teilen.
    c) Unicable Lösung installieren (Nachteil: Keine Ahnung von; ggf. kosten)


    Komplett unabhängig ein Programm schauen und ein anderes aufzeichnen reicht mir. Schauen aber gerne Alternativ über VDR oder direkt am TV.


    Danke für Anregungen...

    Ok, danke für die schnelle Rückmeldung!


    Hatte das Softdevice vorher auf 50Hz - da kam die Meldung exakt alle 50 Sekunden.
    X ist so, wie es automatisch erkannt wurde. Ich kann ja auch beides mal auf 50Hz drehen, und schauen ob es geht und was dann passiert.


    Sonst ignoriere ich die Log Einträge einfach - läuft ja.


    Danke nochmal!

    Hallo,


    ich habe regelmäßig im syslog folgendes:


    In einem anderen Thread hier habe ich gesehen, dass es an 50 vs 60Hz liegen könnte.
    Mein Softhddevice läuft auf 60Hz:

    Code
    1. root@vdr:/etc/vdr# grep -R 60Hz *
    2. setup.conf:softhddevice.60HzMode = 1


    mein X ebenfalls:


    Irgendeine Idee, was ich tun kann um das weiter einzugrenzen/zu korrigieren?

    Danke für Dein Script und and der Stelle auch mal Danke für die super Arbeit, die Du hier machst...


    Bei mir gab's aber nen Problem mit der Unicode Konvertierung:

    Code
    1. Traceback (most recent call last):
    2. File "./get_de_channels.sh", line 14, in <module>
    3. c.write(line + '\n')
    4. UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 14: ordinal not in range(128)


    Ich habe es jetzt nach kurzem googlen so angepasst (habe keine Ahnung von Python...):


    Also in der letzten Zeile ein ".encode('utf-8')" ergänzt.
    Das tut dann auch bei mir.

    Hallo zusammen,


    primär als Referenz für mich - aber vielleicht profitiert auch der ein oder andere davon.


    Bei meiner Hardware ist in yavdr 0.6.1 noch das selbe Problem, wie in der 0.5 und der 0.4.
    Das IMON Kernel Modul "denkt" aufgrund eines Fehlers im KernelModul, es wäre eine MCE Fernbedienung, ist es aber nicht.


    Der Fix geht so:


    Code
    1. cd /usr/src/media-build-experimental-0~20150719.122100/linux/drivers/media/rc/
    2. sudo vi imon.c


    Dort dann das "case 0x7e:" bei /* iMON VFD, MCE IR */ entfernen und zu dem Block darüber /* iMON VFD, iMON IR */ hinzufügen.Sollte dann so aussehen:


    Dann schauen, welche Module man so mit DKMS gebaut hat...

    Code
    1. dkms status


    Und dann erstmal das media-build-experimental für alle Kernels entfernen:

    Code
    1. sudo dkms remove -m media-build-experimental -v 0~20150719.122100 -k 3.13.0-110-generic
    2. sudo dkms remove -m media-build-experimental -v 0~20150719.122100 -k 3.13.0-79-generic


    Dann neu bauen und installieren (dauert ne ganze Weile)

    Code
    1. sudo dkms add -m media-build-experimental -v 0~20150719.122100
    2. sudo dkms build -m media-build-experimental -v 0~20150719.122100
    3. sudo dkms install -m media-build-experimental -v 0~20150719.122100
    4. sudo depmod -a
    5. sudo reboot


    Und alles wieder heile...

    Hallo,


    der Thread ist zwar fast 1 Jahr alt, ich versuchs trotzdem mal hier.
    Erstmal vielen Dank für das Script - bei mir tuts aber leider nicht:


    Code
    1. ./newbobhue.py -H 192.168.178.97 -i 7 --testcolor "0 128 254"
    2. Press the button on the Hue bridge
    3. Unhandled error creating configuration on the Hue
    4. [{u'error': {u'type': 6, u'description': u'parameter, username, not available', u'address': u'/username'}}]


    Egal, ob ich den Button vorher gedrückt habe - der Fehler kommt sofort. Wahrscheinlich hat sich irgendwie die API bei der HUE Bridge geändert...
    Ich habe Version 01036562 auf der Hue Bridge.


    Wenn ich einen Key mitgebe, den ich aus meinem FHEM habe, dann kommt zwar:

    Code
    1. ./newbobhue.py -H 192.168.178.97 -i 4 -u u8DgKzU1XXXX-XXXXYDJqHgqwKSmNEKiCSwTgzN --testcolor "0 128 254"
    2. Connected to the Hub


    Aber bei den Lampen ändert sich nichts - ich habe auch alle möglichen "-i" schon durchprobiert - ich gehe ja mal davon aus, dass die ID die selbe ist, wie sie auch in FHEM angezeigt wird.


    Über FHEM/Hue App etc. kann ich natürlich kommunizieren und ja, die IP stimmt.


    Kann ich noch irgendetwas tun, um zu debuggen?


    Danke!


    EDIT:
    Habe in dem anderen Thread noch gefunden, dass man mit folgendem den User registrieren soll:

    Code
    1. curl -H "Content-Type: application/json" -X POST -d '{"devicetype": "boblight", "username": "1234567890"}' http://192.168.178.97/api


    Die Dev Seite von Philips sagt nun aber:

    Code
    1. curl -H "Content-Type: application/json" -X POST -d '{"devicetype": "boblight"}' http://192.168.178.97/api


    Also ohne Username - und siehe da - das funktioniert. Ich bekomme einen Usernamen zurück.
    Vielleicht kann mir ja jemand helfen, der Python kann - bevor ich mich da durchfummeln muss ;-)


    EDIT2:
    ...und das Thema ist wohl, dass das Script die beautifulhue lib verwendet, die nicht mehr gepflegt wird. Ein Philips Mitarbeiter hat sogar genau zu diesem Problem vorher ein issue aufgemacht: https://github.com/allanbunch/beautifulhue/issues/13
    Hierscheint es einen ähnlichen Ansatz zu geben (wenn auch älter) - mit einem Script, was ich einfacher durchschaue und was nicht auf die bibliothek setzt. Ich werde das mal als Startpunkt fürs weitere Basteln nehmen.

    Kann man sicher machen, aber ich will eigentlich nur den einen Treiber patchen - alles andere funktioniert ja.


    EDIT:
    Habe jetzt das linux-media-dkms installiert, gepatcht entsprechend meiner Anleitung von damals - und alles tut.
    Das mit dem media-build-experimental war ein guter Tipp und hat mich mal nach allen dkms Paketen im Repo schauen lassen.


    Kann ich noch etwas tun, damit die Allgemeinheit profitiert?

    Danke für die Schnelle Antwort.


    Code
    1. oliver@vdr:~$ sudo ir-keytable
    2. [sudo] password for oliver:
    3. Found /sys/class/rc/rc0/ (/dev/input/event7) with:
    4. Driver imon, table rc-imon-mce
    5. Supported protocols: RC-6
    6. Enabled protocols: RC-6
    7. Repeat delay = 500 ms, repeat period = 125 ms


    Der Treiber erlaubt nur RC-6 - und das ist falsch.


    Dem Treiber kann man das nicht direkt mitgeben:

    Code
    1. oliver@vdr:~$ modinfo rc-core
    2. filename: /lib/modules/3.2.0-54-generic/kernel/drivers/media/rc/rc-core.ko
    3. license: GPL
    4. author: Mauro Carvalho Chehab <mchehab@redhat.com>
    5. srcversion: 0B51EDD3AD37BF0DDA2B5C2
    6. depends:
    7. intree: Y
    8. vermagic: 3.2.0-54-generic SMP mod_unload modversions
    9. parm: debug:int


    Und dem imon leider auch nicht:

    Hallo zusammen,


    habe gerade auf yavdr 0.5 aktualisiert - vieles funktioniert OOTB. Danke ans Team für die Super Arbeit!


    Mit meiner Fernbedienung habe ich aber das gleiche Problem, wie damals mit 0.4, siehe hier
    Habe zwar bisher noch keinen panischen Kernel gehabt, aber die Fernbedienung tut nicht.


    Moral von der Geschichte: das Kernel Modul "denkt" aufgrund meines Config Bytes 0x7e, ich hätte eine "0xffdc iMON VFD, MCE IR", ich habe aber eine "0xffdc iMON VFD, iMON IR".

    Code
    1. oliver@vdr:~$ dmesg | grep imon
    2. [ 4.846861] imon 2-6:1.0: 0xffdc iMON VFD, MCE IR (id 0x7e)


    Ich hatte das damals nach langer Recherche gepatcht, damals über DKMS war das dann auch für immer gelöst - und ich hätte das gerne auch jetzt dauerhaft gelöst.


    Bevor ich zu lange google bemühe:
    Hat einer von Euch einen Tip, wie ich in der Standard yavdr 0.5 installation ein Kernel Modul so patche, dass es auch bei zukünftigen Kerneln nach updates automatisch neu gebaut wird und entsprechend auch nach einem achtlosen "apt-get update && apt-get dist-upgrade" noch funktioniert.


    DKMS scheint wohl ein Stichwort zu sein, wenn ich in meinen Aufzeichnungen von damals krame...
    aktuell sind aber nur nvidia Treiber bei mir im dkms, siehe:

    Code
    1. oliver@vdr:~$ dkms status
    2. nvidia-304, 304.88, 3.2.0-41-generic, x86_64: installed
    3. nvidia-304, 304.88, 3.2.0-54-generic, x86_64: installed


    Geht sowas wie: imon.c source besorgen und patchen, in dkms einbinden und ap sofort vergessen?
    Falls ja - kann mich einer auf die richtige Spur setzen?
    ...ist alles schon ein Weilchen her ;-)


    Danke für Tipps,


    Oliver

    Danke erstmal für die vielen Antworten.
    Also: Installation auf/Boot von USB, da ich dann ohne Virtualisierung direkt ein Linux booten könnte, ohne an meinen Partitionen irgendetwas rumzubasteln. Ich dachte einfach eine VDR Installation auf den Stick gepackt, davon gebootet, fertig.


    Das ganze muss auch nur eine temporäre Lösung sein - es geht mir wirklich nur um die EM Spiele. Das muss nicht dauerhaft funktionieren und super sein. Wenn HD funktionieren würde, wäre schön; die 20€ mehr für die größere Karte wärs mir wert - wenn bei meinem MacBook nur SD tut, ist auch ok. Würde mir dann die kleinere Karte kaufen.
    Im Urlaub brauche ich eigentlich kein TV. Anschließend wird das Zeug demnach hier rumliegen, bis ich nochmal bei einer EM/WM unterwegs bin ;-)
    Zuhause bin ich ausgestattet - und ja, mein Surround Receiver bleibt zuhause :-)


    Ich habe aktuell per Bootcamp auch ein Windows XP installiert, auf das ich auch per Parallels zugreife (Bootcamp Partition).
    Vielleicht wäre ja auch das eine Alternative. Einfach Mit Bootcamp XP booten, die Windows Software nutzen, die bei der TT Karte dabei ist - und gut ist.
    ...Ich muss nichts Aufnehmen, Streamen, Konvertieren o.ä.


    Dachte auch schon an DVB-T - ich habe hier nen alten Stick rumfliegen (Leadtek WinFast DTV Dongle), aber der tut nicht unter OS X - und unter Linux auch nur mit Gefummel. Unter Win XP (Bootcamp) oder auch auf meinem EeePC 701 läuft der zwar, aber dann habe ich nur "Orangen" Ton - wenn ich überhaupt was empfange. Da ist mir SAT dann lieber...


    Olli