Posts by X-Dimension

    Nachdem ich etwas mit den Einstellungen gespielt habe, bin ich jetzt an einem Punkt angelangt, an dem ich recht zufrieden mit der Haswell GPU bin.
    Ich nutze nun xineliboutput-sxfe mit dem opengl2 treiber anstelle von vaapi oder xv.
    Das vdr-sxfe Frontend starte ich dabei mit folgenden Optionen:


    Code
    1. vdr-sxfe -V opengl2 --post tvtime:method=Linear,pulldown=0,use_progressive_frame_flag=1



    Vorteile:
    - Keine Ton-Aussetzer wie bei vaapi
    - Vernünftiges OSD (Im Gegensatz zu xv)
    - Deinterlacer funktioniert (das habe ich weder mit vaapi noch mit xv in Verbindung mit Xineliboutput hinbekommen)
    - CPU Last liegt bei FullHD irgendwo zwischen 10 und 20%


    Nachteile:
    - Hin und wieder verabschiedet sich das Frontend beim Zappen
    - Im Fenstermodus Skaliert das OSD nicht auf die Fenstergröße sondern bleibt auf FullHD


    Die Deinterlacer Optionen gebe ich beim Start in der Kommandozeile mit, da er die Einstellungen sonst bei jedem Frontend Neustart "vergessen" hatte, wenn ich diese im Xineliboutput-Plugin in den Video-Einstellungen gesetzt habe.
    Das ist zwar alles noch nicht ganz auf VDPAU/Nvidia Niveau, aber für meine Ansprüche völlig in Ordnung! Falls jemand bessere Deinterlacer Optionen kennt, die man vdr-sxfe mitgeben könnte, dann immer her damit!

    Ähh ja...
    Wie ich gestern feststellen musste, lief mein VDR seit dem Update nicht mehr mit VAAPI sondern nutzte XV.
    Mir ist es zufällig aufgefallen als ich vdr-sxfe mit dem Parameter -V vaapi starten wollte und eine Fehlermeldung bekam.
    Also habe ich alles was Intel/VAAPI angeht runter geschmissen und wieder neu installiert.
    Das Ergebnis war leider das Gleiche wie im Ausgangsposting: Tonaussetzer, OSD verhunzt, aufhängen des Frontends.
    Schade... dann muss wohl XV erstmal her halten, oder ich investiere doch in eine extra Nvidia Grafikkarte, was ich
    eigentlich vermeiden wollte...

    Nein, vermutlich hast du mich da falsch verstanden. Xine-Ui als Mediaplayer hat ja unabhängig vom VDR selbst ein eigenes OSD! Drückt man zum Beispiel die Taste m oder n für "Audio/Video-Versatz" blendet Xine ein OSD ein und dieses ist bereits verzerrt.


    ABER, gestern sind bei einem Update neue VAAPI Treiber installiert worden und nun ist das OSD nicht mehr verzerrt!
    Ich bin jetzt auch wieder zurück gegangen auf Xineliboutput mit SXFE Frontend und YaVDR Testing.
    Seit dem VAAPI Update sind nun auch die Tonaussetzer mit SXFE verschwunden und das Frontend lief gestern 3 Stunden
    stabil und problemlos. :-)
    Allerdings kann das OSD jetzt keine Transparenz mehr darstellen wenn ich Xineliboutput OSD auf Hardware stelle,
    stelle ich es auf Software, ist zwar Transparenz da, aber die Schriften sind alle sehr verpixelt.


    Kurzum: Alle Probleme die ich habe/hatte scheinen von VAAPI abhängig zu sein.
    Offenbar wird hier noch ordentlich gebastelt, aber man macht definitiv große Fortschritte.
    Vielen Dank an die fleißigen Entwickler. :cool1
    Derzeit hilft wohl nur abwarten und Tee trinken und regelmäßig VAAPI auf den neuesten Stand bringen.

    So, mit dem PPA von FNU habe ich nun auch ein Bild mit Softhddevice, allerdings habe ich auch
    hier wie bei Xineliboutput nur ein OSD im Vollbildmodus, aber im Fenster-Modus ist es kaputt.
    Leider hing sich mein System nachdem ich die sehr gute Bildqualität bewundern durfte, nach
    wenigen Minuten komplett auf. :(
    Die OSD Problematik scheint offenbar ein generelles Treiber/VAAPI Problem zu sein und hat nix
    mit Xine zu tun.

    Hier mal die Logs, wenn ich Softhddevice attache:

    Ganz ehrlich? Ich dachte es wäre so einfach wie mit dem Xineliboutput Plugin -> installieren, starten, Frontend anwerfen, läuft. :-)
    Kurzum: Ich habe keine Ahnung mit welchen Parametern Softhddevice gestartet wird. Sicherlich mit den Standard-Einstellungen die die Jungs vom YaVDR Team in Ihren Skripten eingebaut haben. Ich bin davon ausgegangen, dass die Default-Einstellungen nicht angepasst werden müssen.
    Ich habe auch noch nicht so ganz verstanden wie diese Softhddevice Geschichte eigentlich funktioniert.
    Ist dieses Fenster, dass ich mit "svdrpsend plug softhddevice atta" öffne eine neue X-Server Sitzung, die ich in ein Fenster "quetsche", oder ist es einfach nur
    wie beim Xineliboutput ein Fenster des bestehenden X-Servers das einfach nur einen "Videostream" abfängt?

    Danke für die Info!
    Ich habe jetzt mal xineliboutput runter geworfen und softhddevice installiert.
    Über die Befehle

    Code
    1. xhost +si:localuser:vdr
    2. svdrpsend plug softhddevice deta
    3. svdrpsend plug softhddevice atta


    sehe ich zwar nun ein neues Fenster auf dem Bildschirm und sämtliche Tastaturbefehle werden an den VDR weitergeleitet wie ich am VFD Display sehen kann,
    aber ich habe weder ein Bild noch ein Ton. :(

    Softhddevice klingt interessant, jedoch nutze ich wie gesagt den VDR als TV Anwendung unter Gnome und ich habe bisher nirgendwo etwas darüber gefunden wie ich die Ausgabe von Softhddevice in ein Fenster packen kann, dass dann auf meinem Gnome Desktop hin und her geschoben und vergrößert/verkleinert werden kann.
    Wenn es da doch eine Möglichkeit geben sollte, wäre das natürlich optimal.

    Ich bin jetzt ein wenig weiter gekommen und konnte folgendes feststellen:


    1. Das OSD Problem scheint ein Xine/Intel-Treiber Problem zu sein, denn wenn ich Xine UI starte ist auch das Xine eigene OSD nur im Vollbild-Modus sichtbar, im Fenster Modus ist es ebenfalls kaputt


    2. Nutze ich als Frontend xine xvdr://127.0.0.1 anstelle von vdr-sxfe, läuft der Ton ohne Probleme.
    wenn ich die Konfigurationsdateien unter ~/.xine vergleiche, sind die Einstellungen dort jedoch identisch.

    Hallo,


    im Gegensatz zu dem vermutlich größten Teil hier, benutze ich den VDR nicht als "Standalone System", sondern als "TV Anwendung" unter Ubuntu, da ich auch im Wohnzimmer
    auf ein vollwertiges Linux nicht verzichten möchte.
    Bisher hatte ich hierfür ein Nvidia nforce 730a/8300 basiertes Mainboard mit Athlon II X2 CPU in Verbindung mit Xineliboutput und VDR-SXFE als Frontend laufen,
    das zwar zum TV gucken optimal ist, aber mit FullHD Flash Videos komplett überfordert war und 80-100% CPU Auslastung erzeugte.


    Aufgrund vieler positiver Berichte hier, dass die neue Intel CPU Generation in Verbindung mit VAAPi mittlerweile recht brauchbar geworden ist und erfahrungsgemäß
    FullHD Flash Videos den Prozessor vielleicht zu 10% belasten, habe ich mich für ein System mit Haswell Prozessor entschieden. (Siehe unten)
    Das böse erwachen kam jedoch als ich in den letzten Tagen feststellen musste, dass die Intel Grafik zumindest bei mir in Verbindung mit Xineliboutput-SXFE überhaupt
    nicht stabil laufen will.


    Aktuell habe ich folgende Probleme:
    1. Ständige Tonaussetzer (nutze HDMI)
    2. On Screen Display funktioniert nur im Vollbildmodus, im Fenster-Modus sehe ich hingegen nur schräge Treppenförmige Streifen.
    Wenn ich Compiz anstelle von Metacity als Fenstermanager nutze, funktioniert das OSD zwar, aber es breitet sich auch im Fenster-Modus
    auf den ganzen Bildschirm aus und das VDR Bild füllt im Vollbildmodus nicht den Bildschirm aus, sondern bleibt als keines Fenster in der linken oberen Ecke.
    3. VDR-SXFE hängt sich ständig auf


    Leider habe ich keine Idee wo ich anfangen könnte um die Probleme zu lösen.
    Mich würde mal interessieren wie die Intel VAAPi Experten hier ihre Systeme konfiguriert haben, damit es dort halbwegs "fluppt".
    Ich hoffe es ist auch jemand dabei, der den VDR wir ich als TV-Anwendung nutzt.


    Vielen Dank!

    Ich kenne mich mit der Materie leider nicht so gut aus.
    Wenn ich den Quellcode von hier nehme: http://projects.vdr-developer.…cts/plg-skinpearlhd/files


    und den Patch einspielen will, erhalte ich immer folgende Fehlermeldung:

    Quote

    Hunk #1 FAILED at 831 (different line endings).
    Hunk #2 FAILED at 959 (different line endings).
    Hunk #3 FAILED at 1002 (different line endings).
    Hunk #4 FAILED at 1280 (different line endings).

    Sicher ist es schade, dass der Patch offenbar keine Beachtung gefunden hat, aber ich finde den PearlHD Skin immernoch am schönsten.

    Ich habe das Upstart-Skript von hsteinhaus auch erfolgreich im Einsatz. (Vielen Dank dafür!)


    Es könnte bei mir jedoch evtl noch etwas "Fein-Tuning" gebrauchen.
    Mein VFD Display startet zwar nun vor dem VDR, aber es dauert anschließend immernoch
    etwas über eine Minute bis dann die Ausgaben des LcdProc Plugins angezeigt werden.
    Kann man da noch irgendwo ein paar Optimierungen vornehmen?

    Wie es aussieht werden die Einstellungen aus /etc/default/cpufrequtils erst übernommen wenn ich den Dienst "cpufrequtils" neu starte.
    Ein ps ax | grep cpufrequtils zeigt mir, dass der Dienst beim YaVDR Start geladen wird, trotzdem läuft die CPU im Performance Modus, bis der Dienst neu gestartet wird.
    Was könnte noch dazwischen funken?

    Ja, habe ich! Die Frequenz wird aber erst dann als Mindest-Frequenz eingestellt wenn ich manuell cpufreq-set -g ondemand eingebe.
    Nach einem Neustart läuft der Prozessor aber wieder mit 2500Mhz und taktet auch nicht auf 2000Mhz runter wie mir cpufreq-info zeigt.
    Die Konfiguration unter /etc/default/cpufrequtils scheint also Standardmäßig nicht geladen zu werden.