Posts by Pete248

    Mein yaVDR wollte nach ein paar Umbauten keinen Ton mehr abspielen. Das Softdevice Plugin wird nur mit Parameter -D gestartet, sonst nix. Starte ich mit -D -a hw:0,8 -p hw:0,8 ist alles wieder in Butter.


    Betrachte ich mir


    /usr/share/yavdr/templates/etc/vdr/plugins/plugin.softhddevice.conf/20_main


    dann finde ich dort


    -D <?cs var:mixer ?>


    Anscheinend hat bei mir die Variable mixer keinen Wert. Wo/wie wird die eigentlich gesetzt?


    Habe mich jetzt damit beholfen, -a hw:0,8 -p hw:0,8 in die plugin.softhddevice.conf reinzufummeln. So ganz wohl ist mir dabei nicht. Das hw:0,8 sollte besser wo anders hinterlegt werden, so dass es in der mixer Variablen landet, oder nicht.

    Habe div. Anleitungen gefunden, wie man über den Titel von speziellen Suchtimern verändern kann über eine Datei im conf.d des EPGSearch plugins.


    Z.B.


    Code
    1. [epgsearchdirs]
    2. %Großstadtrevier%
    3. [epgsearchuservars]
    4. %Großstadtrevier%=%title% %subtitle%


    und dann im Großstadtrevier Suchtimer %Großstadtrevier% als Verzeichnisname unter "Verzeichnis" auswählen.


    Soweit so gut.


    Wie muss so eine eine Datei aussehen, wenn ich alle Aufnahmen, die manuell über den EPG erstellt werden, so behandeln möchte? Gibt es irgendeine Default Variable, die den Titel bei manuellen Timern enthält und die ich in der Config Datei dann verändern kann?


    Ich will nat. nicht, dass individuelle Vorgaben, die in Suchtimern gemacht wurden, dadurch nochmals verändert werden. D.h. diese Config soll nur bei manuellen Timern greifen.

    Aktuell landen die meisten meiner manuell programmierten Aufzeichnungen in einem Ordner mit dem Titelnamen, darunter ein Ordner mit dem Untertitelnamen und erst darunter der bekannte Ordner mit der Aufnahmezeit. Das bedeutet dann in der Anzeige der Aufzeichnungen, dass die Aufzeichnung den Untertitelnamen trägt und in einem Ordner mit dem Titelnamen liegt. Macht wenig Sinn, wenn es sich nicht um Serien handelt.


    Nach längerem Suchen, woran das liegt, bin ich auf das Epgsearch-Plugin gestossen, das in seinen Einstellungen einen Punkt "Untertitel in manuellen Timern" hat, der bei mir auf "intelligent" gesetzt ist. Das erweitert dann bei Aufnahmen unter 80 min den Timer-Namen um ein "~Untertitel", worauf dann bei der Aufzeichnung besagtes Unterverzeichnis angelegt wird. Setze ich den Wert auf "nie", ist der Spuk mit den Unterverzeichnissen vorbei. Allerdings hat die Aufzeichnung jetzt auch nur noch den Titelnamen. Um den Untertitel zu sehen muss man immer in die Info gehen.


    Gibt es eine Möglichkeit, manuell programmierte Aufzeichnungen so benennen zu lassen, dass Titel und falls vorhanden Untertitel verkettet werden, ohne dass dabei ein Unterverzeichnis erstellt wird, entweder mit VDR Bordmitteln oder per Plugin?


    Vielleicht hilft das hier?


    Merci, habe es mal eingebaut und teste die Tage mal, ob es hilft.


    Ist wohl noch nicht in der 0.5.0a stable angekommen. Finde es zumindest nicht in sleep.d.
    Sollte ich vielleicht doch wieder auf testing umsteigen, wenn es soll lange dauert, bis Änderungen in der stable ankommen?


    Pete

    Habe einen Mac Mini als VDR am Fernseher und parallel dazu einen VDR Server für Archiv und automatische Aufnahmen.


    Mac Mini wird nicht ausgeschaltet sondern nur in S3 versetzt. Hatte in letzter Zeit immer mal wieder das Problem, dass er beim Aufwachen mit dem VDR Logo hängengeblieben ist. Naja, zumindest hatte ich das so interpretiert. Nach einigem Rumprobieren habe ich jetzt den Grund gefunden. Er bleibt gar nicht hängen sondern wartet auf den Timeout beim Verbinden mit dem Server, wenn der Server noch an war, als sich der Mac Mini in den Ruhezustand begeben hat. Offenbar geht er beim Aufwachen davon aus, dass der NFS Share noch da sein müsste, was aber nicht der Fall ist und wartet bis zum Timeout, was durchaus 2-3 Minuten dauern kann.


    Ich habe ein Skript mit umount -t nfs -a in /etc/pm/sleep.d abgelegt, das den NFS Share beim S3 entfernen sollte. Bisher scheint das Problem damit gelöst.


    Schreibe das, damit die yaVDR Entwickler so etwas vielleicht in die Distro integrieren könnten oder, falls es schon drin ist und nur bei mir nicht tut, wie ich es richtig machen müsste, damit ich diese Timeouts beim Aufwachen nicht mehr erhalte.



    Grüße


    Pete

    Nachdem ich jetzt erkannt habe, dass das Problem beim SoftHDDevice liegt, erlaube ich mir ausnahmsweise ein Crosspost:


    Seit Neuaufsetzen des VDR mit SoftHDDevice als Ausgabegerät, habe ich das Problem, dass bei Sendern, die 5.1 Sound senden, mein Yamaha Soundsystem einen vermeintlichen 7.1 Sound (also das was normalerweise von Blueray kommt, DTS etc.) erkennt. Das kann natürlich nicht sein, da kein Sender bislang 7.1 Sound ausstrahlt. Entsprechend übel klingt dann auch die Sound Ausgabe. Die Kanäle sind falsch abgemischt, das Ganze klingt extrem hallig. Muss deswegen bei 5.1 Sound derzeit auf Stereo zurückschalten. Früher mit Xine oder Xineliboutput hatte ich das Problem nicht.


    asound.conf:


    pcm.!default {
    type hw
    card 0
    device 8


    setup.conf:
    ...
    softhddevice.AudioBufferTime = 0
    softhddevice.AudioCompression = 0
    softhddevice.AudioDelay = 0
    softhddevice.AudioDownmix = 0
    softhddevice.AudioDrift = 0
    softhddevice.AudioMaxCompression = 0
    softhddevice.AudioMaxNormalize = 0
    softhddevice.AudioNormalize = 0
    softhddevice.AudioPassthrough = 1
    softhddevice.AudioSoftvol = 0
    softhddevice.AudioStereoDescent = 0
    ..


    Habe derzeit keine Ahnung wie/wo ich darauf Einfluss nehmen kann, zumal bei Passthrough der VDR den Ton eigentlich unverändert weitergeben sollte, was er aber wohl bei mir nicht tut. Kommen dieselben Sender vom Fernsehtuner, erkennt das Soundsystem 5.1 Ton und das Ganze klingt ok. Für einen Tipp wäre ich dankbar.


    PS: Eben nochmals getestet: Es liegt definitiv am SoftHDDevice. Stelle ich im Webinterface (yaVDR) auf Xine oder Xineliboutput, wird 5.1 Sound erkannt.


    Lässt sich da was am SoftHDDevice konfigurieren oder was patchen beim Kompilieren?


    Grüße Pete

    Seit Neuaufsetzen des VDR mit SoftHDDevice als Ausgabegerät, habe ich das Problem, dass bei Sendern, die 5.1 Sound senden, mein Yamaha Soundsystem einen vermeintlichen 7.1 Sound (also das was normalerweise von Blueray kommt, DTS etc.) erkennt. Das kann natürlich nicht sein, da kein Sender bislang 7.1 Sound ausstrahlt. Entsprechend übel klingt dann auch die Sound Ausgabe. Die Kanäle sind falsch abgemischt, das Ganze klingt extrem hallig. Muss deswegen bei 5.1 Sound derzeit auf Stereo zurückschalten. Früher mit Xine oder Xineliboutput hatte ich das Problem nicht.


    asound.conf:


    pcm.!default {
    type hw
    card 0
    device 8


    setup.conf:
    ...
    softhddevice.AudioBufferTime = 0
    softhddevice.AudioCompression = 0
    softhddevice.AudioDelay = 0
    softhddevice.AudioDownmix = 0
    softhddevice.AudioDrift = 0
    softhddevice.AudioMaxCompression = 0
    softhddevice.AudioMaxNormalize = 0
    softhddevice.AudioNormalize = 0
    softhddevice.AudioPassthrough = 1
    softhddevice.AudioSoftvol = 0
    softhddevice.AudioStereoDescent = 0
    ..


    Habe derzeit keine Ahnung wie/wo ich darauf Einfluss nehmen kann, zumal bei Passthrough der VDR den Ton eigentlich unverändert weitergeben sollte, was er aber wohl bei mir nicht tut. Kommen dieselben Sender vom Fernsehtuner, erkennt das Soundsystem 5.1 Ton und das Ganze klingt ok. Für einen Tipp wäre ich dankbar.


    PS: Eben nochmals getestet: Es liegt definitiv am SoftHDDevice. Stelle ich im Webinterface (yaVDR) auf Xine oder Xineliboutput, wird 5.1 Sound erkannt.


    Lässt sich da was am SoftHDDevice konfigurieren oder was patchen beim Kompilieren?


    Grüße Pete

    Ich möchte, nachdem mein Sundtek DVB Stick eingebunden wurde (was in yaVDR IMHO per dynamite plugin geschieht), ein Shellscript ausführen, das 2 Dinge tut:


    1.) den IR Empfänger des Sundtek abschalten per /opt/bin/mediaclient --disablerc
    2.) Auf Kanal 1 umschalten (der automatische Umschaltbefehl des VDR kommt wohl zu früh, der Sundtek hängt bei "No Signal")


    Gibt es eine Konfigurationsdatei, aus der ich so ein Skript aufrufen kann oder ein Verzeichnis, in dem ich das Skript ablegen kann, so dass es eben erst aufgerufen wird, NACHDEM der Sundtek eingebunden ist?


    Diverse Versuche mit den Sundtek Skripten in /etc/init waren nicht erfolgreich, die Kommandos werden viel zu früh gesendet.


    Pete

    yaVDR benutzt ja schon einen ganze Weile MHDDFS um die Aufnahmen anderen yaVDRs zur Verfügung zu stellen. Mein yaVDR Server mit mehreren Platten nutzt aber intern immer noch die video.00, video.01 etc. Methode mit Symlinks. Wenn man beim Verschieben von Aufnahmen nicht höllisch aufpasst, kommt einem die Verzeigerung recht schnell durcheinander.


    Ich frage mich jetzt, ob ich nicht besser auf dem Server das MHDDFS Volume direkt als Aufnahmeverzeichnis setzen soll. Optional könnte ich dann wohl einfach die Symlinks auf video.00 löschen. Hat das mal jemand probiert? Gab es irgendwelche Probleme?


    So ich gelesen habe wird dann anders als bei der klassischen Methode, nicht immer auf die Platte mit dem meisten freien Platz geschrieben, sondern es wird erst die 1. Platte vollgeschrieben, dann die 2. usw. Man muss dann wohl den minimal freien Platz pro Platte (ab dem auf die nächste Platte gewechselt wird) auf einen Wert kleiner als die max. Dateigröße für Aufnahmen setzen. Eine extrem große max. Dateigröße, um die Aufnahme möglichst in nur eine TS Datei zu quetschen, wäre hier evt. nicht so ideal. Ansonsten sehe ich keinen Nachteil im Vergleich zur klassischen Symlink Methode.


    Für Feedback wäre ich dankbar, bevor ich mir Arbeit mache, die ich nachträglich wieder rückgängig machen muss.



    Pete

    Merci für die Hinweis.


    Ich glaube zwar nicht, dass es verboten ist, einen Link zu einem Skript zu posten, dass nichts weiter tut, als für private Zwecke ein paar öffentlich zugängliche Bilder runterzuladen. Wenn das hier schon verboten wäre, würde ich ernsthaft ans Auswandern denken. Wenn es hier aber nicht erwünscht ist, so etwas zu posten, dann halte ich mich nat. dran. Die Forenbetreiber haben schließlich Hausrecht, genau wie die Hoteliers. ;-)


    Dann mache mich mal auf die Suche nach dem Voldemort-Skript - uups, nu isser mir doch rausgerutscht. ;-)


    Pete

    Hi,
    der Skin erwartet die epgimages unter /var/cache/vdr/epgimages als *.jpg

    Danke.


    Und wie/woher kommen die epgimages da rein. Dazu braucht es vermutlich noch ein weiteres Plugin, das sich diese von irgendwelchen Webseiten saugt, oder?


    Vielleicht tvm2vdr ?


    Gibt es aber - glaube ich - nicht als yaVDR Paket, hmm ...


    Pete

    Wenn ich meinen VDR Client aufwecke will ich in den meisten Fällen auf Aufnahmen meines VDR Server zugreifen. Deshalb habe in den PM Settings des Client einen WOL Befehl zum Starten des Servers eingebaut. Geht soweit prima.


    Der VDR Client hat zwischenzeitlich einen eigenen Sundtek Tuner bekommen und darf gelegentlich auch selbstständig Sendungen aufzeichnen. Bei meiner jetzigen Konfiguration startet er dabei aber auch immer den Server per WOL. Das müsste nat. nicht sein.


    Wo müsste ich den WOL Befehl unterbringen, damit er nur dann gesendet wird, wenn der Client per FB aufgeweckt wird, nicht aber, wenn er via Aufnahmetimer aufgeweckt wird?


    Pete

    Als workaround könnte erst mal das funktionieren:
    ----
    /usr/bin/dbus-send --system --type=method_call --dest=de.tvdr.vdr /Remote de.tvdr.vdr.remote.CallPlugin string:'conflictcheckonly'
    ----
    das öffnet einfach das conflictcheckonly Menü (so wie du es jetzt auch manuell tust).

    Yep, tut.


    Kann ich den Befehl noch so erweitern, dass das Menü automatisch wieder geschlossen wird?


    Pete

    Mein yaVDR mit Sundtek Stick hat das Problem, dass beim Aufwachen aus S3 auf Timerkonflikte geprüft wird, bevor der Sundtek Stick aktiv ist. Ergo bekomme ich Timerkonfikt Warnungen für alle gesetzten Timer, da ohne Empfänger nat. nichts aufgezeichnet werden kann. Die Warnung verschwindet, wenn ich im Menü auf Timerkonflikte gehe, dann sind plötzlich keine mehr da.


    Ich müsste den VDR dazu bringen, dass er nach dem Aktivieren des Sundtek Sticks automatisch nochmals auf Timerkonflikte prüft. Der Befehl müsste vermutlich nach /etc/sundtek.d/attach/
    Nur weiß ich leider nicht, welchen Befehl ich da eintragen muss. Versuche mit /usr/lib/vdr/svdrpsend.pl plug conflictcheckonly brachten keinen Erfolg.


    Weiß jemand Rat?


    Pete

    Merci für den Hinweis.


    Wie kann ich jetzt aber testen, ob ich evt. neue Dosen brauche bzw. ob mein Hausverstärker entzerrt werden müsste?


    Kann/darf man den selber entzerren? Wie?




    Hatte vor einem halben Jahr einen Techniker von KabelBW im Haus wegen den Störungen. Der hat mit einem Oszilloskop ähnlichen Gerät alle Dosen vermessen und meinte "sauberes Signal, wenn, dann eher zu stark als zu schwach". Und wenn einzelne Geräte Probleme mit dem starken Signal hätten, dann sollte ich ein Dämpfungsglied vorschalten.


    Habe schon diverse Basteleien hinter mir als da wären:


    • Verschiedene Dosen im Haus ausprobiert.
    • Verschiedene Antennenkabel von Fertigware bis selber geschraubt oder gecrimpt.
    • Zusätzlicher Antennenverstärker (war vor dem Technikerbesuch).
    • Justierbare Dämpfungsglieder (war nach dem Technikerbesuch).
    • Wechsel von TT-Budget (PCI) auf DigitalDevices (PCIe) Tuner.


    Mal habe ich dem Eindruck es wäre etwas besser, irgendwann sind die Störungen aber wird da und mindestens genau so oft wie zu Beginn der Experimente.


    Seltsam nur, dass der im Sony Fernseher verbaute DVB-C Tuner noch nie derartige Probleme hatte, was das Reklamieren beim Kabelprovider nat. etwas schwierig macht. -> "Das liegt an Ihren Geräten, nicht an unserem Signal." ;(



    Pete