Posts by derknut

    Hallo,


    (english version available if requested)


    leider funktioniert mein neu erworbener Fritz!WLAN Repeater DVB-C mit meinem altgedienten VDR nicht.


    Versionsinfo:

    - VDR zum Test auf meinem Ubuntu 16.04 Desktop Headless mit lokalem Kodi PVR VDR VNSI

    - channels.conf über Fritz mit VDR erzeugt, dann Kanalupdate im VDR abgeschaltet und die Einträge zum Test auf eine handvoll ÖR/SD Sender reduziert

    - vdr (2.2.0/2.2.0) - The Video Disk Recorder

    - satip (2.2.3) - SAT>IP Devices

    - vnsiserver (1.3.1) - VDR-Network-Streaming-Interface (VNSI) Server

    - femon (2.2.1) - DVB Signal Information Monitor (OSD)

    - Kodi 18.0-BETA3 Git:20181003-c2e1b31 Media Center Kodi

    - Fritz OS 06.92 (neuere gibt es laut AVM noch nicht)


    DVB-C über den Repeater funktioniert klaglos mit VLC und Kodi/IPTV.


    satip Konfiguration in /etc/vdr/conf.d/50-satip.conf:

    -s 192.168.1.33|DVBC-2|fritzdvbc


    Habe auch versucht dort nur einen Tuner anzugeben, kein Erfolg:

    -s 192.168.1.33|DVBC-1|fritzdvbc

    -d 1


    Der syslog sieht zunächst vielversprechend aus:

    Oct 7 13:38:31 knut-destop vdr: [32351] SATIP: Adding server '192.168.1.33|DVBC-2|fritzdvbc' CI: no Quirks: PlayPids,ForceLock

    Oct 7 13:38:31 knut-destop vdr: [32351] new device number 1

    Oct 7 13:38:31 knut-destop vdr: [32351] SATIP: Creating device CardIndex=0 DeviceNumber=0 [device 0]

    Oct 7 13:38:31 knut-destop vdr: [32357] SATIP#0 tuner thread started (pid=32351, tid=32357, prio=high)

    Oct 7 13:38:31 knut-destop vdr: [32358] SATIP#0 section handler thread started (pid=32351, tid=32358, prio=high)

    Oct 7 13:38:31 knut-destop vdr: [32351] new device number 2

    Oct 7 13:38:31 knut-destop vdr: [32359] device 1 section handler thread started (pid=32351, tid=32359, prio=low)

    Oct 7 13:38:31 knut-destop vdr: [32351] SATIP: Creating device CardIndex=1 DeviceNumber=1 [device 1]

    Oct 7 13:38:31 knut-destop vdr: [32360] SATIP#1 tuner thread started (pid=32351, tid=32360, prio=high)

    Oct 7 13:38:31 knut-destop vdr: [32351] SATIP: Using CURL 7.47.0 rtsp

    Oct 7 13:38:31 knut-destop vdr: [32351] starting plugin: vnsiserver

    Oct 7 13:38:31 knut-destop vdr: [32351] VNSI: Starting vnsi server at port=34890

    Oct 7 13:38:31 knut-destop vdr: [32351] VNSI: VNSI Server started

    Oct 7 13:38:31 knut-destop vdr: [32351] VNSI: Channel streaming timeout: 10 seconds

    Oct 7 13:38:31 knut-destop vdr: [32363] VDR VNSI Server thread started (pid=32351, tid=32363, prio=high)

    Oct 7 13:38:31 knut-destop vdr: [32351] switching to channel 1 (Das Erste)

    Oct 7 13:38:31 knut-destop vdr: [32351] setting watchdog timer to 60 seconds

    Oct 7 13:38:31 knut-destop vdr: [32361] SATIP#1 section handler thread started (pid=32351, tid=32361, prio=high)

    ....
    Danach folgen einige Fehlermeldungen, die aber nach Kanalwechsel mit Kodi aufhören:

    Oct 7 13:38:32 knut-destop vdr: [32357] SATIP-ERROR: Detected invalid status code 500: rtsp://192.168.1.33/ [device 0]

    Oct 7 13:38:32 knut-destop vdr: [32357] SATIP-ERROR: Pid update failed - retuning [device 0]

    Oct 7 13:38:32 knut-destop vdr: [32357] SATIP-ERROR: Detected invalid status code 500: rtsp://192.168.1.33/ [device 0]

    Oct 7 13:38:32 knut-destop vdr: [32357] SATIP-ERROR: Connect failed [device 0]

    Oct 7 13:38:32 knut-destop vdr: [32357] SATIP-ERROR: Detected invalid status code 500: rtsp://192.168.1.33/ [device 0]

    ...

    Ein Kanalwechsel ergibt folgendes:

    Oct 7 14:29:51 knut-destop vdr: [5920] VNSI: cxSocket::read: eof, connection closed

    Oct 7 14:29:51 knut-destop vdr: [5864] loading /var/lib/vdr/plugins/vnsiserver/allowed_hosts.conf

    Oct 7 14:29:51 knut-destop vdr: [5864] VNSI: Client with ID 3 connected: 127.0.0.1:60572

    Oct 7 14:29:51 knut-destop vdr: [5965] VNSI: Welcome client 'XBMC Media Center' with protocol version '12'

    Oct 7 14:29:51 knut-destop vdr: [5965] VNSI: LiveStreamer::Close - close

    Oct 7 14:29:51 knut-destop vdr: [5965] VNSI: close video input ...

    Oct 7 14:29:51 knut-destop vdr: [5965] VNSI: Successfully found following device: 0x24c3430 (1) for receiving

    Oct 7 14:29:51 knut-destop vdr: [5966] device 1 receiver thread started (pid=5852, tid=5966, prio=high)

    Oct 7 14:29:51 knut-destop vdr: [5965] VNSI: Successfully switched to channel 1 - Das Erste

    Oct 7 14:29:51 knut-destop vdr: [5965] VNSI: Started streaming of channel Das Erste (timeout 10 seconds)

    Oct 7 14:29:51 knut-destop vdr: [5968] cLiveStreamer stream processor thread started (pid=5852, tid=5968, prio=high)

    Oct 7 14:29:51 knut-destop vdr: [5967] VNSI: VideoInput: no pat/pmt within timeout, falling back to channel pids

    Oct 7 14:29:51 knut-destop vdr: [5967] VNSI: Video Input - new pmt, attaching receiver

    Oct 7 14:29:51 knut-destop vdr: [5923] VNSI: exit streamer thread

    Oct 7 14:29:51 knut-destop vdr: [5923] cLiveStreamer stream processor thread ended (pid=5852, tid=5923)

    Oct 7 14:29:51 knut-destop vdr: [5920] VNSI: LiveStreamer::Close - close

    Oct 7 14:29:51 knut-destop vdr: [5920] VNSI: close video input ...

    Oct 7 14:29:51 knut-destop vdr: [5920] VNSI: call retune ...

    Oct 7 14:29:51 knut-destop vdr: [5920] VNSI: call retune ...

    Oct 7 14:29:51 knut-destop vdr: [5920] VNSI: close video input ...

    Oct 7 14:29:51 knut-destop vdr: [5921] device 2 receiver thread ended (pid=5852, tid=5921)

    Oct 7 14:29:51 knut-destop vdr: [5865] VNSI: Client with ID 2 seems to be disconnected, removing from client list

    Oct 7 14:29:51 knut-destop vdr: [5861] curl_easy_perform() [rtsp.c,313] failed: RTSP CSeq mismatch or invalid CSeq (85)

    Oct 7 14:29:51 knut-destop vdr: [5861] SATIP-ERROR: Detected invalid status code 454: rtsp://192.168.1.33/ [device 1]

    Oct 7 14:29:52 knut-destop vdr: [5857] SATIP: Detected 1 RTP packet errors [device 0]

    Oct 7 14:29:52 knut-destop vdr: [5968] VNSI: Created stream for pid=101 and type=7

    Oct 7 14:29:52 knut-destop vdr: [5968] VNSI: Created stream for pid=102 and type=2

    Oct 7 14:29:52 knut-destop vdr: [5968] VNSI: Created stream for pid=104 and type=11

    Oct 7 14:30:01 knut-destop vdr: [5968] VNSI: Channel: startcode 5 // Kodi sagt "Channel encrypted?")


    Im Fritz Webinterface - Live TV sehe ich die IP des VDR, aber dort werden Sender gescannt die nicht in der channels.conf vorkommen. Mit Wireshark sehe ich jede Menge EPG Daten trotz setup.conf mit:

    satip.EnableEITScan = 0


    Was mach ich falsch? :wand


    Danke und Grüße


    Knut

    Hallo,


    ich möchte mit meinem Laptop auf den VDR zugreifen. Das funktioniert dank streamdev-plugin und xine wunderbar.


    Leider kann ich mir keine Aufnahmen von meinem Server anschauen. Im Readme des Plugin wird auf einen Main-Menu Eintrag "Streaming Control" verwiesen den es bei mir nicht gibt.


    Habe:


    vdr (1.4.7/1.4.5) - The Video Disk Recorder
    xine (0.7.11) - Software based playback using xine
    streamdev-server (0.3.3-pre3-geni) - VDR Streaming Server
    streamdev-client (0.3.3-pre3-geni) - VTP Streaming Client


    Den Server hatte ich nur zum Test aufgenommen, brauche ich hier sonst nicht. streamdev aus dem aktuellen CVS. Im Code finde ich auch die im Readme beschriebenen Menu Einträge, aber keinen Hinweis wovon die noch abhängen.


    Was habe ich vergessen?


    Danke und Grüße


    Knut

    Hallo,


    das ist eine Augabe von lilo. lilo muss den root wissen/setzen um die entsprechenden Dateien zu finden und dort absolute Pfade zu setzen. Kenne ich noch aus den alten Tagen, wenn Windoof den MBR besetzt hatte und per von CD gestarteten Linux und lilo vertrieben werden musste.


    Noch mal, ich ruf chroot nicht, das tut lilo. Das funktioniert auch immer, außer wenn der vdr bei booten automatisch starte.


    Danke


    Knut

    Hallo,


    nach dem ich nun meinen 2.VDR neu mit Debian hoch gezogen habe gibt es noch ein Problem mit dem Rebbot per Lilo um die Weckdaten für nvram-wakeup zu aktivieren.


    Ich rufe in vdrshutdown lilo zum Reboot so auf:


    /sbin/lilo -v -v -v -v -v -R powerdown >/home/knut/log2.txt


    (Schon mit mehr Info um zu sehen was abgeht).


    Lilo gibt dann folgende Fehlermeldung aus:


    Fatal: chroot /dev/root: Not a directory


    Es ist alles in Ordnung, d.h. Reboot funzt einwandfrei, wenn ich
    - lilo direkt aufrufe
    - vdrshutdown direkt aufrufe
    - den vdr in einer shell starte und dann PowerOff betätige


    Nur wenn ich den vdr automatisch im Startscript beim Booten starten lasse kriege ich die Fehlermeldung oben und Reboot geht nicht.
    Ich vermute das hat was mit dem Kontext zu tun in dem der vdr läuft, aber so genau kenn ich mich da nicht aus. Alles läuft beim manuellen und beim automatischen Start als root. Habe das nach besten Wissen und Gewissen genauso gemacht wie bei meinem 1.Vdr, da gehts. Bin ratlos.


    Nutze normalerweise auch grub aber da geht einer von ca. 10 Boots in die Hose, weil der Timeout beim Start nicht funktioniert. Der vdr wartet dann im Bootmenu auf eine Eingabe die mangels Monitor und Tastatur niemals kommt. Deshalb bin ich auf lilo ausgewichen und das war bislang erfolgreich.


    Bin für jede Hilfe dankbar


    Knut

    Hallo,
    da ich nun aus der "nur" DVB-C/-T-Wohnung ausziehe und endlich in der Lage bin DVB-S zu bekommen möchte ich meine VDRchen umrüsten. Da ich mich mit Sat noch nie beschäftigt habe dazu ein paar Fragen:


    - Wo gibts es denn brauchbare Anfänger Infos / Links zu Schüsseln/LNB/sonstiges?
    - Lohnt es sich schon DVB-S2 HW zu verbauen?
    - Was brauch ich für eine Schüssel/LNB/??? wenn ich 2-3 DVB-S Karten versorgen will?
    - Muss ich zur Installation der Schüssel kundige Hilfe oder gar einen Fachmann haben?
    Danke
    derknut

    Hallo!


    Ich habe das Problem das manchmal nach dem Einschalten das MPlayer Plugin nicht funktioniert. Nach längerem Suchen in den Logs und im Forum habe ich festgestellt das es an dem Ausgabegerät liegt. Also die mplayer.sh.conf entsprechend den Hinweisen im Forum angepasst um das korrekte Primary/Ausgabe Device aus der setup.conf zu lesen:


    # DVB Primary Device bestimmen
    GERAET=":card=$(awk -F= '/^PrimaryDVB/ {printf("%i",$2);}' /vdr/setup.conf)"
    AO="mpegpes"$GERAET
    VO="mpegpes"$GERAET


    Das funktioniert auch nicht immer. Anscheinend sortiert mein VDR die drei DVB Karten (nur eine FF Karte, s.u.) manchmal um (die FF ist mal 1/adapter0, 2/adapter1 oder 3/adapter2 =:-(. VDR erkennt zwar automatisch das Ausgabegerät, speichert es aber nur nach Beenden in die setup.conf. D.h. direkt nach dem Einschalten steht dort u.U. das falsche Device. Füre ich per Menu einen Neustart (nur des VDR) durch ist alles prima.


    Nach dem ganzen Sermon nun endlich die Fragen:


    - Wie kann das korrekte Ausgabegerät direkt bestimmen?


    oder noch besser


    - Wie kann ich das beliebige Umsortieren beim Einschalten verhindern, d.h. die PCI Erkennung dazu bringen die DVB Karten immer als die gleichen Devcies einzubinden (Debian Sarge).


    Bin für jede Hilfe dankbar


    derknut

    Hallo!


    Habe meinen VDR mit der 1.41 aufgerüstet und nun das Problem das das DVD Plugin bei DVD mit AC3 Ton stumm bleibt. Im Forum fand ich die Lösung "Dolby-Digital-Ton benutzen" auf "Nein" zu stellen. Dann funktioniert das, aber VDR nimmt keinen AC3 Ton mehr auf.


    Wie kann man das getrennt einstellen? Bei der Wiedergabe brauche ich den AC3 Ton nicht, da meine Premium DVB-C Karte nur einen analogen Ausgang hat. Aber wenn ich Aufnahmen zu DVDs umrubel hätte ich schon gern AC3 Ton.


    Vielen Dank für jede Hilfe


    derknut

    Hallo!


    Erstmal vielen Dank an alle die geholfen haben!


    Die channel.conf wars. Die hier geposteten sehen genauso aus wie meine urspruengliche (vor dem Umbau) und die geht jetzt plötzlich auch. Dabei hab ich mit der ganzen Umkonfiguriererei erst angefangen weil die urspruengliche Konfig kein Bild/Ton hatte.


    Wahrscheinlich hab ich den Fehler in den letzten Naechten aus Versehen behoben. Werd jetzt langsam zurueck bauen und mal sehen was es war.


    Trotzdem scheint dem aktuellen VDR (1.3.24-30 hab ich versucht) eine channels.conf.cable beizuliegen die falsche Frequenzeintraege enthaelt (z.B. 410 statt 410000) und damit klappt natuerlich auch kein AutoPID.


    Oder (wahrscheinlicher!) sollte ich nicht nachts, mit halb geschlossenen Augen, am VDR basteln.


    Nochmals vielen Dank, das Forum hat mal wieder bewiesen DIE Instanz zu sein wenn es um Probleme mit dem VDR geht.


    Viel Spass und stoerungsfreie Aufnahmen


    Knut

    Hallo!


    Vielen Dank fuer die prompte Antwort. Die channels.conf ist wie gesagt die dem VDR beiliegende channels.conf.cable:


    Das Erste:410:M64:C:6900:101:102:104:0:28106:0:0:0
    ZDF:394:M64:C:6900:110:120:130:0:28006:0:0:0
    3sat:394:M64:C:6900:210:220:230:0:28007:0:0:0
    arte:410:M64:C:6900:401:402,403:404:0:28109:0:0:0
    ...


    in der channels.conf-dvbc-berlin von czap steht dazu, z.B.


    arte:410000000:INVERSION_OFF:6900000:FEC_NONE:QAM_64:401:403


    Hab mal die DVB Treiber mit debug gestartet, beim VDR Start:


    Aug 25 21:33:01 vdr vdr[14821]: VDR version 1.3.30 started
    Aug 25 21:33:01 vdr vdr[14821]: loading /video/sources.conf
    Aug 25 21:33:01 vdr vdr[14821]: loading /video/channels.conf
    Aug 25 21:33:01 vdr vdr[14821]: loading /video/remote.conf
    Aug 25 21:33:01 vdr vdr[14821]: probing /dev/dvb/adapter0/frontend0
    Aug 25 21:33:01 vdr kernel: dvb-ttpci: dvb_video_open(): av7110:d0e78000,
    Aug 25 21:33:01 vdr kernel: dvb-ttpci: SetPIDs(): d0e78000
    Aug 25 21:33:01 vdr kernel: dvb-ttpci: dvb_audio_open(): av7110:d0e78000,
    Aug 25 21:33:01 vdr kernel: dvb-ttpci: dvb_video_ioctl(): av7110:d0e78000,
    Aug 25 21:33:01 vdr kernel: dvb-ttpci: dvb_video_ioctl(): av7110:d0e78000,
    Aug 25 21:33:03 vdr vdr[14821]: probing /dev/dvb/adapter1/frontend0
    Aug 25 21:33:03 vdr vdr[14821]: found 1 video device
    Aug 25 21:33:03 vdr vdr[14821]: setting primary device to 1
    Aug 25 21:33:03 vdr vdr[14821]: tuner on device 1 thread started (pid=14821, tid=1078545328)
    Aug 25 21:33:03 vdr vdr[14821]: Section handler thread started (pid=14821, tid=1080646576)
    Aug 25 21:33:03 vdr kernel: dvb-ttpci: dvb_video_ioctl(): av7110:d0e78000,
    Aug 25 21:33:03 vdr kernel: dvb-ttpci: dvb_video_ioctl(): av7110:d0e78000,
    Aug 25 21:33:03 vdr vdr[14821]: SVDRP listening on port 2001
    Aug 25 21:33:03 vdr vdr[14821]: loading /video/themes/sttng-default.theme
    Aug 25 21:33:03 vdr vdr[14821]: loading /video/themes/sttng-default.theme
    Aug 25 21:33:03 vdr vdr[14821]: remote control KBD - keys known
    Aug 25 21:33:03 vdr kernel: dvb-ttpci: dvb_audio_ioctl(): av7110:d0e78000,
    Aug 25 21:33:03 vdr kernel: dvb-ttpci: av7110_set_volume(): av7110:d0e78000,
    Aug 25 21:33:03 vdr vdr[14821]: KBD remote control thread started (pid=14821, tid=1082747824)


    Mehr kommt nicht. Irgendwelche Kanalwechsel sind nicht zu erkennen, da wie gesagt VDR auf die Tastatureingaben nicht reagiert, also auch kein Kanalwechsel statt findet.


    Bei czap kommt nicht nur wunderbar Bild und Ton sondern auch:


    Aug 25 21:49:13 vdr kernel: dvb-ttpci: av7110_start_feed(): d0e78000
    Aug 25 21:49:13 vdr kernel: dvb-ttpci: dvb_feed_start_pid(): d0e78000
    Aug 25 21:49:13 vdr kernel: dvb-ttpci: ChangePIDs(): d0e78000
    Aug 25 21:49:13 vdr kernel: dvb-ttpci: av7110_start_feed(): d0e78000
    Aug 25 21:49:13 vdr kernel: dvb-ttpci: dvb_feed_start_pid(): d0e78000
    Aug 25 21:49:13 vdr kernel: dvb-ttpci: ChangePIDs(): d0e78000
    Aug 25 21:49:13 vdr kernel: dvb-ttpci: SetPIDs(): d0e78000


    Irgendwie klingt "start_feed" fuer mich nach genau dem was ich suche, warum kommt das nicht beim VDR? Verhaelt sich auch insgesamt voellig anders.


    Dachte eigentlich ich kenn mich langsam aus mit VDR, aber jeder Tag bringt neue Zweifel.


    Waere dankbar fuer jede Hilfe.


    Danke


    Knut

    Hallo!


    Die Karte ist eine Technotrend/HauppaugeWinTV DVB-C rev2.1, eine aeltere gebraucht erstandene FF/Premium Karte.


    Die Karte scheint in Ordnung, da ja mit czap Bild und Ton einwandfrei sind. Da der Rechner noch offen ist, ist mir aufgefallen das die Karte sehr heiss wird, aber das scheint bei diesem Typ lt. Forum nicht ungewoehnlich zu sein. Aber auch nach Abkuehlung, Neustart, Treiber laden und VDR starten kein Bild kein Ton. Bei anschliessendem czap alles prima.


    Hab fuer den VDR die beiliegende channels.conf.cable für DVB-C in Berlin benutzt. Die Werte stimmen soweit zu sehen mit der entsprechenden Datei aus szap/czap ueberein, aber das Format scheint anders. Kann ich die Datei aus szap/czap direkt als channels.conf benutzen?


    Hab auch die ersten paar Zeilen aus meiner alten channels.conf probiert (DXR3+DVB-C+DVB-T Budget funzte mit VDR 1.3.24). Auch den VDR 1.3.24 in der vorhergenden und auch ale neue Installation hab ich probiert, immer das gleiche.


    Bislang war immer bei Treiber ok + OSD ok = VDR ok, aber nun weis ich wirklich nicht mehr weiter. Auch wenn es Tuningprobleme gibt muesste doch mindestens auf Tastatureingaben reagiert werden oder "Kanal nicht verfuegbar" im OSD stehen, oder?


    Danke fuer jede Hilfe


    Knut

    Hallo!


    Hab meinen 2. VDR umgeruestet und die wackelige DXR3 gegen eine DVB-C FF Karte ausgetauscht. Hab nach Hubertus DVB Treiber und VDR installiert. Die Treiber laden ohne Auffaelligkeiten:


    Aug 24 23:35:58 vdr kernel: saa7146: register extension 'dvb'.
    Aug 24 23:35:58 vdr kernel: ACPI: PCI interrupt 0000:02:09.0[A] -> GSI 21 (level, low) -> IRQ 225
    Aug 24 23:35:58 vdr kernel: saa7146: found saa7146 @ mem e102e400 (revision 1, irq 225) (0x13c2,0x0002).
    Aug 24 23:35:58 vdr kernel: DVB: registering new adapter (Technotrend/HauppaugeWinTV DVB-C rev2.X).
    Aug 24 23:35:58 vdr kernel: adapter has MAC addr = 00:d0:5c:01:f3:aa
    Aug 24 23:35:58 vdr kernel: dvb-ttpci: gpioirq unknown type=0 len=0
    Aug 24 23:35:58 vdr kernel: dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 8000261c
    Aug 24 23:35:58 vdr kernel: dvb-ttpci: firmware @ card 0 supports CI link layerinterface
    Aug 24 23:35:58 vdr kernel: dvb-ttpci: Crystal audio DAC @ card 0 detected
    Aug 24 23:35:58 vdr kernel: saa7146_vv: saa7146 (0): registered device video0 [v4l2]
    Aug 24 23:35:58 vdr kernel: DVB: registering frontend 0 (VLSI VES1820 DVB-C)...
    Aug 24 23:35:58 vdr kernel: dvb-ttpci: found av7110-0.
    Aug 24 23:35:58 vdr kernel: saa7146: register extension 'budget dvb'.
    Aug 24 23:35:58 vdr kernel: saa7146: register extension 'budget_ci dvb'.
    Aug 24 23:35:58 vdr kernel: saa7146: register extension 'budget dvb /w video in'.


    Der VDR startet auch ohne Fehlermeldung:


    Aug 24 23:48:34 vdr vdr[13088]: VDR version 1.3.30 started
    Aug 24 23:48:34 vdr vdr[13088]: loading /video/sources.conf
    Aug 24 23:48:34 vdr vdr[13088]: loading /video/channels.conf
    Aug 24 23:48:34 vdr vdr[13088]: loading /video/remote.conf
    Aug 24 23:48:34 vdr vdr[13088]: probing /dev/dvb/adapter0/frontend0
    Aug 24 23:48:36 vdr vdr[13088]: probing /dev/dvb/adapter1/frontend0
    Aug 24 23:48:36 vdr vdr[13088]: found 1 video device
    Aug 24 23:48:36 vdr vdr[13088]: setting primary device to 1
    Aug 24 23:48:36 vdr vdr[13088]: tuner on device 1 thread started (pid=13088, tid=1078545328)
    Aug 24 23:48:36 vdr vdr[13088]: Section handler thread started (pid=13088, tid=1080646576)
    Aug 24 23:48:36 vdr vdr[13088]: SVDRP listening on port 2001
    Aug 24 23:48:36 vdr vdr[13088]: loading /video/themes/sttng-default.theme
    Aug 24 23:48:36 vdr vdr[13088]: loading /video/themes/sttng-default.theme
    Aug 24 23:48:36 vdr vdr[13088]: remote control KBD - keys known
    Aug 24 23:48:36 vdr vdr[13088]: KBD remote control thread started (pid=13088, tid=1082747824)


    Wenn ich remote.conf loesche kommt auch der uebliche Anlerndialog, also scheint auch OSD zu funzen.


    Aber hab kein Bild, weder TV noch Menues. VDR reagiert auf keine Tastatureingabe.


    Die DVB Treiber hab ich mit czap getestet:


    czap -c channels.conf-dvbc-berlin Arte
    using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
    reading channels from file 'channels.conf-dvbc-berlin'
    133 arte:410000000:INVERSION_OFF:6900000:FEC_NONE:QAM_64:401:403
    133 arte: f 410000000, s 6900000, i 0, fec 0, qam 3, v 0x191, a 0x193
    status 00 | signal 7e7e | snr 0000 | ber 009ffff6 | unc 0000002b |
    status 1f | signal ffff | snr e0e0 | ber 009ffff6 | unc ffffffff | FE_HAS_LOCK
    status 1f | signal ffff | snr e0e0 | ber 009ffff6 | unc 00000000 | FE_HAS_LOCK


    und hab prima Bild und Ton.


    Weis jemand Rat, ich bin mit meinem Latein am Ende.


    Vielen Dank


    Knut

    Hallo, Mitleidene!


    Kaum ist man zwei Tage nicht in VDR-Nähe, schon über 150 Postings, fleißig, fleißig. Hatte schon angefangen eine Lösung zu stricken bevor ich mich in die Vatertagsfeierlichkeiten verabschiedet habe, also ist dies nicht als Konkurrenz für die tollen direkten Ausleselösungen zu sehen. Leider laufen die bei mir nicht, vdr beendet sich kommentarlos bei TVTV update.


    Voraussetzungen:
    1) tvtvForPC.dat installieren (von www.tvtv.de). Hab ich bei mir umbenannt in tvtvget (klingt schöner) und nach /vdr kopiert (Beispielpfad, ändern siehe unten).
    2) Patch einspielen (Vorsicht, ist mein erster selbsterzeugter Patch)
    3) in tvtv.c oben folgende Zeile ggf. anpassen:
    string tvtvFilePath("/vdr");
    4) Dann mit
    ./tvtvget -s --login ... --passwd ... --target www.tvtv.de -p /vdr
    wie im README von tvtv.de beschrieben das config Verzeichnis "/vdr/tvtv" anlegen. Dort wird dann auch die Jobsdatei angelegt. Ausprobieren mit "./tvtvget -j -p /vdr".
    Dann sollten folgende Dateien vorhanden sein:
    /vdr/tvtv/tvtv.conf
    /vdr/tvtv/tvtv.log
    /vdr/tvtv/tvtvJobs.csv
    5) Wenn man trotz der 1h Zeitsperre nochmal holen will in tvtv.conf folgende Werte wieder auf 0 setzen:
    [JOBS]
    serial=0;
    lastSync=0;
    dann gehts gleich nochmal
    6) Hab nicht nur das Plugin geändert sondern auch timer.h und timer.c des vdr. Damit lassen sich ohne den Umweg über Stringkonvertierungen und cTimer.Parse Timer im VDR setzen (auch im patch enthalten).



    Dann sollte es nach dem üblichen kompilieren (make und make plugins) gehen.


    Im Plugin wird dann per fork/exec (Vorsicht! Hab ich auch zum ersten mal gemacht) das tool gerufen, die damit erzeugte Datei gelesen und die Werte in die Timerliste übernommen, inkl. löschen und VPS.


    Bei VPS wird keine Vorlaufzeit für den Timer gespeichert, weis nicht ob das so ok ist, hab ich aber absichlich so gemacht.


    Auch bei mir wird nicht die gesamte Merkliste gelesen (Fehlermeldung im Log sagt das jemand das begrenzt, wahrscheinlich der Server). Eine entsprechende Anfrage hab ich an Den Support von tvtv.de geschickt.


    Was noch zu tun ist:


    1) Außer das "extended file format" flag wird keine Wert aus der Config für das TVTV-Plugin übernommen (User/Passwort/URL stehen in tvtv.conf).
    Das sollte wieder mehr werden (Pfad/Name des Tools/ConfigDatei; VPS Übernahme; Delete ausführen uvm)
    2)Vielleicht doch ohne Ändeurng in timer.c/.h auskommen
    3) Die Werte in tvtv.conf aus dem Plugin heraus zurücksetzen um zu beliebigen Zeitpunkten die Daten holen zu können.
    4) Die Info zur Sendung ist noch abgehackt, da müssen noch die Sonderzeichen ersetzt werden.


    Wie gesagt bei mit klappts, aber Vorsicht, ist die eine oder andere Premiere meinerseits enthalten und C++ ist auch nicht gerade meine Muttersprache (die seltsame Warning beim Kompilieren war schon =;-)


    Werd das auch bei mir so lassen, ist näher am Original und falls die bei tvtv.de sich wieder was neues einfallen lassen, tausch ich einfach das Tools aus und pass ggf. die Datenreihenfolge an. Kein Ärger mit XML links- oder rechtsrum, POST oder GET.


    Viel Spass und schreibt mal ob es gefällt, ich geh jetzt pennen


    Knut

    Hallo!


    Hab ein Abo bei tvtv.de bestellt und kann nun auch mit dem auf tvtv.de
    angebotenen Linux Tool "tvtvForPC.dat" (witzige Beschreibung dort: "Beim Linux download handelt es nicht um ein fertiges Programm, sondern nur um eine binary !") die Merkliste im CSV Format runterladen. Die 20 Teuro im Jahr ist mir der Service wert (die halbe Schachtel Kippen im Monat spar ich allemal, wenn mein VDR sich wie zuvor stressfrei aus der ganzen weiten Welt programmieren laesst).


    Nur ist das ja noch weit von einer Loesung entfernt:


    1) Arbeitet schon jemand daran diese Daten wie zuvor in den VDR zu kriegen?
    Genka?


    2) Leider krieg ich nicht die gesamte Merkliste, es scheint dort eine
    Beschränkung der Anzahl der Eintraege im Tool zu geben. Im tvtv.log steht:
    "Warning: server truncated list of active jobs or list of deleted jobs to a
    maximum number of entries". Hat noch jemand das Problem?


    Wie gesagt, hab mich an tvtv.de gewoehnt und nach dem Lesen der Alternativen wuerde ich das gern weiter nutzen.


    Hab ein Ethereal Log und meine runtergeladene Merliste kann ich zur Verfuegung stellen. Versuch mal das hier anzuhaengen, hab das aber noch nie gemacht.


    Werd selber probieren die CSV Daten in den VDR zu kriegen, das tvtv plugin von Genka ist da ja sehr uebersichtlich und die Daten in der CSV Datei sind durch Komma getrennter Klartext. Das kann ein Weilchen dauern, bin zwar ganz fit in C aber mit C++, Plugins und Webprotokollen steh ich auf Kriegsfuss, naja was zum Lernen.


    Waere fuer Hilfe dankbar:


    3) Wer hat Ahnung von HTTP Geschichten aus C/C++ raus und kann !einfach! eine POST Nachricht codieren, abschicken und die Antwort einsammeln? Beispielcode willkommen, wenn er simpel ist. Muesste mit dem gehen was Genka dort gemacht hat, aber wie gesagt hab ich keinen Blassen. Hab mir curl angesehen (damit ist auch tvtvForPC gemacht), aber das ist wohl mit Kanonen nach Spatzen geworfen.


    4) Wie kann ich aus dem Plugin das Tool mit geringster Prio aufrufen? Kann man ja auch machen, sich den ganzen HTTP Quatsch sparen und dann einfach die erzeugte Datei einlesen.


    5) Wuerde das ganze in das tvtv plugin haemmern, aber mit der Kettensaege nicht mit dem Skalpell. Wie macht man Patchfiles?


    6) Weis jemand warum Genka die Daten zunaechst in einen String bringt und erst dann mit Timer.Parse in das Timer-Object? Syntaxcheck? Wie sieht der String aus? ("Die Dokumentation finden Sie in den Datei die auf .c enden!" =:-)


    7) Hat jemand Lust, Zeit und die Kenntnisse das schmerzfreier als ich auf die Fuesse zu kriegen?


    An den Fragen seht ihr schon was das wird =:-)


    Gruss


    Knut

    Files

    • tvtv.zip

      (34.1 kB, downloaded 108 times, last: )

    Hallo
    !
    Bin nun stolzer Besitzer eines Silverstone LC10M inkl. imon FB und VFD. Zur Zeit läuft das ganze zwecks Test der Hardwarekomponenten noch unter Windoof, aber bald sind die neuen DVB Karten da und dann kommt da VDR drauf. Aber das muss erst laufen bevor ich meinen Hermes ausser Betrieb nehme, gibt ja jeden Tag was zum Aufnehmen =:-)


    Nun endlich meine Frage:


    Hab den imon nach Anleitung angeschlossen und funzt gut. Auch den Einschalter hab ich durchgeschleift und kann den PC per FB ausschalten. Nur das einschalten klappt nicht.


    Wo kriegt der imon im ausgeschalteten Zustand den Strom her? Vom USB? Die eigentliche Stromversorgung scheint vom Floppy-Stromanschluss zu kommen, da ist aber bei ausgeschaltetem PC kein Saft drauf.


    Darf der PC nur im Standby sein?


    Hat jemand das schon hingekriegt?


    Vielen Dank und Gruesse aus Berlin


    Knut

    Das ist auch mein Traumsystem.


    Dazu ein paar Fragen an den Erfahrenen:


    Betifft IR:
    Das DIGN gibt es auch mit Fernbedienung und IR-Empfänger. Geht der mit VDR/LIRC und lässt sich die Büchse damit einschalten? Wahrscheinlich nicht, weil Du den atric Einschalter verbaut hast. Gibt es dafür Platinen, der Link sagt die wären vergriffen.


    Betrifft Display:
    Die Danksagung lässt darauf schliessen das das geht. Ist es auch brauchbar? Was zeigst Du da an?


    Betrifft Festplatte:


    Der DIGN 5 sieht sehr nach nur einer Festplatte aus, dafür dann ziemlich viel umbaute Luft. Der DIGN 3 soll je nach Info-Quelle auch 2 Verbauplätze haben. Stimmt das?


    Mein Hermes ist mir zu klein geworden und werd den Verdacht nicht los, dass die, zum Glück nur sporadischen, Hänger thermische Ursachen haben. Ausserdem sieht der aus wie Grotte und den Platz hinter verschlossenen Türen, an den ich den verband habe, brauch ich anderweitig. Aber hat treue Dienste geleistet, werd ihn vermissen =:-)


    Danke und Grüsse aus Bärlin


    Knut