Posts by Sinclair73

    Jetzt habe ich endlich mal alles auf die aktuellen Versionen von etobi aktualisiert:


    Server:

    vdr 2.4.0-2~etobi1

    vdr-plugin-streamdev-server 0.6.1+git20180514-1


    Client:

    vdr 2.4.0-2~etobi1

    vdr-plugin-streamdev-client 0.6.1+git20180514-1


    Leider kommt immer noch die gleiche Fehlermeldung "Fehler beim Ansprechen des fernen Timers 0@SERVERNANE" (Servername ist der Name des VDR-Servers). Ich habs auch schon mit IP-Adresse statt Servername versucht, auch kein Erfolg. Wie zuvor sehe ich keine Meldungen im Log des Servers.


    Kann mir jemand mal seine Setup.conf vom Server und vom Client posten?

    Bis vor 3 Monaten hatte ich mehrere Jahre lang VDR+SAT-Karte in einem ATOM-HTPC im Wohnzimmer. Da hat Shutdown, Shutdown bei Inaktivität und ACPI-Wakeup problemlos funktioniert.


    Jetzt habe ich den ATOM-PC mit SAT-Karte in den Keller verbannt und neu als reiner Server ohne TV/Monitor installiert. Als Client verwende ich einen Raspberry PI.

    Ich hab auch hin bekommen, dass wenn der RPI bootet der VDR-Server per WakeOnLan automatisch auch gestartet wird. Dank SSD im Server ist dann auch spätestens nach 20-30 Sekunden auch ein Bild da.

    Mittelfristig will ich aber auch einen zweiten RPI benutzen.


    Was jedoch noch nicht funktioniert sind die oben genannten Shutdown-Funktionen. Ich hätte gerne folgende Funktionalität:

    1. User macht Shutdown oder beendet VDR auf dem RPI -> Server macht nach 5min auch einen Shutdown wenn keine (andere) Streamdev-Verbindung mehr aktiv ist

    2. User schaltet TV aus -> Nach kurzer Zeit (z.B. 2min) soll dann der RPI herunterfahren (geht das über cecremote und wenn ja, dann wie?). Der Server soll danach dann herunterfahren wie in 1.

    3. Nach eingestellter Inaktivität auf dem Client -> Client fährt herunter, Server macht das gleiche wie in 1.

    4. Immer wenn der RPI herunterfährt (also nicht schon wenn nur VDR gestoppt wird) soll der TV auch aus ausgehen.


    Was davon geht mit der Grundinstallation von VDR >=2.3.8 unter Debian (eTobi-Pakete) und wo müsste man speziell für die Client/Server-Lösung noch was basteln?

    Vielleicht hat schon jemand dafür eine Lösung zusammengebastelt bzw. konfiguriert und kann mir dazu ein paar Infos zukommen lassen.

    Hallo,

    ich habe 2x VDR unter Debian laufen:

    1x als Server im Keller mit einer Dual-Sat-Karte und

    1x als Client (2.3.8-2~etobi1) auf einem Raspberry im Wohnzimmer.


    Das Ganze läuft jetzt auch schon seit ein paar Monaten recht stabil (Server war bis vor kurzem noch eine sehr alte VDR-Version) . Jetzt habe ich extra auch den Server auf den aktuelle Stand (2.4.0-2~etobi1) aktualisiert, in der Hoffnung dass jetzt die Timer-Programmierung für den Server auch über den Client möglich ist.

    Auf dem Client habe ich in SVDRPDefaultHost den Servernamen eingetragen und im OSD die "SVDRP Verbindung" auf "mit jeder Maschine" gesetzt.

    Versuche ich nun einen Timer über das EPG zu setzen dann bekomme ich aber im OSD folgende Fehlermeldung:

    "Fehler beim Ansprechen des fernen Timers 0@SERVERNANE" (Servername ist der Name des VDR-Servers)

    Im Syslog des Servers sehe ich auch keine SVDRP-Meldung


    Ist die 0 (Null) bei der Fehlermeldung vielleicht ein Hinweis auf die Ursache?


    Folgendes habe ich schon getestet:

    - svdrpsend -d SERVERNAME LSTT bzw auch NEWT mit Settings vom Client aus. Das hat einwandfrei funktioniert und daher sollte die SVDRP-Verbindung möglich sein. Hier sehe ich auch eine Syslog-Meldung am Server

    - Alle Einstellungen von "SVDRP Verbindung" durchgespielt

    - Quellcode angeschaut: Leider gibt es mehrere Stellen wo die Fehlermeldung auftreten kann.


    Ich sehe auch auf dem Client in der Timerliste keine Einträge, obwohl auf dem Server welche eingetragen sind.


    Wer hat mir noch eine Idee was ich ausprobieren kann? Leider kann ich aus irgendwelchen Gründen auf dem Raspberry nicht auf die 2.4 Version updaten. Beim ersten Versuch bekam ich kein Bild mehr und hab dann wieder auch 2.3.8 downgegradet.


    Viele Grüße

    Sinclair

    Zum Thema ausschalten:


    Was ich rausgefunden habe dass wenn das /etc/init.d/halt script mit #!/bin/sh läuft.... dann bleibt die SMT an.
    Läuft das script aber mit #!/bin/bash dann geht die SMT aus und reagiert auch auf die anderen Befehle an ttyS1.
    WARUM das so ist habe ich aber noch nicht herrausgefunden.


    Gruß
    Sinclair

    Hallo,


    ich habe nochmal mit einer Neuinstallation angefangen, habe aber immer noch das Problem, dass die SMT sich nicht abschaltet.
    Habe nur Debian mit debootstrap installiert, den SMT-Kernel und Grub und ein paar nötige Pakete installiert und die /etc/init.d/halt modifiziert.
    Wenn ich nun ein shutdown -h now mache, dann kommen in der console als letzte Zeilen:


    deactivating swap...done
    will now halt.
    INIT: no more processes left in this runlevel


    Dann passiert nichts mehr. Ich habe extra mal die /sbin/hdparm und /bin/sync auskommentiert, aber das ändert nichts. Keine Änderung der Meldungen und kein Poweroff. Da ich bis dahin keine sonstigen SMT-spezifischen Dateien installiert habe und auch die SMTPowerOff Befehle nicht drin habe, kann das ganze meiner Meinung nach auch nichts mehr mit dem fehlenden WakeUp-Board zu tun haben.


    Noch eine Idee?


    Gruß
    Sinclair

    Hallo Mase,


    jetzt geht der Ton. Aber frage mich nicht warum...
    Vielleicht hat nach irgendeiner Änderung ein reboot gefehlt. Der Ton kommt mir zwar leiser vor als vom alten Image, aber das muss ich nochmal im Detail vergleichen.
    Leider schaltet meine SMT sich beim Runterfahren noch nicht aus. Aber dazu muss ich nochmal alle Rechte usw. prüfen.


    Was mich noch interessieren würde, ist ob Du eine Chance siehst das VDR als Debian-Paket zu installieren. Auf meinem HTPC (Atom/ION basierend) habe ich VDR-Pakete (1.7.18-2~ctvdr1) installiert. So sind updates usw. viel leichter zu machen und für meinen Geschmack ist die Installation nach deiner Anleitung auch etwas überladen an plugins. Wenn ich weiss ob ich irgendwelche SMT-spezifischen Patches beachten muss, kann ich die Paketerstellung auch selber mal angehen.


    Gruß
    Sinclair

    Hallo Mase


    erstmal vielen Dank für die tolle Anleitung. Endlich kann ich meine SMT auch mal wieder auf einen aktuellen Softwarestand bringen.
    Ich habe testweise die Installation auf eine alte Platte gemacht um mein laufendes (aber sehr altes) System nicht gleich kaputt zu machen.
    Ich bin jetzt so weit gekommen, dass vdr läuft und ich auch ein Bild habe. Was leider nicht geht ist der Ton. Ich höre hier garnichts :-(
    Lautstärke usw. habe ich schon kontrolliert, daran liegts nicht.
    Vielleicht hast Du da eine Idee oder sonst jemand hier im Forum.


    Abweichend zu deiner Anleitung habe ich Debian per debootstrap statt vom netinstaller installiert. Vielleicht fehlen da bei mir noch irgendwelche Pakete? Und ich habe kein WakeUp-Board, aber das hat vermutlich nichts damit zu tun.
    Den Sound erwarte ich aktuell direkt am TV (über das SCART-Kabel) also nicht am Line oder SPDIF Ausgang.


    Gruß
    Sinclair

    Hallo,


    ich habe eine Frage an alle die VDR und XBMC (PVR-Testing) auf einer Maschine laufen haben und aber nur 1 Fernbedienung (und eventl. 1 LCD) benutzen.


    Wie verwendet Ihr insbesondere die Fernbedienung und das LCD in der Praxis?


    Mein HTPC sieht aktuell so aus:
    ANTEC MICRO Fusion 350 mit Remote RM100 und LCD (15c2:0038 SoundGraph Inc), Debian Lenny mit vdrdevel 1.7.14 (e-tobi) und xbmc 1:pre10.05+pvr-testing2-svn29376+opp~1 (debian.oppserver.net).
    VDR läuft immer, XBMC nur bei Bedarf, sonst KDE oder auch mal vdr-sxfe.


    Nach einigen Versuchen läuft jetzt das LCD und zeigt VDR-Informationen an. Auch kann ich mit der Fernbedienung das VDR steuern. Aber eigentlich will ich überwiegend XBMC verwenden und vdr-sxfe nur bei Bedarf (oder auf anderem X-Server) starten. Was muss ich jetzt prinzipell tun, damit ich XBMC statt VDR steuern kann (oder geht eventuell auch irgendwie beides)?
    Das gleiche gilt eigentlich auch für das LCD.


    Idealerweise würde solange XBMC läuft, die Fernbedienung nur XBMC steuern (und nichts von VDR) und auch das LCD nur XBMC informationen anzeigen. Beende ich dann XBMC dann könnte Anzeige und Steuerung auf VDR umschalten. Aber ist sowas überhaupt möglich? VDR soll ja nicht beendet und neu gestartet werden, da könnte ja gerade eine Aufnahme laufen.


    Wer hat da Tipps oder Ideen?


    Gruß
    Sinclair

    Hallo UFO,


    ich habs nochmal probiert:
    Alles identisch, mit fw15 geht das tunen bei mir nicht:



    Mit fw17 habe ich das Problem definitiv NICHT!
    Kannst Du etwas genauer sagen warum man fw17 nicht nehmen soll?


    Gruß
    Sinclair

    Hallo,


    ich habe die die miniPCIe Tunerkarte von DigitalDevices.
    Weiss jemand ob die [ID: 18c3:0720 Subsystem 18c3:dd10] schon in einem der Repositories drin ist?
    Habe dann die ID einfach in die ngene-cards.c rein gebaut:


    Code
    1. NGENE_ID(0x18c3, 0xdd00, ngene_info_cineS2v5),
    2. + NGENE_ID(0x18c3, 0xdd10, ngene_info_cineS2mini),
    3. NGENE_ID(0x1461, 0x062e, ngene_info_m780),


    und


    nach dem Laden des Treibers konnt ich die Kanäle scannen und dann mit xbmc auf den streamdev-server vom vdr zugreifen und hab auch ein Bild. :-)
    Hab leider aktuell nur ein Sat-Kabel, so dass ich nur einen Tuner testen kann.


    Kann mir jemand sagen ob meine Änderungen so in Ordnung sind und wer kann das dann in das Repo aufnehmen? (wenn noch nicht geschehen)


    Gruß
    Sinclair

    Hi Egalus,


    sind die von Dir verwendeten DVB-Patches auch separat irgendwo zu bekommen? Ich meine also nicht schon in den Kernel gepatched.
    Die einzigen separaten Patches die ich für die SMT gefunden habe sind schon fast ein Jahr alt und ich denke die sind nicht mehr ganz aktuell.
    In den linuxtv Sourcen scheint die SMT ja (noch) nicht aufgenommen. Zumindest ist in der aktuellen Version die Device-ID der SMT nicht in der cx88-cards.c


    Gruß
    Sinclair


    Sorry, hab vergessen zu erwähnen dass ich eine SMT Box hab.
    Wie schon erwähnt ist der Fernseher ein 4:3er.


    Das OSD kleiner konfigurieren wird wohl nix bringen, den auf einigen Kanälen passt die Größe ja einwandfrei. Aber halt nicht auf allen.


    Nach der xorg.conf muss ich mal schauen. In der /etc/zendeb/config hab ich ASPECTRATIO="4:3" stehen. Das sollte ja eigentlich die richtige config ranziehen.


    Gruß
    Sinclair

    Hallo,


    ich habe mit 0.3.0 ein kleines Problem mit dem OSD:
    Bei manchen Kanälen passt das OSD schön auf meinen Fernseher, in anderen Kanälen ist das OSD viel zu breit so dass der rechte Teil nicht mehr sichtbar ist.


    Ich muss aber sagen daß ich vdr mittlerweile selbst compiliert und installiert habe. Aber sonst ist das System noch weitgehend sendeb 0.3.0.


    Habe einen normalen 4:3 Röhren-Fernseher und diesen über SCART angeschlossen.


    Hat jemand das gleiche Problem oder weiss eine Abhilfe?


    Gruß
    Sinclair

    Also ich hab mir vor einiger Zeit einen 8 zu 3 Adapter gebastelt.
    Alles mit ganz normalen TTL-Bausteinen und 5V Versorgung.
    8 Empfänger werden auf 3 einzelne 74151 (8zu1 Multiplexer) geschaltet und der Ausgang des 74151 geht dann auf jeweils einen Sender.


    Bisher schalte ich die Eingänge über 3 Jumper um, aber wenn mal Zeit ist soll das ein PIC mit IR-Empfänger übernehmen.


    Gruß
    Sinclair

    Quote

    Original von Egalus


    Da gibts nun mindestens 3 Möglichkeiten:
    - Die beiden Rechner liegen nicht im gleichen Subnetz
    - kommentier mal den Aufruf vom "firewall" script in /etc/zendeb/zendeb.local aus
    - Firewall auf dem PC deaktivieren


    Danke für die Hilfe!
    Punkt 2 war die Lösung! Spricht die Firewall verhindert den Zugriff.
    Die Firewall läßt standardmässig nur 192.168.10.xxx zu und ich hab die IP-Adresse des SMT auf 192.168.0.xxx geändert.


    Eventuell macht es Sinn einen Hinweis in die Installationsanleitung hinter dem Ändern von etc/network/interfaces einzufügen.


    Gruß
    Sinclair