Posts by e9hack

    Quote

    Original von joe0815
    habt Ihr eigentlich auch ein so schlechtes Bild auf dem S39 bei ORF/SF? Ist so seit der Kabel BW Umstellung auf QAM256. Gibt's dafür eigentlich eine Lösung?


    Hi,


    wenn die Hauppauge eine ältere Karte mit dem VES1820 als Demodulator ist, sieht es schlecht aus für QAM256. Bei einer neuren Karte mit dem STV0297 könnte ein Verstärker was bringen.


    Bei mir funktioniert eine TT-C2300 alleine am Antennenanschluß problemlos. Über einen Splitter (ohne Verstärker) betrieben, sind nur S02 und S03 klötzchenfrei. Ich benutze einen Verstärker mit zwei Ausgängen zur Signalaufteilung zwischen TV und VDR.


    Gruß
    e9hack

    Quote

    Original von woppr
    das mit ausgabe über testpins kann nicht sein, siehe register 0F datenbuch ves1820 rev. B die fusi hat rev. A weil einige register, die im datenblatt rev. B readable angegeben sind bei dem A noch nicht lesbar sind.


    Über CTRL2 vom VES1820 wird Pin 9 vom TDA9819 geschaltet. Möglicherweise hängt PIN 30 mit dran.


    Gruß
    e9hack

    Quote

    Original von helmer
    Hi!
    Ich wohne im Weser-Ems-Bereich. Kabel-Deutschland hat hier die Kanäle neu gemischt. Nachdem ich mit w_scan die channels.conf neu erstellt habe, bekomme ich keine EPG-Daten mehr für die freien Kanäle. EPG-Daten sind jedoch für die Grundverschlüsselten Sender (RTL, Sat.1, etc.) vorhanden.


    Das liegt an einem kleinen Bug in w_scan/scan. VDR benötigt die ORIGINAL NID, w_scan ermittelt jedoch die NID. Wenn ONID und NID unterschiedlich sind, gibts keine EPG Daten mehr. Versuchs mal mit dem Patch.


    Gruß
    e9hack

    Quote

    Original von e9hack


    Die TT C-2300 benutzt GPIO3 vom SAA7146 zum Umschalten (0V = AGC extern, 5V = AGC intern).


    Laut einer Uralt-Mail schaltet die FuSi die Pin's vom TDA9819 (Pin 9 und 30) über die Test-Output-Pin's vom VES1820. Der VES1820 hat 17 davon. Warum braucht ein IC 17 Test-Output-Pin's?


    Gruß
    e9hack

    Quote

    Original von pompase
    Mit dern Technodtrend gehen die Kanäle wunderbar mit UNC 0


    Bei der TT wird immer UNC 0 angezeigt, da UCB counting nicht aktiviert ist.


    Genauso sinnfrei sind die Werte für STR, SNR und BER.


    Gruß
    e9hack


    Ich benutze das v4l-dvb Repository von www.linuxtv.org.


    Gruß
    e9hack

    Quote

    Original von arghgra


    Was tut das bzw. tut es bei qam256 dann nicht?


    arghgra


    Register 0x4b initialisiert:
    QAM64 funktioniert, QAM256 benötigt 30..60 Minuten bis zum Sync/Lock.


    Register 0x4b nicht initialisiert:
    QAM64 keine Sync/Lock, QAM256 funktioniert


    Ich bin beim Kopieren verschiedener Init-Tabellen dahinter gekommen. Irgendwann habe ich Register 0x4b vergessen zu kopieren, und auf einmal ging QAM 256 und QAM 64 ging nicht mehr. Es is aber keine wirkliche Lösung, da unter Windows Register 0x4b immer (unabhängig von der Modulation) initialisiert wird.


    Gruß
    e9hack

    Quote

    Original von arghgra


    Kannst du die Quelle des Diffs angeben? Stammt das aus Andrew de Quinceys Änderungen am cablestar2-stv0297?


    arghgra


    Das Nicht-Initialisieren von Register 0x4b bei QAM 256 stammt von mir, der Rest ist von drivers/media/dvb/b2c2/stv0297_cs2 abgeleitet.


    Gruß
    e9hack

    Quote

    Original von osmanovic100


    nutzt dein Patch auch für FuSie dvb-c ?


    hat auch stv0297 auch was mit FuSie zu tun?


    Der Patch ist für eine TT C-2300 mit stv0297. Die FuSie hat einen VES1820 als Demodulator.


    Quote

    Original von osmanovic100


    wie schalte ich intern und extern über pin30?


    Die TT C-2300 benutzt GPIO3 vom SAA7146 zum Umschalten (0V = AGC extern, 5V = AGC intern).


    Da es für die FuSie ein Analog-Modul gibt, sollte es möglich sein, Pin 30 zu schalten.


    Gruß
    e9hack

    Quote

    Original von woppr
    kann jemand mit ner tt c-2300 bestätigen (mit bildanhang und syslog bitte) dass 256qam sauber geht? die hat den 9819 nämich auch drauf.


    Die TT C-2300 demoduliert QAM 256 (ORF1, ORF2, SF1 bzw. SF2 bei KabelBW) ohne Probleme (BER: 600..800, UNC: 0). Allerdings muß ich das Frontend (stv0297) patchen, da es sonst ca. 30..60 Minuten dauert, bis der Demodulator synchronisiert.


    Im übrigen kann man beim TDA9819 die AGC zwischen intern und extern über Pin 30 umschalten. Wenn ich auf intern umschalte, gibts bei QAM 64 viele Klötzchen und bei QAM 256 ist das Bild weg.


    Gruß
    e9hack

    Files

    • qam256.diff

      (3.25 kB, downloaded 172 times, last: )