Posts by mementor

    Hallo,


    ich habe mal eine Frage an die Fernsehtechniker unter uns.
    Seit kurzem habe ich keine Tonausgabe über die Eingange AV 2 / HDMI 1 und HDMI 2. Das Problem trat folgendermaßen auf:
    Bei laufendem TV (über Eingang HDMI 2) wurde der Ton immer leiser bis gar nichts mehr zu hören war. Ein Umstecken auf HDMI 1 brachte auch keinen Erfolg.
    Zuerst dachte ich, dass mein VDR hier evtl. das Problem darstellt, also habe ich meine „alte“ Dbox2 aktiviert und über AV 2 angesteckt.
    Leider war hier auch nur eine Bildausgabe möglich.



    Derzeit ist leider nur über TV-Eingang „AV 1“ eine Bild + Tonausgabe möglich ;(


    Der Fernseher (LG 42LF66) ist ca. 4 Jahre alt.
    Meiner Meinung ist das ganz klar ein TV Problem!


    Ist sowas zu reparieren bzw. ist das ein bekanntes Problem?


    Vielen Dank im Voraus.


    Gruß


    Roger

    Hallo gda,


    da freue ich mich ja schon richtig auf die neue Version. Wenn so schnell gebootet wird, dann kann ich auch auf die Logo-Animationen verzichten :strike1:strike1:strike1
    Kann man aber evtl. über Grub ein Logo (nur eins und kein Start-Script) anzeigen/laden?


    Gruß


    mementor

    Hallo,


    nachdem ich jetzt mein LCD zum Laufen gebracht habe, musste dieses natürlich beim Starten und Beenden des VDR's auch entsprechende Grafiken anzeigen. Ich habe mal kurz hier zusammen geschrieben wie ich da vorgegangen bin:


    Die Logos habe ich von hannsens. Hier noch mal ein Dankeschön für die gelungenen LCD-Logos! Unter Logos stehen mehrere Varianten von LCD-Logos zur Auswahl und zum Download bereit.
    Nachdem man sich die gewählten Bilder „downgeloaded“ hat, müssen diese entpackt und auf den VDR in die Verzeichnisse kopiert werden:


    Code
    1. /etc/vdr/plugins/graphlcd/splash/start ’ alle Bilder für das Starten
    2. /etc/vdr/plugins/graphlcd/splash/stop ’ alle Bilder für das Beenden


    Diese Verzeichnisse müssen natürlich vorher erst mal angelegt werden:


    Code
    1. sudo mkdir /etc/vdr/plugins/graphlcd/splash
    2. sudo mkdir /etc/vdr/plugins/graphlcd/splash/start
    3. sudo mkdir /etc/vdr/plugins/graphlcd/splash/stop


    Die Zugriffsrechte der Bilder in stop und start setzen:


    Code
    1. sudo chmod 755 /etc/vdr/plugins/graphlcd/splash/stop/*
    2. sudo chmod 755 /etc/vdr/plugins/graphlcd/splash/start/*


    Der erste Schritt ist geschafft.


    Jetzt muß ein Start/Stop-Script erzeugt werden.


    sudo vim /etc/init.d/glcd (Script unten einfügen)


    Im Falle von stop/restart wird ein weiteres Script gestartet, um den Prozess parallel auszuführen.


    Das Script muss wieder angelegt werden über:


    sudo vim /etc/vdr/plugins/graphlcd/stopglcd.sh (Script unten einfügen)


    Hier wird solange mit der Anzeige der Beenden-Logos gewartet , bis der VDR sich beendet hat. Dies hat den Grund, da sonst die Anzeige (LCD) immer zwischen graphlcd-Anzeige und Beenden-Logos hin und her schaltet.


    Für die beiden Scripte müssen jetzt die Zugriffsrechte gesetzt werden. Dies geschieht über:

    Code
    1. sudo chmod 755 /etc/init.d/glcd
    2. sudo chmod 755 /etc/vdr/plugins/graphlcd/stopglcd.sh


    Anschließend wird der Dienst noch registriert:

    Code
    1. sudo update-rc.d glcd defaults 05


    und schon startet und beendet sich der VDR mit LCD-Logos. Das Starten, muss ich zugeben, ist Aufgrund des upstart-Verfahrens etwas dürftig. Hier wird nur sehr kurz und fast umittelbar vor dem VDR-Start das Script und die Logos gestartet. Hier habe ich aber keine Möglichkeit gefunden dies anders zu gestalten. Vielleicht hat da noch jemand eine andere/bessere Idee.


    Gruß


    mementor

    Hurra!!!!!!


    danke gerdh, dass war der entscheidende Hinweis. Es läuft, und wie!
    :portal1


    !!!!Ich musste bei mir auch das Device in der /etc/graphlcd.conf einstellen!!!!!


    Danke noch mal allen die mir geholfen haben!


    Gruß


    mementor

    Hallo,


    kann das was damit zu tun haben?


    ....
    Apr 19 21:55:38 vdr kernel: [ 10.924775] parport_pc 00:05: reported by Plug and Play ACPI
    Apr 19 21:55:38 vdr kernel: [ 10.924836] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
    Apr 19 21:55:38 vdr kernel: [ 10.929174] [Firmware Bug]: ACPI(IGPU) defines _DOD but not _DOS
    Apr 19 21:55:38 vdr kernel: [ 10.929360] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:12/device:13/input/input4
    Apr 19 21:55:38 vdr kernel: [ 10.929390] ACPI: Video Device [IGPU] (multi-head: yes rom: no post: no)
    Apr 19 21:55:38 vdr kernel: [ 10.930141] i2c-adapter i2c-0: nForce2 SMBus adapter at 0x600
    Apr 19 21:55:38 vdr kernel: [ 10.930166] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    Apr 19 21:55:38 vdr kernel: [ 11.023522] ppdev: user-space parallel port driver
    Apr 19 21:55:38 vdr kernel: [ 11.032180] lp0: using parport0 (interrupt-driven).
    Apr 19 21:55:38 vdr kernel: [ 11.124865] HDA Intel 0000:00:07.0: power state changed by ACPI to D0
    ....

    Hallo randy,


    hier ist ein Auszug aus meiner /etc/group
    ....
    sys:x:3:
    adm:x:4:vdruser
    tty:x:5:
    disk:x:6:
    lp:x:7:vdr
    .....


    Das sollte doch so passen, oder?
    Irgendwie verstehe ich das Ganze nicht. Das Device ist auf Gruppe 'lp' gesetzt. Dieser Gruppe ist aber der VDR zugeordnet. Dann sollte dieser doch berechtigt sein, darauf zugreifen zu dürfen. Oder ist das bei Devices anders?

    Hallo randy,


    folgende Rechte habe ich schon gesetzt:


    chmod 0666 /dev/parport0
    chgrp lp /dev/parport0
    chmod g+w /dev/parport0


    Ich habe auch dem Benutzer 'vdr' der Gruppe 'lp' zugewiesen


    adduser vdr lp


    Dein Vorschlag:


    chgrp vdr /dev/parport0


    habe ich probiert. Nach einem Neustart ist die Gruppe für das Device wieder auf lp gesetzt.Wie kann ich die Gruppe vdr für das Device dauerhaft setzen?


    Gruß


    mementor

    Hallo noch mal,


    kann leider keine Lösung zu meinem Problem finden. Es muß auf jeden Fall irgendein Rechteproblem sein. Leider kann ich die Rechte für die restlichen Benutzer (nicht 'root' und nicht Gruppe 'lp') nicht setzen, da bei jedem Neustart diese wieder entfernt sind.
    Es wäre vielleicht auch hilfreich, wenn sich evtl. noch mal BlueVIP zu Wort melden würde, wie bzw. was genau er gemacht hat um das Display zum Laufen zu bekommen.


    Vielen Dank im Voraus,


    Gruß


    mementor

    Hallo,


    ich versuche jetzt schon mehrere Stunden mein LCD zum Laufen zu bringen. Leider bis jetzt ohne Erfolg. Ich habe alles nach Anleitung () angeschlossen und installiert. Aber irgendwo hat sich der Fehlerteufel eingeschlichen. Jetzt lässt sich auch der VDR nicht mehr starten.


    Folgender Befehl lässt sich auch nicht ausführen:


    showpic -d t6963c /usr/share/vdr-plugin-graphlcd/logos/ARTE_l.glcd
    ->ERROR: Failed initializing display t6963c


    Mit:
    sudo showpic -d t6963c /usr/share/vdr-plugin-graphlcd/logos/ARTE_l.glcd
    wird der Befehl korrekt ausgeführt und es erscheint die entsprechende Grafik auf dem Display.


    Die Module scheinen geladen worden zu sein:


    Ich habe auch, wie in der Anleitung beschrieben folgende Befehle ausgeführt:


    sudo chmod 0666 /dev/parport0
    sudo chgrp lp /dev/parport0
    sudo chmod g+w /dev/parport0
    worauf dann über:
    ls -all /dev/parport0


    crw-rw-rw- 1 root lp 99, 0 2010-04-18 21:18 /dev/parport0
    angezeigt wird.


    Nach einem Neustart sind aber meine gesetzten Rechte wieder weg. Kann das was damit zu tun haben?


    Ich weiß jetzt nicht mehr weiter und kann auch nichts in der Suche finden. Könnte mir vielleicht irgendwer hier weiterhelfen?


    Wäre für jede Hilfe dankbar.


    Gruß


    mementor

    Hallo Neoxxx,


    ich hatte das gleiche Problem bei meinem Laptop.
    Durch ersetzen der UUID mit dem Device (bei Dir /dev/sda6) konnte ich mein Problem lösen.


    In deiner fstab sollte sowas in der Art:
    /dev/sda6 /Video ext4 0 2
    jetzt stehen! ext4 muß dann ggf. mit xfs (das Dateisystem kenne ich aber nicht) ersetzt werden.


    Vielleicht kannst Du ja mal den Befehl blkid ausführen. Hierüber werden die UUID deiner Partitionen ermittelt!


    Gruß


    mementor

    Hallo,

    Quote


    Hast Du eigentlich schon die Kanalliste (channels.conf) verändert oder ist das noch die Originalversion mit 3sat als IPTV?
    Ist Dein VDR per Kabel mit der AirStation verbunden oder per WLAN?


    zu 1.) ich verwende meine "uralt" channels.conf. Im Büro an meinen PC-TFT über VGA funktioniert der VDR damit auch einwandfrei. Ich habe jetzt auch mal die AirStation ins Büro verfrachtet, um zu testen obs an der Netzwerkverbindung liegt. Dies kann ich jetzt ausschließen, da hier alles supi geht (VDR/Netzwerk...).


    zu 2.) Ich bin über Kabel an der AirStation verbunden. Diese AirStation dient als WLAN-Bridge und funktioniert eigentlich gut.


    Kann das evtl. mit meinen TV zusammenhängen? Oder an der xorg.conf? Als xorg.conf.yavdr verwende ich noch die Originale (von der Installation).
    Ich werde auf jeden Fall mal bootchart verwenden, vielleicht kann ich dort was genaueres entdecken.


    Gruß


    mementor

    Hallo,


    danke für die schnellen Antworten. Kann evtl. die Geschichte mit dem Netzwerk das Problem darstellen? Im Büro habe ich LAN. Hier funktioniert der VDR so wie gewollt. Aber im Wohnzimmer ist der VDR über eine AirStation angeschlossen. Hier treten die Probleme auf. Werde morgen mal die Netzwerk-Verbindung überprüfen. Sollte das nichts bringen, dann werde ich das Problem über bootchart versuchen einzugrenzen.


    Danke nochmal:lachen3


    Gruß


    mementor

    Hallo CouchPotato,


    ich habe bei mir das video.00 auch auf mein /home verzeichnis verbogen. Hierfür kannst du in der Konsole/Putty foldende Befehle ausführen:


    Code
    1. sudo rm -r /var/lib/video.00
    2. sudo ln -s /video0 /var/lib/video.00
    3. sudo chown -R vdr /var/lib/video.00
    4. sudo chgrp -R vdr /var/lib/video.00


    der Link /var/lib/video -> /var/lib/video.00 kann/muß bestehen bleiben. Mit obigen
    Befehlen wird von /var/lib/video.00 auf dein Verzeichnis weiter umgelenkt. Dann sollte es
    eigentlich dauerhaft funzen!


    Gruß


    mementor

    Hallo Wicky,


    ist eigentlich schade, dass Du jetzt den Punkt 6.6 entfernt hast. Trotzdem noch mal vielen Dank für Dein HowTo. Es hat mir wirklich sehr weitergeholfen:respekt . Ich hatte zwar ein "paar" Probleme, diese ließen sich aber ganz einfach lösen.
    Vielleicht ist Dein Vorschlag, einen eigenen Thread für die minimal Variante zu beginnem, wirklich die bessere Variante. Werde mal darüber nachdenken, ob ich noch mal komplett neu aufsetze, minimal Variante -> also ohne Gnome-Installation, und gleichzeitig ein HowTo dafür erstelle. Wäre eigentlich hauptsächlich für mich interessant (bin halt sehr vergesslich) das Thema, genauestens zu dokumentieren. :] Mal sehen:]


    Ich hoffe ich habe Dir vor Weihnachten nicht zu viel ärger bereitet und wünsche Dir und auch allen anderen VDR'lern ein frohes Fest!
    :fans


    Gruß


    Roger

    Hallo,


    lirc läuft bei mir jetzt auch. Ich glaube ich habe folgendes gemacht:
    1. Ich musste eine Datei namens /etc/modprobe.d/lirc anlegen, mit
    dem Inhalt:

    Code
    1. alias char-major-61 lirc_serial
    2. options lirc_serial irq=4 io=0x3f8


    2. Die Datei /var/lib/setserial/autoserial.conf anpassen (wenn bereits eine Zeile mit ttyS0 vorhanden ist, auskommentieren mit #):

    Code
    1. ###manuell###
    2. /dev/ttyS0 uart none


    Danach konnte der Lirc-Daemon korrekt geladen werden und die FB funzt!
    Habe dies hier noch mal aufgeführt, da ich denke, dass dies ein allgemeines Ubuntu-Problem darstellen könnte. Sollte dies allerdings nur wieder bei meiner Installation der Fall sein, dann kann ich den Beitrag auch wieder löschen!


    Gruß


    Roger

    Hallo,


    irgendwie habe ich wie immer Probleme mit lirc. Ich habe bereits meine lircd.conf und die
    angepasste hardware.conf nach /etc/lirc kopiert.


    Aber irgendwie werden die Treiber nicht korrekt geladen. Habe ich da noch was übersehen?


    Wäre für jeden Tipp dankbar.


    Gruß


    Roger