Posts by cekaro

    Moin,


    beim Skin estuary4vdr wird die Aufnahmeliste ständig neu geschrieben. Im Aufnahmemenü wird jede Sekunde die Liste ausgeblendet und sofort wieder von oben nach unten eingeblendet, so dass es zu einer Art flackern kommt.

    Beim Skin metrixhd ist die Liste zwar ok aber hierbei wird der Infobereich ständig neu geschrieben.

    Kennt jemand dieses Verhalten?

    Gibt es dafür eine Einstellung, die ich ändern kann?


    Gruß


    Marco

    Moin,
    das Abschalten des PC´s in den Ruhezustand funktioniert nur einmal nach einem reset.
    Beim zweiten mal wird der VDR beendet, das Display (iMon) wird abgeschaltet und auf dem TV ist das yaVDR Logo zu sehen.
    Der PC ist weiterhin übers wfe zu erreichen.
    Das erste mal funktioniert mit anschließendem Aufwachen ohne Probleme.
    Wo liegt der Unterschied?


    Das syslog sagt bei fehlerhaftem Abschalten folgendes:


    Bei erfolgreichem Abschalten mit anschließendem Aufwachen:

    Gestern abend hat sich der VDR beim ausschalten aufgehängt.
    Nach einem Neustart heute morgen funktionierte die Ferbedienung nur noch teilweise. Es waren nur noch die cursor-Tasten aktiv.


    Durch das Anlegen der Dateien

    Code
    /etc/yavdr/templates_custom/etc/rc_maps.cfg/31_imon-mce
    /etc/yavdr/templates_custom/etc/rc_maps.cfg/40_mceusb


    mit den Inhalten

    Code
    imon rc-imon-mce    	/etc/rc_keymaps/rc-imon-mce
    mceusb rc-rc6-mce /etc/rc_keymaps/rc-rc6-mce


    wird doch die Datei /etc/rc_maps.cfg um die Einträge

    Code
    imon rc-imon-mce /etc/rc_keymaps/rc-imon-mce
    mceusb rc-rc6-mce /etc/rc_keymaps/rc-rc6-mce


    ergänzt, oder?


    Die /etc/rc_maps.cfg sieht nun folgendermaßen aus (gekürzt):


    Sollte nicht eigentlich durch ein process-template /etc/rc_maps.cfg ir-keytable gefüllt werden?
    Dies passiert aber nicht.
    Was habe ich vergessen oder falsch verstanden?

    Ich habe nun (parallel zu Deiner Antwort) folgendes gemacht:


    Die "Vorlage" kopiert:

    Code
    cp /usr/share/yavdr/templates/etc/rc_maps.cfg/40_mceusb /etc/yavdr/templates_custom/etc/rc_maps.cfg/40_mceusb


    Diese Kopie entsprechend angepasst:

    Code
    mceusb rc-rc6-mce


    Die keymap kopiert:

    Code
    cp /lib/udev/rc_keymaps/rc-rc6-mce /etc/rc_keymaps/rc-rc6-mce


    Und wie folgt bearbeitet:


    Danach habe ich die keytable gelöscht:

    Code
    ir-keytabl -c


    Anschließend habe ich den Inhalt der keymap geladen:

    Code
    root@yavdr:/etc/rc_keymaps# ir-keytable -w /etc/rc_keymaps/rc-rc6-mce
    Read rc-rc6-mce table
    Wrote 46 keycode(s) to driver
    Protocols changed to RC-6


    Leider hat es nicht funktioniert.


    ir-keytable -r ergibt folgendes:


    Während ir-keytable -t -s rc1 folgendes ausgibt (Farbtasten):


    Sollte hier nicht das selbe stehen?
    0x800f044a = KEY_RED (0x18e)
    800f044a 0x0189

    @seahawk 1986
    So soll es eigentlich aussehen:


    scancode 0x800f0446 = KEY_YELLOW (0x190)
    scancode 0x800f0447 = KEY_GREEN (0x18f)
    scancode 0x800f0449 = KEY_BLUE (0x191)
    scancode 0x800f044a = KEY_RED (0x18e)

    ir-keytable


    ir-keybable -t -s rc0


    ir-keytable -t -s rc1

    Moin,
    nach langer Zeit habe ich doch mal wieder Zeit mich um meinen VDR zu kümmern.
    Das meiste läuft sehr gut nur die Fernbedienung ist noch ausbaufähig.
    Ich habe eine Universalfernbedienung die ich aufs MCE-Format angelernt habe.
    Zudem sind am VDR zwei Empfänger angeschlossen. Zum Einen der im imon-Display integrierte Empfänger und zum Anderen ein USB MCE Empfänger. Die meisten Tasten funktionieren gut. Nur die Farbtasten machen noch Probleme.
    Wie hier beschrieben habe ich dann die keymap (/etc/rc_keymaps/rc-imon-mce) an meine Tastencodes angepasst.


    Dies beeinflusst allerding nur den iMon Empfänger. Der MCE-Empfänger reagiert weiterhin nicht auf die Farbtasten.
    Welche Datei muss ich noch ändern, damit beide Empfänger auf die Farbtasten reagieren?


    lsusb


    ir-keytable -t (hierauf reagiert nur der MCE-Empfänger. Ich habe folgende Tasten gedrückt: rot, grün, gelb, blau)


    ir-keytable -r


    irw


    cat /proc/bus/input/devices


    VG


    Marco

    Bei mir steckt im Digitainer Gehäuse ein anderes Mainboard. In meiner Signatur kannst Du sehen, welche Komponenten mit dem Original-Netzteil versorgt werden. Flüsterleise ist dies übrigens nicht!
    Pollin scheint das Angebot verändert zu haben. Ich habe ca. 20€ dafür bezahlt. Im Angebotstext war vermerkt, dass für den DVD-Brenner keine Funktionsgarantie übernommen wird.
    Das Mainboard aus dem Produktiv-VDR nutze ich als HD-VDR und streame gelegentlich auch HD Sender. Dies hängt allerdings wenig vom Mainboard ab.


    Marco

    Moin,
    der DVD-Brenner wird wahrscheinlich defekt sein! War zumindestens bei mir und auch anderen Forumsmitgliedern so.
    Verstehe ich die Vorgabe "Board mit HDMI" so, dass das Board eine onboard GraKa haben soll, die vdpau unterstützt?
    Mit dieser Kombination gibt es keine aktuellen Boards. (Oder hat sich da mittlerweile etwas geändert?)
    Wenn Du eine GraKa einbauen würdest, könnte ich Dir das Board aus meiner Signatur (Produktiv) empfehlen.


    Marco

    So, ich habe ein wenig Zeit freischaufeln können. :)
    /opt/etc/init.d/S56nfs-utils ergibt folgendes (gefolgt von "status" erscheint die selbe Meldung.)


    /var/log/syslog auf der Linkstation sagt folgendes:


    In einem anderen Forum hatte auch jemand die Meldung aus der letzten Zeile. Dort wurde nach dem Dateisystem gefragt, welches gemounted werden sollte.
    Auf der Linkstation läuft XFS. Ist dies wichtig?


    dippes
    Ich habe nfs-utils über ipkg installiert, da es laut Internetrecherche besser sein soll als unfsd.


    /opt/etc/init.d hat folgenden Inhalt:

    Code
    root@LS-GL181:/opt/etc/init.d# ls -l
    -rwxr-xr-x	1 root 	root      	108 May 18  2010 S55portmap
    -rwxr-xr-x	1 root 	root      	515 Nov  2  2010 S56nfs-utils
    root@LS-GL181:/opt/etc/init.d#


    Marco

    Das Verzeichnis, das ich von root auf vdr geändert habe ist auf dem VDR und nicht auf dem NAS. massi hatte nach dem Besitzer des Verzeichnis gefragt.


    Hier die Berechtigungen von /mnt bzw. /mnt/disk1

    Code
    drwxrwxrwx	9 root 	root      	101 Aug 24 20:21 mnt


    Code
    drwxr-xr-x	8 root 	root       	81 Aug 24 12:54 disk1


    Demnach sollte vdr darauf zugreifen können.


    Marco

    massi
    Ich habe ehrlich gesagt keine Ahnung welches Linux darauf läuft. :D


    exports sind angepasst (siehe oben). Daher ja meine Frage ob dies so richtig ist. :)


    Faudeer


    Ja, es wird tatsächlich /opt/etc genutzt.


    showmount --exports 192.168.2.195 sagt folgendes:


    Code
    root@LS-GL181:/mnt/disk1# showmount --exports 192.168.2.195
    Export list for 192.168.2.195:
    /mnt/disk1/musik   192.168.0.0/255.255.0.0
    /mnt/disk1/video00 192.168.0.0/255.255.0.0
    root@LS-GL181:/mnt/disk1#


    Bedeutet dies das nfs läuft?
    Ich habe nfs-utils über ipkg installiert.


    Marco

    Moin,
    meine Linkstation dient als Aufnahmespeicher für meine VDR-Aufnahmen. Zur Zeit läuft die Freigabe über samba. Da es aber hierbei Probleme mit dem zeitversetzten Fernsehen gibt möchte ich nfs ausprobieren.
    Was habe ich bisher gemacht?


    Ich habe auf der Linkstation nfs-utils installiert.
    Meine /opt/etc/exports sieht folgendermaßen aus:

    Code
    /mnt/disk1/video00 192.168.0.0/255.255.0.0(rw,sync,no_root_squash)
    /mnt/disk1/musik   192.168.0.0/255.255.0.0(rw,sync,no_root_squash)


    1.Frage: Sind diese Einstellungen richtig?


    Danach habe ich nfs folgendermaßen gestartet:

    Code
    /opt/etc/init.d/S56nfs-utils


    Nun bin ich mir nicht sicher, ob das starten auch geklappt hat.
    ps sagt folgendes:


    2.Frage: Sollte hierbei nicht nfs-utils auftauchen?


    Des Weiteren habe ich einen Benutzer vdr und eine Gruppe vdr eingerichtet.
    Dieser Benutzer hat die gleiche uid und gid wie der Benutzer vdr auf meinem VDR.
    id vdr auf der Linkstation:

    Code
    root@LS-GL181:~# id vdr
    uid=107(vdr) gid=109(vdr)


    id vdr auf dem VDR

    Code
    root@yavdr:/home/marco# id vdr
    uid=107(vdr) gid=109(vdr) Gruppen=109(vdr),20(dialout),24(cdrom),29(audio),44(video),46(plugdev)


    3. Frage: Reicht es, wenn gid und uid vom Benutzer vdr gleich sind, oder muss ich weitere Einstellungen vornehmen?


    Nun habe ich für einen ersten Test versucht den Ordner /mnt/disk1/musik zu mounten:

    Code
    mount -t nfs 192.168.2.195:/mnt/disk1/musik /mnt/nas/music


    (Der Ordner /mnt/nas/music ist auf dem VDR vorhanden.)
    Das Ergebnis schaut so aus:

    Code
    root@yavdr:/mnt/nas/music# mount -t nfs 192.168.2.195:/mnt/disk1/musik /mnt/nas/music
    mount.nfs: access denied by server while mounting 192.168.2.195:/mnt/disk1/musik
    root@yavdr:/mnt/nas/music#


    Hier die Besitzverhältnisse und Rechte von video00 bzw. musik auf der Linkstation:

    Code
    root@LS-GL181:/mnt/disk1# ls -l
    drwxrwxrwx	5 root 	root       	48 Jul 18 15:06 Daten
    drwxrwxrwx  123 root 	root     	4096 Aug 14 10:27 musik
    drwxrwxrwx	2 root 	root       	23 Aug 19 19:02 share
    drwxr-xr-x	2 root 	root       	57 Aug 24 12:59 tmp
    drwxrwxrwx   15 root 	root     	4096 Aug 24 22:04 video00


    4. Frage: Muss ich noch irgendwelche Rechte, Besitzverhältnisse, uid oder gid ändern?


    Danke im Voraus


    Marco