Beiträge von BerndV

    Ich habe jetzt mal MSI im Kernel abgeschaltet:


    Code
    1. root@vdr:~# cat /proc/cmdline
    2. BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=98334508-4299-4072-8870-04ee745a0fde ro pci=nomsi quiet


    bekomme aber immer noch Meldungen:


    Falls jemand mit einem ähnlichen Problem hier liest:
    Auf der ESXi Konsole


    Code
    1. pciPassthru0.msiEnabled = "FALSE"


    an das VMX File der VM anhängen hat geholfen. Mein VDR läuft jetzt seit drei Wochen 24x7 ohne Probleme.


    ich bekomme I2C timeouts trotz "options ddbridge msi=0". Jemand 'ne Idee warum das so ist? Hardware ist eine DD Cine S2 v6.5 plus DuoFlex S2. Läuft unter ESXi 6.0 mit VT-d Passthrough.

    Ich habe jetzt mal MSI im Kernel abgeschaltet:


    Code
    1. root@vdr:~# cat /proc/cmdline
    2. BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=98334508-4299-4072-8870-04ee745a0fde ro pci=nomsi quiet


    bekomme aber immer noch Meldungen:


    Code
    1. root@vdr:~# dmesg -T|tail -8
    2. [Sun Jan 31 02:57:22 2016] DDBridge I2C timeout, card 0, port 0, link 0
    3. [Sun Jan 31 02:57:22 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000c03
    4. [Sun Jan 31 02:57:22 2016] DDBridge I2C timeout, card 0, port 1, link 0
    5. [Sun Jan 31 02:57:22 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000000
    6. [Sun Jan 31 03:02:19 2016] DDBridge I2C timeout, card 0, port 0, link 0
    7. [Sun Jan 31 03:02:19 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000d03
    8. [Sun Jan 31 03:02:19 2016] DDBridge I2C timeout, card 0, port 1, link 0
    9. [Sun Jan 31 03:02:19 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000000


    Wie kann das sein? Oder haben die I2C timeouts nix mit MSI zu tun?

    Hallo zusammen,


    ich habe hier ein Problem bei dem ich nicht mehr weiter weiß.


    Ich habe einen VDR 2.2 mit streamdev-server Plugin. Das liefert manchmal keine Daten:



    Danach kommt nix. Heißt: der Header kommt, danach aber keine Daten. Natürlich zeigen dann auch diverse Clients nix an.


    Woran kann das liegen? Das Log sagt nix (--log=3):




    Umgebung wie folgt, mit DD Cine S2 und DuoFlex S2:


    Hallo zusammen,


    ich bekomme I2C timeouts trotz "options ddbridge msi=0". Jemand 'ne Idee warum das so ist? Hardware ist eine DD Cine S2 v6.5 plus DuoFlex S2. Läuft unter ESXi 6.0 mit VT-d Passthrough.


    Code
    1. root@vdr:~# uname -a
    2. Linux vdr 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux


    Code
    1. root@vdr:~# cat /etc/modprobe.d/ddbridge.conf
    2. options ddbridge msi=0


    dmesg Auszug wenn ddbridge geladen wird:


    dmesg Auszug mit I2C timeouts:

    Code
    1. root@vdr:~# dmesg -T|tail -8
    2. [Fri Jan 22 17:12:31 2016] DDBridge I2C timeout, card 0, port 0, link 0
    3. [Fri Jan 22 17:12:31 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000f03
    4. [Fri Jan 22 17:12:32 2016] DDBridge I2C timeout, card 0, port 1, link 0
    5. [Fri Jan 22 17:12:32 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000000
    6. [Fri Jan 22 18:06:02 2016] DDBridge I2C timeout, card 0, port 0, link 0
    7. [Fri Jan 22 18:06:02 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000e03
    8. [Fri Jan 22 18:06:02 2016] DDBridge I2C timeout, card 0, port 1, link 0
    9. [Fri Jan 22 18:06:02 2016] ddbridge 0000:03:00.0: DDBridge IRS 00000000


    Woran kann das liegen?

    Hallo zusammen,


    ich installiere gerade einen neuen VDR mit Live Plugin und versuche Live die deutsche Sprache beizubringen, klappt bisher nicht und ich weiss nicht warum. Live Benutzeroberfläche ist Englisch und Umlaute in EPG-Daten werden im Browser als Fragenzeichen-Raute dargestellt?


    VDR und Plugin Versionen:



    Betriebssystem ist

    Code
    1. Linux vdr 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u5 (2015-10-09) x86_64 GNU/Linux

    Das möchte ich auf Englisch lassen, ich komme mit englischen Meldungen auf der Shell besser zurecht.


    Im VDR Start-Skript (gepatchtes runvdr) habe ich folgendes stehen:


    Code
    1. export LANG="de_DE.UTF-8"
    2. export VDR_LANG="de_DE.UTF-8"
    3. export LC_ALL="de_DE.UTF-8"


    VDR sagt folgendes im syslog:


    Code
    1. ...
    2. Dec 25 20:44:47 vdr vdr: [9639] VDR version 2.2.0 started
    3. Dec 25 20:44:47 vdr vdr: [9639] codeset is 'UTF-8' - known
    4. ...


    Habt ihr 'ne Idee woran das liegt?


    Vielen Dank,
    Bernd

    Sorry, ich hatte 'n Brett vor dem Kopf...


    ffnetdev schickt einen rohen TCP Stream raus. Ich hatte versucht den in VLC mit einer HTTP URL zu öffnen und VLC hat keine Header gefunden. Mit tcp://... klappt es.


    Viele Grüße,
    Bernd

    Hallo zusammen,


    hat schon mal jemand das ffnetdev Plugin mit dem VDR 2.2 zum laufen bekommen?


    Ich habe den ffnetdev Code so weit dass er mit VDR 2.2 compiliert und startet. Ich bekomme aber keinen Stream.


    Syslog sagt:

    Code
    1. Oct 30 16:54:29 vdr vdr: [28834] [ffnetdev] Streamer: Accepted client 192.168.0.75:65419
    2. Oct 30 16:54:31 vdr vdr: [28834] [ffnetdev] Streamer: Connection closed: client 0.0.0.0:0


    ffnetdev Debug sagt:

    Code
    1. [ffnetdev] Streamer: Closing of TS-streaming client socket requested.
    2. [ffnetdev] Streamer: Client socket closed successfully.


    Zwischen den Log-Einträgen läuft VLC in einen Timeout ohne was anzuzeigen.


    Jemand 'ne Idee? Oder bin ich der einzige der ffnetdev noch verwendet :D


    Viele Grüße,
    Bernd



    Edit: Streamdev-server läuft auf diesem VDR, VLC kann den Stream anzeigen

    Hallo zusammen,


    angeregt durch diesen Beitrag:

    Sind SAT>IP-Lösungen uninteressant für Dein Setup, Bernd? Ich würde heute auch SAT>IP-Server mit einbeziehen in die Diskussion.


    Viele Grüße
    hepi

    habe ich erstmal festgestellt dass da ein "neues" Thema im Sat-Bereich komplett an mir vorbeigegangen ist. Momentan lese ich mich in SAT>IP ein um mal zu schauen ob das was für mich wäre.


    Ich habe deshalb moch keine Entscheidung für eine Sat-Karte getroffen.


    Viele Grüße,
    Bernd

    Nur mit Debian wird es schwierig. Der Treiber für die S952 ist ziemlich neu. Ab Kernel 3.19 vorhanden.

    Hmm, das ist ja "bleeding edge". Also doch wieder selber Kernel bauen... Das habe ich ganz zu Anfang schon für die TT-1401 gemacht und war ganz froh als die Treiber irgendwann im Distri-Kernel waren.


    Ist das bei allen S2-Karten so? Oder gibt es welche die besser unterstützt werden?


    Viele Grüße,
    Bernd


    Nö, sagtest du nicht. Du hast gesagt, es möge mit Debian "Standard-Kernel" laufen:



    Und das tun schließich auch solche Karten, wo man vorher den Treiber erst selbst kompilieren muss. Out of the box ist wiederum was anderes.

    Sorry für die Unklarheit: Ich suche eine Karte die mit dem Debian-Wheezy-Distributionskernel läuft. Wenn's geht möchte ich es vermeiden, eigene Kernel zu bauen. Oder anders herum: Ich möchte Kernel per

    Code
    1. apt-get upgrade && apt-get update

    updaten können.


    Viele Grüße,
    Bernd

    Erstmal: Ich plane in der Tat einen neuen VDR zu bauen. Der VDR aus meiner Signatur läuft noch und ist sehr zuverlässig (der Hauptgrund warum ich hier seit einiger Zeit nicht mehr aktiv war :-). Ich hatte aber vor einiger Zeit einen kleinen Zwischenfall bei dem ich mir GRUB zerschossen habe. Es war eine ziemliche Bastelei den Rechner wieder zum laufen zu bekommen. Das Mainboard ist aaaaalt, es kann nur von P-ATA booten und ich muste erst mal ein passendes CD-ROM organisieren. Und ich bin dabei den ganzen Server-Kram in ein 19-Zoll Rack umzuziehen. Deshalb: neuer VDR.

    Sind SAT>IP-Lösungen uninteressant für Dein Setup, Bernd? Ich würde heute auch SAT>IP-Server mit einbeziehen in die Diskussion.


    Viele Grüße
    hepi

    SAT>IP kenne ich nicht genug um das zu bewerten. Eigentlich ist mein VDR eine Sat>IP-Brücke. Er streamt Live-TV in das Haus-Netz, via streamdev und ffnetdev.


    Die TT-1401 Karten die ich jetzt benutze sind super-unproblematisch. Deshalb meine Frage, gibt's was ähnlich einfaches für DVB-S2?


    Viele Grüße,
    Bernd

    Hmm, anscheinend suche die eierlegende Wollmilchsau :-)


    Läuft out of the box auf gängigen Distributionen oder es sind gut geplegte Treiber verfügbar. Hier ist die eigentlich Crux...

    Sag ich doch: soll mit out-of-the-box Debian laufen.


    Viele Grüße,
    Bernd

    Hallo zusammen,


    ich plane im Augenblick einen neuen VDR und wollte mal fragen ob es eine "Standardantwort" oder Empfehlung für eine VDR Sat-Karte gibt.


    Ich brauche:
    - DVB-S2 mit Twin Tuner
    - Budget-Karte (nur Aufnahme)
    - Einbau-Länge möglichst kleiner als 16cm (sonst müsste ich ein anderes Gehäuse suchen)
    - Niederiger Stromverbrauch/Wärmeabgabe (wird im Dauerbetrieb laufen)
    - Schnelle Umschaltzeit
    - Läuft mit Debian Wheezy Standard-Kernel (den VDR baue ich selber)
    - Guter Preis: -)


    Was gibt's denn da so?


    Viele Grüße,
    Bernd

    Hallo zusammen,


    ich versuche gerade meinem VDR den Sender "WDR Dortmund" (DVB-S SD) beizubringen. channels.conf enthält die entsprechende Zeile aus dem VDR-Wiki, der VDR kann auf den Kanal umschalten, nur leider bekomme ich kein Bild.


    WDR Köln klappt problemlos...


    Hiiiilfe, ich muss heute Abend unbedingt was aus der Lokalzeit aufnehmen.


    Hat jemand einen Tip oder eine funktionierende Zeile aus channels.conf?


    Ich habe einen "headless" VDR, deshalb ist das mit Suchlauf oder so etwa schwierig, ich muss schon die channels.conf direkt ändern. Der VDR ist Version 2.0.1.


    Viele Grüße,
    Bernd

    Hallo zusammen,


    ich betreibe einen "headless" VDR, der Rechner steht recht unzugänglich in einer Ecke. Ich muss eigentlich nur an den Rechner wenn ich ihn mal neu starten muss.


    Dafür hängt jetzt ein ur-alter 15" VGA Monitor dran, bei dem ich mir nie sicher bin, ob er das nächste Einschalten noch mitmacht. Ich würde den Monitor gerne mit etwas anderem ersetzen, klein (7" bis 10" ist OK, ich brauche nur die VGA Textausgabe) und preiswert soll es ein.


    Für "klein" habe ich bisher nur was im KFZ-Bereich gefunden, Monitore für On-Board-Rechner, die scheinen aber recht teuer zu sein. Presiwert kann ich einen billigen TFT-Monitor nehmen aber die fangen erst bei 17" an. Es muss VGA sein, USB oder so kann ich leider nicht brauchen.


    Habt Ihr eine Idee hierfür?


    Danke,
    Bernd

    Moin!


    Ist libvdr-upnp-rec-provider überhaupt ein vdr-Plugin? Ich dachte, es wäre ein Plugin für upnp und darf nicht direkt per "-P" vom vdr geladen werden.
    Allerdings müsste es dann eigentlich "libupnp-rec-provider..." heißen, denn nur "richtige" vdr-Plugins dürfen "libvdr-<name>" heißen, siehe PLUGINS.html, Abschnitt "The plugin directory structure".


    Lars.


    Ähm, das kann natürlich sein.


    Ich habe in der UPnP Plugin Doku allerdings nix darüber gefunden wie die Sub-Plugins geladen werden und bin deshalb davon ausgegangen dass die auch normal über -P geladen werden.


    Wenn ich so nachdenke, dann kann man die gar nicht über -P laden weil sie nicht die VDR Plugin Infrastruktur implementieren.


    Danke dir dafür,
    Bernd

    Hallo zusammen,


    ich bin gerade dabei, das UPnP Plugin zum Laufen zu bekommen. Dabei bin ich auf ein Problem gestoßen dessen Ursache ich nicht so ganz verstehe.


    UPnP ist in mehrere Teile aufgeteilt, die separat als Plugins geladen werden, ich lade libvdr-upnp.so.2.0.0 und libvdr-upnp-rec-provider.so.2.0.0.


    Der VDR bricht ab mit:


    Code
    1. [16042] loading plugin: /usr/src/vdr/PLUGINS/lib/libvdr-upnp.so.2.0.0
    2. [16042] loading plugin: /usr/src/vdr/PLUGINS/lib/libvdr-upnp-rec-provider.so.2.0.0
    3. [16042] ERROR: /usr/src/vdr/PLUGINS/lib/libvdr-upnp-rec-provider.so.2.0.0: undefined symbol: _ZN4upnp21cUPnPResourceProvider10GetHTTPUriERKSsS2_S2_


    UPnPResourceProvider ist eine Basisklasse aus libvdr-upnp.so, die in libvdr-upnp-rec-provider abgeleitet wird. Kann man in den Libraries auch sehen:


    Code
    1. nm -o * |grep _ZN4upnp21cUPnPResourceProvider10GetHTTPUriERKSsS2_S2_
    2. libvdr-upnp-rec-provider.so.2.0.0: U _ZN4upnp21cUPnPResourceProvider10GetHTTPUriERKSsS2_S2_
    3. libvdr-upnp.so.2.0.0:0008da20 T _ZN4upnp21cUPnPResourceProvider10GetHTTPUriERKSsS2_S2_


    Wieso findet der Loader das Symbol nicht?


    Vielen Dank,
    Bernd