Posts by tefans

    moin!


    ich hatte einen alten Speedport 500V (aus dem S100 Paket) bei meinem Vater verbaut. Nach langem unproblematischen Betrieb ist das Ding jetzt leider verendet.
    Welcher Router erfüllt die folgenden Bedingungen:

    • eingebautes Modem (ADSL-2)
    • PPPoE
    • WLAN 802.11g
    • WPA2 Verschlüsselung
    • gute WLAN Reichweite
    • preiswert

    Weitere Features werden nicht gebraucht.
    Ich habe heute mit einer geliehenen "AVM Fritz! Box Fon WLAN 7320" getestet und sah mich mit einer schockierend schlechten WLAN Reichweite konfrontiert. Dieses Problem lässt mich zögern es einfach mal wieder mit einer relativ günstigen Horstbox (50€) zu versuchen, denn diese ist leider nicht gerade für ein leistungsfähiges WLAN-interface bekannt.


    Die Verwendung von Leitungen ist in diesem Fall leider keine Option :(.


    Was nehmt ihr?


    cu, Stefan

    Zum Glück hatte ich noch nicht solved vor das Subject beschrieben.
    Jetzt ist das Bild des Menüs auf 16:9 gezogen und wie der Film an den Seiten abgeschnitten. Die Buttons sind an den alten, jetzt falschen Stellen.


    Möglicherweise sind mein oller Fernseher und der 40 € DVD-Player auch nicht ganz unschuldig, denn ein neuer portabler LCD Fernseher mit eingebautem DVD Laufwerk hatte gar kein Problem mit diesen Bildformatänderungen.


    Ich fürchte bloß das die Leute für die ich die DVDs gebrannt habe, ebenfalls damit Probleme haben werden. Denen einfach Videodateien zuwerfen, wie ich es mir ansonsten angewöhnt habe ist in diesem Fall leider keine Option.


    cu, Stefan

    moin!


    Ich habe hier leider ein offenbar grundsätzliches Problem mit dem Burn-Plugin. Ich hatte das Problem früher schon mal und jetzt taucht es wieder auf.
    Wenn ich DVD mit Aufnahmen im Format 16:9 erzeuge haben diese trotzdem im Menu das Format 4:3. Eine ganze Reihe von "DVD Player - Scart - 4:3 Fernseher" Kombinationen scheinen damit ein ernsthaftes Problem zu haben: Das Bild wird nicht in Letterbox dargestellt und die seitlichen Ränder werden abgeschnitten.


    Gibt es eine Möglichkeit 16:9 im DVD-Menu zu erwingen?


    cu, Stefan

    moin!


    FireFly


    Ich habe gestern einen kleinen Bug im vdrburn-dvd.sh Skript gefunden. Der Patch ist trivial:

    Diff
    1. --- vdrburn-dvd.sh.ORI 2010-12-16 23:40:42.000000000 +0100
    2. +++ vdrburn-dvd.sh 2010-12-16 23:41:02.000000000 +0100
    3. @@ -1,4 +1,4 @@
    4. -#!/bin/sh
    5. +#!/bin/bash
    6. # For DEBUG Output - can be left since logfiles are deleted when job finishes
    7. set -x


    Auf gefallen ist das weil in Debian Squeeze /bin/sh ein Link auf /bin/dash und nicht auf /bin/bash ist. Deshalb bricht das Skript an der Stelle:

    Code
    1. ((DVD_ID = `cat $CONFIG_PATH/counters/standard | sed "s/^0*//"` + 1))

    ab. Korrekter /bin/sh Code wäre:

    Code
    1. DVD_ID = $(( `cat $CONFIG_PATH/counters/standard | sed "s/^0*//"` + 1))

    Andere Stellen mit bash-Syntax sind mir nicht aufgefallen. Ich werfe das jetzt hier herein weil der Bugtracker im Moment nicht läuft.


    cu, Stefan

    Ich habe mir so ein Teil von Conrad geholt. Der steckt auf der SATA-Platte, wird über ein Floppy-Stromkabel versorgt und mit einem 80 poligen PATA-Kabel angeschlossen.
    Wahrscheinlich ist das Ding langsamer als ein direkter Anschluss ein einen SATA-Port. Für den typischen Betrieb im VDR ist das aber kein Problem.


    Das Ding macht überhaupt keine Probleme.


    cu, Stefan

    Ich habe das mal ungefähr so gemacht:


    Code
    1. # cd /var/lib/video.00
    2. # find . -type l -print | xargs rm
    3. # cp -r * /mnt/neu
    4. # cd /var/lib/video.01
    5. # cp -r * /mnt/neu
    6. # chown -R vdr:vdr /mnt/neu


    Bitte nicht einfach stumpf kopieren, vielleicht bin ich schon zu müde.


    cu, Stefan

    Ich habe ein AAO 110 L seit 2 Jahren und habe das Linpus Linux sehr schnell gegen Debian und später gegen Ubuntu getauscht.


    Da die eingebauten 512MB RAM dafür zu wenig sind habe ich ein 1GB Modul zusätzlich eingebaut. Das ist relativ aufwendig weil man das Ding fast komplett zerlegen muss, lohnt sich aber auf alle Fälle.


    Anleitungen gibt es auf Youtube.


    Mit der Ubuntu 10.10 Netbook Edition läuft das Ding jetzt ganz gut, man muss nur manchmal Geduld mit der langsamen SSD haben.


    Mein Schwager hat sich damals auch so ein Ding gekauft und betreibt es immer noch dem originalen System.


    cu, Stefan

    Das upnp-Plugin funktionierte meines Wissens nur mit TS-Aufnahmen, die 1.6er Version benutzt aber noch das PES Format.


    cu, Stefan

    Mein VDR 1.6 hat in der toten Stunde offenbar keine Timer gestartet. Hat noch jemand so etwas beobachtet?


    Betroffen war "My Name ise Earl" -- hat das jemand komplett?


    Ich liebe es :)


    cu, Stefan


    Nachtrag: die Timer starten zur Winterzeit

    Quote

    Original von joker4791
    Vorschläge?

    Ein paar mehr Details könnten helfen.


    Der Effekt das ICMP und UDP laufen aber TCP nicht hatte ich mal als ich den Eintrag in der MANGLE Queue vergessen hatte.

    Code
    1. iptables -t mangle -A FORWARD -o ppp0 -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
    2. iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    3. echo 1 >/proc/sys/net/ipv4/ip_forward

    Aber das war direkt auf dem Router.


    Du müsstest auf der Fritzbox eigentlich nur alle Netze, die von dort aus gesehen hinter dem Server liegen, zum Server routen.


    cu, Stefan

    Quote

    ich kann auch wieder lesen und schreiben.


    Das ist natürlich schlecht. Vielleicht war da auch schon zu viel kaputt.


    Ich hatte damals die Situation das ich bei 2 fehlenden Platten keine wieder hinzufügen konnte. Ich hatte das Raid deshalb aufgelöst und dann mit --create --assume-clean wieder zusammengesetzt. Danach kam dann bei mir der Logical Volume Manager in dem es natürlich auch noch wieder read-only Flags für Volumes gibt. Danach beschehrte mir fsck auf meine ext3 Dateisystem ein gut gefülltes lost+found Verzeichnis, aber keinen wirklich spürbaren Datenverlust.
    Wenn zwischen dem Auseinanderfallen und Wiederzusammensetzen zu viel passiert oder noch andere Störungen eintreten sinkt leider die Warscheinlichkeit das die Methode funktioniert.
    Wer kann, sollte Images der Platten ziehen, was jedoch wegen des Zeitaufwandes nicht wirklich praktisch ist.
    Das ganze hat mich Tage (oder auch Wochen) gekostet.


    Die Hardware bei mir ist ein Intel Atom 330 Board mit 3 Seagate 1,5GB (ST31500341AS) Platten. Ein Rebuild nach dem Verlust einer Platte dauert ungefähr 9 Stunden, wenn sonst nicht so viel los ist! Raid 6 wäre also eigentlich angeraten macht bei dann bei nur 4 Platten keinen Sinn.


    viel Glück
    Stefan

    moin!


    Ich hatte anfangs des Jahres große Probleme mit meinen Software RAID5 und leider etwas Erfahrung mit diesem Thema gemacht. Das Problem liegt wahrscheinlich daran das die verwendeten 1,5GB Seagate Platten einfach nicht weiter zu empfehlen sind. (SATA-Kabel dürften auch gern mechanisch etwas stabiler sein.)


    Auf alle Fälle habe ich regelmäßig einzelne Platten verloren entsprechend oft Rebuilds laufen gehabt.


    Irgendwann war es dann mal so weit das sich das RAID komplett zerlegt hatte und das Device komplett weg war.


    Die mdadm Option die unsere Videos gerettet hat war --assume-clean, die --create verlasst den Inhalt der Platte möglichst wenig zu verändern.


    Code
    1. mdadm /dev/md1 --create --assume-clean --level 5 --raid-devices 3 /dev/sda3 /dev/sdb3 /dev/sdc3


    Danach war das Device /dev/md1 wieder da und nach dem Starten des Volume Managers auch die Logical Volumes.


    Danach habe ich fsck über die betroffenen Dateisysteme laufen lassen und (fast) alles war wieder gut.


    Falls das Device noch da ist, aber nur noch eine Platte hält und die restlichen fehlen muß man das Device erst mit mdadm --stop anhalten.


    Das hat bei mir bisher 2 Mal funktioniert und ich habe keine nennenswerten Datenverluste erlitten, aber ich übernehme natürlich keine Verantwortung für andere Situationen.


    Ich drücke sämtliche Daumen!


    cu, Stefan