Posts by nationat

    Wenn es mit der Digitainer-Config funzt, dann könntest du die erste Zeile mal so abändern (/etc/rc_maps.cfg):

    Code
    1. ati_remote rc-medion-x10 /lib/udev/rc_keymaps/rc-medion-x10-digitainer


    Hinten also nur "-digitainer" anhängen.


    Wenn es funzt, dann templaten..

    Bei yavdr 0.5 wurde meine X10 noch als "rc-medion-X10" angesprochen.
    Bei yavdr 0.6 wird die X10 als "rc-medion-X10-digitainer".


    So habe ich die /etc/rc_maps.cfg so templatet, bzw. die folgenden Zeilen so abgeändert:

    Code
    1. ati_remote rc-medion-x10 /etc/rc_keymaps/rc-medion-x10 #/lib/udev/rc_keymaps/rc-medion-x10
    2. ati_remote rc-medion-x10-or2x /lib/udev/rc_keymaps/rc-medion-x10-or2x
    3. ati_remote rc-medion-x10-digitainer /etc/rc_keymaps/rc-medion-x10 #/lib/udev/rc_keymaps/rc-medion-x10-digitainer


    1. Zeile: yavdr 0.5
    3. Zeile: yavdr 0.6


    Die Kommentare dahinter dienen für mich nur zur Gedankenstütze. Es reicht nur die benötigte Zeile abzuändert.

    Okay. Super.


    Templaten nicht vergessen. Sonst ist es nach dem nächsten Update von Grub wieder futsch.


    Bei mir habe ich zusätzlich in /etc/modprobe.d/ eine Datei "usb-suspend.conf" angelegt.


    Inhalt:

    Code
    1. options usbcore autosuspend_delay_ms=-1


    Nur falls das Modul zur Laufzeit nochmal geladen wird. Kann aber durchaus auch überflüssig sein.

    In dieser Zeile in /etc/default/grub:
    GRUB_CMDLINE_LINUX_DEFAULT="vmalloc=256m quiet splash noresume nohz=off acpi_enforce_resources=lax"


    muss es dann mit beiden Optionen so aussehen:
    GRUB_CMDLINE_LINUX_DEFAULT="vmalloc=256m quiet splash noresume nohz=off acpi_enforce_resources=lax usbcore.autosuspend_delay_ms=-1 irqpoll"


    Nach der Änderung muss einmal "update-grub" ausgeführt werden. Dann den Rechner neu starten.

    Quote

    seahawk1986


    Quote

    Wenn du mit Netzwerk installierst, bekommst du einen entsprechenden Eintrag durch den Ubuntu-Installer in /etc/network/interfaces. Da wir nicht wissen, ob der User zum Zeitpunkt der Installation etwas an der Netzwerkkonfiguration geändert hat und was für Dienste sonst noch auf dem yaVDR genutzt werden, die von einem fertig initialisierten Netzwerk abhängen, halte ich die durch die /etc/init/failsafe.conf vorgegebenen Zeiträume OOTB für gerechtfertigt. Nebenbei bemerkt sind das nicht 60 Minuten zusätzlich, sondern nur 60 Sekunden (so dass auch bei einem Timer-Start mit den standardmäßig zwei Minuten Vorlaufzeit durch den VDR und den paar Minuten, die das vdr-addon-acpiwakeup als Sicherheitsmarge drauf schlägt, keine Probleme entstehen sollten. Alle davon abweichenden Einstellungen sind die Sache des jeweiligen Administrators


    Könnte man sicher Abfragen. Genug Anhaltspunkte bietet die /etc/network/interfaces.
    Natürlich 60 Sekunden :-D Das ist aber eine "gefühlte" Ewigkeit und damit das genaue Gegenteil von dem, was ihr mit der ganzen Arbeit erreichen wolltet. ;-)
    Das mit den zusätzlich vom User installierten Diensten, ist ein Argument. Wobei die Dienste auch von selbst auf das Netzwerk warten sollten.


    Quote

    Welches WOL-Skript meinst du? Das hier geht doch eigentlich über alle Netzwerkgeräte, die kein WLAN, localhost oder pp... sind (da fehlen nur noch tun/tap-Adapter auf der Ausschlussliste, falls ein VPN genutzt wird): https://github.com/yavdr/yavdr-base/blob…c/init/wol.conf


    Mein Fehler. Es werden ja alle Interfaces angesprochen, haupsache eine Zahl dahinter. Ich könnte jetzt mal sehen, warum es bei mir über TFTP-Boot nicht gegriffen hat. Aber das ist meine spezielle Baustelle..


    Quote

    Das mit der X10-Fernbedienung ist ein sehr guter Hinweis, den ich gerne in die Dokumentation aufnehme.


    Wie gesagt, ist es sicher besser, das über die Udev-Rules zu regeln. Bei meiner Lösung wird ja der komplette Suspend für USB deaktiviert.


    Quote

    Ja, das ist nicht optimal, aber leider kann das WFE anhand der whitelist bislang nicht unterscheiden, ob ein Plugin nur deaktivierbar oder auch deinstallierbar sein soll.


    Um das DAU-sicher zu machen, würde ich auf die Deinstallieren-Auswahl eher ganz verzichten.

    Jetzt bin ich endlich dazu gekommen die neue Distri zu installieren. Sehr gelungen. Vielen Dank!


    Hier möchte ich euch ein paar Vorschläge, bzw. Anregungen geben:


    - Auf 3 verschiedenen Mainboards gab es die Meldung "Waiting for Network". Teilweise noch den Zusatzcountdown "60 minutes more"
    Wenn in der /etc/network/interfaces statt "auto eth0", "allow-hotplug eth0" eingetragen wird, erledigt sich das Problem mit dem verzögerten Start.


    - Das WOL-Script bezieht sich "nur" auf ethX. Bei einigen System wird die Schnittstelle allerdings mit p1p5 o.ä. angesprochen.
    (Da ich über PXE boote, habe ich hier das init-script auf die alte Version "ethtool eth0 wol -g" abgeändert. Muss ich das templaten? Ansonsten besser umbenennen..)


    - Das Modul "ati_ remote" verträgt den usb-suspend nicht. Fernbedienung funzt anfangs normal, aber nach dem Reaktivieren (im laufenden Betrieb) werden die Kommandos doppelt, bis dreifach interpretiert.
    Ein "usbcore.autosuspend_delay_ms=-1" für den Kernel (hab ich zusätzlich als option für usbcore in der modprobe.d eingetragen) erledigt das Problem.
    Besser wäre sicherlich eine Udev-Regel anzulegen. Soweit bin ich aber noch nicht eingestiegen..


    - Im Webfrontend, in der Paketverwaltung werden Pakete zur Deinstallation angeboten, von denen yavdr-essentials abhängt. Den apt-get autoremove hab ihr ja rausgenommen, aber yavdr-essentials wird deinstalliert und lädt den user zum zerschießen des Systems ein.


    - Pulseaudio nutze ich nicht, aber seit Anbeginn von yaVDR nutze ich die die angehängte asound.conf für alsa. Hat den Vorteil, dass gleichzeitig auf allen (angegebenen) Ausgängen der Sound ankommt.
    Es muss darauf geachtet werden, dass man vorher im Webfrontend auf Alsa umstellt und die "card" und "device" Nummer auch dem entspricht, was aplay -l ausgibt.

    Files

    • asound.conf

      (624 Byte, downloaded 48 times, last: )

    Hier läuft eine Goflex Home mit 1x Sundtek und 1x USB-Stick, später soll evtl. eine zweite DVB-S2 dazukommen.
    Da die GH über nur einen USB-Port verfügt, benötige ich einen Hub ..


    Das Wichtigste ist natürlich der Datendurchsatz, aber auch der Geiz sollte nicht zu kurz kommen ;-)
    Wir sind ja im USB 3.0 Zeitalter und ich möchte keine Perlen vor die Säue werfen.


    Welchen USB-Hub würdet ihr empfehlen?

    Schau Dir einfach mal an, wie bei Yavdr externe Programme wie z.B. XBMC "standalone" gestartet werden .


    So könntest Du das Konvertierungsprogramm oder eine virtuelle Maschine Deiner Wahl starten.


    Alternativ auch mal XBMC --> Advanced Launcher o.ä. ansehen.


    Vorteil bei beiden Methoden: VDR läuft im Hintergrund weiter und kann aufnehmen......