Posts by vdr_rossi

    Wie hätte ich denn den Commit sauber eingespielt?

    (Ein einfaches "git pull" hat gemeckert...)


    In den Pfad von yavdr-ansible wechseln und git pull ausführen

    fertig.

    vdr-transcode + iHD ist aktualisiert.


    unknown libva error

    So, aktuelles ffmpeg ist installiert.

    weiter im Thema.

    Logfile im Anhang.

    Files

    • logfile.txt

      (4.34 kB, downloaded 18 times, last: )

    Habe fertig:

    Ok, damit hatte ich schon angefangen. Jetzt stoppt es hier:

    Code
    1. root@vdr1:/home/rossi/ffmpeg_sources/ffmpeg# ./configure --prefix=/usr --extra-version=1ubuntu0.2 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu -- incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-swresample --disable-filter=resample --enable-avisynth --enable- gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-lib flite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysof a --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy - -enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --disable-e ncoder=libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-openal --enable -opencl --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libx264 --enabl e-shared --enable-nonfree --enable-vaapi --disable-vdpau --cpu=x86-64 --disable-doc --disable-htmlpages --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-vfpv3 --disable-armv8 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-vsx --disab le-power8 --disable-amd3dnow --disable-amd3dnowext
    2. ERROR: avisynth/avisynth_c.h not found
    3. If you think configure made a mistake, make sure you are using the latest
    4. version from Git. If the latest version fails, report the problem to the
    5. ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.libera.chat.
    6. Include the log file "ffbuild/config.log" produced by configure as this will help
    7. solve the problem.

    Gut, probiere ich:

    dann

    Code
    1. root@vdr1:/home/rossi/ffmpeg_sources# tar xjvf ffmpeg-snapshot.tar.bz2
    2. ...

    weiter

    Code
    1. root@vdr1:/home/rossi/ffmpeg_sources# cd ffmpeg

    und wieder

    Code
    1. root@vdr1:/home/rossi/ffmpeg_sources/ffmpeg# ./configure --prefix=/usr --extra-version=1ubuntu0.2 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-openal --enable-opencl --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared --enable-nonfree --enable-vaapi --disable-vdpau --cpu=x86-64 --disable-doc --disable-htmlpages --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-vfpv3 --disable-armv8 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-vsx --disable-power8 --disable-amd3dnow --disable-amd3dnowext
    2. Unknown option "--enable-avresample".
    3. See ./configure --help for available options.

    Jetzt mag er Unknown option "--enable-avresample"nicht.

    Unwissenheit.


    Habe jetzt configure incl. Variablen in einem Stück ausgeführt -> configure_aufruf.txt


    Dann

    Danach habe ich dpkg-source --commitprobiert - gleiches Ergebnis.

    Bin jetzt ein kleines Stück weiter.


    Vor dem compilieren habe ich configure aufgerufen:

    es kommt am Ende

    Code
    1. ...
    2. --enable-vaapi \Unknown option "".
    3. See ./configure --help for available options.

    wenn ich ./configure --help aufrufe ist nur --disable-vaapi aufgelistet.


    Warum kann ich in ffmpeg-4.2.4 vaapi nur disablen und nicht enablen?

    Danke für die Anleitung.


    Musste erst in /etc/apt/sources.listalle deb-src auskommentieren + apt-get update. Dann ging es weiter.

    Stehe jetzt an dem Punkt -> vi Makefile


    Wo setze ich da --enable-vaapi ? bzw. auch die anderen Optionen? Welche bereits in der installierten Version gesetzt sind:


    Makefile im Anhang.

    Files

    • Makefile.txt

      (5.63 kB, downloaded 28 times, last: )