Posts by badsmurf

    Nach dem dkms hatte ich immer noch die 0.9.13, aus diesem Grund habe ich dann noch die manuelle Installation hinterhergeschoben um auf die 0.9.14 zu kommen. Leider ist es bei der alten Version geblieben, da aber die TV-Karte nun läuft, habe ich vorerst mal nichts mehr gemacht. Wenn ich demnächst mal Luft habe, kann ich das ja nochmal probieren. Für mich ist erst mal wichtig, dass es wieder läuft, alles andere zweitrangig. Was ich rausfinde, poste ich hier, vielleicht gibts ja noch mehr so "Spezialisten" wie mich denen das hilft. Nicht jeder kann sich da so tief reinarbeiten wie ihr und ist dann froh, eine kleine Anleitung zu finden - selbst wenn diese wie hier nicht vom Fachwissen kommt sondern das Ergebnis von try and error ist :P
    Für die Zukunft werde ich vor jeder Änderung nen Klon machen und hier testen. Da die Aufnahmen etc. alle woanders liegen und via NFS gemountet sind, ist das kein Thema da die yavdr-VM nicht mal 10 GB groß ist. Snapshot geht ja leider dank PassThrough nicht....


    Trotzdem nochmal vielen Dank für die Hilfe!

    So, jetzt scheints zu laufen. Hoffe, das ändert sich nicht wieder :-)


    Was habe ich gemacht?
    yavdr neu installiert
    apt-get update
    apt-get dist-upgrade
    apt-get install media-build-experimental-dkms


    apt-get install mercurial build-essential libproc-processtable-perl
    cd /usr/src
    hg clone http://linuxtv.org/hg/~endriss/media_build_experimental
    cd media_build_experimental
    make download
    make untar
    apt-get install git patchutils
    ./build --check-only
    make
    make install


    Dann die Datei /etc/modprobe.d/ddbridge.conf erstellen mit Inhalt


    options ddbridge msi=0


    Jetzt läufts! :-)
    Vielleicht hilft das ja jemandem weiter....
    Letztendlich war der Tip mit ddbridge.conf springende Punkt.
    Der Treiber ist immer noch 0.9.13. Wäre interessant wie ich den auf 0.9.14 bekomme....


    Und was haben wir gelernt:
    1. NICHT MEHR ANFASSEN!
    2. Vor jedem Update eine Kopie der VM ziehen
    3. Alle Updates/Änderungen erst an der Kopie machen


    Ansonsten: Wieder ein schöner Sonnentag vor dem PC verbracht statt mit Frau und Kind was zu unternehmen. Aber Hauptsache die Glotze geht! :-)


    Super, Oliver, Du bist der Held des Tages! Solltest Du mir mal live begegnen, hast Freibier und allyoucaneat frei mehr als Du verträgst :-)


    VIELEN VIELEN DANK!

    Super, vielen Dank! 1x habe ich jetzt beide Tuner gesehen, nach einem Neustart war wieder alles weg. Ich fürchte mal, die VM ist nach den vielen Tests schon ziemlich verbogen. Ich werde jetzt noch ein bisschen probieren und dann wohl neu installieren.... :-(


    Der Treiber stammt so von der DigitalDevices-Hompage, da gibts nur die 0.9.13
    http://shop.digital-devices.de…_Digital_Devices_Produkte
    Wo bekomme ich die neueste Version?


    Aber grundsätzlich mal um bei der Neuinstallation nichts zu verbiegen:
    Ich mache die Grundinstallation von yavdr
    apt-get update
    apt-get upgrade
    (oder gleich apt-get dist-upgrade?)
    apt-get install media-build-experimental-dkms
    dann ggf. noch die /etc/modprobe.d/ddbridge.conf erstellen
    Damit müsste es dann alles gewesen sein? Oder habe ich was vergessen?

    OK, danke schon mal.


    root@tvbackendV2:~# lspci
    00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 01)
    00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 01)
    00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 08)
    00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
    00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
    00:07.7 System peripheral: VMware Virtual Machine Communication Interface (rev 10)
    00:0f.0 VGA compatible controller: VMware SVGA II Adapter
    00:10.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 01)
    00:11.0 PCI bridge: VMware PCI bridge (rev 02)
    00:15.0 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.1 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.2 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.3 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.4 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.5 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.6 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:15.7 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.0 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.1 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.2 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.3 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.4 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.5 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.6 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:16.7 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.0 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.1 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.2 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.3 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.4 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.5 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.6 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:17.7 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.0 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.1 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.2 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.3 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.4 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.5 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.6 PCI bridge: VMware PCI Express Root Port (rev 01)
    00:18.7 PCI bridge: VMware PCI Express Root Port (rev 01)
    02:00.0 Ethernet controller: Intel Corporation 82545EM Gigabit Ethernet Controller (Copper) (rev 01)
    03:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
    root@tvbackendV2:~#


    root@tvbackendV2:~# dmesg |grep -i dvb
    [ 4.568635] v4l-dvb-saa716x: 196681f1e1541c4f77a69882c95c4ab2cbb255b1 saa716x_ff: implement PHI speedup
    [ 4.597832] DDBridge driver detected: Digital Devices Cine S2 V6.5 DVB adapter
    root@tvbackendV2:~#


    Was wird denn noch benötigt? Leider bin ich da im Bezug auf Treiber, Kernel etc. nicht so wirklich fit.

    Files

    • dmesg.zip

      (19 kB, downloaded 79 times, last: )

    Hallo Zusammen,


    nachdem die S2 jetzt einige Monate gelaufen hat, streikt sie nach einem Update und ich bekomms einfach nicht mehr hin. Nun habe ich schon mehrmals yavdr neu installiert (VM auf ESX5.1 via DirectPath Passthrough). Das lief lange gut, aber zwischenzeitlich habe ich wohl mal ein apt-get upgrade oder gar dist-upgrade gemacht, vor ein paar Tagen dann die VMS samt Host neugestartet, seitdem gehts nicht mehr. Ich habe zwischenzeitlich auch yavdr mehrmals neu installiert, ohne Erfolg. Die Karte wird gefunden:


    root@tvbackendV2:~# dmesg |grep -i dvb
    [ 4.568635] v4l-dvb-saa716x: 196681f1e1541c4f77a69882c95c4ab2cbb255b1 saa716x_ff: implement PHI speedup
    [ 4.597832] DDBridge driver detected: Digital Devices Cine S2 V6.5 DVB adapter
    root@tvbackendV2:~#


    lspci bringt folgendes:
    03:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter


    Yavdr zeigt unter DVB-Adapters leider auch nichts an, während der USB-Adapter sauber erkannt wird:
    crw-rw---- 1 root video 212, 0 Jun 8 21:48 demux0
    crw-rw---- 1 root video 212, 1 Jun 8 21:48 dvr0
    crw-rw---- 1 root video 212, 3 Jun 8 21:48 frontend0
    crw-rw---- 1 root video 212, 2 Jun 8 21:48 net0


    Wenn nur die S2 dran ist, bekomme ich hier gar nichts. :-(


    Aber das wars dann schon! Alle Updates sind drauf,
    apt-get install media-build-experimental-dkms
    installiert. Das wars auch wie ich die Karte ursprünglich zum Laufen bekommen habe.
    Die S2 selbst geht direkt in einem anderen PC - ohne VMware. Auch die VM mit einer via USB durchgereichten Technotrend TT4600 oder einer tevii 660 USB geht einwandfrei.
    Seit 2 Tagen habe ich schon so ziemlich alle Anleitungen probiert, ohne Erfolg. Viele sind nicht mehr aktuell oder funktionieren gar nicht mehr. Es muss wohl irgendwas mit ESX in Verbindung mit einem der Updates sein welche seit den letzten Monaten rausgekommen sind.
    Leider habe ich mir von der funktionierenden VM nicht gleich eine Kopie gezogen...


    Hat hier jemand noch eine Idee? Bin jetzt echt am Ende mit meinem Latein....


    Danke schon mal!

    Ich glaube das ist falsch rübergekommen. Es funktioniert tadellos, eine ganz feine Sache, es sei denn man kann es - warum auch immer - nicht brauchen.


    Was ich im ersten Post sagen wollte, wenn ich sowas extra konfigurieren hätte wollen weil ich es brauche dann hätte ich das sicher nicht so einfach hinbekommen. Und nun wo ich es gerade nicht haben will kommt sowas oft ganz Praktisches quasi "von selbst".

    Hallo Zusammen,
    ich habe hier ein lustiges Phänomen, welches wohl wenn es so gewollt wäre nie funktionieren würde :rolleyes:


    Aktuell habe ich als Backend einen yavdr 0.5 headless. Auf diesen greifen mehrere XBMC-Clients via VNSI zu. Klappt alles wunderbar!
    Nun soll noch ein weiterer yavdr 0.5 dazu, auf dem läuft XBMC als frontend welches wiederum via VNSI auf den localhost zugreift. Klappt auch.
    AAAAABER: Der zweite yavdr zieht sich die Kanalliste des ersten Backends und zeigt zudem auch dessen Aufnahmen an mit einem backend1~ jeweils vor der Aufnahme im Dashboard an.
    Auch im vdr-live des zweiten yavdr werden die Aufnahmen des ersten Backends angezeigt. Wie kann ich den zweiten yavdr nun vom ersten abnabeln so dass der quasi standalone läuft? VNSI soll weiter klappen, so dass sich die XBMC-Clients wahlweise auf den einen oder anderen yavdr verbinden können.
    Wie bekomme ich diese "Abnabelung" hin? Hat jemand ne Idee?


    Alle Maschinen befinden sich im selben Netz und sind im Prinzip out-of-the-box. Installiert wurde von der aktuellen ISO, yavdr wurde also nicht nachträglich installiert. Auch laufen ansonsten keine weiteren Programme auf den Kisten.
    vdr --version zeigt folgendes an:
    vdr (2.0.3/2.0.0) - The Video Disk Recorder
    channellists (0.0.5) - Manage your channellists
    streamdev-server (0.6.1-git) - VDR Streaming Server
    dvbsddevice (2.0.1) - SD Full Featured DVB device
    iptv (2.0.0) - Experience the IPTV
    xvdr (0.9.9) - XVDR Server
    menuorg (0.5.1) - Reorganizes the main menu
    markad (0.1.5pre) - Mark advertisements
    xineliboutput (1.0.90-cvs) - X11/xine-lib output plugin
    vnsiserver3 (0.9.1) - VDR-Network-Streaming-Interface (VNSI) Server
    live (0.3.0) - Live Interactive VDR Environment
    restfulapi (0.1.2) - Offers a RESTful-API to retrieve data from VDR
    graphtftng (0.4.5) - VDR OSD on TFT
    vdrmanager (0.9) - VDR-Manager support plugin
    wirbelscan (0.0.7) - DVB and pvrinput channel scan for VDR
    femon (2.0.0) - DVB Signal Information Monitor (OSD)
    epgsearch (1.0.1.beta5) - search the EPG for repeats and more
    dynamite (0.1.5) - attach/detach devices on the fly
    xine (0.9.4) - Software based playback using xine
    dummydevice (1.0.3) - Output device that does nothing
    dbus2vdr (17) - control vdr via D-Bus
    conflictcheckonly (0.0.1) - Direct access to epgsearch's conflict check menu
    quickepgsearch (0.0.1) - Quick search for broadcasts
    text2skin (1.3.2+git) - Loader for text-based skins
    pvr350 (1.7.4) - PVR350 as output device
    skinpearlhd (0.0.1) - PearlHD Skin
    epgsearchonly (0.0.1) - Direct access to epgsearch's search menu
    dvbhddevice (2.0.2) - HD Full Featured DVB device
    extrecmenu (1.2.3-git) - Extended recordings menu
    softhddevice (0.6.1rc1) - A software and GPU emulated HD device



    Danke schon mal!

    Hi!


    Ich habe hier einen Quadcore und möchte damit nun die eierlegende Wollmilchsau bauen. Da ich mehrere VMs am laufen habe, war die "einfache" Idee, in den bisherigen Server (Quadcore samt Etch und VMWare) der ja eh immer läuft, einfach die TV-Karte aus dem bisherigen ctvdr (933 MHZ PIII) einzubauen und alles auf einer Maschine laufen zu lassen. Leider unterstützt der ctvdr nur eine CPU. Was ich hier so gelesen habe, läuft vdr nicht auch mehreren CPUs? Hat das jemand schon mal hinbekommen? Bin für jeden Tip dankbar.


    Viele Grüße