Posts by gen2User

    Hi,


    habe mir jetzt den Display Bausatz von Pollin besorgt:


    Hyundai HP12542R-DYO
    LC-Display 128x64
    Controller SED1565


    Display ist funktionstüchtig und läuft unter XP mit der beiliegenden Software.


    Nach einschalten des GraphLCD-Plugins in meiner Gen2 Version bekomme ich allerdings keine Anzeige auf das Display.


    Muß der Parallel-Port noch "eingeschaltet" werden ?
    Im Bios ist der Par Porta ktiviert mit EPP.


    GraphLCD bringt keine Fehlermeldungen. Plugin lässt sich über Admin auch einstellen.


    Hat jemand dieses Display am Laufen und hätte vielleicht mal einen Tip für eine graphlcd.conf ?


    Werd auch nicht so ganz schlau aus der Ansteuerung der Devices unter Gentoo - welches ist das für den Parallel Port ?


    Danke

    Da ich es ja nun so angeschlossen habe, wollte ich es auch so betreiben....
    Ohne Platine ? Also ohne das COMPACT TERMINAL LIGHT 20X4 ?


    Also Display wieder runter löten und dann direkt an den parallelen Port verkabeln ???? - Oder wie meinst Du das ?


    Also - lieber seriell. Wenn es nicht anders (besser) geht .... parallel.....


    Wie wäre die Vorgehnsweise für parallel ?


    Endziel soll eigentlich sein, Ausgaben vom VDR auf das Display zu bringen. Gehe diese ganzen Wege bisher nur, um die Funktionalität und das Zusammenspiel Hardware/Software hinzubekommen.....

    Ok... erste Erfolge zu verzeichnen


    Serieller Port initiert mit
    setserial /dev/tts/0 auto_irq baud_base 19200 autoconfig


    Dann
    lcd4linux -i


    mit dieser config



    Bisher aber leider nur komische Zeichen auf dem Display.


    Ausgabe nach Aufruf von lcd4linux -i :


    video ~ # lcd4linux -i
    removing stale lockfile /var/lock/LCK..tts_0
    Beckmann+Egle: error fetching type of port 0
    Beckmann+Egle: error fetching type of port 1
    Beckmann+Egle: error fetching type of port 2
    Beckmann+Egle: error fetching type of port 3
    Beckmann+Egle: error fetching type of port 4
    Beckmann+Egle: error fetching type of port 5
    Beckmann+Egle: error fetching type of port 6
    Beckmann+Egle: error fetching type of port 7


    eval>


    Danach habe ich das Display voller seltsamer Zeichen.....


    Fonts - Zeichen - ???

    Meine Tests und Ergebnisse....


    video ~ # setserial /dev/ttyS0 uart 16450 port 0x3F8 irq 4
    video ~ # lcd4linux -c key=CPU -i -f /etc/lcd4linux.conf
    Beckmann+Egle: tcgetattr(/dev/tts/0) failed: Input/output error
    video ~ # lcd4linux -c key=CPU -i -f /etc/lcd4linux.conf
    Beckmann+Egle: tcgetattr(/dev/ttyS0) failed: Input/output error
    video ~ # setserial /dev/ttyS0 uart 16450 port 3F8 irq 4
    Cannot set serial info: Device or resource busy
    video ~ # setserial /dev/ttyS0 uart 16450 port 0x3F8 irq 4
    video ~ # lcd4linux -c key=CPU -i -f /etc/lcd4linux.conf
    Beckmann+Egle: tcgetattr(/dev/ttyS0) failed: Input/output error
    video ~ # setserial /dev/ttyS0 uart 16450 port 0x3F8 irq 4 baud_base 19200
    video ~ # setserial /dev/ttyS0 uart 16450 port 0x3F8 irq 4 baud_base 19200
    video ~ # lcd4linux -c key=CPU -i -f /etc/lcd4linux.conf
    Beckmann+Egle: tcgetattr(/dev/ttyS0) failed: Input/output error
    video ~ # setserial /dev/tts/0 uart 16450 port 0x3F8 irq 4 baud_base 19200
    video ~ # setserial /dev/tts/0 uart 16450 port 0x3F8 irq 4 baud_base 19200
    video ~ # lcd4linux -c key=CPU -i -f /etc/lcd4linux.conf
    Beckmann+Egle: tcgetattr(/dev/tts/0) failed: Input/output error


    ---------------------------------------------------------------------------------------------
    Ich geb's auf - teste demnächst nochmal mit einem anderen Board und anderem Display...mal gucken...


    oder hat noch jemand ne zündende Idee ??

    Dies ist das Ansteuermodul, auf welches das Display augesteckt und dann verlötet wird:


    Display Modul


    Produktseite des Herstellers zu den Displays
    Beckann+Egle


    Das 20x4/LED ist mit Produktblatt auch aufgeführt.


    ----------------------------------------------------------------------------------------------
    Dies ist der entsprechend unterstützende Treiber in der lcd4linux.conf:


    Code
    1. Display CT20x4 {
    2. Driver 'Beckmann+Egle'
    3. Model 'CT20x4'
    4. Port '/dev/tts/0'
    5. # Size '16x2'
    6. # Contrast 7
    7. # Backlight 1
    8. Icons 1
    9. }

    Hab ich auch drauf ....
    Ist Bestandteil von serdisplib-1.96.
    Leider finde ich dort aber kinen Treiber/Unterstützung für mein Display.
    Mit LCD4Linux wird mein Display wohl unterstützt...


    Bekomme mit testserdisp auch nur Fehlermeldungen zurück..


    Versucht habe ich das bsp. wie folgt:
    testserdisp -n PCD8544 -p SERRAW:/dev/ttyS0


    testserdisp -n PCD8544 -p /dev/ttyS0


    testserdisp -n SED133X -p SERRAW:/dev/ttyS0


    testserdisp -n SED133X -p /dev/ttyS0


    In allen Fällen kam die Rückmeldung
    Error: Unknown display or unable to open SED133X, additional info:
    oder
    Error: Unknown display or unable to open PCD8544, additional info:
    --------------------------------------------------------------------------------------------


    Habe mal ein wenig im Gentoo-System geschnüffelt. Webmin instralliert und mir mal angesehen, was so beim Booten aktiviert wird....
    S0 und S1 ist inaktiv. Sind doch die seriellen Schnittstellen ? Zumindest sind die dort mit Geschwindigkeitsinitiierung von 9200 angegeben. Aber eben inaktiv. - Und....
    Wenn ich über die "/etc/serial.conf" die Einträge
    #/dev/ttyS0 uart 16450 port 0x3F8 irq 4
    #/dev/ttyS1 uart 16450 port 0x2F8 irq 3
    abändere in
    /dev/ttyS0 uart 16450 port 0x3F8 irq 4
    /dev/ttyS1 uart 16450 port 0x2F8 irq 3


    erhalte ich im Logfile die Fehlermeldung:
    Id "s0" respawning too fast: disabled for 5 minutes
    oder
    Id "s1" respawning too fast: disabled for 5 minutes
    Wenn ich die oben genbannten Einträge aktiv lasse wird diese Fehlermeldung auch immer wieder ins Logfile geschrieben und stört sogar irgendwann den VDR-Betrieb erheblich. (Umschaltträgheit und andere seltsame Verhaltensweisen...)


    Könnte es vielleicht auch sein, daß der serielle Port auf dem Board von Linux nicht richtig erkannt wird....... *grübel*
    -----------------------------------------------------------------------------------------------


    Habe jetzt auch eine Möglichkeit geschaffen, daß man sich mit dem VDR hier bei mir von extern über eine Dyndns.org Adresse verbinden kann. - Mit WinSCP und Putty. Wer also mal Lust hat genauer dahinter zu gucken, möge sich bitte per EMail melden.
    Es gibt bestimmt Leute, die von Linux mehr verstehen als ich...aber wie es eben oft so ist, muß man ins System gucken, um die Zusammenhäge erkennen zu können.
    Mail an smokie33@nexgo.de - Danke


    Ich selbst bin Fachinformatiker/Systemintegration - Aber es gibt eben Dinge, die einem keiner beibringt....da muss man sich einarbeiten...

    und im VDR-log sehe ich gerade:


    Id "s0" respawning too fast: disabled for 5 minutes


    ttyS0: ioctl: Input/output error


    ...Nachdem ich das mit ttyS0 in der lcd4linux.conf angetestet habe...


    -----------------------------------------------------------------------------------------------


    BIOS geprüft. Einstellung für seriell: 3F8/IRQ4


    also eigentlich ...OK...

    Ich gebs auf...ich weiß nicht mehr weiter...


    habe hier ein Display (20x4) Bausatz von Conrad. Fertig verlötet. Auch schon mal am Strom gehabt und seriell verkabelt. Display zeigt Statusmeldung an.


    Habe dann mit lcdproc experimentiert. Klappte aber nicht...man soll LCD's damit wohl auch parallel ansteuern ?
    Seriell soll aber auch gehen - ? Habe das Forum schon auf den Kopf gestellt ..aber nix gefunden...oder zu blöd zum Suchen :-)


    Kann mir jemand dabei helfen, das Ding seriell anzusteuern ? Oder wenn es mit diesem Dingen denn so gar nicht klappen sollte...mir einen Tip geben, welches Display mit welchem Controller oder welche Lösung am VDR mit sehr hoher Wahrscheinlichkeit läuft und mir eine Bezugsquelle nennen ? Ich will doch nur ein funktionierendes Display *jammer*


    Wenn man das Conrad-Display seriell am VDR nicht zum Laufen bekäme, würde ich es auch gerne loswerden wollen. Kann's dann vielleicht jemand gebrauchen ?


    Mein VDR-System ist Gentoo VDR RC4. Habe ein ASROCK VM800 Mainboard.


    Fotos vom Display:


    [Blocked Image: http://www.cof-server.de/bilder/vdr/display/display-1.jpg]
    [Blocked Image: http://www.cof-server.de/bilder/vdr/display/Bild39.jpg]
    [Blocked Image: http://www.cof-server.de/bilder/vdr/display/Bild40.jpg]
    [Blocked Image: http://www.cof-server.de/bilder/vdr/display/Bild42.jpg]


    Würde mich für Hilfe auch erkenntlich zeigen wollen.
    Danke im Voraus


    Lösungsvorschläge ?

    Danke für den Tip....nur soweit war ich irgendwie auch schon....
    Ich möchte keine Linux-GUI installieren um VideoClients unter Linux für das Fersehen zu benutzen. Sondern die Ausgabe direkt zum TV Out der Grafikkarte lenken...wenn möglich...

    Hallo,
    bin noch neu hier (registriert - lesen schon länger ) und möchte mit der neuesten Gentoo VDR-Version ein DVB-T System aufbauen.
    Habe auch schon die Forensuche benutzt ... hat mir aber bisher nicht so wirklich geholfen. Vielleicht habe ich auch was übersehen...
    Daher nun meine Frage. Was muss ich tun, um mit folgender Hardware ein Gen2-System mit DVB-T zum Laufen zu bringen ?


    Vorhanden sind:
    K8Upgrade-NF3 S754 Mainboard, AMD Sempron 3000+
    512 MB RAM
    WinTV Nova T
    ATI Radeon 9250


    Kenne mich bisher nur mit DVB-S Basis aus.
    Habe bereits ein DVB-S -Premiere System mit der letzen Gentoo laufen.
    Basis ist dort ein ASROCK Board mit AMD Sempron 2600+ mit 512MB und einer WinTV Nexus-s
    Funktioniert übrigends prächtig. Super stabil und alles an Plugins, was das Herz begehrt... :-)


    Nun möchte ich das mal mit DVB-T versuchen. Weiß nur, es muss wohl mit dem Softdevice-Plugin gemacht werden. Aber wie ist das mit der TV-Ausgabe ? Zusammenspiel von DVB-T Karte und Grafikkarte ? Wie zaubere ich das Bild über den TV-Out der Graka nach draussen ? Die Ausgabe direkt über die Karte wie bei der Nexus-S ist ja hierbei nicht möglich..


    Für Eure Hilfe bedanke ich mich im Voraus. Sollte ich Forenbeiträge übersehen haben, möge man es mir bitte nachsehen -